Initial import of perl2html version 0.6.1.

A Perl source to HTML converter.

PR:		11907
Submitted by:	Martin Kammerhofer <mkamm@gmx.net>
This commit is contained in:
Steve Price 1999-06-06 17:17:35 +00:00
parent f90dfc50e8
commit 7b5716ea0b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=19259
6 changed files with 66 additions and 0 deletions

View file

@ -0,0 +1,28 @@
# New ports collection makefile for: perl2html
# Version required: 0.6.1
# Date created: 27 May 1999
# Whom: Martin Kammerhofer
#
# $Id$
#
DISTNAME= perl2html-0.6.1
CATEGORIES= textproc www
MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= apps/www/converters
MAINTAINER= mkamm@gmx.net
USE_AUTOCONF= yes
MAN1= perl2html.1
.if !defined(NOPORTDOCS)
post-install:
${MKDIR} ${PREFIX}/share/doc/perl2html
.for file in AUTHORS NEWS README
${INSTALL_MAN} ${WRKSRC}/${file} ${PREFIX}/share/doc/perl2html
.endfor
.endif
.include <bsd.port.mk>

View file

@ -0,0 +1 @@
MD5 (perl2html-0.6.1.tar.gz) = 2c23b1cc2f74cdc25f08b5a3f2aa0adb

View file

@ -0,0 +1,20 @@
--- Makefile.in.orig Wed May 26 19:31:36 1999
+++ Makefile.in Thu May 27 21:54:22 1999
@@ -9,7 +9,7 @@
# for gzip because otherwise the load on the web server
# grows without having big benefits.
# COMPRESSION = -DCOMPRESSION=4
-COMPRESSION = -DCOMPRESSION=1
+COMPRESSION ?= -DCOMPRESSION=1
# Dont change things beyond this line.
TARGET = @PROJECT_NAME@
@@ -40,7 +40,7 @@
srcdir = @srcdir@
CPPFLAGS = @CPPFLAGS@
-CFLAGS += -O2 -Wall
+CFLAGS ?= -O2 -Wall
ALL_CFLAGS = $(CFLAGS) -I$(srcdir) $(COMPRESSION)
all: $(TARGET)

View file

@ -0,0 +1 @@
Perl sources to HTML converter

View file

@ -0,0 +1,11 @@
Perl2html is a syntax highlighter for Perl source code that produces a
highlighted html file as output.
Perl2html offers the following features:
- fast (single pass conversion using flex)
- doesn't change formatting - only adds <FONT COLOR=#XXXX> tags
and properly escapes non-ascii characters
- easy integration with webservers - browse your sources colourized
- gzips http output for browsers to save bandwidth (only in CGI mode)
- documentation and manpage included

View file

@ -0,0 +1,5 @@
bin/perl2html
share/doc/perl2html/AUTHORS
share/doc/perl2html/NEWS
share/doc/perl2html/README
@dirrm share/doc/perl2html