- Fix MASTER_SITES
- Support CFLAGS properly - Remove obsolete WWW: line PR: ports/60627 Submitted by: Ports Fury
This commit is contained in:
parent
7664565a22
commit
7b7c3ad636
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=96689
5 changed files with 34 additions and 53 deletions
|
@ -7,24 +7,29 @@
|
|||
|
||||
PORTNAME= pclock
|
||||
PORTVERSION= 0.13.1
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= x11-clocks windowmaker afterstep
|
||||
MASTER_SITES= ftp://ftp.kourakos.com/pub/pclock/
|
||||
EXTRACT_SUFX= .tgz
|
||||
MASTER_SITES= ${MASTER_SITE_DEBIAN_POOL}
|
||||
DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Simple analog clock program for the Window Maker dock
|
||||
|
||||
USE_GMAKE= yes
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}.orig/src
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_XPM= yes
|
||||
USE_GETOPT_LONG= yes
|
||||
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" OBJS="Main.o Graphics.o" \
|
||||
INCDIR="-I. -I${X11BASE}/include ${CPPFLAGS}" \
|
||||
LIBDIR="-L${X11BASE}/lib ${LDFLAGS}"
|
||||
|
||||
post-extract:
|
||||
cd ${WRKSRC} && ${RM} -f getopt*
|
||||
|
||||
do-install:
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/src/pclock ${PREFIX}/bin
|
||||
@${MKDIR} ${PREFIX}/share/pclock/pixmaps && ${CHMOD} a+rx ${PREFIX}/share/pclock/pixmaps
|
||||
@${ECHO} "===> Installing sample pixmaps in ${PREFIX}/share/pclock/pixmaps"
|
||||
@${INSTALL_DATA} ${WRKSRC}/XPM/*.xpm ${PREFIX}/share/pclock/pixmaps
|
||||
|
||||
post-install:
|
||||
@${ECHO} "===> Use 'pclock --help' for usage instructions"
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/pclock ${PREFIX}/bin
|
||||
@${MKDIR} ${DATADIR}/pixmaps
|
||||
${INSTALL_DATA} ${WRKSRC}/../XPM/*.xpm ${DATADIR}/pixmaps
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (pclock-0.13.1.tgz) = c700933e3ec53beed738c5167fc255c1
|
||||
MD5 (pclock_0.13.1.orig.tar.gz) = 7d6284d50b7e8c76b1e8b68dad5fe44f
|
||||
|
|
|
@ -1,22 +0,0 @@
|
|||
--- src/Makefile.orig Fri Dec 3 16:29:46 1999
|
||||
+++ src/Makefile Fri Dec 3 16:33:00 1999
|
||||
@@ -1,14 +1,14 @@
|
||||
-BINDIR = /usr/X11R6/bin
|
||||
+BINDIR = ${X11BASE}/bin
|
||||
|
||||
PROG = pclock
|
||||
OBJS = Main.o Graphics.o getopt.o getopt1.o
|
||||
|
||||
DEFAULT_XPM = round-3d.xpm
|
||||
|
||||
-INCDIR = -I/usr/X11R6/include -I.
|
||||
-LIBDIR = -L/usr/X11R6/lib
|
||||
-CC = gcc
|
||||
-CFLAGS = -O -s -Wall
|
||||
+INCDIR = -I${X11BASE}/include -I.
|
||||
+LIBDIR = -L${X11BASE}/lib
|
||||
+CC ?= gcc
|
||||
+CFLAGS = -s -fomit-frame-pointer -Wall
|
||||
LIBS = -lXpm -lXext -lX11 -lm
|
||||
|
||||
###############################################################################
|
|
@ -2,6 +2,4 @@ pclock is a simple analog clock program designed to run under the
|
|||
Window Maker window manager. Any 64x64 pixmap may be used as a
|
||||
background, including tiles.
|
||||
|
||||
WWW: http://kraanerg.apex-it.com/~awk/pclock/
|
||||
|
||||
- Jim <jim@FreeBSD.org>
|
||||
|
|
|
@ -1,19 +1,19 @@
|
|||
bin/pclock
|
||||
share/pclock/pixmaps/glowclock.xpm
|
||||
share/pclock/pixmaps/green.xpm
|
||||
share/pclock/pixmaps/moonphase.xpm
|
||||
share/pclock/pixmaps/oclock.xpm
|
||||
share/pclock/pixmaps/radar.xpm
|
||||
share/pclock/pixmaps/rolex2.xpm
|
||||
share/pclock/pixmaps/rolexgmt.xpm
|
||||
share/pclock/pixmaps/round-3d.xpm
|
||||
share/pclock/pixmaps/square.xpm
|
||||
share/pclock/pixmaps/swatch.xpm
|
||||
share/pclock/pixmaps/time-icon.xpm
|
||||
share/pclock/pixmaps/will-return.xpm
|
||||
share/pclock/pixmaps/wmaker-tile.xpm
|
||||
share/pclock/pixmaps/wood-tile.xpm
|
||||
share/pclock/pixmaps/wristwatch.xpm
|
||||
share/pclock/pixmaps/yellow-diamond.xpm
|
||||
@dirrm share/pclock/pixmaps
|
||||
@dirrm share/pclock
|
||||
%%DATADIR%%/pixmaps/glowclock.xpm
|
||||
%%DATADIR%%/pixmaps/green.xpm
|
||||
%%DATADIR%%/pixmaps/moonphase.xpm
|
||||
%%DATADIR%%/pixmaps/oclock.xpm
|
||||
%%DATADIR%%/pixmaps/radar.xpm
|
||||
%%DATADIR%%/pixmaps/rolex2.xpm
|
||||
%%DATADIR%%/pixmaps/rolexgmt.xpm
|
||||
%%DATADIR%%/pixmaps/round-3d.xpm
|
||||
%%DATADIR%%/pixmaps/square.xpm
|
||||
%%DATADIR%%/pixmaps/swatch.xpm
|
||||
%%DATADIR%%/pixmaps/time-icon.xpm
|
||||
%%DATADIR%%/pixmaps/will-return.xpm
|
||||
%%DATADIR%%/pixmaps/wmaker-tile.xpm
|
||||
%%DATADIR%%/pixmaps/wood-tile.xpm
|
||||
%%DATADIR%%/pixmaps/wristwatch.xpm
|
||||
%%DATADIR%%/pixmaps/yellow-diamond.xpm
|
||||
@dirrm %%DATADIR%%/pixmaps
|
||||
@dirrm %%DATADIR%%
|
||||
|
|
Loading…
Reference in a new issue