Update to 0.9.8.
This commit is contained in:
parent
a4eadd0644
commit
7b87ae92f5
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=53675
14 changed files with 276 additions and 100 deletions
|
@ -6,8 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= xine
|
||||
PORTVERSION= 0.9.7
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 0.9.8
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://xine.sourceforge.net/files/ \
|
||||
${MASTER_SITE_SOURCEFORGE}
|
||||
|
@ -19,10 +18,13 @@ MAINTAINER= nobutaka@FreeBSD.org
|
|||
|
||||
BUILD_DEPENDS= ${LOCALBASE}/lib/libavcodec.a:${PORTSDIR}/graphics/ffmpeg
|
||||
LIB_DEPENDS= a52.0:${PORTSDIR}/audio/liba52 \
|
||||
aa.1:${PORTSDIR}/graphics/aalib
|
||||
aa.1:${PORTSDIR}/graphics/aalib \
|
||||
intl.1:${PORTSDIR}/devel/gettext
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-lib-${PORTVERSION}
|
||||
CONFIGURE_ARGS= --with-w32-path=${LOCALBASE}/lib/win32
|
||||
CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include LIBS=-L${LOCALBASE}/lib
|
||||
|
||||
USE_AUTOMAKE= yes
|
||||
USE_GMAKE= yes
|
||||
USE_X_PREFIX= yes
|
||||
|
@ -72,41 +74,9 @@ PLIST_SUB+= HAVE_OGG=""
|
|||
PLIST_SUB+= HAVE_OGG="@comment "
|
||||
.endif
|
||||
|
||||
# DVD input plugin for xine-0.9.7 is not available yet.
|
||||
.if 0
|
||||
.if defined(WITH_CSS)
|
||||
# http://members.home.nl/mphm.janssen/linuxvideo/linuxvideo.html
|
||||
MASTER_SITES+= http://members.home.nl/mphm.janssen/files/
|
||||
DISTFILES+= ${PLUGIN_CSS}${EXTRACT_SUFX}
|
||||
|
||||
LIB_DEPENDS+= dvdcss.0:${PORTSDIR}/graphics/libdvdcss
|
||||
|
||||
PLUGIN_CSS= dvd-plugin-${PLUGIN_CSS_VERSION}
|
||||
PLUGIN_CSS_VERSION= 0.4
|
||||
.endif
|
||||
.endif
|
||||
|
||||
pre-everything::
|
||||
.if 0
|
||||
.if !defined(WITH_CSS)
|
||||
@${ECHO_MSG} "====>"
|
||||
@${ECHO_MSG} "====> To enable css support, define WITH_CSS"
|
||||
@${ECHO_MSG} "====>"
|
||||
.endif
|
||||
.endif
|
||||
|
||||
# XXX: To avoid internal error in gcc.
|
||||
post-configure:
|
||||
@${SED} -e "s/-funroll-loops//" < ${WRKSRC}/src/libw32dll/wine/Makefile > ${WRKSRC}/src/libw32dll/wine/Makefile.tmp
|
||||
@${MV} ${WRKSRC}/src/libw32dll/wine/Makefile.tmp ${WRKSRC}/src/libw32dll/wine/Makefile
|
||||
|
||||
post-patch:
|
||||
.if 0
|
||||
.if defined(WITH_CSS)
|
||||
@${PERL} -pi.orig -e 's/(xineplug_inp_dvd_la_LDFLAGS = -avoid-version -module)/\1 -ldvdcss/' \
|
||||
${WRKSRC}/src/input/Makefile.am
|
||||
@${CP} -f ${WRKDIR}/${PLUGIN_CSS}/*.[ch] ${WRKSRC}/src/input
|
||||
.endif
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (xine-lib-0.9.7.tar.gz) = 52f3cfdcf2066d36746fb98b735b0fbc
|
||||
MD5 (xine-lib-0.9.8.tar.gz) = d8fc9b30e15b50af8ab7552bbda7aeda
|
||||
|
|
|
@ -1,12 +1,12 @@
|
|||
--- src/xine-engine/Makefile.am.orig Sun Oct 21 09:06:25 2001
|
||||
+++ src/xine-engine/Makefile.am Sun Oct 21 09:07:43 2001
|
||||
@@ -18,8 +18,7 @@
|
||||
-lm
|
||||
--- src/xine-engine/Makefile.am.orig Sat Dec 29 02:31:25 2001
|
||||
+++ src/xine-engine/Makefile.am Thu Jan 24 13:42:50 2002
|
||||
@@ -15,8 +15,7 @@
|
||||
libxine_la_LIBADD = $(THREAD_LIBS) $(DYNAMIC_LD_LIBS) @INTLLIBS@ -lm -lz
|
||||
|
||||
libxine_la_LDFLAGS = \
|
||||
- -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
|
||||
- -release $(LT_RELEASE)
|
||||
- -release $(LT_RELEASE)
|
||||
+ -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)
|
||||
|
||||
include_HEADERS = buffer.h metronom.h configfile.h \
|
||||
monitor.h cpu_accel.h attributes.h utils.h \
|
||||
audio_out.h resample.h video_out.h xine_internal.h spu_decoder.h \
|
||||
|
|
|
@ -6,7 +6,6 @@ include/xine/buffer.h
|
|||
include/xine/configfile.h
|
||||
include/xine/demux.h
|
||||
include/xine/dxr3_video_out.h
|
||||
include/xine/dxr3_vo_encoder.h
|
||||
include/xine/events.h
|
||||
include/xine/input_plugin.h
|
||||
include/xine/lrb.h
|
||||
|
@ -20,6 +19,7 @@ include/xine/video_out.h
|
|||
include/xine/video_out_x11.h
|
||||
include/xine/video_overlay.h
|
||||
include/xine/xine_internal.h
|
||||
include/xine/xineintl.h
|
||||
include/xine/xineutils.h
|
||||
include/xine.h
|
||||
lib/libxine.la
|
||||
|
@ -52,6 +52,8 @@ lib/xine/plugins/xineplug_decode_mpeg2.la
|
|||
lib/xine/plugins/xineplug_decode_mpeg2.so
|
||||
lib/xine/plugins/xineplug_decode_spu.la
|
||||
lib/xine/plugins/xineplug_decode_spu.so
|
||||
lib/xine/plugins/xineplug_decode_spucc.la
|
||||
lib/xine/plugins/xineplug_decode_spucc.so
|
||||
lib/xine/plugins/xineplug_decode_sputext.la
|
||||
lib/xine/plugins/xineplug_decode_sputext.so
|
||||
%%HAVE_VORBIS%%lib/xine/plugins/xineplug_decode_vorbis.la
|
||||
|
@ -147,6 +149,15 @@ share/doc/xine/xine-lib-API/html/structxine__t.html
|
|||
share/doc/xine/xine-lib-API/html/xine_8h-source.html
|
||||
share/doc/xine/xine-lib-API/html/xine_8h.html
|
||||
share/doc/xine/xine-lib-API/html/xine_logo.png
|
||||
share/locale/fr/LC_MESSAGES/xine-lib.mo
|
||||
share/xine/fonts/cc-16.xinefont.gz
|
||||
share/xine/fonts/cc-20.xinefont.gz
|
||||
share/xine/fonts/cc-24.xinefont.gz
|
||||
share/xine/fonts/cc-32.xinefont.gz
|
||||
share/xine/fonts/cci-16.xinefont.gz
|
||||
share/xine/fonts/cci-20.xinefont.gz
|
||||
share/xine/fonts/cci-24.xinefont.gz
|
||||
share/xine/fonts/cci-32.xinefont.gz
|
||||
share/xine/fonts/cetus-16.xinefont.gz
|
||||
share/xine/fonts/cetus-20.xinefont.gz
|
||||
share/xine/fonts/cetus-24.xinefont.gz
|
||||
|
|
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= xine
|
||||
PORTVERSION= 0.9.7
|
||||
PORTVERSION= 0.9.8
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://xine.sourceforge.net/files/ \
|
||||
${MASTER_SITE_SOURCEFORGE}
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (xine-ui-0.9.7.tar.gz) = 60e79e052c9c694001e1ed1d480a6bca
|
||||
MD5 (xine-ui-0.9.8.tar.gz) = 35ede263e540db5a3e125255c4433945
|
||||
|
|
|
@ -1,11 +1,13 @@
|
|||
bin/aaxine
|
||||
bin/xine
|
||||
share/doc/xine-ui/FAQ
|
||||
bin/xine-bugreport
|
||||
bin/xine-check
|
||||
share/doc/xine-ui/FAQ_en
|
||||
share/doc/xine-ui/FAQ_es
|
||||
share/doc/xine-ui/FAQ_fr
|
||||
share/doc/xine-ui/FAQ_it
|
||||
share/doc/xine-ui/FAQ_pl
|
||||
share/doc/xine-ui/README
|
||||
share/doc/xine-ui/README.config_en
|
||||
share/doc/xine-ui/README.corba
|
||||
share/doc/xine-ui/README.divx4
|
||||
share/doc/xine-ui/README.dxr3
|
||||
|
@ -15,7 +17,7 @@ share/doc/xine-ui/README.irix
|
|||
share/doc/xine-ui/README.mrl
|
||||
share/doc/xine-ui/README.solaris
|
||||
share/doc/xine-ui/README.syncfb
|
||||
share/doc/xine-ui/README.xinerc
|
||||
share/doc/xine-ui/README_en
|
||||
share/doc/xine-ui/README_es
|
||||
share/doc/xine-ui/README_it
|
||||
share/doc/xine-ui/README_pl
|
||||
|
@ -25,6 +27,8 @@ share/locale/es/LC_MESSAGES/xine-ui.mo
|
|||
share/locale/es/LC_MESSAGES/xitk.mo
|
||||
share/locale/fr/LC_MESSAGES/xine-ui.mo
|
||||
share/locale/fr/LC_MESSAGES/xitk.mo
|
||||
share/locale/pt_BR/LC_MESSAGES/xine-ui.mo
|
||||
share/locale/pt_BR/LC_MESSAGES/xitk.mo
|
||||
share/xine/desktop/xine.desktop
|
||||
share/xine/desktop/xine.wmconfig
|
||||
share/xine/desktop/xine.xpm
|
||||
|
@ -32,7 +36,60 @@ share/xine/desktop/xine_16x16.png
|
|||
share/xine/desktop/xine_22x22.png
|
||||
share/xine/desktop/xine_32x32.png
|
||||
share/xine/desktop/xine_48x48.png
|
||||
share/xine/scripts/xineshot
|
||||
share/xine/skins/cloudy/ComBox.png
|
||||
share/xine/skins/cloudy/ComDismiss.png
|
||||
share/xine/skins/cloudy/ComLetters.png
|
||||
share/xine/skins/cloudy/ComScrollArrowDown.png
|
||||
share/xine/skins/cloudy/ComScrollArrowUp.png
|
||||
share/xine/skins/cloudy/ComScrollBg.png
|
||||
share/xine/skins/cloudy/ComScrollPad.png
|
||||
share/xine/skins/cloudy/CtlBg.png
|
||||
share/xine/skins/cloudy/CtlSkinItem.png
|
||||
share/xine/skins/cloudy/CtlSkinScrollBg.png
|
||||
share/xine/skins/cloudy/CtlSliderBg.png
|
||||
share/xine/skins/cloudy/CtlSliderPad.png
|
||||
share/xine/skins/cloudy/MainAutoButton.png
|
||||
share/xine/skins/cloudy/MainBg.png
|
||||
share/xine/skins/cloudy/MainClose.png
|
||||
share/xine/skins/cloudy/MainCtlBtn.png
|
||||
share/xine/skins/cloudy/MainEject.png
|
||||
share/xine/skins/cloudy/MainFullScreen.png
|
||||
share/xine/skins/cloudy/MainMrlBtn.png
|
||||
share/xine/skins/cloudy/MainMute.png
|
||||
share/xine/skins/cloudy/MainNext.png
|
||||
share/xine/skins/cloudy/MainPause.png
|
||||
share/xine/skins/cloudy/MainPlBtn.png
|
||||
share/xine/skins/cloudy/MainPlay.png
|
||||
share/xine/skins/cloudy/MainPlayFast.png
|
||||
share/xine/skins/cloudy/MainPlaySlow.png
|
||||
share/xine/skins/cloudy/MainPower.png
|
||||
share/xine/skins/cloudy/MainPrev.png
|
||||
share/xine/skins/cloudy/MainSetup.png
|
||||
share/xine/skins/cloudy/MainSliderBg.png
|
||||
share/xine/skins/cloudy/MainSliderPad.png
|
||||
share/xine/skins/cloudy/MainSmallArrowDown.png
|
||||
share/xine/skins/cloudy/MainSmallArrowUp.png
|
||||
share/xine/skins/cloudy/MainSnapshot.png
|
||||
share/xine/skins/cloudy/MainStop.png
|
||||
share/xine/skins/cloudy/MainVolumeBg.png
|
||||
share/xine/skins/cloudy/MainVolumePad.png
|
||||
share/xine/skins/cloudy/MrlBg.png
|
||||
share/xine/skins/cloudy/MrlItem.png
|
||||
share/xine/skins/cloudy/MrlPlay.png
|
||||
share/xine/skins/cloudy/MrlSelect.png
|
||||
share/xine/skins/cloudy/PlAdd.png
|
||||
share/xine/skins/cloudy/PlBg.png
|
||||
share/xine/skins/cloudy/PlDelete.png
|
||||
share/xine/skins/cloudy/PlDeleteAll.png
|
||||
share/xine/skins/cloudy/PlInputText.png
|
||||
share/xine/skins/cloudy/PlItem.png
|
||||
share/xine/skins/cloudy/PlMoveDown.png
|
||||
share/xine/skins/cloudy/PlMoveUp.png
|
||||
share/xine/skins/cloudy/PlPlay.png
|
||||
share/xine/skins/cloudy/fat.pcf.gz
|
||||
share/xine/skins/cloudy/fonts.dir
|
||||
share/xine/skins/cloudy/skinconfig
|
||||
share/xine/skins/cloudy/smooth.pcf.gz
|
||||
share/xine/skins/lcd/arrowdn.png
|
||||
share/xine/skins/lcd/arrowup.png
|
||||
share/xine/skins/lcd/bg.png
|
||||
|
@ -82,6 +139,55 @@ share/xine/skins/lcd/stop.png
|
|||
share/xine/skins/lcd/tool.png
|
||||
share/xine/skins/lcd/volumebg.png
|
||||
share/xine/skins/lcd/volumepad.png
|
||||
share/xine/skins/mp2k/autoplay_btn.png
|
||||
share/xine/skins/mp2k/bg.png
|
||||
share/xine/skins/mp2k/cam_btn.png
|
||||
share/xine/skins/mp2k/close_btn.png
|
||||
share/xine/skins/mp2k/control.png
|
||||
share/xine/skins/mp2k/ctl_sk_item.png
|
||||
share/xine/skins/mp2k/ctl_sk_slidbg.png
|
||||
share/xine/skins/mp2k/ctl_slidbg.png
|
||||
share/xine/skins/mp2k/ctl_slidpad.png
|
||||
share/xine/skins/mp2k/ctrl_btn.png
|
||||
share/xine/skins/mp2k/eject_btn.png
|
||||
share/xine/skins/mp2k/enlarge_btn.png
|
||||
share/xine/skins/mp2k/fast_btn.png
|
||||
share/xine/skins/mp2k/letters.png
|
||||
share/xine/skins/mp2k/letters2.png
|
||||
share/xine/skins/mp2k/letters3.png
|
||||
share/xine/skins/mp2k/letters4.png
|
||||
share/xine/skins/mp2k/menu_btn.png
|
||||
share/xine/skins/mp2k/mrl_btn.png
|
||||
share/xine/skins/mp2k/mrlbrowser.png
|
||||
share/xine/skins/mp2k/mute_btn.png
|
||||
share/xine/skins/mp2k/next_btn.png
|
||||
share/xine/skins/mp2k/pause_btn.png
|
||||
share/xine/skins/mp2k/pl_btn.png
|
||||
share/xine/skins/mp2k/pl_btn2.png
|
||||
share/xine/skins/mp2k/pl_erasemany.png
|
||||
share/xine/skins/mp2k/pl_eraseone.png
|
||||
share/xine/skins/mp2k/pl_input.png
|
||||
share/xine/skins/mp2k/pl_item_btn.png
|
||||
share/xine/skins/mp2k/pl_movedn.png
|
||||
share/xine/skins/mp2k/pl_moveup.png
|
||||
share/xine/skins/mp2k/pl_slidbg.png
|
||||
share/xine/skins/mp2k/pl_sliddn.png
|
||||
share/xine/skins/mp2k/pl_slidpad.png
|
||||
share/xine/skins/mp2k/pl_slidup.png
|
||||
share/xine/skins/mp2k/play_btn.png
|
||||
share/xine/skins/mp2k/playlist.png
|
||||
share/xine/skins/mp2k/point_btn.png
|
||||
share/xine/skins/mp2k/prev_btn.png
|
||||
share/xine/skins/mp2k/reduce_btn.png
|
||||
share/xine/skins/mp2k/select_btn.png
|
||||
share/xine/skins/mp2k/setup_btn.png
|
||||
share/xine/skins/mp2k/skinconfig
|
||||
share/xine/skins/mp2k/slider_bg.png
|
||||
share/xine/skins/mp2k/slider_pad.png
|
||||
share/xine/skins/mp2k/slow_btn.png
|
||||
share/xine/skins/mp2k/stop_btn.png
|
||||
share/xine/skins/mp2k/volumebg.png
|
||||
share/xine/skins/mp2k/volumepad.png
|
||||
share/xine/skins/pitt/arrowdn.png
|
||||
share/xine/skins/pitt/arrowup.png
|
||||
share/xine/skins/pitt/bg.png
|
||||
|
@ -192,10 +298,11 @@ share/xine/skins/xinetic/skinconfig
|
|||
@dirrm man/fr
|
||||
@dirrm man/pl/man1
|
||||
@dirrm man/pl
|
||||
@dirrm share/xine/skins/cloudy
|
||||
@dirrm share/xine/skins/lcd
|
||||
@dirrm share/xine/skins/mp2k
|
||||
@dirrm share/xine/skins/pitt
|
||||
@dirrm share/xine/skins/xinetic
|
||||
@dirrm share/xine/scripts
|
||||
@dirrm share/xine/desktop
|
||||
@unexec rmdir %D/share/idl 2>/dev/null || true
|
||||
@unexec rmdir %D/share/xine/skins 2>/dev/null || true
|
||||
|
|
|
@ -6,8 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= xine
|
||||
PORTVERSION= 0.9.7
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 0.9.8
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://xine.sourceforge.net/files/ \
|
||||
${MASTER_SITE_SOURCEFORGE}
|
||||
|
@ -19,10 +18,13 @@ MAINTAINER= nobutaka@FreeBSD.org
|
|||
|
||||
BUILD_DEPENDS= ${LOCALBASE}/lib/libavcodec.a:${PORTSDIR}/graphics/ffmpeg
|
||||
LIB_DEPENDS= a52.0:${PORTSDIR}/audio/liba52 \
|
||||
aa.1:${PORTSDIR}/graphics/aalib
|
||||
aa.1:${PORTSDIR}/graphics/aalib \
|
||||
intl.1:${PORTSDIR}/devel/gettext
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-lib-${PORTVERSION}
|
||||
CONFIGURE_ARGS= --with-w32-path=${LOCALBASE}/lib/win32
|
||||
CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include LIBS=-L${LOCALBASE}/lib
|
||||
|
||||
USE_AUTOMAKE= yes
|
||||
USE_GMAKE= yes
|
||||
USE_X_PREFIX= yes
|
||||
|
@ -72,41 +74,9 @@ PLIST_SUB+= HAVE_OGG=""
|
|||
PLIST_SUB+= HAVE_OGG="@comment "
|
||||
.endif
|
||||
|
||||
# DVD input plugin for xine-0.9.7 is not available yet.
|
||||
.if 0
|
||||
.if defined(WITH_CSS)
|
||||
# http://members.home.nl/mphm.janssen/linuxvideo/linuxvideo.html
|
||||
MASTER_SITES+= http://members.home.nl/mphm.janssen/files/
|
||||
DISTFILES+= ${PLUGIN_CSS}${EXTRACT_SUFX}
|
||||
|
||||
LIB_DEPENDS+= dvdcss.0:${PORTSDIR}/graphics/libdvdcss
|
||||
|
||||
PLUGIN_CSS= dvd-plugin-${PLUGIN_CSS_VERSION}
|
||||
PLUGIN_CSS_VERSION= 0.4
|
||||
.endif
|
||||
.endif
|
||||
|
||||
pre-everything::
|
||||
.if 0
|
||||
.if !defined(WITH_CSS)
|
||||
@${ECHO_MSG} "====>"
|
||||
@${ECHO_MSG} "====> To enable css support, define WITH_CSS"
|
||||
@${ECHO_MSG} "====>"
|
||||
.endif
|
||||
.endif
|
||||
|
||||
# XXX: To avoid internal error in gcc.
|
||||
post-configure:
|
||||
@${SED} -e "s/-funroll-loops//" < ${WRKSRC}/src/libw32dll/wine/Makefile > ${WRKSRC}/src/libw32dll/wine/Makefile.tmp
|
||||
@${MV} ${WRKSRC}/src/libw32dll/wine/Makefile.tmp ${WRKSRC}/src/libw32dll/wine/Makefile
|
||||
|
||||
post-patch:
|
||||
.if 0
|
||||
.if defined(WITH_CSS)
|
||||
@${PERL} -pi.orig -e 's/(xineplug_inp_dvd_la_LDFLAGS = -avoid-version -module)/\1 -ldvdcss/' \
|
||||
${WRKSRC}/src/input/Makefile.am
|
||||
@${CP} -f ${WRKDIR}/${PLUGIN_CSS}/*.[ch] ${WRKSRC}/src/input
|
||||
.endif
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (xine-lib-0.9.7.tar.gz) = 52f3cfdcf2066d36746fb98b735b0fbc
|
||||
MD5 (xine-lib-0.9.8.tar.gz) = d8fc9b30e15b50af8ab7552bbda7aeda
|
||||
|
|
|
@ -1,12 +1,12 @@
|
|||
--- src/xine-engine/Makefile.am.orig Sun Oct 21 09:06:25 2001
|
||||
+++ src/xine-engine/Makefile.am Sun Oct 21 09:07:43 2001
|
||||
@@ -18,8 +18,7 @@
|
||||
-lm
|
||||
--- src/xine-engine/Makefile.am.orig Sat Dec 29 02:31:25 2001
|
||||
+++ src/xine-engine/Makefile.am Thu Jan 24 13:42:50 2002
|
||||
@@ -15,8 +15,7 @@
|
||||
libxine_la_LIBADD = $(THREAD_LIBS) $(DYNAMIC_LD_LIBS) @INTLLIBS@ -lm -lz
|
||||
|
||||
libxine_la_LDFLAGS = \
|
||||
- -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
|
||||
- -release $(LT_RELEASE)
|
||||
- -release $(LT_RELEASE)
|
||||
+ -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)
|
||||
|
||||
include_HEADERS = buffer.h metronom.h configfile.h \
|
||||
monitor.h cpu_accel.h attributes.h utils.h \
|
||||
audio_out.h resample.h video_out.h xine_internal.h spu_decoder.h \
|
||||
|
|
|
@ -6,7 +6,6 @@ include/xine/buffer.h
|
|||
include/xine/configfile.h
|
||||
include/xine/demux.h
|
||||
include/xine/dxr3_video_out.h
|
||||
include/xine/dxr3_vo_encoder.h
|
||||
include/xine/events.h
|
||||
include/xine/input_plugin.h
|
||||
include/xine/lrb.h
|
||||
|
@ -20,6 +19,7 @@ include/xine/video_out.h
|
|||
include/xine/video_out_x11.h
|
||||
include/xine/video_overlay.h
|
||||
include/xine/xine_internal.h
|
||||
include/xine/xineintl.h
|
||||
include/xine/xineutils.h
|
||||
include/xine.h
|
||||
lib/libxine.la
|
||||
|
@ -52,6 +52,8 @@ lib/xine/plugins/xineplug_decode_mpeg2.la
|
|||
lib/xine/plugins/xineplug_decode_mpeg2.so
|
||||
lib/xine/plugins/xineplug_decode_spu.la
|
||||
lib/xine/plugins/xineplug_decode_spu.so
|
||||
lib/xine/plugins/xineplug_decode_spucc.la
|
||||
lib/xine/plugins/xineplug_decode_spucc.so
|
||||
lib/xine/plugins/xineplug_decode_sputext.la
|
||||
lib/xine/plugins/xineplug_decode_sputext.so
|
||||
%%HAVE_VORBIS%%lib/xine/plugins/xineplug_decode_vorbis.la
|
||||
|
@ -147,6 +149,15 @@ share/doc/xine/xine-lib-API/html/structxine__t.html
|
|||
share/doc/xine/xine-lib-API/html/xine_8h-source.html
|
||||
share/doc/xine/xine-lib-API/html/xine_8h.html
|
||||
share/doc/xine/xine-lib-API/html/xine_logo.png
|
||||
share/locale/fr/LC_MESSAGES/xine-lib.mo
|
||||
share/xine/fonts/cc-16.xinefont.gz
|
||||
share/xine/fonts/cc-20.xinefont.gz
|
||||
share/xine/fonts/cc-24.xinefont.gz
|
||||
share/xine/fonts/cc-32.xinefont.gz
|
||||
share/xine/fonts/cci-16.xinefont.gz
|
||||
share/xine/fonts/cci-20.xinefont.gz
|
||||
share/xine/fonts/cci-24.xinefont.gz
|
||||
share/xine/fonts/cci-32.xinefont.gz
|
||||
share/xine/fonts/cetus-16.xinefont.gz
|
||||
share/xine/fonts/cetus-20.xinefont.gz
|
||||
share/xine/fonts/cetus-24.xinefont.gz
|
||||
|
|
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= xine
|
||||
PORTVERSION= 0.9.7
|
||||
PORTVERSION= 0.9.8
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://xine.sourceforge.net/files/ \
|
||||
${MASTER_SITE_SOURCEFORGE}
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (xine-ui-0.9.7.tar.gz) = 60e79e052c9c694001e1ed1d480a6bca
|
||||
MD5 (xine-ui-0.9.8.tar.gz) = 35ede263e540db5a3e125255c4433945
|
||||
|
|
|
@ -1,11 +1,13 @@
|
|||
bin/aaxine
|
||||
bin/xine
|
||||
share/doc/xine-ui/FAQ
|
||||
bin/xine-bugreport
|
||||
bin/xine-check
|
||||
share/doc/xine-ui/FAQ_en
|
||||
share/doc/xine-ui/FAQ_es
|
||||
share/doc/xine-ui/FAQ_fr
|
||||
share/doc/xine-ui/FAQ_it
|
||||
share/doc/xine-ui/FAQ_pl
|
||||
share/doc/xine-ui/README
|
||||
share/doc/xine-ui/README.config_en
|
||||
share/doc/xine-ui/README.corba
|
||||
share/doc/xine-ui/README.divx4
|
||||
share/doc/xine-ui/README.dxr3
|
||||
|
@ -15,7 +17,7 @@ share/doc/xine-ui/README.irix
|
|||
share/doc/xine-ui/README.mrl
|
||||
share/doc/xine-ui/README.solaris
|
||||
share/doc/xine-ui/README.syncfb
|
||||
share/doc/xine-ui/README.xinerc
|
||||
share/doc/xine-ui/README_en
|
||||
share/doc/xine-ui/README_es
|
||||
share/doc/xine-ui/README_it
|
||||
share/doc/xine-ui/README_pl
|
||||
|
@ -25,6 +27,8 @@ share/locale/es/LC_MESSAGES/xine-ui.mo
|
|||
share/locale/es/LC_MESSAGES/xitk.mo
|
||||
share/locale/fr/LC_MESSAGES/xine-ui.mo
|
||||
share/locale/fr/LC_MESSAGES/xitk.mo
|
||||
share/locale/pt_BR/LC_MESSAGES/xine-ui.mo
|
||||
share/locale/pt_BR/LC_MESSAGES/xitk.mo
|
||||
share/xine/desktop/xine.desktop
|
||||
share/xine/desktop/xine.wmconfig
|
||||
share/xine/desktop/xine.xpm
|
||||
|
@ -32,7 +36,60 @@ share/xine/desktop/xine_16x16.png
|
|||
share/xine/desktop/xine_22x22.png
|
||||
share/xine/desktop/xine_32x32.png
|
||||
share/xine/desktop/xine_48x48.png
|
||||
share/xine/scripts/xineshot
|
||||
share/xine/skins/cloudy/ComBox.png
|
||||
share/xine/skins/cloudy/ComDismiss.png
|
||||
share/xine/skins/cloudy/ComLetters.png
|
||||
share/xine/skins/cloudy/ComScrollArrowDown.png
|
||||
share/xine/skins/cloudy/ComScrollArrowUp.png
|
||||
share/xine/skins/cloudy/ComScrollBg.png
|
||||
share/xine/skins/cloudy/ComScrollPad.png
|
||||
share/xine/skins/cloudy/CtlBg.png
|
||||
share/xine/skins/cloudy/CtlSkinItem.png
|
||||
share/xine/skins/cloudy/CtlSkinScrollBg.png
|
||||
share/xine/skins/cloudy/CtlSliderBg.png
|
||||
share/xine/skins/cloudy/CtlSliderPad.png
|
||||
share/xine/skins/cloudy/MainAutoButton.png
|
||||
share/xine/skins/cloudy/MainBg.png
|
||||
share/xine/skins/cloudy/MainClose.png
|
||||
share/xine/skins/cloudy/MainCtlBtn.png
|
||||
share/xine/skins/cloudy/MainEject.png
|
||||
share/xine/skins/cloudy/MainFullScreen.png
|
||||
share/xine/skins/cloudy/MainMrlBtn.png
|
||||
share/xine/skins/cloudy/MainMute.png
|
||||
share/xine/skins/cloudy/MainNext.png
|
||||
share/xine/skins/cloudy/MainPause.png
|
||||
share/xine/skins/cloudy/MainPlBtn.png
|
||||
share/xine/skins/cloudy/MainPlay.png
|
||||
share/xine/skins/cloudy/MainPlayFast.png
|
||||
share/xine/skins/cloudy/MainPlaySlow.png
|
||||
share/xine/skins/cloudy/MainPower.png
|
||||
share/xine/skins/cloudy/MainPrev.png
|
||||
share/xine/skins/cloudy/MainSetup.png
|
||||
share/xine/skins/cloudy/MainSliderBg.png
|
||||
share/xine/skins/cloudy/MainSliderPad.png
|
||||
share/xine/skins/cloudy/MainSmallArrowDown.png
|
||||
share/xine/skins/cloudy/MainSmallArrowUp.png
|
||||
share/xine/skins/cloudy/MainSnapshot.png
|
||||
share/xine/skins/cloudy/MainStop.png
|
||||
share/xine/skins/cloudy/MainVolumeBg.png
|
||||
share/xine/skins/cloudy/MainVolumePad.png
|
||||
share/xine/skins/cloudy/MrlBg.png
|
||||
share/xine/skins/cloudy/MrlItem.png
|
||||
share/xine/skins/cloudy/MrlPlay.png
|
||||
share/xine/skins/cloudy/MrlSelect.png
|
||||
share/xine/skins/cloudy/PlAdd.png
|
||||
share/xine/skins/cloudy/PlBg.png
|
||||
share/xine/skins/cloudy/PlDelete.png
|
||||
share/xine/skins/cloudy/PlDeleteAll.png
|
||||
share/xine/skins/cloudy/PlInputText.png
|
||||
share/xine/skins/cloudy/PlItem.png
|
||||
share/xine/skins/cloudy/PlMoveDown.png
|
||||
share/xine/skins/cloudy/PlMoveUp.png
|
||||
share/xine/skins/cloudy/PlPlay.png
|
||||
share/xine/skins/cloudy/fat.pcf.gz
|
||||
share/xine/skins/cloudy/fonts.dir
|
||||
share/xine/skins/cloudy/skinconfig
|
||||
share/xine/skins/cloudy/smooth.pcf.gz
|
||||
share/xine/skins/lcd/arrowdn.png
|
||||
share/xine/skins/lcd/arrowup.png
|
||||
share/xine/skins/lcd/bg.png
|
||||
|
@ -82,6 +139,55 @@ share/xine/skins/lcd/stop.png
|
|||
share/xine/skins/lcd/tool.png
|
||||
share/xine/skins/lcd/volumebg.png
|
||||
share/xine/skins/lcd/volumepad.png
|
||||
share/xine/skins/mp2k/autoplay_btn.png
|
||||
share/xine/skins/mp2k/bg.png
|
||||
share/xine/skins/mp2k/cam_btn.png
|
||||
share/xine/skins/mp2k/close_btn.png
|
||||
share/xine/skins/mp2k/control.png
|
||||
share/xine/skins/mp2k/ctl_sk_item.png
|
||||
share/xine/skins/mp2k/ctl_sk_slidbg.png
|
||||
share/xine/skins/mp2k/ctl_slidbg.png
|
||||
share/xine/skins/mp2k/ctl_slidpad.png
|
||||
share/xine/skins/mp2k/ctrl_btn.png
|
||||
share/xine/skins/mp2k/eject_btn.png
|
||||
share/xine/skins/mp2k/enlarge_btn.png
|
||||
share/xine/skins/mp2k/fast_btn.png
|
||||
share/xine/skins/mp2k/letters.png
|
||||
share/xine/skins/mp2k/letters2.png
|
||||
share/xine/skins/mp2k/letters3.png
|
||||
share/xine/skins/mp2k/letters4.png
|
||||
share/xine/skins/mp2k/menu_btn.png
|
||||
share/xine/skins/mp2k/mrl_btn.png
|
||||
share/xine/skins/mp2k/mrlbrowser.png
|
||||
share/xine/skins/mp2k/mute_btn.png
|
||||
share/xine/skins/mp2k/next_btn.png
|
||||
share/xine/skins/mp2k/pause_btn.png
|
||||
share/xine/skins/mp2k/pl_btn.png
|
||||
share/xine/skins/mp2k/pl_btn2.png
|
||||
share/xine/skins/mp2k/pl_erasemany.png
|
||||
share/xine/skins/mp2k/pl_eraseone.png
|
||||
share/xine/skins/mp2k/pl_input.png
|
||||
share/xine/skins/mp2k/pl_item_btn.png
|
||||
share/xine/skins/mp2k/pl_movedn.png
|
||||
share/xine/skins/mp2k/pl_moveup.png
|
||||
share/xine/skins/mp2k/pl_slidbg.png
|
||||
share/xine/skins/mp2k/pl_sliddn.png
|
||||
share/xine/skins/mp2k/pl_slidpad.png
|
||||
share/xine/skins/mp2k/pl_slidup.png
|
||||
share/xine/skins/mp2k/play_btn.png
|
||||
share/xine/skins/mp2k/playlist.png
|
||||
share/xine/skins/mp2k/point_btn.png
|
||||
share/xine/skins/mp2k/prev_btn.png
|
||||
share/xine/skins/mp2k/reduce_btn.png
|
||||
share/xine/skins/mp2k/select_btn.png
|
||||
share/xine/skins/mp2k/setup_btn.png
|
||||
share/xine/skins/mp2k/skinconfig
|
||||
share/xine/skins/mp2k/slider_bg.png
|
||||
share/xine/skins/mp2k/slider_pad.png
|
||||
share/xine/skins/mp2k/slow_btn.png
|
||||
share/xine/skins/mp2k/stop_btn.png
|
||||
share/xine/skins/mp2k/volumebg.png
|
||||
share/xine/skins/mp2k/volumepad.png
|
||||
share/xine/skins/pitt/arrowdn.png
|
||||
share/xine/skins/pitt/arrowup.png
|
||||
share/xine/skins/pitt/bg.png
|
||||
|
@ -192,10 +298,11 @@ share/xine/skins/xinetic/skinconfig
|
|||
@dirrm man/fr
|
||||
@dirrm man/pl/man1
|
||||
@dirrm man/pl
|
||||
@dirrm share/xine/skins/cloudy
|
||||
@dirrm share/xine/skins/lcd
|
||||
@dirrm share/xine/skins/mp2k
|
||||
@dirrm share/xine/skins/pitt
|
||||
@dirrm share/xine/skins/xinetic
|
||||
@dirrm share/xine/scripts
|
||||
@dirrm share/xine/desktop
|
||||
@unexec rmdir %D/share/idl 2>/dev/null || true
|
||||
@unexec rmdir %D/share/xine/skins 2>/dev/null || true
|
||||
|
|
Loading…
Reference in a new issue