- Update to 0.8.0.1
PR: ports/114052 Submitted by: Rene Ladan <r.c.ladan@gmail.com> Approved by: maintainer timeout (2 weeks)
This commit is contained in:
parent
7d30acf3df
commit
7b8e17ec95
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=196616
8 changed files with 90 additions and 30 deletions
|
@ -6,8 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= fuse
|
||||
PORTVERSION= 0.7.0
|
||||
PORTREVISION= 5
|
||||
PORTVERSION= 0.8.0.1
|
||||
CATEGORIES= emulators
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= fuse-emulator
|
||||
|
@ -15,7 +14,7 @@ MASTER_SITE_SUBDIR= fuse-emulator
|
|||
MAINTAINER= kemm@in-line.ru
|
||||
COMMENT= Free Unix (Sinclair ZX-)Spectrum Emulator
|
||||
|
||||
LIB_DEPENDS= spectrum.4:${PORTSDIR}/emulators/libspectrum \
|
||||
LIB_DEPENDS= spectrum.5:${PORTSDIR}/emulators/libspectrum \
|
||||
765.4:${PORTSDIR}/emulators/lib765 \
|
||||
xml2.5:${PORTSDIR}/textproc/libxml2 \
|
||||
png.5:${PORTSDIR}/graphics/png
|
||||
|
@ -27,6 +26,7 @@ USE_PERL5_BUILD= yes
|
|||
USE_GETOPT_LONG= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --with-plus3-disk-prefix=${LOCALBASE}
|
||||
CFLAGS+= `${LOCALBASE}/bin/libpng-config --I_opts` -I${LOCALBASE}/include
|
||||
|
||||
OPTIONS= SMALLMEM "Low memory compile needed" off \
|
||||
GTK "Use GTK1 user interface" off \
|
||||
|
@ -37,7 +37,11 @@ OPTIONS= SMALLMEM "Low memory compile needed" off \
|
|||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
# adjust location of manual page
|
||||
CONFIGURE_ARGS+= --mandir=${PREFIX}/man
|
||||
|
||||
.if defined(WITH_SMALLMEM)
|
||||
BROKEN= Does not compile
|
||||
CONFIGURE_ARGS+= --enable-smallmem
|
||||
.endif
|
||||
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (fuse-0.7.0.tar.gz) = d81ad260cd6a8dd533af01ee6a5f9527
|
||||
SHA256 (fuse-0.7.0.tar.gz) = 266177f8d9cd8959fc2b4358b56afb343f98fb56e5d4da352589ac1d49ce32e7
|
||||
SIZE (fuse-0.7.0.tar.gz) = 872031
|
||||
MD5 (fuse-0.8.0.1.tar.gz) = 34f85578c64d94ebf0cca309f837d502
|
||||
SHA256 (fuse-0.8.0.1.tar.gz) = 6e00199c7025ec47885002928237fd408444ace399e58146016a1c0b8d11f4b0
|
||||
SIZE (fuse-0.8.0.1.tar.gz) = 1270551
|
||||
|
|
18
emulators/fuse/files/patch-log2.c
Normal file
18
emulators/fuse/files/patch-log2.c
Normal file
|
@ -0,0 +1,18 @@
|
|||
--- sound/sdlsound.c.orig 2007-04-27 23:18:27.000000000 +0200
|
||||
+++ sound/sdlsound.c 2007-07-29 14:54:59.000000000 +0200
|
||||
@@ -52,6 +52,15 @@
|
||||
/* Records sound writer status information */
|
||||
static int audio_output_started;
|
||||
|
||||
+/*
|
||||
+ * log2() seems to be a Linuxism, define it here as it is absent in libm
|
||||
+ */
|
||||
+double
|
||||
+log2(double x)
|
||||
+{
|
||||
+ return log(x)/log(2);
|
||||
+}
|
||||
+
|
||||
int
|
||||
sound_lowlevel_init( const char *device, int *freqptr, int *stereoptr )
|
||||
{
|
|
@ -1,13 +0,0 @@
|
|||
--- sound.c.orig Sun Jul 4 20:52:15 2004
|
||||
+++ sound.c Sun Apr 15 19:31:45 2007
|
||||
@@ -58,8 +58,8 @@
|
||||
int sound_stereo_ay_abc=0; /* (AY stereo) true for ABC stereo, else ACB */
|
||||
int sound_stereo_ay_narrow=0; /* (AY stereo) true for narrow AY st. sep. */
|
||||
|
||||
-static int sound_stereo_ay=0; /* local copy of settings_current.stereo_ay */
|
||||
-static int sound_stereo_beeper=0; /* and settings_current.stereo_beeper */
|
||||
+int sound_stereo_ay=0; /* local copy of settings_current.stereo_ay */
|
||||
+int sound_stereo_beeper=0; /* and settings_current.stereo_beeper */
|
||||
|
||||
|
||||
/* assume all three tone channels together match the beeper volume (ish).
|
11
emulators/fuse/files/patch-svgadisplay.c
Normal file
11
emulators/fuse/files/patch-svgadisplay.c
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- ui/svga/svgadisplay.c.orig 2007-07-29 14:53:05.000000000 +0200
|
||||
+++ ui/svga/svgadisplay.c 2007-07-29 14:53:45.000000000 +0200
|
||||
@@ -258,7 +258,7 @@
|
||||
scaled_x = scale * x; scaled_y = scale * y;
|
||||
|
||||
/* Create scaled image */
|
||||
- scaler_proc16( (libspectrum_byte*)&svgadisplay_image[y][x], display_pitch,
|
||||
+ scaler_proc16( (libspectrum_byte*)&svgadisplay_image[y][x], svgadisplay_pitch,
|
||||
(libspectrum_byte*)&scaled_image[scaled_y][scaled_x],
|
||||
scaled_pitch, w, h );
|
||||
|
22
emulators/fuse/files/patch-svgakeyboard.c
Normal file
22
emulators/fuse/files/patch-svgakeyboard.c
Normal file
|
@ -0,0 +1,22 @@
|
|||
--- ui/svga/svgakeyboard.c.orig 2007-07-29 14:59:10.000000000 +0200
|
||||
+++ ui/svga/svgakeyboard.c 2007-07-29 15:10:19.000000000 +0200
|
||||
@@ -75,7 +75,8 @@
|
||||
if( fuse_keysym == INPUT_KEY_NONE ) return 0;
|
||||
|
||||
fuse_event.type = INPUT_EVENT_KEYPRESS;
|
||||
- fuse_event.types.key.key = fuse_keysym;
|
||||
+ fuse_event.types.key.native_key = fuse_keysym;
|
||||
+ fuse_event.types.key.spectrum_key = fuse_keysym;
|
||||
|
||||
return input_event( &fuse_event );
|
||||
}
|
||||
@@ -91,7 +92,8 @@
|
||||
if( fuse_keysym == INPUT_KEY_NONE ) return 0;
|
||||
|
||||
fuse_event.type = INPUT_EVENT_KEYRELEASE;
|
||||
- fuse_event.types.key.key = fuse_keysym;
|
||||
+ fuse_event.types.key.native_key = fuse_keysym;
|
||||
+ fuse_event.types.key.spectrum_key = fuse_keysym;
|
||||
|
||||
return input_event( &fuse_event );
|
||||
}
|
11
emulators/fuse/files/patch-svgakeysyms.c
Normal file
11
emulators/fuse/files/patch-svgakeysyms.c
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- ui/svga/keysyms.c.orig 2007-07-29 15:36:40.000000000 +0200
|
||||
+++ ui/svga/keysyms.c 2007-07-29 15:36:48.000000000 +0200
|
||||
@@ -116,7 +116,7 @@
|
||||
{ SCANCODE_CURSORBLOCKLEFT, INPUT_KEY_Left },
|
||||
{ SCANCODE_CURSORBLOCKRIGHT, INPUT_KEY_Right },
|
||||
{ SCANCODE_INSERT, INPUT_KEY_Insert },
|
||||
- { SCANCODE_DELETE, INPUT_KEY_Delete },
|
||||
+ { SCANCODE_REMOVE, INPUT_KEY_Delete },
|
||||
{ SCANCODE_HOME, INPUT_KEY_Home },
|
||||
{ SCANCODE_END, INPUT_KEY_End },
|
||||
{ SCANCODE_PAGEUP, INPUT_KEY_Page_Up },
|
|
@ -10,8 +10,12 @@ bin/fuse
|
|||
%%DATADIR%%/256s-3.rom
|
||||
%%DATADIR%%/48.rom
|
||||
%%DATADIR%%/cassette.bmp
|
||||
%%DATADIR%%/disk_plus3.z80
|
||||
%%DATADIR%%/disk_plus3.szx
|
||||
%%DATADIR%%/fuse.font
|
||||
%%DATADIR%%/if1-1.rom
|
||||
%%DATADIR%%/if1-2.rom
|
||||
%%DATADIR%%/keyboard.scr
|
||||
%%DATADIR%%/microdrive.bmp
|
||||
%%DATADIR%%/plus2-0.rom
|
||||
%%DATADIR%%/plus2-1.rom
|
||||
%%DATADIR%%/plus3-0.rom
|
||||
|
@ -25,16 +29,19 @@ bin/fuse
|
|||
%%DATADIR%%/plus3e-3.rom
|
||||
%%DATADIR%%/se-0.rom
|
||||
%%DATADIR%%/se-1.rom
|
||||
%%DATADIR%%/tape_128.z80
|
||||
%%DATADIR%%/tape_16.z80
|
||||
%%DATADIR%%/tape_2048.z80
|
||||
%%DATADIR%%/tape_2068.z80
|
||||
%%DATADIR%%/tape_48.z80
|
||||
%%DATADIR%%/tape_pentagon.z80
|
||||
%%DATADIR%%/tape_plus2.z80
|
||||
%%DATADIR%%/tape_plus2a.z80
|
||||
%%DATADIR%%/tape_plus3.z80
|
||||
%%DATADIR%%/tape_scorpion.z80
|
||||
%%DATADIR%%/tape_128.szx
|
||||
%%DATADIR%%/tape_16.szx
|
||||
%%DATADIR%%/tape_2048.szx
|
||||
%%DATADIR%%/tape_2068.szx
|
||||
%%DATADIR%%/tape_48.szx
|
||||
%%DATADIR%%/tape_pentagon.szx
|
||||
%%DATADIR%%/tape_plus2.szx
|
||||
%%DATADIR%%/tape_plus2a.szx
|
||||
%%DATADIR%%/tape_plus3.szx
|
||||
%%DATADIR%%/tape_plus3e.szx
|
||||
%%DATADIR%%/tape_se.szx
|
||||
%%DATADIR%%/tape_scorpion.szx
|
||||
%%DATADIR%%/tape_ts2068.szx
|
||||
%%DATADIR%%/tc2048.rom
|
||||
%%DATADIR%%/tc2068-0.rom
|
||||
%%DATADIR%%/tc2068-1.rom
|
||||
|
|
Loading…
Reference in a new issue