- Update to 0.5.4

This commit is contained in:
Dmitry Marakasov 2018-12-07 19:48:32 +00:00
parent ab2e58be07
commit 7b93d4230f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=486887
3 changed files with 40 additions and 16 deletions

View file

@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= easyrpg-player
PORTVERSION= 0.5.3
PORTREVISION= 4
PORTVERSION= 0.5.4
CATEGORIES= games
MAINTAINER= amdmi3@FreeBSD.org
@ -12,16 +11,22 @@ COMMENT= RPG Maker 2000/2003 and EasyRPG games interpreter
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libfreetype.so:print/freetype2 \
LIB_DEPENDS= liblcf.so:games/liblcf \
libpng.so:graphics/png \
liblcf.so:games/liblcf \
libfreetype.so:print/freetype2 \
libharfbuzz.so:print/harfbuzz \
libmpg123.so:audio/mpg123 \
libvorbis.so:audio/libvorbis \
libsndfile.so:audio/libsndfile \
libxmp.so:audio/libxmp \
libspeexdsp.so:audio/speexdsp \
libopusfile.so:audio/opusfile
libmpg123.so:audio/mpg123 \
libsndfile.so:audio/libsndfile \
libvorbis.so:audio/libvorbis \
libogg.so:audio/libogg \
libopusfile.so:audio/opusfile \
libopus.so:audio/opus \
libWildMidi.so:audio/wildmidi \
libxmp.so:audio/libxmp
# these come from liblcf
LIB_DEPENDS+= libicui18n.so:devel/icu \
libexpat.so:textproc/expat2
BUILD_DEPENDS= asciidoc:textproc/asciidoc \
${LOCALBASE}/include/boost/shared_ptr.hpp:devel/boost-libs
@ -29,16 +34,21 @@ USE_GITHUB= yes
GH_ACCOUNT= EasyRPG
GH_PROJECT= Player
USES= autoreconf compiler:c++11-lib gmake libtool localbase pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-bash-completion-dir=${PREFIX}/share/bash-completion/completions
USES= cmake compiler:c++11-lib pkgconfig
CMAKE_ARGS= -DCMAKE_INSTALL_MANDIR=man \
-DPLAYER_AUDIO_BACKEND=SDL2_mixer
USE_XORG= pixman
USE_SDL= sdl2 mixer2
PORTDOCS= AUTHORS README
PORTDOCS= AUTHORS.md README.md
OPTIONS_DEFINE= DOCS
post-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/share/bash-completion/completions
${INSTALL_DATA} ${WRKSRC}/resources/unix/bash-completion/easyrpg-player \
${STAGEDIR}${PREFIX}/share/bash-completion/completions/
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1508950823
SHA256 (EasyRPG-Player-0.5.3_GH0.tar.gz) = f820f4fadd7fb944f9f3ea80594349b7c5f78c2011ab0adf179aeeef9d0a1449
SIZE (EasyRPG-Player-0.5.3_GH0.tar.gz) = 4151265
TIMESTAMP = 1541171708
SHA256 (EasyRPG-Player-0.5.4_GH0.tar.gz) = a504d873114706f01ff77145669938d41a977bbc3656c4a5aa431e7e6a1d21e4
SIZE (EasyRPG-Player-0.5.4_GH0.tar.gz) = 5393488

View file

@ -0,0 +1,14 @@
--- CMakeLists.txt.orig 2018-10-27 09:58:54 UTC
+++ CMakeLists.txt
@@ -419,9 +419,9 @@ if(NOT A2X_EXECUTABLE STREQUAL "A2X_EXEC
DEPENDS resources/${MAN_NAME}.adoc
COMMENT "(Re-)building manpage ${MAN_NAME}"
VERBATIM)
- if(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
+ if(UNIX)
add_custom_target(man ALL DEPENDS resources/${MAN_NAME})
- install(FILES resources/${MAN_NAME} DESTINATION share/man/man6)
+ install(FILES resources/${MAN_NAME} DESTINATION ${CMAKE_INSTALL_MANDIR}/man6)
else()
add_custom_target(man DEPENDS resources/${MAN_NAME})
endif()