- Update to version 1.8

PR:		58963
Submitted by:	Ports Fury
This commit is contained in:
Kirill Ponomarev 2003-11-05 16:08:58 +00:00
parent 0c75d0b9d2
commit 7bb43374b6
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=93158
8 changed files with 67 additions and 48 deletions

View file

@ -6,8 +6,7 @@
#
PORTNAME= gnofract4d
PORTVERSION= 1.7
PORTREVISION= 1
PORTVERSION= 1.8
CATEGORIES= graphics gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@ -16,20 +15,11 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Weird GNOME fractal generator
USE_X_PREFIX= yes
USE_GNOME= gnomeprefix gnomehack gnomelibs
USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GNOME= gnomehack gnomeprefix gnometarget libgnomeui
USE_GMAKE= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --enable-compile-warnings=no
INSTALLS_SHLIB= yes
.include <bsd.port.pre.mk>
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|^CXXFLAGS =.* -D|CXXFLAGS = @CXXFLAGS@ -D|g ; \
s|gnofract4d_helpdir)/images|gnofract4d_helpdir)|g'
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (gnofract4d-1.7.tar.gz) = a585048b1c4348f02142b515adad4bfc
MD5 (gnofract4d-1.8.tar.gz) = 20c38e07ca6f7863fcffe32cd96c7f52

View file

@ -0,0 +1,10 @@
--- configure.orig Mon Oct 27 03:26:03 2003
+++ configure Sun Nov 2 22:36:00 2003
@@ -7325,6 +7325,7 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'

View file

@ -0,0 +1,11 @@
--- libfract4d/Makefile.in.orig Mon Oct 27 03:26:16 2003
+++ libfract4d/Makefile.in Sun Nov 2 22:29:23 2003
@@ -123,7 +123,7 @@
lib_LTLIBRARIES = libfract4d.la
-CXXFLAGS = -O3 -ffast-math -Wall $(GNOFRACT4D_CFLAGS)
+CXXFLAGS = @CXXFLAGS@ $(GNOFRACT4D_CFLAGS)
libfract4d_la_SOURCES = \
fract4d.h \

View file

@ -1,5 +1,5 @@
--- src/colorizer.cpp.orig Mon Feb 3 07:51:41 2003
+++ src/colorizer.cpp Fri Oct 17 22:34:56 2003
--- libfract4d/colorizer.cpp.orig Fri Mar 28 12:11:16 2003
+++ libfract4d/colorizer.cpp Sun Nov 2 23:04:34 2003
@@ -2,6 +2,7 @@
#include "iterFunc.h"
#include "io.h"

View file

@ -0,0 +1,10 @@
--- libfract4d/iterFunc.cpp.orig Mon Oct 27 12:34:10 2003
+++ libfract4d/iterFunc.cpp Sun Nov 2 23:06:05 2003
@@ -3,6 +3,7 @@
#include "iterFunc.h"
#include "io.h"
+#include <cassert>
#include <cstddef>
#include <iostream>
#include <iomanip> // setprecision

View file

@ -0,0 +1,9 @@
--- src/image.cpp.orig Mon Mar 17 15:00:25 2003
+++ src/image.cpp Sun Nov 2 23:13:40 2003
@@ -1,4 +1,5 @@
-#include <stdlib.h>
+#include <cassert>
+#include <cstdlib>
#include "image.h"
#include "iterFunc.h"

View file

@ -1,36 +1,20 @@
bin/gnofract4d
lib/libfract4d.a
lib/libfract4d.so
lib/libfract4d.so.0
share/gnome/apps/Graphics/gnofract4d.desktop
share/gnome/gnofract4d/compiler_template.cpp
share/gnome/gnofract4d/pointFunc.h
share/gnome/gnofract4d/state.h
share/gnome/help/gnofract4d/C/about.html
share/gnome/help/gnofract4d/C/docbook.css
share/gnome/help/gnofract4d/C/filemenu.html
share/gnome/help/gnofract4d/C/gnofract4d.html
share/gnome/help/gnofract4d/C/hybrid.png
share/gnome/help/gnofract4d/C/julia_perturbed.png
share/gnome/help/gnofract4d/C/julia_standard.png
share/gnome/help/gnofract4d/C/mandelbrot_perturbed.png
share/gnome/help/gnofract4d/C/mandelbrot_standard.png
share/gnome/help/gnofract4d/C/maths.html
share/gnome/help/gnofract4d/C/mouse.html
share/gnome/help/gnofract4d/C/preferences.html
share/gnome/help/gnofract4d/C/stylesheet-images/caution.gif
share/gnome/help/gnofract4d/C/stylesheet-images/home.gif
share/gnome/help/gnofract4d/C/stylesheet-images/important.gif
share/gnome/help/gnofract4d/C/stylesheet-images/next.gif
share/gnome/help/gnofract4d/C/stylesheet-images/note.gif
share/gnome/help/gnofract4d/C/stylesheet-images/prev.gif
share/gnome/help/gnofract4d/C/stylesheet-images/tip.gif
share/gnome/help/gnofract4d/C/stylesheet-images/toc-blank.gif
share/gnome/help/gnofract4d/C/stylesheet-images/toc-minus.gif
share/gnome/help/gnofract4d/C/stylesheet-images/toc-plus.gif
share/gnome/help/gnofract4d/C/stylesheet-images/up.gif
share/gnome/help/gnofract4d/C/stylesheet-images/warning.gif
share/gnome/help/gnofract4d/C/toolbar.html
share/gnome/help/gnofract4d/C/topic.dat
share/gnome/help/gnofract4d/C/types.html
share/gnome/help/gnofract4d/C/xw_plane.png
share/gnome/help/gnofract4d/C/figures/hybrid.png
share/gnome/help/gnofract4d/C/figures/julia_perturbed.png
share/gnome/help/gnofract4d/C/figures/julia_standard.png
share/gnome/help/gnofract4d/C/figures/mandelbrot_perturbed.png
share/gnome/help/gnofract4d/C/figures/mandelbrot_standard.png
share/gnome/help/gnofract4d/C/figures/xw_plane.png
share/gnome/help/gnofract4d/C/figures/xz_plane.png
share/gnome/help/gnofract4d/C/figures/yz_plane.png
share/gnome/help/gnofract4d/C/gnofract4d-manual.xml
share/gnome/maps/gnofract4d/4zebbowx.map
share/gnome/maps/gnofract4d/Digiorg1.map
share/gnome/maps/gnofract4d/Gallet02.map
@ -109,12 +93,17 @@ share/gnome/maps/gnofract4d/vooon.map
share/gnome/maps/gnofract4d/wild.map
share/gnome/maps/gnofract4d/wine.map
share/gnome/maps/gnofract4d/world.map
@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/gnofract4d/gnofract4d-manual-C.omf 2>/dev/null || true
share/gnome/omf/gnofract4d/gnofract4d-manual-C.omf
@exec scrollkeeper-install -q %D/share/gnome/omf/gnofract4d/gnofract4d-manual-C.omf 2>/dev/null || true
share/gnome/pixmaps/gnofract4d/deepen_now.png
share/gnome/pixmaps/gnofract4d/explorer_mode.png
share/gnome/pixmaps/gnofract4d/gnofract4d-logo.png
@dirrm share/gnome/pixmaps/gnofract4d
@dirrm share/gnome/omf/gnofract4d
@dirrm share/gnome/maps/gnofract4d
@dirrm share/gnome/maps
@dirrm share/gnome/help/gnofract4d/C/stylesheet-images
@dirrm share/gnome/help/gnofract4d/C/figures
@dirrm share/gnome/help/gnofract4d/C
@dirrm share/gnome/help/gnofract4d
@dirrm share/gnome/gnofract4d