Update to 3.91
PR: 33945 Submitted by: maintainer
This commit is contained in:
parent
0c69cabb3c
commit
7c14c477fe
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=53223
5 changed files with 25 additions and 71 deletions
|
@ -6,35 +6,21 @@
|
|||
#
|
||||
|
||||
PORTNAME= lame
|
||||
PORTVERSION= 3.70
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 3.91
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
|
||||
ftp://lame.sourceforge.net/pub/
|
||||
MASTER_SITE_SUBDIR= lame
|
||||
DISTNAME= ${PORTNAME}${PORTVERSION}
|
||||
|
||||
MAINTAINER= yoshiaki@kt.rim.or.jp
|
||||
|
||||
USE_GMAKE= yes
|
||||
WANT_GTK= yes
|
||||
ALL_TARGET= lame
|
||||
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
USE_GTK= yes
|
||||
CONFIGURE_ARGS= --enable-nasm
|
||||
|
||||
MAN1= lame.1
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(HAVE_GTK)
|
||||
USE_GTK= yes
|
||||
.endif
|
||||
|
||||
do-install:
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/lame ${PREFIX}/bin
|
||||
@${INSTALL_MAN} ${WRKSRC}/doc/man/lame.1 ${PREFIX}/man/man1
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${PREFIX}/share/doc/lame
|
||||
@${INSTALL_DATA} ${WRKSRC}/doc/html/*.html \
|
||||
${WRKSRC}/doc/html/*.css ${PREFIX}/share/doc/lame
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (lame3.70.tar.gz) = 44e29880a21535a7c935046a531e15af
|
||||
MD5 (lame-3.91.tar.gz) = c09562caa789c946403f6f9661592ee5
|
||||
|
|
|
@ -1,27 +0,0 @@
|
|||
--- Makefile.orig Sat Jul 1 15:31:35 2000
|
||||
+++ Makefile Sat Jul 1 15:36:07 2000
|
||||
@@ -11,8 +11,8 @@
|
||||
|
||||
# defaults:
|
||||
PGM = lame
|
||||
-CC = gcc
|
||||
-CC_OPTS = -O
|
||||
+CC ?= gcc
|
||||
+CC_OPTS = ${CFLAGS}
|
||||
GTK =
|
||||
GTKLIBS =
|
||||
SNDLIB = -DLAMESNDFILE
|
||||
@@ -136,8 +136,10 @@
|
||||
##########################################################################
|
||||
ifeq ($(UNAME),FreeBSD)
|
||||
# remove if you do not have GTK or do not want the GTK frame analyzer
|
||||
- GTK = -DHAVEGTK `gtk12-config --cflags`
|
||||
- GTKLIBS = `gtk12-config --libs`
|
||||
+ifdef HAVE_GTK
|
||||
+ GTK = -DHAVEGTK `$(GTK_CONFIG) --cflags`
|
||||
+ GTKLIBS = `$(GTK_CONFIG) --libs`
|
||||
+endif
|
||||
# Comment out next 2 lines if you want to remove VBR histogram capability
|
||||
BRHIST_SWITCH = -DBRHIST
|
||||
LIBTERMCAP = -lncurses
|
||||
|
|
@ -1,11 +0,0 @@
|
|||
--- lame.c.orig Thu Apr 20 01:48:22 2000
|
||||
+++ lame.c Thu Apr 20 01:49:04 2000
|
||||
@@ -1196,7 +1196,7 @@
|
||||
/*
|
||||
* Disable floating point exepctions
|
||||
*/
|
||||
-#ifdef __FreeBSD__
|
||||
+#if defined(__FreeBSD__) && !defined(__alpha__)
|
||||
# include <floatingpoint.h>
|
||||
{
|
||||
/* seet floating point mask to the Linux default */
|
|
@ -1,12 +1,18 @@
|
|||
bin/lame
|
||||
%%PORTDOCS%%share/doc/lame/contributors.html
|
||||
%%PORTDOCS%%share/doc/lame/examples.html
|
||||
%%PORTDOCS%%share/doc/lame/history.html
|
||||
%%PORTDOCS%%share/doc/lame/id3.html
|
||||
%%PORTDOCS%%share/doc/lame/index.html
|
||||
%%PORTDOCS%%share/doc/lame/lame.css
|
||||
%%PORTDOCS%%share/doc/lame/node5.html
|
||||
%%PORTDOCS%%share/doc/lame/node6.html
|
||||
%%PORTDOCS%%share/doc/lame/node7.html
|
||||
%%PORTDOCS%%share/doc/lame/switchs.html
|
||||
include/lame/lame.h
|
||||
lib/libmp3lame.a
|
||||
lib/libmp3lame.la
|
||||
lib/libmp3lame.so
|
||||
lib/libmp3lame.so.0
|
||||
%%PORTDOCS%%share/doc/lame/html/basic.html
|
||||
%%PORTDOCS%%share/doc/lame/html/contributors.html
|
||||
%%PORTDOCS%%share/doc/lame/html/examples.html
|
||||
%%PORTDOCS%%share/doc/lame/html/history.html
|
||||
%%PORTDOCS%%share/doc/lame/html/id3.html
|
||||
%%PORTDOCS%%share/doc/lame/html/index.html
|
||||
%%PORTDOCS%%share/doc/lame/html/lame.css
|
||||
%%PORTDOCS%%share/doc/lame/html/modes.html
|
||||
%%PORTDOCS%%share/doc/lame/html/node6.html
|
||||
%%PORTDOCS%%share/doc/lame/html/switchs.html
|
||||
%%PORTDOCS%%@dirrm share/doc/lame/html
|
||||
%%PORTDOCS%%@dirrm share/doc/lame
|
||||
|
|
Loading…
Reference in a new issue