Don't hardcode STRIP unconditionally [1]. Instead, respect the build
environment's settings. Add a DEBUG option. Based on patch from: tobik [1] Requested by: Leander Schäfer <info netocean de>
This commit is contained in:
parent
fd2cbd68b6
commit
7c59a19689
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=384865
2 changed files with 18 additions and 1 deletions
|
@ -64,7 +64,7 @@ OPENLDAP_SHLIB_MAJOR= 2
|
|||
OPENLDAP_SHLIB_MINOR= 10.3
|
||||
OPENLDAP_MAJOR= ${DISTVERSION:R}
|
||||
|
||||
OPTIONS_DEFINE= FETCH GSSAPI
|
||||
OPTIONS_DEFINE= DEBUG FETCH GSSAPI
|
||||
|
||||
FETCH_DESC= Enable fetch(3) support
|
||||
GSSAPI_DESC= With GSSAPI support (implies SASL support)
|
||||
|
@ -276,6 +276,12 @@ CONFIGURE_ARGS+= --enable-constraint=${OVERLAY_ENABLE}
|
|||
CONFIGURE_ARGS+= --enable-dds=${OVERLAY_ENABLE}
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MDEBUG}
|
||||
CONFIGURE_ARGS+= --enable-debug=yes
|
||||
.endif
|
||||
|
||||
MAKE_ENV+= STRIP=${STRIP}
|
||||
|
||||
.if ${PORT_OPTIONS:MDEREF}
|
||||
CONFIGURE_ARGS+= --enable-deref=${OVERLAY_ENABLE}
|
||||
.endif
|
||||
|
|
11
net/openldap24-server/files/patch-build__top.mk
Normal file
11
net/openldap24-server/files/patch-build__top.mk
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- build/top.mk.orig 2014-09-18 18:48:49.000000000 -0700
|
||||
+++ build/top.mk 2015-04-27 12:02:52.234737749 -0700
|
||||
@@ -59,8 +59,6 @@
|
||||
INSTALL_DATA = $(INSTALL) -m 644
|
||||
INSTALL_SCRIPT = $(INSTALL)
|
||||
|
||||
-STRIP = -s
|
||||
-
|
||||
LINT = lint
|
||||
5LINT = 5lint
|
||||
|
Loading…
Reference in a new issue