Update to 0.3.2
PR: 92228 Submitted by: Andreas Kohn <andreas@syndrom23.de> (maintainer)
This commit is contained in:
parent
b429ce7a35
commit
7c5a29f918
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=154367
8 changed files with 32 additions and 50 deletions
|
@ -6,8 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= notification-daemon
|
||||
PORTVERSION= 0.2.4
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 0.3.2
|
||||
CATEGORIES= deskutils gnome
|
||||
MASTER_SITES= http://www.galago-project.org/files/releases/source/notification-daemon/
|
||||
|
||||
|
@ -15,18 +14,17 @@ MAINTAINER= andreas@syndrom23.de
|
|||
COMMENT= Send small notifications to your desktop
|
||||
|
||||
LIB_DEPENDS= dbus-1.2:${PORTSDIR}/devel/dbus \
|
||||
notify.0:${PORTSDIR}/devel/libnotify \
|
||||
sexy:${PORTSDIR}/x11-toolkits/libsexy
|
||||
sexy:${PORTSDIR}/x11-toolkits/libsexy \
|
||||
popt.0:${PORTSDIR}/devel/popt
|
||||
|
||||
USE_GNOME= gnomehack gnometarget intlhack gtk20
|
||||
USE_GNOME= gnomehack gnometarget intlhack glib20 gtk20 gconf2
|
||||
USE_AUTOTOOLS= libtool:15
|
||||
USE_GMAKE= yes
|
||||
USE_X_PREFIX= yes
|
||||
GNU_CONFIGURE= yes
|
||||
GCONF_SCHEMAS= notification-daemon.schemas
|
||||
CONFIGURE_ARGS= --with-dbus-services=${PREFIX}/share/dbus-1/services
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} < 500000
|
||||
EXTRA_PATCHES= ${FILESDIR}/extra-patch-src-main.cc
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (notification-daemon-0.2.4.tar.gz) = d5c9739f60d04fe17dc64cf16f91d043
|
||||
SHA256 (notification-daemon-0.2.4.tar.gz) = 7b7e0d6e00d90f9cfbc4cf9fd09bdbeaa8db1cd4e81e93ca6a1604f35e3dde54
|
||||
SIZE (notification-daemon-0.2.4.tar.gz) = 159190
|
||||
MD5 (notification-daemon-0.3.2.tar.gz) = ff55cfeecebad1e40ab58fa96820d5ff
|
||||
SHA256 (notification-daemon-0.3.2.tar.gz) = 82ac3c60beb16534afd92f99bf2b8605113c5e813300486098d8988d811d6d72
|
||||
SIZE (notification-daemon-0.3.2.tar.gz) = 377518
|
||||
|
|
|
@ -1,10 +0,0 @@
|
|||
--- src/main.cc.orig Wed Aug 10 10:43:56 2005
|
||||
+++ src/main.cc Wed Aug 31 23:25:36 2005
|
||||
@@ -622,7 +622,6 @@
|
||||
int
|
||||
main(int argc, char **argv)
|
||||
{
|
||||
- std::set_terminate(__gnu_cxx::__verbose_terminate_handler);
|
||||
DBusError error;
|
||||
|
||||
dbus_error_init(&error);
|
|
@ -1,10 +0,0 @@
|
|||
--- src/Notification.hh.orig Thu Jul 28 10:50:44 2005
|
||||
+++ src/Notification.hh Wed Aug 31 23:14:48 2005
|
||||
@@ -31,6 +31,7 @@
|
||||
#include "Hint.hh"
|
||||
#include "Image.hh"
|
||||
|
||||
+#include <sys/types.h>
|
||||
|
||||
/*
|
||||
* This class represents a notification. It's a class rather than a struct
|
|
@ -1,3 +1,10 @@
|
|||
etc/dbus-1/system.d/notification-daemon.conf
|
||||
lib/notification-daemon/engines/libbubble.a
|
||||
lib/notification-daemon/engines/libbubble.so
|
||||
lib/notification-daemon/engines/libbubble.so.0
|
||||
lib/notification-daemon/engines/libstandard.a
|
||||
lib/notification-daemon/engines/libstandard.so
|
||||
lib/notification-daemon/engines/libstandard.so.0
|
||||
libexec/notification-daemon
|
||||
share/dbus-1/services/org.freedesktop.Notifications.service
|
||||
share/dbus-1/services/notification-daemon.service
|
||||
@dirrm lib/notification-daemon/engines
|
||||
@dirrm lib/notification-daemon
|
||||
|
|
|
@ -6,8 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= libnotify
|
||||
PORTVERSION= 0.2.2
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 0.3.2
|
||||
CATEGORIES= devel gnome
|
||||
MASTER_SITES= http://www.galago-project.org/files/releases/source/libnotify/
|
||||
|
||||
|
@ -17,22 +16,19 @@ COMMENT= A library for desktop notifications
|
|||
LIB_DEPENDS= dbus-1.2:${PORTSDIR}/devel/dbus \
|
||||
popt.0:${PORTSDIR}/devel/popt
|
||||
|
||||
USE_GNOME= gnomehack gnometarget intlhack glib20
|
||||
USE_GNOME= gnomehack gnometarget intlhack glib20 gtk20
|
||||
USE_GMAKE= yes
|
||||
USE_AUTOTOOLS= libtool:15
|
||||
INSTALLS_SHLIB= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} < 500000
|
||||
|
||||
USE_REINPLACE= yes
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e 's|tests||' ${WRKSRC}/Makefile.in
|
||||
|
||||
.if ${OSVERSION} < 500000
|
||||
@${REINPLACE_CMD} -e 's|tests||' ${WRKSRC}/Makefile.in
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (libnotify-0.2.2.tar.gz) = cbf2ff0a8a62eb1f310367a0a174a273
|
||||
SHA256 (libnotify-0.2.2.tar.gz) = 3a7710fc937f4fb06cb78f3dc9e9fdc64032e61ed4f9f3f317ba3c4c11d3646e
|
||||
SIZE (libnotify-0.2.2.tar.gz) = 316520
|
||||
MD5 (libnotify-0.3.2.tar.gz) = 12bcb4949e4be783a2db388e9155afac
|
||||
SHA256 (libnotify-0.3.2.tar.gz) = 1e35a969e498546613e2ef9bf01d6de90526eedc9e0ecf81930637b0ab82f285
|
||||
SIZE (libnotify-0.3.2.tar.gz) = 337224
|
||||
|
|
|
@ -1,7 +1,8 @@
|
|||
bin/notify-send
|
||||
include/libnotify/notification.h
|
||||
include/libnotify/notify.h
|
||||
lib/libnotify.a
|
||||
lib/libnotify.so
|
||||
lib/libnotify.so.0
|
||||
lib/libnotify.so.1
|
||||
libdata/pkgconfig/libnotify.pc
|
||||
@dirrm include/libnotify
|
||||
|
|
Loading…
Reference in a new issue