. Upgrade to 3.0.7, fixes Apache support
. GNU make is now required for compilation . USE_REINPLACE and REINPLACE_CMD instead of sed -i . make makesum to compute file size . config files in etc/resin3 PR: 64844 Submitted by: Jean-Baptiste Quenot <jb.quenot@caraldi.com> (maintainer)
This commit is contained in:
parent
3676196422
commit
7c5f2d9a14
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=105626
9 changed files with 86 additions and 119 deletions
|
@ -8,7 +8,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= resin
|
||||
PORTVERSION= 3.0.6
|
||||
PORTVERSION= 3.0.7
|
||||
CATEGORIES= www java
|
||||
MASTER_SITES= http://www.caucho.com/download/
|
||||
|
||||
|
@ -17,7 +17,9 @@ COMMENT= Resin, a Java-based Application Server, 3.x branch
|
|||
|
||||
USE_JAVA= 1.2+
|
||||
HAS_CONFIGURE= yes
|
||||
USE_GMAKE= yes
|
||||
USE_PERL5= yes
|
||||
USE_REINPLACE= yes
|
||||
|
||||
# Customizable settings
|
||||
RUNASUSER?= www
|
||||
|
@ -53,7 +55,7 @@ REPLACE_FILES= ${FILESDIR}/pkg-install \
|
|||
${WRKSRC}/conf/resin.conf \
|
||||
${WRKSRC}/bin/wrapper.pl.in \
|
||||
${FILESDIR}/resin.sh.in
|
||||
COPYDIRS= doc lib webapps xsl
|
||||
COPYDIRS= doc lib libexec webapps
|
||||
|
||||
# Pass JAVA_HOME as determined by bsd.java.mk
|
||||
CONFIGURE_ARGS+= --with-java-home=${JAVA_HOME}
|
||||
|
@ -108,7 +110,7 @@ SUBSTITUTIONS= -e "s|%%APP_HOME%%|${APP_HOME}|g" \
|
|||
|
||||
post-patch:
|
||||
.for FILE in ${REINPLACE_FILES}
|
||||
@${SED} -i bak ${SUBSTITUTIONS} ${FILE}
|
||||
@${REINPLACE_CMD} ${SUBSTITUTIONS} ${FILE}
|
||||
.endfor
|
||||
.for FILE in ${REPLACE_FILES}
|
||||
@${SED} ${SUBSTITUTIONS} ${FILE} > ${WRKDIR}/`basename ${FILE}`
|
||||
|
@ -121,7 +123,15 @@ defined(WITH_APACHE) && (${WITH_APACHE} == yes || ${WITH_APACHE} == YES))
|
|||
in the Apache configuration file, where you should also \
|
||||
add a line to specify the location of the Resin configuration \
|
||||
server, for example: | fmt -w 80 >> ${PKGMESSAGE}
|
||||
@${ECHO_CMD} ResinConfigServer localhost 6802 >> ${PKGMESSAGE}
|
||||
@${ECHO_CMD} >> ${PKGMESSAGE}
|
||||
@${ECHO_CMD} "<IfModule mod_caucho.c>" >> ${PKGMESSAGE}
|
||||
.if (defined(WITH_APACHE2) && (${WITH_APACHE2} == yes || ${WITH_APACHE2} == YES))
|
||||
@${ECHO_CMD} " ResinConfigServer localhost 6802" >> ${PKGMESSAGE}
|
||||
.endif
|
||||
.if (defined(WITH_APACHE) && (${WITH_APACHE} == yes || ${WITH_APACHE} == YES))
|
||||
@${ECHO_CMD} " CauchoConfigFile ${PREFIX}/etc/${APP_NAME}/resin.xml" >> ${PKGMESSAGE}
|
||||
.endif
|
||||
@${ECHO_CMD} "</IfModule>" >> ${PKGMESSAGE}
|
||||
.endif
|
||||
@${MV} ${WRKDIR}/wrapper.pl.in ${WRKSRC}/bin/wrapper.pl.in
|
||||
|
||||
|
|
|
@ -1 +1,2 @@
|
|||
MD5 (resin-3.0.6.tar.gz) = 032fc45db04945a95cb080fda1b8f216
|
||||
MD5 (resin-3.0.7.tar.gz) = 337043c5e20341409628002afa263cdd
|
||||
SIZE (resin-3.0.7.tar.gz) = 5332182
|
||||
|
|
|
@ -3,29 +3,31 @@
|
|||
set -e
|
||||
|
||||
warning() {
|
||||
echo "Kept %%PREFIX%%/etc/%%APP_NAME%%.xml intact from previous installation, please diff"
|
||||
echo "against %%APP_NAME%%.xml-dist"
|
||||
echo "Kept %%PREFIX%%/etc/%%APP_NAME%%/resin.xml intact from previous installation, please diff"
|
||||
echo "against %%PREFIX%%/etc/%%APP_NAME%%/resin.xml-dist for merging changes"
|
||||
}
|
||||
|
||||
# Install config file only if none is already there
|
||||
if test -e %%PREFIX%%/etc/%%APP_NAME%%.xml && \
|
||||
! cmp -s %%WRKDIR%%/resin.conf %%PREFIX%%/etc/%%APP_NAME%%.xml ; then
|
||||
if test -e %%PREFIX%%/etc/%%APP_NAME%%/resin.xml && \
|
||||
! cmp -s %%WRKDIR%%/resin.conf %%PREFIX%%/etc/%%APP_NAME%%/resin.xml ; then
|
||||
echo
|
||||
echo "********************************************************************************"
|
||||
warning | fmt -w 80
|
||||
echo "********************************************************************************"
|
||||
echo
|
||||
else
|
||||
install %%WRKDIR%%/resin.conf %%PREFIX%%/etc/%%APP_NAME%%.xml
|
||||
echo Installed %%PREFIX%%/etc/%%APP_NAME%%.xml
|
||||
test -d %%PREFIX%%/etc/%%APP_NAME%% || mkdir %%PREFIX%%/etc/%%APP_NAME%%
|
||||
echo Created configuration directory %%PREFIX%%/etc/%%APP_NAME%%
|
||||
install %%WRKDIR%%/resin.conf %%PREFIX%%/etc/%%APP_NAME%%/resin.xml
|
||||
echo Installed %%PREFIX%%/etc/%%APP_NAME%%/resin.xml
|
||||
fi
|
||||
|
||||
# Install new config file with '-dist' appended
|
||||
install %%WRKDIR%%/resin.conf %%PREFIX%%/etc/%%APP_NAME%%.xml-dist
|
||||
echo Installed %%PREFIX%%/etc/%%APP_NAME%%.xml-dist
|
||||
install %%WRKDIR%%/resin.conf %%PREFIX%%/etc/%%APP_NAME%%/resin.xml-dist
|
||||
echo Installed %%PREFIX%%/etc/%%APP_NAME%%/resin.xml-dist
|
||||
|
||||
install %%WRKSRC%%/conf/app-default.xml %%PREFIX%%/etc/
|
||||
echo Installed %%PREFIX%%/etc/app-default.xml
|
||||
install %%WRKSRC%%/conf/app-default.xml %%PREFIX%%/etc/%%APP_NAME%%
|
||||
echo Installed %%PREFIX%%/etc/%%APP_NAME%%/app-default.xml
|
||||
|
||||
install %%WRKDIR%%/resin.sh.in %%PREFIX%%/etc/rc.d/%%APP_NAME%%.sh
|
||||
chmod 755 %%PREFIX%%/etc/rc.d/%%APP_NAME%%.sh
|
||||
|
@ -39,13 +41,13 @@ echo Created installation directory %%APP_HOME%%
|
|||
|
||||
list()
|
||||
{
|
||||
for dir in %%COPYDIRS%% libexec ; do
|
||||
for dir in %%COPYDIRS%% ; do
|
||||
( cd %%WRKSRC%% ; find $dir )
|
||||
done
|
||||
}
|
||||
|
||||
# Remove all empty dirs
|
||||
( cd %%WRKSRC%% && find %%COPYDIRS%% libexec -type d -empty -delete )
|
||||
( cd %%WRKSRC%% && find %%COPYDIRS%% -type d -empty -delete )
|
||||
|
||||
echo Installing in %%APP_HOME%%
|
||||
list | xargs tar -C %%WRKSRC%% -cf- | tar -C %%APP_HOME%% -xpf-
|
||||
|
|
|
@ -1,12 +1,12 @@
|
|||
--- src/c/plugin/apache/Makefile.in.orig Thu Nov 13 09:27:52 2003
|
||||
+++ src/c/plugin/apache/Makefile.in Thu Nov 13 09:28:36 2003
|
||||
--- src/c/plugin/apache/Makefile.in.orig Sun Mar 28 12:45:11 2004
|
||||
+++ src/c/plugin/apache/Makefile.in Sun Mar 28 12:47:59 2004
|
||||
@@ -29,8 +29,7 @@
|
||||
$(CC) -c $(INCLUDES) $(CFLAGS) $<
|
||||
|
||||
install :
|
||||
- sh install.sh -conf $(apache_conf) -libexec $(apache_libexec) \
|
||||
- -resin_home $(resin_home)
|
||||
+ %%APXS%% -i -a -n caucho mod_caucho.so
|
||||
|
||||
clean :
|
||||
- rm *.o *.lo *.la *.so
|
||||
$(CC) -c $(INCLUDES) $(CFLAGS) $<
|
||||
|
||||
install :
|
||||
- sh install.sh -conf $(apache_conf) -libexec $(apache_libexec) \
|
||||
- -resin_home $(resin_home)
|
||||
+ %%APXS%% -i -a -n caucho mod_caucho.so
|
||||
|
||||
clean :
|
||||
- rm *.o *.lo *.la *.so
|
||||
|
|
|
@ -1,12 +1,12 @@
|
|||
--- src/c/plugin/apache2/Makefile.in.orig Tue Sep 23 00:54:34 2003
|
||||
+++ src/c/plugin/apache2/Makefile.in Mon Nov 17 11:33:19 2003
|
||||
--- src/c/plugin/apache2/Makefile.in.orig Thu Mar 25 01:29:07 2004
|
||||
+++ src/c/plugin/apache2/Makefile.in Sun Mar 28 12:52:01 2004
|
||||
@@ -30,8 +30,7 @@
|
||||
$(CC) -c $(INCLUDES) $(CFLAGS) $<
|
||||
|
||||
install :
|
||||
- sh install.sh -conf $(apache_conf) -apache_dir $(apache_dir) \
|
||||
- -libexec $(apache_libexec) -resin_home $(resin_home)
|
||||
+ %%APXS%% -i -a -n caucho mod_caucho.so
|
||||
|
||||
clean :
|
||||
- rm *.o *.lo *.so
|
||||
$(CC) -c $(INCLUDES) $(CFLAGS) $<
|
||||
|
||||
install :
|
||||
- sh install.sh -conf $(apache_conf) -apache_dir $(apache_dir) \
|
||||
- -libexec $(apache_libexec) -resin_home $(resin_home)
|
||||
+ %%APXS%% -i -a -n caucho mod_caucho.so
|
||||
|
||||
clean :
|
||||
- rm *.o *.lo *.so
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
--- conf/resin.conf.orig Wed Jan 21 01:46:58 2004
|
||||
+++ conf/resin.conf Fri Jan 23 12:09:34 2004
|
||||
@@ -63,7 +63,7 @@
|
||||
</class-loader>
|
||||
--- conf/resin.conf.orig Thu Mar 25 01:28:47 2004
|
||||
+++ conf/resin.conf Sun Mar 28 13:07:28 2004
|
||||
@@ -67,7 +67,7 @@
|
||||
<keepalive-timeout>120s</keepalive-timeout>
|
||||
|
||||
<!-- The http port -->
|
||||
- <http id="" host="*" port="8080"/>
|
||||
|
@ -9,3 +9,21 @@
|
|||
|
||||
<!--
|
||||
- SSL port configuration:
|
||||
@@ -148,7 +148,7 @@
|
||||
- With another web server, like Apache, this can be commented out
|
||||
- because the web server will log this information.
|
||||
-->
|
||||
- <access-log path='logs/access.log'
|
||||
+ <access-log path='log/access.log'
|
||||
format='%h %l %u %t "%r" %s %b "%{Referer}i" "%{User-Agent}i"'
|
||||
rollover-period='1W'/>
|
||||
|
||||
@@ -176,7 +176,7 @@
|
||||
</host-default>
|
||||
|
||||
<!-- includes the web-app-default for default web-app behavior -->
|
||||
- <resin:import path="${resinHome}/conf/app-default.xml"/>
|
||||
+ <resin:import path="%%PREFIX%%/etc/%%APP_NAME%%/app-default.xml"/>
|
||||
|
||||
<!-- configures the default host, matching any host name -->
|
||||
<host id=''>
|
||||
|
|
|
@ -1,4 +1,6 @@
|
|||
Resin is now installed in %%APP_HOME%%. You may want to start it using the
|
||||
startup script installed as %%PREFIX%%/etc/rc.d/%%APP_NAME%%.sh, and then point
|
||||
Resin is now installed in %%APP_HOME%%
|
||||
|
||||
You may want to start it using the
|
||||
startup script installed as %%PREFIX%%/etc/rc.d/%%APP_NAME%%.sh and then point
|
||||
your web browser to the default home page at http://localhost:%%PORT%%/ to read
|
||||
the doc. Resin can be configured using %%PREFIX%%/etc/%%APP_NAME%%.xml.
|
||||
the doc. Resin configuration is located at %%PREFIX%%/etc/%%APP_NAME%%/resin.xml
|
||||
|
|
|
@ -15,7 +15,7 @@ fi
|
|||
|
||||
# Set some variables
|
||||
MYSELF=`basename $0`
|
||||
ARGS="-conf $PREFIX/etc/%%APP_NAME%%.xml \
|
||||
ARGS="-conf $PREFIX/etc/%%APP_NAME%%/resin.xml \
|
||||
-chdir \
|
||||
-name %%APP_NAME%% \
|
||||
-class com.caucho.server.resin.Resin \
|
||||
|
|
|
@ -1,36 +1,4 @@
|
|||
%%APP_NAME%%/doc/css/default.css
|
||||
%%APP_NAME%%/doc/images/apache_srun.gif
|
||||
%%APP_NAME%%/doc/images/appserver.gif
|
||||
%%APP_NAME%%/doc/images/background.gif
|
||||
%%APP_NAME%%/doc/images/backup.gif
|
||||
%%APP_NAME%%/doc/images/ball8.gif
|
||||
%%APP_NAME%%/doc/images/bean.gif
|
||||
%%APP_NAME%%/doc/images/bean1.gif
|
||||
%%APP_NAME%%/doc/images/caucho-white.jpg
|
||||
%%APP_NAME%%/doc/images/caucho.gif
|
||||
%%APP_NAME%%/doc/images/compiler.gif
|
||||
%%APP_NAME%%/doc/images/file.gif
|
||||
%%APP_NAME%%/doc/images/folder.gif
|
||||
%%APP_NAME%%/doc/images/hbleed.gif
|
||||
%%APP_NAME%%/doc/images/httpd.gif
|
||||
%%APP_NAME%%/doc/images/iis_srun.gif
|
||||
%%APP_NAME%%/doc/images/jndi_tree.gif
|
||||
%%APP_NAME%%/doc/images/jsp.gif
|
||||
%%APP_NAME%%/doc/images/left_background.gif
|
||||
%%APP_NAME%%/doc/images/logo.gif
|
||||
%%APP_NAME%%/doc/images/pixel.gif
|
||||
%%APP_NAME%%/doc/images/resin_powered.gif
|
||||
%%APP_NAME%%/doc/images/same_srun.gif
|
||||
%%APP_NAME%%/doc/images/script.gif
|
||||
%%APP_NAME%%/doc/images/srunc.gif
|
||||
%%APP_NAME%%/doc/images/sticky-sessions.gif
|
||||
%%APP_NAME%%/doc/images/style.gif
|
||||
%%APP_NAME%%/doc/images/webserver.gif
|
||||
%%APP_NAME%%/doc/images/website_srun.gif
|
||||
%%APP_NAME%%/doc/changes-1.xtp
|
||||
%%APP_NAME%%/doc/changes.xtp
|
||||
%%APP_NAME%%/doc/index.xtp
|
||||
%%APP_NAME%%/doc/toc.xml
|
||||
%%APP_NAME%%/doc/index.jsp
|
||||
%%APP_NAME%%/lib/dom.jar
|
||||
%%APP_NAME%%/lib/isorelax.jar
|
||||
%%APP_NAME%%/lib/jca-15.jar
|
||||
|
@ -42,54 +10,20 @@
|
|||
%%APP_NAME%%/lib/resin.jar
|
||||
%%APP_NAME%%/lib/webutil.jar
|
||||
%%APP_NAME%%/webapps/resin-doc.war
|
||||
%%APP_NAME%%/xsl/caucho/comment.xsl
|
||||
%%APP_NAME%%/xsl/caucho/contents.xsl
|
||||
%%APP_NAME%%/xsl/caucho/control.xsl
|
||||
%%APP_NAME%%/xsl/caucho/debug.xsl
|
||||
%%APP_NAME%%/xsl/caucho/defaultcopy.xsl
|
||||
%%APP_NAME%%/xsl/caucho/format.xsl
|
||||
%%APP_NAME%%/xsl/caucho/fun.xsl
|
||||
%%APP_NAME%%/xsl/caucho/href.xsl
|
||||
%%APP_NAME%%/xsl/caucho/include.xsl
|
||||
%%APP_NAME%%/xsl/caucho/newstyle.xsl
|
||||
%%APP_NAME%%/xsl/caucho/nodeinfo.xsl
|
||||
%%APP_NAME%%/xsl/caucho/toc.xsl
|
||||
%%APP_NAME%%/xsl/caucho/viewfile.xsl
|
||||
%%APP_NAME%%/xsl/caucho/weblog.xsl
|
||||
%%APP_NAME%%/xsl/js/caucho/defaultcopy.xsl
|
||||
%%APP_NAME%%/xsl/js/caucho/format.xsl
|
||||
%%APP_NAME%%/xsl/js/caucho/weblog.xsl
|
||||
%%APP_NAME%%/xsl/tools/indexer.xsl
|
||||
%%APP_NAME%%/xsl/caucho_default.xsl
|
||||
%%APP_NAME%%/xsl/caucho_header.xsl
|
||||
%%APP_NAME%%/xsl/caucho_subpage.xsl
|
||||
%%APP_NAME%%/xsl/default.xsl
|
||||
%%APP_NAME%%/xsl/doc_header.xsl
|
||||
%%APP_NAME%%/xsl/header.xsl
|
||||
%%APP_NAME%%/xsl/js_header.xsl
|
||||
%%APP_NAME%%/xsl/new_doc_header.xsl
|
||||
%%APP_NAME%%/xsl/search.xsl
|
||||
%%APP_NAME%%/xsl/subpage.xsl
|
||||
%%APP_NAME%%/libexec/libresin.so
|
||||
%%APP_NAME%%/libexec/libresinssl.so
|
||||
etc/app-default.xml
|
||||
etc/%%APP_NAME%%/app-default.xml
|
||||
etc/rc.d/%%APP_NAME%%.sh
|
||||
sbin/%%APP_NAME%%ctl
|
||||
%%MOD_DIR%%/mod_caucho.so
|
||||
%%APACHE%%@exec %%APXS%% -e -a -n caucho %f
|
||||
%%APACHE%%@unexec %%APXS%% -e -A -n caucho %f
|
||||
@dirrm %%APP_NAME%%/doc/css
|
||||
@dirrm %%APP_NAME%%/doc/images
|
||||
@dirrm %%APP_NAME%%/doc
|
||||
@dirrm %%APP_NAME%%/lib
|
||||
@dirrm %%APP_NAME%%/webapps
|
||||
@dirrm %%APP_NAME%%/xsl/caucho
|
||||
@dirrm %%APP_NAME%%/xsl/js/caucho
|
||||
@dirrm %%APP_NAME%%/xsl/js
|
||||
@dirrm %%APP_NAME%%/xsl/tools
|
||||
@dirrm %%APP_NAME%%/xsl
|
||||
@dirrm %%APP_NAME%%/libexec
|
||||
@dirrm %%APP_NAME%%
|
||||
@unexec if cmp -s %D/etc/%%APP_NAME%%.xml %D/etc/%%APP_NAME%%.xml-dist; then rm -f %D/etc/%%APP_NAME%%.xml; else echo If permanently deleting this package, %D/etc/%%APP_NAME%%.xml must be removed manually; fi
|
||||
etc/%%APP_NAME%%.xml-dist
|
||||
@exec if test -f %B/%%APP_NAME%%.xml ; then echo Keeping %B/%%APP_NAME%%.xml intact from previous installation; else cp %F %B/%%APP_NAME%%.xml; fi
|
||||
@unexec if cmp -s %D/etc/%%APP_NAME%%/resin.xml %D/etc/%%APP_NAME%%/resin.xml-dist; then rm -f %D/etc/%%APP_NAME%%/resin.xml ; else echo If permanently deleting this package, %D/etc/%%APP_NAME%%/resin.xml must be removed manually; fi
|
||||
etc/%%APP_NAME%%/resin.xml-dist
|
||||
@dirrm etc/%%APP_NAME%%
|
||||
@exec if test -f %B/resin.xml ; then echo Keeping %B/resin.xml intact from previous installation; else cp %F %B/resin.xml; fi
|
||||
|
|
Loading…
Reference in a new issue