at-poke is a testing and inspection tool for accessibility aware applications
using the AT-SPI interfaces as used by GNOME. WWW: http://developer.gnome.org/gap PR: ports/104794 Submitted by: Marcus von Appen <mva at sysfault.org>
This commit is contained in:
parent
3cfaacc54a
commit
7c6331b627
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=176545
6 changed files with 122 additions and 0 deletions
|
@ -3,6 +3,7 @@
|
|||
|
||||
COMMENT = Ports to help disabled users
|
||||
|
||||
SUBDIR += at-poke
|
||||
SUBDIR += at-spi
|
||||
SUBDIR += at-spi-reference
|
||||
SUBDIR += atk
|
||||
|
|
25
accessibility/at-poke/Makefile
Normal file
25
accessibility/at-poke/Makefile
Normal file
|
@ -0,0 +1,25 @@
|
|||
# New ports collection makefile for: at-poke
|
||||
# Date created: 24 Oct 2006
|
||||
# Whom: Marcus von Appen <mva@sysfault.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= at-poke
|
||||
PORTVERSION= 0.2.3
|
||||
CATEGORIES= accessibility gnome
|
||||
MASTER_SITES= ${MASTER_SITE_GNOME}
|
||||
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
|
||||
DIST_SUBDIR= gnome2
|
||||
|
||||
MAINTAINER= mva@sysfault.org
|
||||
COMMENT= Accessibility testing and poking tool
|
||||
|
||||
USE_XLIB= yes
|
||||
USE_GMAKE= yes
|
||||
USE_GNOME= gnomeprefix libglade2 libgailgnome
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
|
||||
.include <bsd.port.mk>
|
3
accessibility/at-poke/distinfo
Normal file
3
accessibility/at-poke/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (gnome2/at-poke-0.2.3.tar.gz) = a5c541c59f4b978caea757c63ac8c71e
|
||||
SHA256 (gnome2/at-poke-0.2.3.tar.gz) = fb64b084a180c920990795dc2881da05ee86aa05af46a1d77127e9a81ccb514a
|
||||
SIZE (gnome2/at-poke-0.2.3.tar.gz) = 347995
|
86
accessibility/at-poke/files/patch-configure
Normal file
86
accessibility/at-poke/files/patch-configure
Normal file
|
@ -0,0 +1,86 @@
|
|||
--- configure Thu Oct 26 20:52:31 2006
|
||||
+++ configure.new Thu Oct 26 20:54:20 2006
|
||||
@@ -19660,14 +19660,12 @@
|
||||
libglade-2.0
|
||||
cspi-1.0 >= 1.3.12
|
||||
gtk+-2.0 >= 2.0.0
|
||||
- libgnomeui-2.0
|
||||
- libgail-gnome \"") >&5
|
||||
+ libgnomeui-2.0 \"") >&5
|
||||
($PKG_CONFIG --exists --print-errors "
|
||||
libglade-2.0
|
||||
cspi-1.0 >= 1.3.12
|
||||
gtk+-2.0 >= 2.0.0
|
||||
- libgnomeui-2.0
|
||||
- libgail-gnome ") 2>&5
|
||||
+ libgnomeui-2.0 ") 2>&5
|
||||
ac_status=$?
|
||||
echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
(exit $ac_status); }; then
|
||||
@@ -19675,8 +19673,7 @@
|
||||
libglade-2.0
|
||||
cspi-1.0 >= 1.3.12
|
||||
gtk+-2.0 >= 2.0.0
|
||||
- libgnomeui-2.0
|
||||
- libgail-gnome " 2>/dev/null`
|
||||
+ libgnomeui-2.0 " 2>/dev/null`
|
||||
else
|
||||
pkg_failed=yes
|
||||
fi
|
||||
@@ -19689,14 +19686,12 @@
|
||||
libglade-2.0
|
||||
cspi-1.0 >= 1.3.12
|
||||
gtk+-2.0 >= 2.0.0
|
||||
- libgnomeui-2.0
|
||||
- libgail-gnome \"") >&5
|
||||
+ libgnomeui-2.0 \"") >&5
|
||||
($PKG_CONFIG --exists --print-errors "
|
||||
libglade-2.0
|
||||
cspi-1.0 >= 1.3.12
|
||||
gtk+-2.0 >= 2.0.0
|
||||
- libgnomeui-2.0
|
||||
- libgail-gnome ") 2>&5
|
||||
+ libgnomeui-2.0 ") 2>&5
|
||||
ac_status=$?
|
||||
echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
(exit $ac_status); }; then
|
||||
@@ -19704,8 +19699,7 @@
|
||||
libglade-2.0
|
||||
cspi-1.0 >= 1.3.12
|
||||
gtk+-2.0 >= 2.0.0
|
||||
- libgnomeui-2.0
|
||||
- libgail-gnome " 2>/dev/null`
|
||||
+ libgnomeui-2.0 " 2>/dev/null`
|
||||
else
|
||||
pkg_failed=yes
|
||||
fi
|
||||
@@ -19718,8 +19712,7 @@
|
||||
libglade-2.0
|
||||
cspi-1.0 >= 1.3.12
|
||||
gtk+-2.0 >= 2.0.0
|
||||
- libgnomeui-2.0
|
||||
- libgail-gnome "`
|
||||
+ libgnomeui-2.0 "`
|
||||
# Put the nasty error message in config.log where it belongs
|
||||
echo "$POKE_PKG_ERRORS" 1>&5
|
||||
|
||||
@@ -19727,8 +19720,7 @@
|
||||
libglade-2.0
|
||||
cspi-1.0 >= 1.3.12
|
||||
gtk+-2.0 >= 2.0.0
|
||||
- libgnomeui-2.0
|
||||
- libgail-gnome ) were not met.
|
||||
+ libgnomeui-2.0 ) were not met.
|
||||
Consider adjusting the PKG_CONFIG_PATH environment variable if you
|
||||
installed software in a non-standard prefix.
|
||||
|
||||
@@ -19739,8 +19731,7 @@
|
||||
libglade-2.0
|
||||
cspi-1.0 >= 1.3.12
|
||||
gtk+-2.0 >= 2.0.0
|
||||
- libgnomeui-2.0
|
||||
- libgail-gnome ) were not met.
|
||||
+ libgnomeui-2.0 ) were not met.
|
||||
Consider adjusting the PKG_CONFIG_PATH environment variable if you
|
||||
installed software in a non-standard prefix.
|
||||
|
4
accessibility/at-poke/pkg-descr
Normal file
4
accessibility/at-poke/pkg-descr
Normal file
|
@ -0,0 +1,4 @@
|
|||
at-poke is a testing and inspection tool for accessibility aware applications
|
||||
using the AT-SPI interfaces as used by GNOME.
|
||||
|
||||
WWW: http://developer.gnome.org/gap
|
3
accessibility/at-poke/pkg-plist
Normal file
3
accessibility/at-poke/pkg-plist
Normal file
|
@ -0,0 +1,3 @@
|
|||
bin/at-poke
|
||||
share/gnome/at-poke/at-poke.glade2
|
||||
@dirrm share/gnome/at-poke
|
Loading…
Reference in a new issue