pkcs11-helper is a library that simplifies the interaction
with PKCS#11 providers for end-user applications. pkcs11-helper allows using multiple PKCS#11 providers at the same time, enumerating available token certificates, or selecting a certificate directly by serialized id, handling card removal and card insert events, handling card re-insert to a different slot, supporting session expiration and much more all using a simple API. pkcs11-helper is not designed to manage card content, since object attributes are usually vendor specific, and 99% of application need to access existing objects in order to perform signature and decryption. WWW: http://www.opensc-project.org/pkcs11-helper/
This commit is contained in:
parent
bf23c2dac2
commit
7c7317bc09
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=181752
6 changed files with 89 additions and 0 deletions
|
@ -546,6 +546,7 @@
|
|||
SUBDIR += pinentry-gtk2
|
||||
SUBDIR += pinentry-qt
|
||||
SUBDIR += pkcrack
|
||||
SUBDIR += pkcs11-helper
|
||||
SUBDIR += pks
|
||||
SUBDIR += pktsuckers
|
||||
SUBDIR += poc
|
||||
|
|
37
security/pkcs11-helper/Makefile
Normal file
37
security/pkcs11-helper/Makefile
Normal file
|
@ -0,0 +1,37 @@
|
|||
# New ports collection makefile for: pkcs11-helper
|
||||
# Date created: 8 Jan 2007
|
||||
# Whom: Alex Dupre <ale@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= pkcs11-helper
|
||||
PORTVERSION= 1.02
|
||||
CATEGORIES= security devel
|
||||
MASTER_SITES= http://www.opensc-project.org/files/${PORTNAME}/
|
||||
|
||||
MAINTAINER= ale@FreeBSD.org
|
||||
COMMENT= A helper library for multiple PKCS#11 providers
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_OPENSSL= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GNOME= gnomehack pkgconfig
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
CONFIGURE_ENV= OPENSSL_CFLAGS="-I${OPENSSLINC}" \
|
||||
OPENSSL_LIBS="-L${OPENSSLLIB} -lssl"
|
||||
|
||||
CONFIGURE_ARGS= --mandir=${PREFIX}/man
|
||||
|
||||
MAN8= pkcs11-helper.8
|
||||
|
||||
PORTDOCS= *
|
||||
|
||||
.if defined(NOPORTDOCS)
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} 's|install-data-am: install-dist_docDATA|install-data-am|'
|
||||
${WRKSRC}/Makefile.in
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
3
security/pkcs11-helper/distinfo
Normal file
3
security/pkcs11-helper/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (pkcs11-helper-1.02.tar.bz2) = db8a23bee8fb31f0f3a23666f0a6e057
|
||||
SHA256 (pkcs11-helper-1.02.tar.bz2) = 9596b41a9dbc04b482835c1976580f527a05a675360604bb3620b985699ad184
|
||||
SIZE (pkcs11-helper-1.02.tar.bz2) = 325416
|
13
security/pkcs11-helper/files/patch-configure
Normal file
13
security/pkcs11-helper/files/patch-configure
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- configure.orig Mon Jan 8 10:03:39 2007
|
||||
+++ configure Mon Jan 8 10:05:15 2007
|
||||
@@ -22472,8 +22472,8 @@
|
||||
PKCS11H_FEATURES="${PKCS11H_FEATURES} engine_crypto"
|
||||
fi
|
||||
|
||||
-docdir="${docdir}-${PACKAGE_VERSION}"
|
||||
-pkgconfigdir="${libdir}/pkgconfig"
|
||||
+docdir="${docdir}"
|
||||
+pkgconfigdir="${prefix}/libdata/pkgconfig"
|
||||
|
||||
|
||||
|
19
security/pkcs11-helper/pkg-descr
Normal file
19
security/pkcs11-helper/pkg-descr
Normal file
|
@ -0,0 +1,19 @@
|
|||
pkcs11-helper is a library that simplifies the interaction
|
||||
with PKCS#11 providers for end-user applications.
|
||||
|
||||
pkcs11-helper allows using multiple PKCS#11 providers at
|
||||
the same time, enumerating available token certificates, or
|
||||
selecting a certificate directly by serialized id, handling
|
||||
card removal and card insert events, handling card re-insert
|
||||
to a different slot, supporting session expiration and much
|
||||
more all using a simple API.
|
||||
|
||||
pkcs11-helper is not designed to manage card content, since
|
||||
object attributes are usually vendor specific, and 99% of
|
||||
application need to access existing objects in order to
|
||||
perform signature and decryption.
|
||||
|
||||
WWW: http://www.opensc-project.org/pkcs11-helper/
|
||||
|
||||
- Alex Dupre
|
||||
ale@FreeBSD.org
|
16
security/pkcs11-helper/pkg-plist
Normal file
16
security/pkcs11-helper/pkg-plist
Normal file
|
@ -0,0 +1,16 @@
|
|||
include/pkcs11-helper-1.0/pkcs11.h
|
||||
include/pkcs11-helper-1.0/pkcs11h-certificate.h
|
||||
include/pkcs11-helper-1.0/pkcs11h-core.h
|
||||
include/pkcs11-helper-1.0/pkcs11h-data.h
|
||||
include/pkcs11-helper-1.0/pkcs11h-def.h
|
||||
include/pkcs11-helper-1.0/pkcs11h-engines.h
|
||||
include/pkcs11-helper-1.0/pkcs11h-openssl.h
|
||||
include/pkcs11-helper-1.0/pkcs11h-token.h
|
||||
include/pkcs11-helper-1.0/pkcs11h-version.h
|
||||
lib/libpkcs11-helper.a
|
||||
lib/libpkcs11-helper.la
|
||||
lib/libpkcs11-helper.so
|
||||
lib/libpkcs11-helper.so.1
|
||||
libdata/pkgconfig/libpkcs11-helper-1.pc
|
||||
share/aclocal/pkcs11-helper-1.m4
|
||||
@dirrm include/pkcs11-helper-1.0
|
Loading…
Reference in a new issue