x11/xdo: do not patch to handle manpages
While here move manpages to share/man
This commit is contained in:
parent
5433d7556e
commit
7c999aa2c8
2 changed files with 2 additions and 14 deletions
|
@ -16,7 +16,8 @@ USES= gmake localbase:ldflags xorg
|
|||
USE_XORG= xcb
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= baskerville
|
||||
MAKE_ARGS= MANPREFIX="${PREFIX}/share/man"
|
||||
|
||||
PLIST_FILES= bin/xdo man/man1/xdo.1.gz
|
||||
PLIST_FILES= bin/xdo share/man/man1/xdo.1.gz
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -9,16 +9,3 @@
|
|||
CFLAGS += -std=c99 -pedantic -Wall -Wextra
|
||||
LDLIBS := -lxcb -lxcb-util -lxcb-icccm -lxcb-ewmh -lxcb-xtest
|
||||
|
||||
@@ -26,9 +26,9 @@ $(NAME): $(OBJ)
|
||||
|
||||
install:
|
||||
mkdir -p "$(DESTDIR)$(BINPREFIX)"
|
||||
- cp -p $(NAME) "$(DESTDIR)$(BINPREFIX)"
|
||||
- mkdir -p "$(DESTDIR)$(MANPREFIX)/man1"
|
||||
- cp -p doc/$(NAME).1 "$(DESTDIR)$(MANPREFIX)/man1"
|
||||
+ $(BSD_INSTALL_PROGRAM) $(NAME) "$(DESTDIR)$(BINPREFIX)"
|
||||
+ mkdir -p "$(DESTDIR)$(MANPREFIX)/man/man1"
|
||||
+ $(BSD_INSTALL_MAN) doc/$(NAME).1 "$(DESTDIR)$(MANPREFIX)/man/man1"
|
||||
|
||||
uninstall:
|
||||
rm -f "$(DESTDIR)$(BINPREFIX)/$(NAME)"
|
||||
|
|
Loading…
Reference in a new issue