games/gzdoom: update to 4.7.1

Changelogs for all of the intervening versions can be found on the
ZDoom forums: https://forum.zdoom.org/viewforum.php?f=1

This update moves data up to share/doom, which is a standard location
that gzdoom searches for game data already.  Some of the names are
fairly generic, but not likely to conflict with other doom ports.

While we're here, slim down the dependencies a little bit -- many of
them are not needed anymore.
This commit is contained in:
Kyle Evans 2021-11-05 20:27:14 -05:00
parent 9633fdc9c4
commit 7c9e334403
8 changed files with 44 additions and 89 deletions

View file

@ -1,6 +1,5 @@
PORTNAME= gzdoom
PORTVERSION= 4.1.1
PORTREVISION= 5
PORTVERSION= 4.7.1
DISTVERSIONPREFIX= g
CATEGORIES= games
@ -16,18 +15,19 @@ LICENSE_FILE_LGPL3= ${WRKSRC}/docs/licenses/lgpl.txt
BUILD_DEPENDS= zip:archivers/zip
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
libsndfile.so:audio/libsndfile \
libfluidsynth.so:audio/fluidsynth \
libgme.so:audio/libgme
libzmusic.so:devel/zmusic
USES= cmake compiler:c++11-lang gettext gl gnome jpeg openal \
pkgconfig sdl
USES= cmake compiler:c++11-lang gl gnome jpeg pkgconfig sdl
DATADIR= ${DMDIR}/${PORTNAME}
USE_GITHUB= yes
GH_ACCOUNT= coelckers
CMAKE_ARGS= -DINSTALL_DOCS_PATH=${DOCSDIR} \
-DINSTALL_PK3_PATH=${DMDIR} \
-DINSTALL_SOUNDFONT_PATH=${DMDIR}
USE_GNOME= atk cairo gdkpixbuf2 gtk20 pango
USE_SDL= sdl2
USE_GL= gl glu
@ -36,16 +36,10 @@ LDFLAGS+= -Wl,--as-needed
DESKTOP_ENTRIES= "GZDoom" "" "${PORTNAME}" "${PORTNAME}" "Game;Shooter;" ""
PLIST_FILES= bin/${PORTNAME} \
${DATADIR}/${PORTNAME}.pk3 \
share/pixmaps/${PORTNAME}.xpm
.include "${.CURDIR}/../doom-data/Makefile.include"
do-install:
${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_PROGRAM} ${CONFIGURE_WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
${INSTALL_DATA} ${CONFIGURE_WRKSRC}/${PORTNAME}.pk3 ${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${FILESDIR}/${PORTNAME}.xpm ${STAGEDIR}${PREFIX}/share/pixmaps
post-install:
${INSTALL_DATA} ${FILESDIR}/${PORTNAME}.xpm \
${STAGEDIR}${PREFIX}/share/pixmaps
.include <bsd.port.mk>

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1557581862
SHA256 (coelckers-gzdoom-g4.1.1_GH0.tar.gz) = 50ce34b48518fb8715d6e346ff3ac8d08fd24b34e764be88335810fa592fb84a
SIZE (coelckers-gzdoom-g4.1.1_GH0.tar.gz) = 13008847
TIMESTAMP = 1635720167
SHA256 (coelckers-gzdoom-g4.7.1_GH0.tar.gz) = 454257582be0576501eef1efc99fe7ea70f1c4d7993549db3cbc709ce75fc102
SIZE (coelckers-gzdoom-g4.7.1_GH0.tar.gz) = 19562412

View file

@ -1,13 +0,0 @@
--- game-music-emu/gme/blargg_endian.h.orig 2021-02-10 16:11:06 UTC
+++ game-music-emu/gme/blargg_endian.h
@@ -33,9 +33,7 @@
#if defined (LSB_FIRST) || defined (__LITTLE_ENDIAN__) || BLARGG_CPU_X86 || \
(defined (LITTLE_ENDIAN) && LITTLE_ENDIAN+0 != 1234)
#define BLARGG_LITTLE_ENDIAN 1
-#endif
-
-#if defined (MSB_FIRST) || defined (__BIG_ENDIAN__) || defined (WORDS_BIGENDIAN) || \
+#elif defined (MSB_FIRST) || defined (__BIG_ENDIAN__) || defined (WORDS_BIGENDIAN) || \
defined (__sparc__) || BLARGG_CPU_POWERPC || \
(defined (BIG_ENDIAN) && BIG_ENDIAN+0 != 4321)
#define BLARGG_BIG_ENDIAN 1

View file

@ -1,22 +0,0 @@
https://github.com/KhronosGroup/glslang/commit/24b3e8384e93
In file included from MachineIndependent/glslang.y:60:
In file included from glslang/glslang/MachineIndependent/SymbolTable.h:68:
In file included from glslang/glslang/MachineIndependent/../Include/Common.h:107:
glslang/glslang/MachineIndependent/../Include/PoolAlloc.h:307:54: error: 'operator=' is a private member of 'glslang::TPoolAllocator'
void setAllocator(TPoolAllocator* a) { allocator = *a; }
~~~~~~~~~ ^ ~~
glslang/glslang/MachineIndependent/../Include/PoolAlloc.h:244:21: note: declared private here
TPoolAllocator& operator=(const TPoolAllocator&); // don't allow assignment operator
^
--- glslang/glslang/Include/PoolAlloc.h.orig 2019-05-04 19:58:35 UTC
+++ glslang/glslang/Include/PoolAlloc.h
@@ -304,7 +304,6 @@ class pool_allocator { (public)
size_type max_size() const { return static_cast<size_type>(-1) / sizeof(T); }
size_type max_size(int size) const { return static_cast<size_type>(-1) / size; }
- void setAllocator(TPoolAllocator* a) { allocator = *a; }
TPoolAllocator& getAllocator() const { return allocator; }
protected:

View file

@ -1,16 +1,23 @@
--- src/CMakeLists.txt.orig 2019-05-04 19:58:35 UTC
--- src/CMakeLists.txt.orig 2021-11-07 02:36:36 UTC
+++ src/CMakeLists.txt
@@ -1457,10 +1457,9 @@ if( ZD_CMAKE_COMPILER_IS_GNUCXX_COMPATIBLE )
# Need to enable intrinsics for these files.
if( SSE_MATTERS )
set_source_files_properties(
- gl/system/gl_swframebuffer.cpp
- polyrenderer/poly_all.cpp
- swrenderer/r_all.cpp
- x86.cpp
+ rendering/polyrenderer/poly_all.cpp
+ rendering/swrenderer/r_all.cpp
+ utility/x86.cpp
PROPERTIES COMPILE_FLAGS "-msse2 -mmmx" )
endif()
@@ -1386,14 +1386,12 @@ if( CMAKE_COMPILER_IS_GNUCXX )
endif()
if( ZD_CMAKE_COMPILER_IS_GNUCXX_COMPATIBLE )
# Need to enable intrinsics for these files.
- if( SSE_MATTERS )
- set_property( SOURCE
- common/rendering/polyrenderer/poly_all.cpp
- rendering/swrenderer/r_all.cpp
- utility/palette.cpp
- utility/x86.cpp
- APPEND_STRING PROPERTY COMPILE_FLAGS " -msse2 -mmmx" )
- endif()
+ set_property( SOURCE
+ common/rendering/polyrenderer/poly_all.cpp
+ common/utility/palette.cpp
+ common/utility/x86.cpp
+ rendering/swrenderer/r_all.cpp
+ APPEND_STRING PROPERTY COMPILE_FLAGS " ${SSE2_ENABLE}" )
endif()
if( APPLE )

View file

@ -1,10 +0,0 @@
--- src/gamedata/fonts/font.cpp.orig 2019-05-03 16:07:35 UTC
+++ src/gamedata/fonts/font.cpp
@@ -35,6 +35,7 @@
// HEADER FILES ------------------------------------------------------------
+#include <cwctype>
#include <stdlib.h>
#include <string.h>
#include <math.h>

View file

@ -1,11 +0,0 @@
--- src/rendering/vulkan/thirdparty/vk_mem_alloc/vk_mem_alloc.h.orig 2019-05-03 15:59:56 UTC
+++ src/rendering/vulkan/thirdparty/vk_mem_alloc/vk_mem_alloc.h
@@ -2229,7 +2229,7 @@ remove them if not needed.
#include <mutex> // for std::mutex
#include <atomic> // for std::atomic
-#if !defined(_WIN32) && !defined(__APPLE__)
+#if !defined(_WIN32) && !defined(__APPLE__) && !defined(__FreeBSD__)
#include <malloc.h> // for aligned_alloc()
#endif

10
games/gzdoom/pkg-plist Normal file
View file

@ -0,0 +1,10 @@
bin/gzdoom
%%DMDIR%%/brightmaps.pk3
%%DMDIR%%/fm_banks/GENMIDI.GS.wopl
%%DMDIR%%/fm_banks/gs-by-papiezak-and-sneakernets.wopn
%%DMDIR%%/game_support.pk3
%%DMDIR%%/game_widescreen_gfx.pk3
%%DMDIR%%/gzdoom.pk3
%%DMDIR%%/lights.pk3
%%DMDIR%%/soundfonts/gzdoom.sf2
share/pixmaps/gzdoom.xpm