upgrade to 6.3
maintainer timeout No response from: maintainer
This commit is contained in:
parent
1ae6098ee1
commit
7ceee91313
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=57058
8 changed files with 79 additions and 122 deletions
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= ircd-hybrid
|
||||
PORTVERSION= 6.2
|
||||
PORTVERSION= 6.3
|
||||
CATEGORIES= irc
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ircd-hybrid
|
||||
|
@ -16,10 +16,8 @@ MAINTAINER= davidt@yadt.co.uk
|
|||
|
||||
MAN8= ircd.8
|
||||
|
||||
PATCH_STRIP= -p1
|
||||
USE_GMAKE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
PLIST_SUB= PORTNAME=${PORTNAME}
|
||||
|
||||
.if !defined(PACKAGE_BUILDING) && !defined(BATCH)
|
||||
IS_INTERACTIVE= yes
|
||||
|
@ -39,18 +37,8 @@ pre-install:
|
|||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${PREFIX}/share/doc/${PORTNAME}
|
||||
@${MKDIR} ${PREFIX}/share/doc/${PORTNAME}/old
|
||||
@${MKDIR} ${PREFIX}/share/doc/${PORTNAME}/old/US-Admin
|
||||
for i in old/US-Admin/Networking old/US-Admin/Operators \
|
||||
old/US-Admin/README old/Authors old/Etiquette old/README \
|
||||
CIDR.txt INDEX Makefile README.TSora Tao-of-IRC.940110 \
|
||||
blalloc.txt example.conf example.conf.trillian ircd.8 \
|
||||
mtrie.txt operguide.txt opermyth.txt rfc1459.txt \
|
||||
server-version-info simple.conf ts5.txt yline.txt; do \
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/$$i \
|
||||
${PREFIX}/share/doc/${PORTNAME}/$$i; \
|
||||
done
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
${CP} ${WRKSRC}/doc/* ${DOCSDIR}
|
||||
.endif
|
||||
@${SED} -e "s#%PREFIX%#${PREFIX}#" ${FILESDIR}/ircd.sh \
|
||||
> ${WRKDIR}/ircd.sh
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (ircd-hybrid-6.2.tgz) = 0c4f90b9d23674cb8ea809dde4d3b03a
|
||||
MD5 (ircd-hybrid-6.3.tgz) = 47c14c797142ca3e2fb22d74adfaa727
|
||||
|
|
|
@ -1,19 +0,0 @@
|
|||
diff -Nru ircd-hybrid-6.2.orig/autoconf/configure.in ircd-hybrid-6.2/autoconf/configure.in
|
||||
--- ircd-hybrid-6.2.orig/autoconf/configure.in Sun Oct 7 14:39:21 2001
|
||||
+++ ircd-hybrid-6.2/autoconf/configure.in Sun Oct 7 15:32:51 2001
|
||||
@@ -6,7 +6,7 @@
|
||||
AC_CONFIG_HEADER(include/setup.h zlib/setup.h)
|
||||
|
||||
PACKAGE=ircd-hybrid
|
||||
-VERSION=6.0
|
||||
+VERSION=6.2
|
||||
AC_SUBST(PACKAGE)
|
||||
AC_SUBST(VERSION)
|
||||
|
||||
@@ -180,5 +180,5 @@
|
||||
*) AC_MSG_RESULT(nothing special required) ;;
|
||||
esac
|
||||
|
||||
-AC_OUTPUT(Makefile src/Makefile tools/Makefile zlib/Makefile)
|
||||
+AC_OUTPUT(Makefile src/Makefile tools/Makefile zlib/Makefile include/config.h tools/install_ircd)
|
||||
|
|
@ -1,30 +1,20 @@
|
|||
diff -Nru ircd-hybrid-6.2.orig/configure ircd-hybrid-6.2/configure
|
||||
--- ircd-hybrid-6.2.orig/configure Sun Oct 7 14:39:22 2001
|
||||
+++ ircd-hybrid-6.2/configure Sun Oct 7 15:33:36 2001
|
||||
@@ -544,7 +544,7 @@
|
||||
|
||||
|
||||
PACKAGE=ircd-hybrid
|
||||
-VERSION=6.0
|
||||
+VERSION=6.2
|
||||
|
||||
|
||||
|
||||
@@ -2342,7 +2342,7 @@
|
||||
--- configure.orig Thu Mar 21 16:58:58 2002
|
||||
+++ configure Thu Mar 21 17:00:54 2002
|
||||
@@ -2517,7 +2517,7 @@
|
||||
ac_given_srcdir=$srcdir
|
||||
ac_given_INSTALL="$INSTALL"
|
||||
|
||||
-trap 'rm -fr `echo "Makefile src/Makefile tools/Makefile zlib/Makefile include/setup.h zlib/setup.h" | sed "s/:[^ ]*//g"` conftest*; exit 1' 1 2 15
|
||||
+trap 'rm -fr `echo "Makefile src/Makefile tools/Makefile zlib/Makefile include/config.h include/setup.h tools/install_ircd zlib/setup.h" | sed "s/:[^ ]*//g"` conftest*; exit 1' 1 2 15
|
||||
-trap 'rm -fr `echo "Makefile adns/Makefile src/Makefile tools/Makefile include/setup.h" | sed "s/:[^ ]*//g"` conftest*; exit 1' 1 2 15
|
||||
+trap 'rm -fr `echo "Makefile adns/Makefile src/Makefile tools/Makefile include/setup.h include/config.h tools/install_ircd" | sed "s/:[^ ]*//g"` conftest*; exit 1' 1 2 15
|
||||
EOF
|
||||
cat >> $CONFIG_STATUS <<EOF
|
||||
|
||||
@@ -2440,7 +2440,7 @@
|
||||
@@ -2615,7 +2615,7 @@
|
||||
|
||||
cat >> $CONFIG_STATUS <<EOF
|
||||
|
||||
-CONFIG_FILES=\${CONFIG_FILES-"Makefile src/Makefile tools/Makefile zlib/Makefile"}
|
||||
+CONFIG_FILES=\${CONFIG_FILES-"Makefile src/Makefile tools/Makefile zlib/Makefile include/config.h tools/install_ircd"}
|
||||
-CONFIG_FILES=\${CONFIG_FILES-"Makefile adns/Makefile src/Makefile tools/Makefile"}
|
||||
+CONFIG_FILES=\${CONFIG_FILES-"Makefile adns/Makefile src/Makefile tools/Makefile include/config.h tools/install_ircd"}
|
||||
EOF
|
||||
cat >> $CONFIG_STATUS <<\EOF
|
||||
for ac_file in .. $CONFIG_FILES; do if test "x$ac_file" != x..; then
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- ircd-hybrid-6.2/include/config.h.in.orig Wed Sep 26 04:04:02 2001
|
||||
+++ ircd-hybrid-6.2/include/config.h.in Mon Oct 8 02:31:28 2001
|
||||
@@ -109,8 +109,9 @@
|
||||
--- include/config.h.in.orig Thu Mar 21 16:37:57 2002
|
||||
+++ include/config.h.in Thu Mar 21 16:41:01 2002
|
||||
@@ -100,8 +100,9 @@
|
||||
*
|
||||
*/
|
||||
|
||||
|
@ -12,14 +12,14 @@
|
|||
#define CPATH "ircd.conf"
|
||||
#define KPATH "kline.conf"
|
||||
#define DLPATH "kline.conf"
|
||||
@@ -561,8 +562,8 @@
|
||||
* define IRC_UID to that UID. This should only be defined if you are running
|
||||
* as root and even then perhaps not.
|
||||
@@ -208,8 +209,8 @@
|
||||
*
|
||||
* These need to be defined if you want to use SYSLOG logging, too.
|
||||
*/
|
||||
-#define IRC_UID 1001
|
||||
-#define IRC_GID 31
|
||||
+#define IRC_UID 72
|
||||
+#define IRC_GID 72
|
||||
-#define FNAME_USERLOG "/usr/local/ircd/users"
|
||||
-#define FNAME_OPERLOG "/usr/local/ircd/opers"
|
||||
+#define FNAME_USERLOG "@prefix@/share/ircd/users"
|
||||
+#define FNAME_OPERLOG "@prefix@/share/ircd/opers"
|
||||
|
||||
/* CLIENT_FLOOD - client excess flood threshold
|
||||
* this controls the number of bytes the server will allow a client to
|
||||
/* RFC1035_ANAL
|
||||
* Defining this causes ircd to reject hostnames with non-compliant chars.
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- ircd-hybrid-6.2/tools/install_ircd.in.orig Mon Oct 8 02:37:40 2001
|
||||
+++ ircd-hybrid-6.2/tools/install_ircd.in Tue Jul 3 22:52:19 2001
|
||||
--- tools/install_ircd.in.orig Thu Mar 21 16:41:59 2002
|
||||
+++ tools/install_ircd.in Thu Mar 21 16:47:07 2002
|
||||
@@ -7,6 +7,14 @@
|
||||
# Fixed.
|
||||
#
|
||||
|
@ -39,15 +39,10 @@
|
|||
# DPATH = directory,
|
||||
# SPATH = server executable,
|
||||
# CPATH = conf file,
|
||||
@@ -74,88 +85,47 @@
|
||||
fi
|
||||
|
||||
@@ -76,86 +87,46 @@
|
||||
# try to install their ircd.conf file, unless it already exists.
|
||||
-# install ircd, save old one as ircd.old
|
||||
# install ircd, save old one as ircd.old
|
||||
dir_make `dirname ${SPATH}`
|
||||
+echo installing ircd as ${SPATH}${EXESUFFIX}
|
||||
+$INSTALL_SH -o 72 -g 72 -c src/ircd${EXESUFFIX} ${SPATH}${EXESUFFIX};
|
||||
+strip ${SPATH}${EXESUFFIX};
|
||||
-if [ ! -f ${SPATH}${EXESUFFIX} ]; then
|
||||
- echo installing ircd as ${SPATH}${EXESUFFIX}
|
||||
- $INSTALL_SH -c src/ircd${EXESUFFIX} ${SPATH}${EXESUFFIX};
|
||||
|
@ -57,45 +52,46 @@
|
|||
- mv ${SPATH}${EXESUFFIX} ${SPATH}${EXESUFFIX}.old
|
||||
- $INSTALL_SH -c src/ircd${EXESUFFIX} ${SPATH}${EXESUFFIX};
|
||||
-fi
|
||||
+echo installing ircd as ${SPATH}${EXESUFFIX}
|
||||
+$INSTALL_SH -o 72 -g 72 -c src/ircd${EXESUFFIX} ${SPATH}${EXESUFFIX};
|
||||
+strip ${SPATH}${EXESUFFIX};
|
||||
|
||||
dir_make `dirname ${CPATH}`
|
||||
+echo installing example.conf as ${CPATH}.sample
|
||||
+$INSTALL_SH -o 72 -g 72 -c doc/example.conf ${CPATH}.sample;
|
||||
-if [ ! -f ${CPATH} ]; then
|
||||
- echo installing example.conf as ${CPATH}
|
||||
- $INSTALL_SH -c doc/example.conf ${CPATH};
|
||||
-else
|
||||
- echo You already have ${CPATH}.;
|
||||
-fi
|
||||
+echo installing example.conf as ${CPATH}.sample
|
||||
+$INSTALL_SH -o 72 -g 72 -c doc/example.conf ${CPATH}.sample;
|
||||
|
||||
# try to install their motd file, unless it already exists.
|
||||
dir_make `dirname ${MPATH}`
|
||||
+echo installing a sample MOTD in ${MPATH}.sample
|
||||
+echo "This is ircd-hybrid MOTD replace it with something better" \
|
||||
+ > ${MPATH}.sample;
|
||||
+chown 72:72 ${MPATH}.sample;
|
||||
-if [ ! -f ${MPATH} ]; then
|
||||
- echo installing a sample MOTD in ${MPATH}
|
||||
- echo "This is ircd-hybrid MOTD replace it with something better" > ${MPATH};
|
||||
-else
|
||||
- echo You already have an MOTD in ${MPATH}.;
|
||||
-fi
|
||||
+echo installing a sample MOTD in ${MPATH}.sample
|
||||
+echo "This is ircd-hybrid MOTD replace it with something better" \
|
||||
+ > ${MPATH}.sample;
|
||||
+chown 72:72 ${MPATH}.sample;
|
||||
|
||||
# try to install their kpath file unless it already exists.
|
||||
dir_make `dirname ${KPATH}`
|
||||
+touch ${KPATH}.sample;
|
||||
+chown 72:72 ${KPATH}.sample;
|
||||
-if [ ! -f ${KPATH} ]; then
|
||||
- echo touching K-line file ${KPATH}
|
||||
- touch ${KPATH};
|
||||
-else
|
||||
- echo You already have a K-line file in ${KPATH}.;
|
||||
-fi
|
||||
+touch ${KPATH}.sample;
|
||||
+chown 72:72 ${KPATH}.sample;
|
||||
|
||||
# try to install their opers.txt file, in all cases
|
||||
dir_make `dirname ${HPATH}`
|
||||
+echo installing opers.txt as ${HPATH}.sample
|
||||
+$INSTALL_SH -o 72 -g 72 -c opers.txt ${HPATH}.sample;
|
||||
-if [ ! -f ${HPATH} ]; then
|
||||
- echo installing opers.txt as ${HPATH}
|
||||
- $INSTALL_SH -c opers.txt ${HPATH};
|
||||
|
@ -105,10 +101,10 @@
|
|||
- mv ${HPATH} ${HPATH}.old
|
||||
- $INSTALL_SH -c opers.txt ${HPATH};
|
||||
-fi
|
||||
+echo installing opers.txt as ${HPATH}.sample
|
||||
+$INSTALL_SH -o 72 -g 72 -c opers.txt ${HPATH}.sample;
|
||||
|
||||
# install mkpasswd
|
||||
+echo installing mkpasswd as ${BPATH}mkpasswd${EXESUFFIX}
|
||||
+$INSTALL_SH -o 72 -g 72 -c tools/mkpasswd${EXESUFFIX} ${BPATH}mkpasswd${EXESUFFIX};
|
||||
-if [ ! -f ${DPATH}mkpasswd ]; then
|
||||
- echo installing mkpasswd as ${DPATH}mkpasswd${EXESUFFIX}
|
||||
- $INSTALL_SH -c tools/mkpasswd${EXESUFFIX} ${DPATH}mkpasswd${EXESUFFIX};
|
||||
|
@ -118,13 +114,10 @@
|
|||
- mv ${DPATH}mkpasswd${EXESUFFIX} ${DPATH}mkpasswd${EXESUFFIX}.old
|
||||
- $INSTALL_SH -c tools/mkpasswd${EXESUFFIX} ${DPATH}mkpasswd${EXESUFFIX};
|
||||
-fi
|
||||
+echo installing mkpasswd as ${BPATH}mkpasswd${EXESUFFIX}
|
||||
+$INSTALL_SH -o 72 -g 72 -c tools/mkpasswd${EXESUFFIX} ${BPATH}mkpasswd${EXESUFFIX};
|
||||
|
||||
# install viconf
|
||||
+echo installing viconf as ${BPATH}viconf${EXESUFFIX}
|
||||
+$INSTALL_SH -o 72 -g 72 -c tools/viconf${EXESUFFIX} ${BPATH}viconf${EXESUFFIX}
|
||||
+rm -f ${BPATH}vimotd${EXESUFFIX} ${BPATH}viklines${EXESUFFIX}
|
||||
+ln ${BPATH}viconf${EXESUFFIX} ${BPATH}vimotd${EXESUFFIX}
|
||||
+ln ${BPATH}viconf${EXESUFFIX} ${BPATH}viklines${EXESUFFIX};
|
||||
-if [ ! -f ${DPATH}viconf ]; then
|
||||
- echo installing viconf as ${DPATH}viconf${EXESUFFIX}
|
||||
- $INSTALL_SH -c tools/viconf${EXESUFFIX} ${DPATH}viconf${EXESUFFIX}
|
||||
|
@ -140,14 +133,19 @@
|
|||
- ln ${DPATH}viconf${EXESUFFIX} ${DPATH}vimotd${EXESUFFIX}
|
||||
- ln ${DPATH}viconf${EXESUFFIX} ${DPATH}viklines${EXESUFFIX};
|
||||
-fi
|
||||
+echo installing viconf as ${BPATH}viconf${EXESUFFIX}
|
||||
+$INSTALL_SH -o 72 -g 72 -c tools/viconf${EXESUFFIX} ${BPATH}viconf${EXESUFFIX}
|
||||
+rm -f ${BPATH}vimotd${EXESUFFIX} ${BPATH}viklines${EXESUFFIX}
|
||||
+ln ${BPATH}viconf${EXESUFFIX} ${BPATH}vimotd${EXESUFFIX}
|
||||
+ln ${BPATH}viconf${EXESUFFIX} ${BPATH}viklines${EXESUFFIX};
|
||||
|
||||
# install ircd.8
|
||||
+dir_make ${PREFIX}/man/man8
|
||||
+echo installing ircd.8 as ${PREFIX}/man/man8/ircd.8
|
||||
+$INSTALL_SH -o 72 -g 72 -c doc/ircd.8 ${PREFIX}/man/man8/ircd.8
|
||||
-dir_make ${DPATH}man8
|
||||
-echo installing ircd.8 as ${DPATH}man8/ircd.8
|
||||
-$INSTALL_SH -c doc/ircd.8 ${DPATH}man8/ircd.8
|
||||
+dir_make ${PREFIX}/man/man8
|
||||
+echo installing ircd.8 as ${PREFIX}/man/man8/ircd.8
|
||||
+$INSTALL_SH -o 72 -g 72 -c doc/ircd.8 ${PREFIX}/man/man8/ircd.8
|
||||
|
||||
# finished.
|
||||
echo install complete!
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- ircd-hybrid-6.2/Makefile.orig Sun Oct 7 17:58:34 2001
|
||||
+++ ircd-hybrid-6.2/Makefile.in Sun Oct 7 17:58:45 2001
|
||||
--- Makefile.in.orig Thu Mar 21 16:47:44 2002
|
||||
+++ Makefile.in Thu Mar 21 16:47:57 2002
|
||||
@@ -22,7 +22,7 @@
|
||||
RM=@RM@
|
||||
|
||||
|
|
|
@ -3,35 +3,35 @@ bin/mkpasswd
|
|||
bin/viconf
|
||||
bin/viklines
|
||||
bin/vimotd
|
||||
%%PORTDOCS%%share/doc/%%PORTNAME%%/old/US-Admin/Networking
|
||||
%%PORTDOCS%%share/doc/%%PORTNAME%%/old/US-Admin/Operators
|
||||
%%PORTDOCS%%share/doc/%%PORTNAME%%/old/US-Admin/README
|
||||
%%PORTDOCS%%share/doc/%%PORTNAME%%/old/Authors
|
||||
%%PORTDOCS%%share/doc/%%PORTNAME%%/old/Etiquette
|
||||
%%PORTDOCS%%share/doc/%%PORTNAME%%/old/README
|
||||
%%PORTDOCS%%share/doc/%%PORTNAME%%/CIDR.txt
|
||||
%%PORTDOCS%%share/doc/%%PORTNAME%%/INDEX
|
||||
%%PORTDOCS%%share/doc/%%PORTNAME%%/Makefile
|
||||
%%PORTDOCS%%share/doc/%%PORTNAME%%/README.TSora
|
||||
%%PORTDOCS%%share/doc/%%PORTNAME%%/Tao-of-IRC.940110
|
||||
%%PORTDOCS%%share/doc/%%PORTNAME%%/blalloc.txt
|
||||
%%PORTDOCS%%share/doc/%%PORTNAME%%/example.conf
|
||||
%%PORTDOCS%%share/doc/%%PORTNAME%%/example.conf.trillian
|
||||
%%PORTDOCS%%share/doc/%%PORTNAME%%/ircd.8
|
||||
%%PORTDOCS%%share/doc/%%PORTNAME%%/mtrie.txt
|
||||
%%PORTDOCS%%share/doc/%%PORTNAME%%/operguide.txt
|
||||
%%PORTDOCS%%share/doc/%%PORTNAME%%/opermyth.txt
|
||||
%%PORTDOCS%%share/doc/%%PORTNAME%%/rfc1459.txt
|
||||
%%PORTDOCS%%share/doc/%%PORTNAME%%/server-version-info
|
||||
%%PORTDOCS%%share/doc/%%PORTNAME%%/simple.conf
|
||||
%%PORTDOCS%%share/doc/%%PORTNAME%%/ts5.txt
|
||||
%%PORTDOCS%%share/doc/%%PORTNAME%%/yline.txt
|
||||
%%PORTDOCS%%@dirrm share/doc/%%PORTNAME%%/old/US-Admin
|
||||
%%PORTDOCS%%@dirrm share/doc/%%PORTNAME%%/old
|
||||
%%PORTDOCS%%@dirrm share/doc/%%PORTNAME%%
|
||||
etc/ircd/ircd.conf.sample
|
||||
etc/ircd/ircd.motd.sample
|
||||
etc/ircd/kline.conf.sample
|
||||
etc/ircd/opers.txt.sample
|
||||
etc/rc.d/ircd.sh
|
||||
@unexec rmdir %D/etc/ircd 2>/dev/null || true
|
||||
%%PORTDOCS%%share/doc/ircd-hybrid/CIDR.txt
|
||||
%%PORTDOCS%%share/doc/ircd-hybrid/INDEX
|
||||
%%PORTDOCS%%share/doc/ircd-hybrid/Makefile
|
||||
%%PORTDOCS%%share/doc/ircd-hybrid/README.TSora
|
||||
%%PORTDOCS%%share/doc/ircd-hybrid/Tao-of-IRC.940110
|
||||
%%PORTDOCS%%share/doc/ircd-hybrid/blalloc.txt
|
||||
%%PORTDOCS%%share/doc/ircd-hybrid/example.conf
|
||||
%%PORTDOCS%%share/doc/ircd-hybrid/example.conf.trillian
|
||||
%%PORTDOCS%%share/doc/ircd-hybrid/ircd.8
|
||||
%%PORTDOCS%%share/doc/ircd-hybrid/mtrie.txt
|
||||
%%PORTDOCS%%share/doc/ircd-hybrid/old/Authors
|
||||
%%PORTDOCS%%share/doc/ircd-hybrid/old/Etiquette
|
||||
%%PORTDOCS%%share/doc/ircd-hybrid/old/README
|
||||
%%PORTDOCS%%share/doc/ircd-hybrid/old/US-Admin/Networking
|
||||
%%PORTDOCS%%share/doc/ircd-hybrid/old/US-Admin/Operators
|
||||
%%PORTDOCS%%share/doc/ircd-hybrid/old/US-Admin/README
|
||||
%%PORTDOCS%%share/doc/ircd-hybrid/operguide.txt
|
||||
%%PORTDOCS%%share/doc/ircd-hybrid/opermyth.txt
|
||||
%%PORTDOCS%%share/doc/ircd-hybrid/rfc1459.txt
|
||||
%%PORTDOCS%%share/doc/ircd-hybrid/server-version-info
|
||||
%%PORTDOCS%%share/doc/ircd-hybrid/simple.conf
|
||||
%%PORTDOCS%%share/doc/ircd-hybrid/ts5.txt
|
||||
%%PORTDOCS%%share/doc/ircd-hybrid/yline.txt
|
||||
%%PORTDOCS%%@dirrm share/doc/ircd-hybrid/old/US-Admin
|
||||
%%PORTDOCS%%@dirrm share/doc/ircd-hybrid/old
|
||||
%%PORTDOCS%%@dirrm share/doc/ircd-hybrid
|
||||
|
|
Loading…
Reference in a new issue