- Fix build with clang
- Support staging PR: ports/184856 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
This commit is contained in:
parent
54593bf61f
commit
7d368ef278
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=337009
2 changed files with 30 additions and 3 deletions
|
@ -13,11 +13,11 @@ COMMENT= Binary-to-text file-encoder
|
|||
|
||||
MAKEFILE= makefile
|
||||
MAKE_ARGS= CFLAGS="${CFLAGS}" DEST=${PREFIX}/bin
|
||||
PLIST_FILES= bin/ish
|
||||
ALL_TARGET= ish
|
||||
|
||||
NO_STAGE= yes
|
||||
PLIST_FILES= bin/ish
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
|
||||
(cd ${WRKSRC} && ${INSTALL_PROGRAM} ish ${STAGEDIR}${PREFIX}/bin)
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
27
converters/ish/files/patch-mvol.c
Normal file
27
converters/ish/files/patch-mvol.c
Normal file
|
@ -0,0 +1,27 @@
|
|||
--- mvol.c.orig
|
||||
+++ mvol.c
|
||||
@@ -4,6 +4,7 @@
|
||||
/* 930823 modified (aka) */
|
||||
|
||||
#include <stdio.h>
|
||||
+#include <stdlib.h>
|
||||
#include <fcntl.h>
|
||||
#include <ctype.h>
|
||||
#include <string.h>
|
||||
@@ -25,6 +26,8 @@
|
||||
extern char tname[];
|
||||
extern int delvol;
|
||||
|
||||
+void restore_done(char *, char *, long);
|
||||
+
|
||||
#define ID "ID block for multi volume ish file"
|
||||
|
||||
typedef struct {
|
||||
@@ -208,6 +211,7 @@
|
||||
|
||||
#define COPY_BUF 1024
|
||||
|
||||
+void
|
||||
restore_done(src, dst,sz)
|
||||
char *src;
|
||||
char *dst;
|
Loading…
Reference in a new issue