Add one more XMMS aRts output plugin.

This commit is contained in:
Max Khon 2003-11-12 00:14:40 +00:00
parent f164b0b55d
commit 7d49db11e9
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=93766
12 changed files with 96 additions and 18 deletions

View file

@ -360,6 +360,7 @@
SUBDIR += xmmix
SUBDIR += xmms-a52dec
SUBDIR += xmms-arts
SUBDIR += xmms-arts_output
SUBDIR += xmms-audiofile
SUBDIR += xmms-bonk
SUBDIR += xmms-cdparanoia

View file

@ -6,10 +6,10 @@
#
PORTNAME= xmms-arts
PORTVERSION= 0.6.0
PORTVERSION= 0.4
CATEGORIES= audio
MASTER_SITES= http://havardk.xmms.org/plugins/arts_output/
DISTNAME= arts_output-${PORTVERSION}
MASTER_SITES= http://stukach.com/hosted/m.i.a/xmmsarts/
DISTNAME= ${PORTNAME:S/-//}-${PORTVERSION}
MAINTAINER= fjoe@FreeBSD.org
COMMENT= aRts output plugin for XMMS.
@ -18,10 +18,13 @@ LIB_DEPENDS= xmms.4:${PORTSDIR}/multimedia/xmms \
artsc.0:${PORTSDIR}/audio/arts
USE_X_PREFIX= yes
USE_BZIP2= yes
USE_GNOME= gtk12
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${X11BASE}/include"
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PKGMESSAGE= ${WRKDIR}/pkg-message
post-install:

View file

@ -1 +1 @@
MD5 (arts_output-0.6.0.tar.gz) = 6539123bd1dbebcf57073392da13d992
MD5 (xmmsarts-0.4.tar.bz2) = 1e38bf93f7d2fac6dcdb681f6538491a

View file

@ -1,14 +1,5 @@
--- ltmain.sh.orig Wed Aug 6 19:13:39 2003
+++ ltmain.sh Tue Nov 11 22:47:49 2003
@@ -1075,7 +1075,7 @@
esac
elif test "X$arg" = "X-lc_r"; then
case $host in
- *-*-openbsd* | *-*-freebsd*)
+ *-*-openbsd*)
# Do not include libc_r directly, use -pthread flag.
continue
;;
@@ -1084,6 +1084,13 @@
deplibs="$deplibs $arg"
continue

View file

@ -1,5 +1,5 @@
Xmms-arts is an aRts output plugin for XMMS (www.xmms.org).
aRts output plugin for XMMS (www.xmms.org).
Author: Håvard Kvålen <havardk@xmms.org>
Author: Heath Robinson <bheathr@mail.com>
WWW: http://www.xmms.org/plugins.php?category=output

View file

@ -1,3 +1,4 @@
lib/xmms/Output/libarts.a
lib/xmms/Output/libarts.la
lib/xmms/Output/libarts.so
lib/xmms/Output/libartsout.a
lib/xmms/Output/libartsout.la
lib/xmms/Output/libartsout.so
lib/xmms/Output/libartsout.so.0

View file

@ -0,0 +1,32 @@
# New ports collection makefile for: xmms-arts_output
# Date created: 12 Nov 2003
# Whom: Max Khon <fjoe@FreeBSD.org>
#
# $FreeBSD$
#
PKGNAMEPREFIX= xmms-
PORTNAME= arts_output
PORTVERSION= 0.6.0
CATEGORIES= audio
MASTER_SITES= http://havardk.xmms.org/plugins/arts_output/
MAINTAINER= fjoe@FreeBSD.org
COMMENT= aRts output plugin for XMMS.
LIB_DEPENDS= xmms.4:${PORTSDIR}/multimedia/xmms \
artsc.0:${PORTSDIR}/audio/arts
USE_X_PREFIX= yes
USE_GNOME= gtk12
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
PKGMESSAGE= ${WRKDIR}/pkg-message
post-install:
@${SED} -e 's,%%PREFIX%%,${PREFIX},g' \
<${FILESDIR}/pkg-message.in >${PKGMESSAGE}
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>

View file

@ -0,0 +1 @@
MD5 (arts_output-0.6.0.tar.gz) = 6539123bd1dbebcf57073392da13d992

View file

@ -0,0 +1,25 @@
--- ltmain.sh.orig Wed Aug 6 19:13:39 2003
+++ ltmain.sh Tue Nov 11 22:47:49 2003
@@ -1075,7 +1075,7 @@
esac
elif test "X$arg" = "X-lc_r"; then
case $host in
- *-*-openbsd* | *-*-freebsd*)
+ *-*-openbsd*)
# Do not include libc_r directly, use -pthread flag.
continue
;;
@@ -1084,6 +1084,13 @@
deplibs="$deplibs $arg"
continue
;;
+
+ -pthread)
+ compile_command="$compile_command -pthread"
+ finalize_command="$finalize_command -pthread"
+ compiler_flags="$compiler_flags -pthread"
+ continue
+ ;;
-module)
module=yes

View file

@ -0,0 +1,16 @@
In order to use aRts plugin on FreeBSD you must to do the following:
1) Move xmms binary to xmms.bin:
cd %%PREFIX%%/bin && mv xmms xmms.bin
2) Write custom xmms script:
--- cut here ---
#!/bin/sh
LD_PRELOAD=/usr/lib/libstdc++.so exec %%PREFIX%%/bin/xmms.bin "$@"
--- cut here ---
and put it to %%PREFIX%%/bin
/fjoe

View file

@ -0,0 +1,5 @@
aRts output plugin for XMMS (www.xmms.org).
Author: Håvard Kvålen <havardk@xmms.org>
WWW: http://www.xmms.org/plugins.php?category=output

View file

@ -0,0 +1,3 @@
lib/xmms/Output/libarts.a
lib/xmms/Output/libarts.la
lib/xmms/Output/libarts.so