- Fix build on -current
- Use OPTIONS helpers - shebangfix some perl scripts - Add missing file to plist - Don't try to remove directories installed by dependencies
This commit is contained in:
parent
932f3c64d0
commit
7d97cf724a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=366444
6 changed files with 66 additions and 45 deletions
|
@ -3,7 +3,7 @@
|
|||
|
||||
PORTNAME= texmacs
|
||||
PORTVERSION= 1.0.7.21
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= editors print
|
||||
MASTER_SITES= ftp://ftp.texmacs.org/TeXmacs/tmftp/source/ \
|
||||
http://www.predatorlabs.net/dl/
|
||||
|
@ -16,8 +16,7 @@ LICENSE= GPLv3
|
|||
|
||||
LIB_DEPENDS= libguile.so:${PORTSDIR}/lang/guile
|
||||
|
||||
USES= gmake shared-mime-info desktop-file-utils
|
||||
USE_PYTHON= yes
|
||||
USES= gmake shared-mime-info desktop-file-utils python shebangfix
|
||||
USE_TEX= tex
|
||||
GNU_CONFIGURE= yes
|
||||
CPPFLAGS+= -I${LOCALBASE}/include
|
||||
|
@ -27,54 +26,34 @@ MAKE_ARGS= CP="${CP} -R -f"
|
|||
ALL_TARGET= ${PORTNAME:tu}
|
||||
INSTALL_ICONS= yes
|
||||
|
||||
SHEBANG_FILES= plugins/asymptote/bin/tm_asy2 \
|
||||
plugins/feynmf/bin/bbox_add.pl \
|
||||
plugins/asymptote/bin/perl-tm_asy
|
||||
|
||||
DATADIR= ${PREFIX}/share/TeXmacs
|
||||
|
||||
OPTIONS_DEFINE= FREETYPE GHOSTSCRIPT ICONV IMLIB2 PDF QT4
|
||||
OPTIONS_DEFAULT= FREETYPE GHOSTSCRIPT ICONV IMLIB2 QT4
|
||||
OPTIONS_DEFAULT=FREETYPE GHOSTSCRIPT ICONV IMLIB2 QT4
|
||||
PDF_DESC= Experimental PDF renderer
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
FREETYPE_LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2
|
||||
FREETYPE_CONFIGURE_WITH=freetype=linked
|
||||
|
||||
.if ${PORT_OPTIONS:MFREETYPE}
|
||||
LIB_DEPENDS+= libfreetype.so:${PORTSDIR}/print/freetype2
|
||||
CONFIGURE_ARGS+= --with-freetype=linked
|
||||
.else
|
||||
CONFIGURE_ARGS+= --without-freetype
|
||||
.endif
|
||||
GHOSTSCRIPT_USE= GHOSTSCRIPT=yes
|
||||
GHOSTSCRIPT_CONFIGURE_WITH= gs=yes
|
||||
|
||||
.if ${PORT_OPTIONS:MGHOSTSCRIPT}
|
||||
USE_GHOSTSCRIPT= yes
|
||||
CONFIGURE_ARGS+= --with-gs=yes
|
||||
.else
|
||||
CONFIGURE_ARGS+= --without-gs
|
||||
.endif
|
||||
ICONV_USES= iconv
|
||||
ICONV_CONFIGURE_WITH= iconv
|
||||
|
||||
.if ${PORT_OPTIONS:MICONV}
|
||||
USES+= iconv
|
||||
CONFIGURE_ARGS+= --with-iconv
|
||||
.else
|
||||
CONFIGURE_ARGS+= --without-iconv
|
||||
.endif
|
||||
IMLIB2_USE= EFL=imlib2
|
||||
IMLIB2_CONFIGURE_ON= --with-imlib2
|
||||
IMLIB2_CONFIGURE_OFF= --without-imlib
|
||||
|
||||
.if ${PORT_OPTIONS:MIMLIB2}
|
||||
USE_EFL= imlib2
|
||||
CONFIGURE_ARGS+= --with-imlib2
|
||||
.else
|
||||
CONFIGURE_ARGS+= --without-imlib
|
||||
.endif
|
||||
PDF_CONFIGURE_ON= --enable-pdf-renderer
|
||||
|
||||
.if ${PORT_OPTIONS:MPDF}
|
||||
CONFIGURE_ARGS+= --enable-pdf-renderer
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MQT4}
|
||||
USE_QT4= gui moc_build qmake_build rcc uic_build
|
||||
CONFIGURE_ARGS+= --with-qt --enable-qtpipes
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-qt
|
||||
.endif
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
QT4_USE= QT4=gui,moc_build,qmake_build,rcc,uic_build
|
||||
QT4_CONFIGURE_ON= --with-qt --enable-qtpipes
|
||||
QT4_CONFIGURE_OFF= --disable-qt
|
||||
|
||||
post-patch:
|
||||
@${GREP} -lR "#!/bin/bash" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
|
||||
|
@ -87,4 +66,4 @@ post-patch:
|
|||
@${REINPLACE_CMD} -e 's|qdrawutil.h|qt4/Qt/qdrawutil.h|' \
|
||||
${WRKSRC}/src/Plugins/Qt/QTMStyle.cpp
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
|
11
editors/texmacs/files/patch-src__Kernel__Types__tree.cpp
Normal file
11
editors/texmacs/files/patch-src__Kernel__Types__tree.cpp
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- ./src/Kernel/Types/tree.cpp.orig 2014-08-28 13:09:45.011154991 -0400
|
||||
+++ ./src/Kernel/Types/tree.cpp 2014-08-28 13:10:18.050663990 -0400
|
||||
@@ -195,7 +195,7 @@
|
||||
}
|
||||
|
||||
void
|
||||
-print_tree (tree t, int tab) {
|
||||
+print_tree (tree t, int tab=0) {
|
||||
int i;
|
||||
for (i=0; i<tab; i++) cout << " ";
|
||||
if (is_atomic (t)) cout << t->label << "\n";
|
11
editors/texmacs/files/patch-src__Kernel__Types__tree.hpp
Normal file
11
editors/texmacs/files/patch-src__Kernel__Types__tree.hpp
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- ./src/Kernel/Types/tree.hpp.orig 2014-08-28 13:09:50.435479991 -0400
|
||||
+++ ./src/Kernel/Types/tree.hpp 2014-08-28 13:10:38.328730991 -0400
|
||||
@@ -84,7 +84,7 @@
|
||||
friend tree& operator << (tree& t, array<tree> a);
|
||||
friend tm_ostream& operator << (tm_ostream& out, tree t);
|
||||
friend tree operator * (tree t1, tree t2);
|
||||
- friend void print_tree (tree t, int tab=0);
|
||||
+ friend void print_tree (tree t, int tab);
|
||||
friend list<tree> as_trees (list<pointer> l);
|
||||
friend class tree_pointer_rep;
|
||||
friend class tree_position_rep;
|
|
@ -0,0 +1,11 @@
|
|||
--- ./src/Typeset/Boxes/Basic/boxes.cpp.orig 2014-08-28 13:13:07.420709990 -0400
|
||||
+++ ./src/Typeset/Boxes/Basic/boxes.cpp 2014-08-28 13:13:15.171566990 -0400
|
||||
@@ -850,7 +850,7 @@
|
||||
******************************************************************************/
|
||||
|
||||
void
|
||||
-make_eps (url name, box b, int dpi) {
|
||||
+make_eps (url name, box b, int dpi=600) {
|
||||
double inch= ((double) dpi * PIXEL);
|
||||
double cm = inch / 2.54;
|
||||
SI w= b->x4 - b->x3;
|
11
editors/texmacs/files/patch-src__Typeset__boxes.hpp
Normal file
11
editors/texmacs/files/patch-src__Typeset__boxes.hpp
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- ./src/Typeset/boxes.hpp.orig 2014-08-28 13:13:20.617755990 -0400
|
||||
+++ ./src/Typeset/boxes.hpp 2014-08-28 13:13:35.051223990 -0400
|
||||
@@ -255,7 +255,7 @@
|
||||
friend class phrase_box_rep;
|
||||
friend class remember_box_rep;
|
||||
friend class effect_box_rep;
|
||||
- friend void make_eps (url dest, box b, int dpi= 600);
|
||||
+ friend void make_eps (url dest, box b, int dpi);
|
||||
};
|
||||
ABSTRACT_NULL_CODE(box);
|
||||
|
|
@ -4150,16 +4150,14 @@ share/icons/gnome/scalable/mimetypes/text-texmacs.svg
|
|||
share/mime-info/texmacs.keys
|
||||
share/mime-info/texmacs.mime
|
||||
share/mime/packages/texmacs.xml
|
||||
share/mime/text/x-texmacs.xml
|
||||
share/pixmaps/TeXmacs.xpm
|
||||
@dirrmtry share/mime/text
|
||||
@dirrmtry share/mime/packages
|
||||
@dirrmtry share/mime-info
|
||||
@dirrmtry share/mime
|
||||
@dirrmtry share/icons/gnome/scalable/mimetypes
|
||||
@dirrmtry share/icons/gnome/scalable/apps
|
||||
@dirrmtry share/icons/gnome/scalable
|
||||
@dirrmtry share/icons/gnome
|
||||
@dirrmtry share/icons
|
||||
@dirrmtry share/application-registry
|
||||
@dirrm %%DATADIR%%/texts/test
|
||||
@dirrm %%DATADIR%%/texts
|
||||
|
|
Loading…
Reference in a new issue