- Update to 0.9.7 [1]

- Properly respect PREFIX
- Remove unneeded USE_REINPLACE
- Add SIZE to distinfo
- Re-sort pkg-plist
- Re-format pkg-descr

PR:		ports/61820 [1]
Submitted by:	maintainer [1]
This commit is contained in:
Sergei Kolobov 2004-01-31 23:18:12 +00:00
parent 6f3a2bc625
commit 7dafd7e358
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=99645
8 changed files with 52 additions and 113 deletions

View file

@ -6,12 +6,11 @@
#
PORTNAME= firedns
PORTVERSION= 0.1.30
PORTVERSION= 0.9.7
CATEGORIES= dns devel
MASTER_SITES= http://www.wa.apana.org.au/~dean/sources/ \
MASTER_SITES= http://firestuff.org/projects/ \
http://www.wa.apana.org.au/~dean/sources/ \
ftp://ftp.wa.apana.org.au/pub/pc/unix/packages/
DISTNAME= ${PORTNAME}
EXTRACT_SUFX= -${PORTVERSION}.tar.gz
MAINTAINER= dean@odyssey.apana.org.au
COMMENT= A C library for handling asynchronous DNS queries
@ -19,24 +18,24 @@ COMMENT= A C library for handling asynchronous DNS queries
BUILD_DEPENDS= ${LOCALBASE}/include/firestring.h:${PORTSDIR}/misc/firestring
HAS_CONFIGURE= yes
CONFIGURE_ENV= PREFIX="${PREFIX}"
INSTALLS_SHLIB= yes
USE_REINPLACE= yes
MAN3= firedns_aton4.3 firedns_aton6.3 firedns_dnsbl_lookup.3 \
firedns_getip4.3 firedns_getip6.3 firedns_getmx.3 \
firedns_getname4.3 firedns_getname6.3 \
firedns_getresult.3 firedns_gettxt.3 firedns_ntoa4.3 \
WRKSRC= ${WRKDIR}/${PORTNAME}
MAN3= firedns_aton4.3 firedns_aton6.3 \
firedns_dnsbl_lookup.3 firedns_getip4.3 \
firedns_getip6.3 firedns_getmx.3 \
firedns_getmxlist.3 firedns_getname4.3 \
firedns_getname6.3 firedns_getresult.3 \
firedns_gettxt.3 firedns_ntoa4.3 \
firedns_ntoa6.3 firedns_resolveip4.3 \
firedns_resolveip6.3 firedns_resolvemx.3 \
firedns_resolvename4.3 firedns_resolvename6.3 \
firedns_resolvetxt.3 libfiredns.3
firedns_resolveip6.3 firedns_resolvemx.3 \
firedns_resolvemxlist.3 firedns_resolvename4.3 \
firedns_resolvename6.3 firedns_resolvetxt.3 \
libfiredns.3
post-patch:
${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
${WRKSRC}/firemake.cflags ${WRKSRC}/firemake.ldflags
post-install:
@cd ${PREFIX}/lib; ${MV} libfiredns.so libfiredns.so.0; \
${LN} -s libfiredns.so.0 libfiredns.so
pre-configure:
@-${RM} ${WRKSRC}/firemake/*.orig
.include <bsd.port.mk>

View file

@ -1 +1,2 @@
MD5 (firedns-0.1.30.tar.gz) = 0e18e14615036555183ee01b43fffd3c
MD5 (firedns-0.9.7.tar.gz) = dd6fbf0e3a5fbdf5761c7139987d7657
SIZE (firedns-0.9.7.tar.gz) = 91920

View file

@ -1,78 +0,0 @@
--- configure.orig Thu Oct 31 09:47:26 2002
+++ configure Thu Oct 31 10:30:36 2002
@@ -534,33 +534,33 @@
$ECHO -n " adding rule to install binaries..."
$ECHO "install-binaries: $BINARIES" >> Makefile
-$ECHO " install -d -m 0755 -o \$(INSTALL_USER) \$(BINDIR)" >> Makefile
+$ECHO " install -d -m 0755 -o \$(INSTALL_USER) \$(PREFIX)/bin" >> Makefile
$ECHO "done"
for BINARY in $BINARIES; do
$ECHO -n " adding rule to install binary $BINARY..."
- $ECHO " install -m 0755 -o \$(INSTALL_USER) $BINARY \$(BINDIR)" >> Makefile
+ $ECHO " install -m 0755 -o \$(INSTALL_USER) $BINARY \$(PREFIX)/bin" >> Makefile
$ECHO "done"
done;
$ECHO >> Makefile
$ECHO -n " adding rule to install static libraries..."
$ECHO "install-static: $STATIC" >> Makefile
-$ECHO " install -d -m 0755 -o \$(INSTALL_USER) \$(LIBDIR)" >> Makefile
+$ECHO " install -d -m 0755 -o \$(INSTALL_USER) \$(PREFIX)/lib" >> Makefile
$ECHO "done"
for LIBRARY in $STATIC; do
$ECHO -n " adding rule to install static library $LIBRARY..."
- $ECHO " install -m 0755 -o \$(INSTALL_USER) $LIBRARY \$(LIBDIR)" >> Makefile
+ $ECHO " install -m 0755 -o \$(INSTALL_USER) $LIBRARY \$(PREFIX)/lib" >> Makefile
$ECHO "done"
done;
$ECHO >> Makefile
$ECHO -n " adding rule to install shared libraries..."
$ECHO "install-shared: $STATIC" >> Makefile
-$ECHO " install -d -m 0755 -o \$(INSTALL_USER) \$(LIBDIR)" >> Makefile
+$ECHO " install -d -m 0755 -o \$(INSTALL_USER) \$(PREFIX)/lib" >> Makefile
$ECHO "done"
for LIBRARY in $SHARED; do
$ECHO -n " adding rule to install shared library $LIBRARY..."
- $ECHO " install -m 0755 -o \$(INSTALL_USER) $LIBRARY \$(LIBDIR)" >> Makefile
+ $ECHO " install -m 0755 -o \$(INSTALL_USER) $LIBRARY \$(PREFIX)/lib" >> Makefile
$ECHO "done"
done;
$ECHO >> Makefile
@@ -577,10 +577,10 @@
$ECHO "no firemake.headers found"
fi
$ECHO "install-headers: $HEADERS" >> Makefile
-$ECHO " install -d -m 0755 -o \$(INSTALL_USER) \$(INCLUDEDIR)" >> Makefile
+$ECHO " install -d -m 0755 -o \$(INSTALL_USER) \$(PREFIX)/include" >> Makefile
for HEADER in $HEADERS; do
$ECHO -n " adding rule to install header $HEADER..."
- $ECHO " install -m 0644 -o \$(INSTALL_USER) $HEADER \$(INCLUDEDIR)" >> Makefile
+ $ECHO " install -m 0644 -o \$(INSTALL_USER) $HEADER \$(PREFIX)/include" >> Makefile
$ECHO "done"
done;
$ECHO >> Makefile
@@ -592,8 +592,8 @@
LS=`ls man/*.$SECTION 2>>configure.log`
if test "$LS" != ""; then
$ECHO "man/*.$SECTION" >> Makefile
- $ECHO " install -d -m 0755 -o \$(INSTALL_USER) \$(MANDIR)/man$SECTION" >> Makefile
- $ECHO " install -m 0644 -o \$(INSTALL_USER) man/*.$SECTION \$(MANDIR)/man$SECTION" >> Makefile
+ $ECHO " install -d -m 0755 -o \$(INSTALL_USER) \$(PREFIX)/man/man$SECTION" >> Makefile
+ $ECHO " install -m 0644 -o \$(INSTALL_USER) man/*.$SECTION \$(PREFIX)/man/man$SECTION" >> Makefile
$ECHO "done"
else
$ECHO >> Makefile
@@ -618,9 +618,9 @@
$ECHO -n "conf/$CONF " >> Makefile
done
$ECHO >> Makefile
- $ECHO " install -d -m 0755 -o \$(INSTALL_USER) \$(CONFDIR)" >> Makefile
+ $ECHO " install -d -m 0755 -o \$(INSTALL_USER) \$(PREFIX)/etc" >> Makefile
for CONF in $CONFS; do
- $ECHO " if test ! -f \$(CONFDIR)/$CONF; then install -m 0644 -o \$(INSTALL_USER) conf/$CONF \$(CONFDIR); fi" >> Makefile
+ $ECHO " if test ! -f \$(PREFIX)/etc/$CONF; then install -m 0644 -o \$(INSTALL_USER) conf/$CONF \$(PREFIX)/etc; fi" >> Makefile
done
$ECHO "done"
else

View file

@ -1,5 +0,0 @@
--- firemake.libs.orig Sat Nov 16 10:00:14 2002
+++ firemake.libs Sat Nov 16 10:00:23 2002
@@ -1 +1 @@
--lfirestring -lpthread
+-lfirestring -pthread

View file

@ -0,0 +1,11 @@
--- firemake/libraries.orig Tue Jan 27 02:20:13 2004
+++ firemake/libraries Tue Jan 27 02:20:35 2004
@@ -96,7 +96,7 @@ case $PHASE in
dispn " $LIBRARY..."
$ECHO " $INSTALL ${LIBRARY}.a \$(LIBDIR) $INSTALL_USER $INSTALL_GROUP 0755"
$ECHO " $INSTALL ${LIBRARY}.so.$VERSION \$(LIBDIR) $INSTALL_USER $INSTALL_GROUP 0755"
- $ECHO " ln -sf ${LIBRARY}.so.$VERSION \$(LIBDIR)/${LIBRARY}.so.$VERSION2"
+ $ECHO " ln -sf ${LIBRARY}.so.$VERSION \$(LIBDIR)/${LIBRARY}.so.0"
$ECHO " ln -sf ${LIBRARY}.so.$VERSION \$(LIBDIR)/${LIBRARY}.so"
disp "done"
done

View file

@ -0,0 +1,11 @@
--- firemake/makefiletop.orig Tue Jan 27 02:16:48 2004
+++ firemake/makefiletop Tue Jan 27 02:16:58 2004
@@ -3,7 +3,7 @@
#require make
#phase makefile
dispn "Writing Makefile top entries..."
-if test "$MAKE_CONDSET" = "y"; then
+if test "$MAKE_CONDSET" = "never"; then
$ECHO "PREFIX ?= $FM_PREFIX"
if test "$FM_MANDIRSTRICT" = "y"; then

View file

@ -1,16 +1,13 @@
From libfiredns(3):
"libfiredns is a library for handling asynchronous DNS
libfiredns is a library for handling asynchronous DNS
requests. It provides a very simple interface for sending
requests and parsing reponses, as well as low-timeout
blocking functions. It can also be compiled to override
the BIND/LIBC functions with its alternative implementations.
libfiredns functions have much lower timeouts than the stock
functions and tend to be faster because they send requests
to all configured system nameservers at the same time."
to all configured system nameservers at the same time.
WWW: http://ares.penguinhosting.net/~ian/
WWW: http://ares.penguinhosting.net/~ian/
- Dean
dean@odyssey.apana.org.au

View file

@ -1,8 +1,11 @@
@comment $FreeBSD$
bin/fdnsip
bin/fdnsmx
bin/fdnsmxlist
bin/fdnsname
bin/fdnstxt
include/firedns.h
lib/libfiredns.a
lib/libfiredns.so
lib/libfiredns.so.0
lib/libfiredns.a
bin/fdnsip
bin/fdnstxt
bin/fdnsname
lib/libfiredns.so.0.9.7