Update to 0.8.14.
This commit is contained in:
parent
5db6fe3f0f
commit
7db5b3a33f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=119689
22 changed files with 237 additions and 196 deletions
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= ser
|
||||
PORTVERSION= 0.8.12
|
||||
PORTVERSION= 0.8.14
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ftp://ftp.berlios.de/pub/ser/${PORTVERSION}/src/
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION}_src
|
||||
|
@ -15,12 +15,15 @@ MAINTAINER= sobomax@FreeBSD.org
|
|||
COMMENT= A very fast and configurable SIP proxy
|
||||
|
||||
BUILD_DEPENDS= ${LOCALBASE}/lib/mysql/libmysqlclient.a:${PORTSDIR}/databases/mysql40-client
|
||||
LIB_DEPENDS= radiusclient.0:${PORTSDIR}/net/radiusclient
|
||||
LIB_DEPENDS= radiusclient.2:${PORTSDIR}/net/radiusclient \
|
||||
pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
|
||||
RUN_DEPENDS= ${LOCALBASE}/lib/mysql/libmysqlclient.a:${PORTSDIR}/databases/mysql40-client
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||
|
||||
USE_GMAKE= yes
|
||||
POSTGRESQL_PORT?= databases/postgresql7
|
||||
|
||||
USE_GMAKE= yes
|
||||
CFLAGS+= -I${LOCALBASE}/include
|
||||
|
||||
MAN8= ser.8
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
MD5 (ser-0.8.12_src.tar.gz) = 952fadd9f76e128ee9a4be350a647713
|
||||
SIZE (ser-0.8.12_src.tar.gz) = 1509665
|
||||
MD5 (ser-0.8.14_src.tar.gz) = 3e2e12c8dfbd7dad9199304093de0838
|
||||
SIZE (ser-0.8.14_src.tar.gz) = 1551881
|
||||
|
|
|
@ -1,12 +1,15 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- Makefile.orig Fri Aug 29 19:58:39 2003
|
||||
+++ Makefile Wed Sep 10 19:38:09 2003
|
||||
@@ -46,8 +46,8 @@
|
||||
exclude_modules?= cpl cpl-c ext extcmd mangler pdt \
|
||||
postgres snmp \
|
||||
im radius_acc radius_auth \
|
||||
--- Makefile.orig Tue Jul 27 02:18:34 2004
|
||||
+++ Makefile Tue Jul 27 21:01:36 2004
|
||||
@@ -44,10 +44,10 @@
|
||||
|
||||
# if not set on the cmd. line or the env, exclude this modules:
|
||||
exclude_modules?= cpl cpl-c extcmd \
|
||||
- postgres snmp \
|
||||
+ snmp \
|
||||
im \
|
||||
- jabber mysql \
|
||||
- auth_radius group_radius uri_radius
|
||||
+ jabber \
|
||||
|
@ -14,7 +17,7 @@ $FreeBSD$
|
|||
# always exclude the CVS dir
|
||||
override exclude_modules+= CVS $(skip_modules)
|
||||
|
||||
@@ -247,7 +247,7 @@
|
||||
@@ -258,7 +258,7 @@
|
||||
chmod 644 $(cfg-prefix)/$(cfg-dir)ser.cfg.sample
|
||||
if [ -z "${skip_cfg_install}" -a \
|
||||
! -f $(cfg-prefix)/$(cfg-dir)ser.cfg ]; then \
|
||||
|
@ -23,7 +26,7 @@ $FreeBSD$
|
|||
$(cfg-prefix)/$(cfg-dir)ser.cfg; \
|
||||
fi
|
||||
# $(INSTALL-CFG) etc/ser.cfg $(cfg-prefix)/$(cfg-dir)
|
||||
@@ -256,10 +256,10 @@
|
||||
@@ -267,10 +267,10 @@
|
||||
$(INSTALL-TOUCH) $(bin-prefix)/$(bin-dir)/ser
|
||||
$(INSTALL-BIN) ser $(bin-prefix)/$(bin-dir)
|
||||
$(INSTALL-TOUCH) $(bin-prefix)/$(bin-dir)/sc
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- Makefile.defs.orig Thu Nov 20 12:57:22 2003
|
||||
+++ Makefile.defs Wed Feb 4 14:27:53 2004
|
||||
@@ -123,10 +123,11 @@
|
||||
--- Makefile.defs.orig
|
||||
+++ Makefile.defs
|
||||
@@ -133,10 +133,11 @@
|
||||
INSTALL-TOUCH = touch # used to create the file first (good to
|
||||
# make solaris install work)
|
||||
# INSTALL-CFG = $(INSTALL) -m 644
|
||||
|
@ -19,7 +19,7 @@ $FreeBSD$
|
|||
|
||||
#set some vars from the environment (and not make builtins)
|
||||
CC := $(shell echo "$${CC}")
|
||||
@@ -275,10 +276,10 @@
|
||||
@@ -285,10 +286,11 @@
|
||||
-DPKG_MALLOC \
|
||||
-DSHM_MEM -DSHM_MMAP \
|
||||
-DDNS_IP_HACK \
|
||||
|
@ -27,13 +27,14 @@ $FreeBSD$
|
|||
- -DUSE_TCP \
|
||||
-DDISABLE_NAGLE \
|
||||
- -DF_MALLOC \
|
||||
+ # -DUSE_IPV6 \
|
||||
+ # -DUSE_TCP \
|
||||
+ -DNO_DEBUG \
|
||||
+ -DUSE_IPV6 \
|
||||
+ -DUSE_TCP
|
||||
+ # -DF_MALLOC \
|
||||
# -DDBG_QM_MALLOC \
|
||||
# -DDBG_QM_MALLOC \
|
||||
# -DF_MALLOC \
|
||||
@@ -398,8 +399,8 @@
|
||||
@@ -408,8 +410,8 @@
|
||||
found_lock_method=yes
|
||||
endif
|
||||
|
||||
|
@ -44,7 +45,7 @@ $FreeBSD$
|
|||
# setting CFLAGS
|
||||
ifeq ($(mode), release)
|
||||
#if i386
|
||||
@@ -407,7 +408,7 @@
|
||||
@@ -417,7 +419,7 @@
|
||||
# if gcc
|
||||
ifeq ($(CC_NAME), gcc)
|
||||
#common stuff
|
||||
|
@ -53,7 +54,7 @@ $FreeBSD$
|
|||
-Wall \
|
||||
#if gcc 3.0
|
||||
ifeq ($(CC_SHORTVER), 3.0)
|
||||
@@ -433,7 +434,7 @@
|
||||
@@ -443,7 +445,7 @@
|
||||
|
||||
else # CC_NAME, gcc
|
||||
ifeq ($(CC_NAME), icc)
|
||||
|
@ -62,7 +63,7 @@ $FreeBSD$
|
|||
-tpp6 -xK #-openmp #optimize for PIII
|
||||
# -prefetch doesn't seem to work
|
||||
#( ty to inline acroos files, unroll loops,prefetch,
|
||||
@@ -452,7 +453,7 @@
|
||||
@@ -462,7 +464,7 @@
|
||||
#if gcc
|
||||
ifeq ($(CC_NAME), gcc)
|
||||
#common stuff
|
||||
|
@ -71,7 +72,7 @@ $FreeBSD$
|
|||
-Wall\
|
||||
#-Wcast-align \
|
||||
#-Wmissing-prototypes
|
||||
@@ -510,7 +511,7 @@
|
||||
@@ -520,7 +522,7 @@
|
||||
# if gcc
|
||||
ifeq ($(CC_NAME), gcc)
|
||||
#common stuff
|
||||
|
@ -80,3 +81,12 @@ $FreeBSD$
|
|||
-Wall \
|
||||
#if gcc 3.0
|
||||
ifeq ($(CC_SHORTVER), 3.0)
|
||||
@@ -707,7 +709,7 @@
|
||||
found_lock_method=yes
|
||||
LIBS= -pthread -lfl #dlopen is in libc
|
||||
else
|
||||
- LIBS= -lfl #dlopen is in libc
|
||||
+ LIBS= -lfl -L$(LOCALBASE)/lib -lsiplog #dlopen is in libc
|
||||
endif
|
||||
YACC=yacc
|
||||
endif
|
||||
|
|
|
@ -1,14 +1,14 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- modules/acc/acc_mod.c 2004/02/05 19:49:04 1.1
|
||||
+++ modules/acc/acc_mod.c 2004/02/05 19:49:16
|
||||
--- modules/acc/acc_mod.c.orig Mon Jul 19 01:56:23 2004
|
||||
+++ modules/acc/acc_mod.c Tue Jul 27 21:01:36 2004
|
||||
@@ -93,7 +93,7 @@
|
||||
int log_level=L_NOTICE;
|
||||
char *log_fmt=DEFAULT_LOG_FMT;
|
||||
#ifdef RAD_ACC
|
||||
-char *radius_config = "/usr/local/etc/radiusclient/radiusclient.conf";
|
||||
+char *radius_config = (CFG_DIR "radiusclient.conf");
|
||||
-static char *radius_config = "/usr/local/etc/radiusclient/radiusclient.conf";
|
||||
+static char *radius_config = (CFG_DIR "radiusclient.conf");
|
||||
int radius_flag = 0;
|
||||
int radius_missed_flag = 0;
|
||||
int service_type = PW_SIP_SESSION;
|
||||
static int service_type = -1;
|
||||
|
|
|
@ -1,110 +0,0 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- modules/acc/etc/sip_dictionary.orig Sat Apr 5 06:05:19 2003
|
||||
+++ modules/acc/etc/sip_dictionary Wed Dec 17 08:33:05 2003
|
||||
@@ -23,6 +23,14 @@
|
||||
# 7 = 1 (integer encoding)
|
||||
#
|
||||
|
||||
+VENDOR Cisco 9
|
||||
+ATTRIBUTE Cisco-AVPair 1 string Cisco
|
||||
+ATTRIBUTE h323-credit-time 102 string Cisco
|
||||
+ATTRIBUTE h323-return-code 103 string Cisco
|
||||
+ATTRIBUTE h323-preferred-lang 107 string Cisco
|
||||
+ATTRIBUTE h323-billing-model 109 string Cisco
|
||||
+ATTRIBUTE h323-currency 110 string Cisco
|
||||
+
|
||||
#
|
||||
# Following are the proper new names. Use these.
|
||||
#
|
||||
@@ -99,39 +107,42 @@
|
||||
# Experiment SIP-specific attributes:
|
||||
# These attributes are tied between client & server
|
||||
#
|
||||
-ATTRIBUTE Sip-Method 101 integer
|
||||
-ATTRIBUTE Sip-Response-Code 102 integer
|
||||
-ATTRIBUTE Sip-CSeq 103 string
|
||||
-ATTRIBUTE Sip-To-Tag 104 string
|
||||
-ATTRIBUTE Sip-From-Tag 105 string
|
||||
-ATTRIBUTE Sip-Branch-ID 106 string
|
||||
+ATTRIBUTE Sip-Method 101 integer
|
||||
+ATTRIBUTE Sip-Response-Code 102 integer
|
||||
+ATTRIBUTE Sip-CSeq 103 string
|
||||
+ATTRIBUTE Sip-To-Tag 104 string
|
||||
+ATTRIBUTE Sip-From-Tag 105 string
|
||||
+ATTRIBUTE Sip-Branch-ID 106 string
|
||||
ATTRIBUTE Sip-Translated-Request-URI 107 string
|
||||
ATTRIBUTE Sip-Source-IP-Address 108 ipaddr
|
||||
-ATTRIBUTE Sip-Source-Port 109 integer
|
||||
-ATTRIBUTE Sip-User-ID 110 string
|
||||
-ATTRIBUTE Sip-User-realm 111 string
|
||||
-ATTRIBUTE Sip-User-nonce 112 string
|
||||
-ATTRIBUTE Sip-User-method 113 string
|
||||
-ATTRIBUTE Sip-User-digest-uri 114 string
|
||||
-ATTRIBUTE Sip-User-nonce_count 115 string
|
||||
-ATTRIBUTE Sip-User-qop 116 string
|
||||
-ATTRIBUTE Sip-User-opaque 117 string
|
||||
-ATTRIBUTE Sip-User-response 118 string
|
||||
-ATTRIBUTE Sip_User-cnonce 119 string
|
||||
+ATTRIBUTE Sip-Source-Port 109 integer
|
||||
+ATTRIBUTE Sip-User-ID 110 string
|
||||
+ATTRIBUTE Sip-User-Realm 111 string
|
||||
+ATTRIBUTE Sip-User-Nonce 112 string
|
||||
+ATTRIBUTE Sip-User-Method 113 string
|
||||
+ATTRIBUTE Sip-User-Digest-URI 114 string
|
||||
+ATTRIBUTE Sip-User-Nonce-Count 115 string
|
||||
+ATTRIBUTE Sip-User-QOP 116 string
|
||||
+ATTRIBUTE Sip-User-Opaque 117 string
|
||||
+ATTRIBUTE Sip-User-Response 118 string
|
||||
+ATTRIBUTE Sip-User-CNonce 119 string
|
||||
|
||||
+ATTRIBUTE Sip-URI-User 208 string
|
||||
+ATTRIBUTE Sip-Group 211 string
|
||||
+ATTRIBUTE Sip-RPId 213 string
|
||||
|
||||
-ATTRIBUTE Digest-Response 206 string
|
||||
-ATTRIBUTE Digest-Attributes 207 string
|
||||
-ATTRIBUTE Digest-Realm 1063 string
|
||||
-ATTRIBUTE Digest-Nonce 1064 string
|
||||
-ATTRIBUTE Digest-Method 1065 string
|
||||
-ATTRIBUTE Digest-URI 1066 string
|
||||
-ATTRIBUTE Digest-QOP 1067 string
|
||||
-ATTRIBUTE Digest-Algorithm 1068 string
|
||||
-ATTRIBUTE Digest-Body-Digest 1069 string
|
||||
-ATTRIBUTE Digest-CNonce 1070 string
|
||||
-ATTRIBUTE Digest-Nonce-Count 1071 string
|
||||
-ATTRIBUTE Digest-User-Name 1072 string
|
||||
+ATTRIBUTE Digest-Response 206 string
|
||||
+ATTRIBUTE Digest-Attributes 207 string
|
||||
+ATTRIBUTE Digest-Realm 1063 string
|
||||
+ATTRIBUTE Digest-Nonce 1064 string
|
||||
+ATTRIBUTE Digest-Method 1065 string
|
||||
+ATTRIBUTE Digest-URI 1066 string
|
||||
+ATTRIBUTE Digest-QOP 1067 string
|
||||
+ATTRIBUTE Digest-Algorithm 1068 string
|
||||
+ATTRIBUTE Digest-Body-Digest 1069 string
|
||||
+ATTRIBUTE Digest-CNonce 1070 string
|
||||
+ATTRIBUTE Digest-Nonce-Count 1071 string
|
||||
+ATTRIBUTE Digest-User-Name 1072 string
|
||||
|
||||
|
||||
|
||||
@@ -165,6 +176,9 @@
|
||||
VALUE Service-Type Outbound-User 5
|
||||
VALUE Service-Type Administrative-User 6
|
||||
VALUE Service-Type NAS-Prompt-User 7
|
||||
+VALUE Service-Type Call-Check 10
|
||||
+VALUE Service-Type Group-Check 12
|
||||
+VALUE Service-Type Sip-Session 15
|
||||
|
||||
# Framed Protocols
|
||||
|
||||
@@ -196,6 +210,7 @@
|
||||
VALUE Acct-Status-Type Stop 2
|
||||
VALUE Acct-Status-Type Accounting-On 7
|
||||
VALUE Acct-Status-Type Accounting-Off 8
|
||||
+VALUE Acct-Status-Type Failed 15
|
||||
|
||||
# Authentication Types
|
||||
|
|
@ -1,14 +0,0 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- modules/auth_radius/Makefile.orig Fri May 23 18:43:42 2003
|
||||
+++ modules/auth_radius/Makefile Sun Aug 17 14:29:38 2003
|
||||
@@ -8,6 +8,7 @@
|
||||
include ../../Makefile.defs
|
||||
auto_gen=
|
||||
NAME=auth_radius.so
|
||||
-LIBS=-L$(LOCALBASE)/lib -L/usr/pkg/lib -lradiusclient
|
||||
+DEFS+=-I$(LOCALBASE)/include
|
||||
+LIBS=-L$(LOCALBASE)/lib -L/usr/pkg/lib -lradiusclient
|
||||
|
||||
include ../../Makefile.modules
|
|
@ -1,14 +1,14 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- modules/auth_radius/authrad_mod.c 2004/02/05 19:49:04 1.1
|
||||
+++ modules/auth_radius/authrad_mod.c 2004/02/05 19:49:21
|
||||
@@ -59,7 +59,7 @@
|
||||
--- modules/auth_radius/authrad_mod.c.orig Mon Jul 19 01:56:23 2004
|
||||
+++ modules/auth_radius/authrad_mod.c Tue Jul 27 21:50:52 2004
|
||||
@@ -64,7 +64,7 @@
|
||||
/*
|
||||
* Module parameter variables
|
||||
*/
|
||||
-char* radius_config = "/usr/local/etc/radiusclient/radiusclient.conf";
|
||||
+char* radius_config = (CFG_DIR "radiusclient.conf");
|
||||
int service_type = PW_SIP_SESSION;
|
||||
-static char* radius_config = "/usr/local/etc/radiusclient/radiusclient.conf";
|
||||
+static char* radius_config = (CFG_DIR "radiusclient.conf");
|
||||
static int service_type = -1;
|
||||
|
||||
|
||||
|
|
14
net/ser/files/patch-modules::ext::ext.c
Normal file
14
net/ser/files/patch-modules::ext::ext.c
Normal file
|
@ -0,0 +1,14 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- modules/ext/ext.c.orig Sun Apr 6 23:25:51 2003
|
||||
+++ modules/ext/ext.c Tue May 4 19:11:40 2004
|
||||
@@ -49,6 +50,8 @@
|
||||
#include "my_exec.h"
|
||||
#include "config.h"
|
||||
|
||||
+MODULE_VERSION
|
||||
+
|
||||
#define MAX_BUFFER_LEN 1024
|
||||
|
||||
|
|
@ -1,14 +1,14 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- modules/group_radius/grouprad_mod.c 2003/07/06 18:04:54 1.1
|
||||
+++ modules/group_radius/grouprad_mod.c 2003/07/06 18:05:41
|
||||
@@ -52,7 +52,7 @@
|
||||
--- modules/group_radius/grouprad_mod.c.orig Mon Jul 19 01:56:24 2004
|
||||
+++ modules/group_radius/grouprad_mod.c Tue Jul 27 21:01:37 2004
|
||||
@@ -57,7 +57,7 @@
|
||||
/*
|
||||
* Module parameter variables
|
||||
*/
|
||||
-char* radius_config = "/usr/local/etc/radiusclient/radiusclient.conf";
|
||||
+char* radius_config = (CFG_DIR "radiusclient.conf");
|
||||
-static char* radius_config = "/usr/local/etc/radiusclient/radiusclient.conf";
|
||||
+static char* radius_config = (CFG_DIR "radiusclient.conf");
|
||||
int use_domain = 1; /* By default we use domain */
|
||||
|
||||
|
||||
|
|
|
@ -1,14 +1,16 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- modules/postgres/Makefile.orig Wed Jul 30 19:34:46 2003
|
||||
+++ modules/postgres/Makefile Wed Sep 10 19:40:11 2003
|
||||
@@ -7,7 +7,7 @@
|
||||
--- modules/postgres/Makefile.orig Wed Jul 30 19:29:00 2003
|
||||
+++ modules/postgres/Makefile Mon Apr 12 19:12:53 2004
|
||||
@@ -7,8 +7,8 @@
|
||||
NAME=postgres.so
|
||||
|
||||
# libpq-fe.h locations
|
||||
-DEFS +=-I/usr/local/pgsql/include -I/usr/include/postgresql
|
||||
+DEFS +=-I$(LOCALBASE)/pgsql/include -I/usr/include/postgresql
|
||||
LIBS=-L$(LOCALBASE)/pgsql/lib -L$(LOCALBASE)/lib/pgsql -L/usr/pkg/lib \
|
||||
-LIBS=-L$(LOCALBASE)/pgsql/lib -L$(LOCALBASE)/lib/pgsql -L/usr/pkg/lib \
|
||||
+DEFS +=-I$(LOCALBASE)/include -I$(LOCALBASE)/pgsql/include -I/usr/include/postgresql
|
||||
+LIBS=-L$(LOCALBASE)/lib -L$(LOCALBASE)/pgsql/lib -L$(LOCALBASE)/lib/pgsql -L/usr/pkg/lib \
|
||||
-L/usr/pkg/lib/pgsql -lpq
|
||||
|
||||
include ../../Makefile.modules
|
||||
|
|
13
net/ser/files/patch-modules::postgres::db_mod.c
Normal file
13
net/ser/files/patch-modules::postgres::db_mod.c
Normal file
|
@ -0,0 +1,13 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- modules/postgres/db_mod.c.orig Wed Oct 8 16:07:22 2003
|
||||
+++ modules/postgres/db_mod.c Tue Apr 13 22:27:28 2004
|
||||
@@ -35,6 +35,7 @@
|
||||
|
||||
#include <stdio.h>
|
||||
#include "../../sr_module.h"
|
||||
+#include "../../db/db_con.h"
|
||||
#include "dbase.h"
|
||||
|
||||
MODULE_VERSION
|
13
net/ser/files/patch-modules::postgres::db_res.c
Normal file
13
net/ser/files/patch-modules::postgres::db_res.c
Normal file
|
@ -0,0 +1,13 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- modules/postgres/db_res.c.orig Tue Apr 8 04:25:35 2003
|
||||
+++ modules/postgres/db_res.c Tue Apr 13 22:27:28 2004
|
||||
@@ -38,6 +38,7 @@
|
||||
|
||||
#include <stdlib.h>
|
||||
#include "../../db/db_res.h"
|
||||
+#include "../../db/db_con.h"
|
||||
#include "../../dprint.h"
|
||||
#include "../../mem/mem.h"
|
||||
#include "defs.h"
|
13
net/ser/files/patch-modules::postgres::db_val.c
Normal file
13
net/ser/files/patch-modules::postgres::db_val.c
Normal file
|
@ -0,0 +1,13 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- modules/postgres/db_val.c.orig Mon Apr 14 21:52:47 2003
|
||||
+++ modules/postgres/db_val.c Tue Apr 13 22:27:28 2004
|
||||
@@ -188,6 +188,7 @@
|
||||
|
||||
switch(_t) {
|
||||
case DB_INT:
|
||||
+ case DB_BITMAP:
|
||||
sprintf(dbuf, "got int %s", _s);
|
||||
DLOG("str2valp", dbuf);
|
||||
if (str2int(_s, &VAL_INT(_v)) < 0) {
|
22
net/ser/files/patch-modules::postgres::dbase.h
Normal file
22
net/ser/files/patch-modules::postgres::dbase.h
Normal file
|
@ -0,0 +1,22 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- modules/postgres/dbase.h.orig Tue Apr 8 04:25:35 2003
|
||||
+++ modules/postgres/dbase.h Tue Apr 13 22:27:28 2004
|
||||
@@ -106,4 +106,16 @@
|
||||
db_key_t* _uk, db_val_t* _uv, int _n, int _un);
|
||||
|
||||
|
||||
+/*
|
||||
+ * Store name of table that will be used by
|
||||
+ * subsequent database functions
|
||||
+ */
|
||||
+int use_table(db_con_t* _h, const char* _t);
|
||||
+
|
||||
+int val2str(db_val_t* _v, char* _s, int* _len);
|
||||
+
|
||||
+int free_result(db_res_t* _r);
|
||||
+
|
||||
+int convert_result(db_con_t* _h, db_res_t* _r);
|
||||
+
|
||||
#endif /* DBASE_H */
|
29
net/ser/files/patch-modules::tm::t_fwd.c
Normal file
29
net/ser/files/patch-modules::tm::t_fwd.c
Normal file
|
@ -0,0 +1,29 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- modules/tm/t_fwd.c.orig
|
||||
+++ modules/tm/t_fwd.c
|
||||
@@ -359,6 +359,15 @@
|
||||
DBG("DEBUG: e2e_cancel: e2e cancel -- no more pending branches\n");
|
||||
t_reply( t_cancel, cancel_msg, 200, CANCEL_DONE );
|
||||
}
|
||||
+
|
||||
+#ifdef LOCAL_487
|
||||
+
|
||||
+ /* local 487s have been deprecated -- it better handles
|
||||
+ * race conditions (UAS sending 200); hopefuly there are
|
||||
+ * no longer UACs who go crazy waiting for the 487 whose
|
||||
+ * forwarding is being blocked by other unreponsive branch
|
||||
+ */
|
||||
+
|
||||
/* we could await downstream UAS's 487 replies; however,
|
||||
if some of the branches does not do that, we could wait
|
||||
long time and annoy upstream UAC which wants to see
|
||||
@@ -375,6 +384,7 @@
|
||||
"can't reply twice"
|
||||
*/
|
||||
t_reply(t_invite, t_invite->uas.request, 487, CANCELLED );
|
||||
+#endif
|
||||
}
|
||||
|
||||
|
|
@ -1,10 +1,10 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- modules/tm/t_lookup.c.orig Thu Aug 21 22:33:58 2003
|
||||
+++ modules/tm/t_lookup.c Mon Dec 15 20:59:56 2003
|
||||
@@ -96,8 +96,8 @@
|
||||
#include "t_lookup.h"
|
||||
--- modules/tm/t_lookup.c.orig Fri Jul 16 00:18:34 2004
|
||||
+++ modules/tm/t_lookup.c Tue Jul 27 21:01:37 2004
|
||||
@@ -97,8 +97,8 @@
|
||||
#include "t_msgbuilder.h" /* for t_lookup_callid */
|
||||
|
||||
#define EQ_VIA_LEN(_via)\
|
||||
- ( (p_msg->via1->bsize-(p_msg->_via->name.s-(p_msg->_via->hdr.s+p_msg->_via->hdr.len)))==\
|
||||
|
@ -14,7 +14,7 @@ $FreeBSD$
|
|||
|
||||
|
||||
|
||||
@@ -115,7 +115,7 @@
|
||||
@@ -116,7 +116,7 @@
|
||||
#define EQ_VIA_STR(_via)\
|
||||
( memcmp( t_msg->_via->name.s,\
|
||||
p_msg->_via->name.s,\
|
||||
|
|
25
net/ser/files/patch-modules::tm::t_reply.c
Normal file
25
net/ser/files/patch-modules::tm::t_reply.c
Normal file
|
@ -0,0 +1,25 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- modules/tm/t_reply.c.orig
|
||||
+++ modules/tm/t_reply.c
|
||||
@@ -686,6 +686,19 @@
|
||||
/* if final response received at this branch, allow only INVITE 2xx */
|
||||
if (Trans->uac[branch].last_received>=200
|
||||
&& !(inv_through && Trans->uac[branch].last_received<300)) {
|
||||
+ /* don't report on retranmissions */
|
||||
+ if (Trans->uac[branch].last_received==new_code) {
|
||||
+ DBG("DEBUG: final reply retrasnmission\n");
|
||||
+ goto discard;
|
||||
+ }
|
||||
+ /* if you FR-timed-out, faked a local 408 and 487 came, don't
|
||||
+ * report on it either */
|
||||
+ if (Trans->uac[branch].last_received==408 && new_code==487) {
|
||||
+ DBG("DEBUG: 487 came for a timed-out branch\n");
|
||||
+ goto discard;
|
||||
+ }
|
||||
+ /* this looks however how a very strange status rewrite attempt;
|
||||
+ * report on it */
|
||||
LOG(L_ERR, "ERROR: t_should_relay: status rewrite by UAS: "
|
||||
"stored: %d, received: %d\n",
|
||||
Trans->uac[branch].last_received, new_code );
|
|
@ -1,14 +1,14 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- modules/uri_radius/urirad_mod.c 2003/07/06 18:04:54 1.1
|
||||
+++ modules/uri_radius/urirad_mod.c 2003/07/06 18:05:59
|
||||
@@ -48,7 +48,7 @@
|
||||
--- modules/uri_radius/urirad_mod.c.orig Mon Jul 19 01:56:24 2004
|
||||
+++ modules/uri_radius/urirad_mod.c Tue Jul 27 21:01:37 2004
|
||||
@@ -51,7 +51,7 @@
|
||||
/*
|
||||
* Module parameter variables
|
||||
*/
|
||||
-char* radius_config = "/usr/local/etc/radiusclient/radiusclient.conf";
|
||||
+char* radius_config = (CFG_DIR "radiusclient.conf");
|
||||
int service_type = PW_CALL_CHECK;
|
||||
-static char* radius_config = "/usr/local/etc/radiusclient/radiusclient.conf";
|
||||
+static char* radius_config = (CFG_DIR "radiusclient.conf");
|
||||
static int service_type = -1;
|
||||
|
||||
/*
|
||||
|
|
29
net/ser/files/patch-modules::xlog::xl_lib.c
Normal file
29
net/ser/files/patch-modules::xlog::xl_lib.c
Normal file
|
@ -0,0 +1,29 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- modules/xlog/xl_lib.c 2003/11/17 11:31:59 1.1
|
||||
+++ modules/xlog/xl_lib.c 2003/11/17 11:38:37
|
||||
@@ -38,6 +38,7 @@
|
||||
#include "../../ut.h"
|
||||
#include "../../trim.h"
|
||||
|
||||
+#include "../../parser/contact/parse_contact.h"
|
||||
#include "../../parser/parse_from.h"
|
||||
#include "../../parser/parse_uri.h"
|
||||
|
||||
@@ -195,7 +196,14 @@
|
||||
DBG("XLOG: xl_get_contact: no contact header\n");
|
||||
return xl_get_null(msg, res);
|
||||
}
|
||||
-
|
||||
+
|
||||
+ if (msg->contact && msg->contact->parsed &&
|
||||
+ ((contact_body_t*)msg->contact->parsed)->contacts &&
|
||||
+ ((contact_body_t*)msg->contact->parsed)->contacts->uri.len > 0) {
|
||||
+ *res = ((contact_body_t*)msg->contact->parsed)->contacts->uri;
|
||||
+ return 0;
|
||||
+ }
|
||||
+
|
||||
if(!msg->contact || !msg->contact->body.s || msg->contact->body.len<=0)
|
||||
{
|
||||
DBG("XLOG: xl_get_contact: no contact header!\n");
|
|
@ -1,16 +0,0 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- udp_server.c.orig Sat Jun 21 21:38:32 2003
|
||||
+++ udp_server.c Sun Jul 6 20:53:30 2003
|
||||
@@ -326,6 +326,10 @@
|
||||
continue; /* goto skip;*/
|
||||
else goto error;
|
||||
}
|
||||
+ if (len < 8) {
|
||||
+ /* Message is too short, just drop it already */
|
||||
+ continue;
|
||||
+ }
|
||||
/* we must 0-term the messages, receive_msg expects it */
|
||||
buf[len]=0; /* no need to save the previous char */
|
||||
|
|
@ -11,16 +11,19 @@ lib/ser/modules/dbtext.so
|
|||
lib/ser/modules/domain.so
|
||||
lib/ser/modules/enum.so
|
||||
lib/ser/modules/exec.so
|
||||
lib/ser/modules/ext.so
|
||||
lib/ser/modules/group.so
|
||||
lib/ser/modules/mangler.so
|
||||
lib/ser/modules/maxfwd.so
|
||||
lib/ser/modules/msilo.so
|
||||
lib/ser/modules/mysql.so
|
||||
lib/ser/modules/mediaproxy.so
|
||||
lib/ser/modules/nathelper.so
|
||||
lib/ser/modules/pa.so
|
||||
lib/ser/modules/pdt.so
|
||||
lib/ser/modules/permissions.so
|
||||
lib/ser/modules/pike.so
|
||||
lib/ser/modules/postgres.so
|
||||
lib/ser/modules/print.so
|
||||
lib/ser/modules/registrar.so
|
||||
lib/ser/modules/rr.so
|
||||
|
@ -50,6 +53,7 @@ share/doc/ser/README.dbtext
|
|||
share/doc/ser/README.domain
|
||||
share/doc/ser/README.enum
|
||||
share/doc/ser/README.exec
|
||||
share/doc/ser/README.ext
|
||||
share/doc/ser/README.group
|
||||
share/doc/ser/README.mangler
|
||||
share/doc/ser/README.maxfwd
|
||||
|
@ -59,6 +63,7 @@ share/doc/ser/README.pa
|
|||
share/doc/ser/README.pdt
|
||||
share/doc/ser/README.permissions
|
||||
share/doc/ser/README.pike
|
||||
share/doc/ser/README.postgres
|
||||
share/doc/ser/README.print
|
||||
share/doc/ser/README.registrar
|
||||
share/doc/ser/README.rr
|
||||
|
|
Loading…
Reference in a new issue