- Update to 0.8.5

- Unbreak on 4.x

Approved by:	arved (mentor)
This commit is contained in:
Markus Brueffer 2004-03-16 11:42:53 +00:00
parent 2bd78af3cb
commit 7dcc7f9c81
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=104153
15 changed files with 87 additions and 42 deletions

View file

@ -6,7 +6,7 @@
#
PORTNAME= bookcase
PORTVERSION= 0.8.4
PORTVERSION= 0.8.5
CATEGORIES= misc kde
MASTER_SITES= http://www.periapsis.org/bookcase/download/
@ -24,7 +24,6 @@ post-patch:
.if ${OSVERSION} < 500000
CFLAGS+= -D__LIBSTDCPP_PARTIAL_SUPPORT__
BROKEN= "Does not compile on 4.x"
.endif
.include "${PORTSDIR}/x11/kde3/Makefile.kde"

View file

@ -1,2 +1,2 @@
MD5 (bookcase-0.8.4.tar.gz) = 301d1c7c046dd02300bbd98bd6b724b0
SIZE (bookcase-0.8.4.tar.gz) = 1409869
MD5 (bookcase-0.8.5.tar.gz) = 82e0c1909c23d7736547f5f00b7e5f30
SIZE (bookcase-0.8.5.tar.gz) = 1410447

View file

@ -1,10 +0,0 @@
--- src/filehandler.h.orig Tue Feb 24 01:11:58 2004
+++ src/filehandler.h Tue Feb 24 01:08:37 2004
@@ -39,6 +39,7 @@
friend class MainWindow;
friend const Data::Image& addImage(const KURL& url);
+class FileRef;
friend class FileRef;
public:

View file

@ -0,0 +1,14 @@
--- src/image.cpp.orig Mon Mar 15 22:39:08 2004
+++ src/image.cpp Mon Mar 15 22:40:08 2004
@@ -21,11 +21,6 @@
using Bookcase::Data::Image;
-inline
-bool operator== (const Image& img1, const Image& img2) {
- return img1.id() == img2.id();
-}
-
// I'm using the MD5 hash as the id. I consider it rather unlikely that two images in one
// collection could ever have the same has, and this lets me do a fast comparison of two images
// simply by comparing their ids.

View file

@ -0,0 +1,12 @@
--- src/image.h.orig Mon Mar 15 22:39:01 2004
+++ src/image.h Mon Mar 15 22:39:59 2004
@@ -55,6 +55,8 @@
} // end namespace
} // end namespace
-bool operator== (const Bookcase::Data::Image& img1, const Bookcase::Data::Image& img2);
+inline bool operator== (const Bookcase::Data::Image& img1, const Bookcase::Data::Image& img2) {
+ return img1.id() == img2.id();
+};
#endif

View file

@ -6,7 +6,7 @@
#
PORTNAME= bookcase
PORTVERSION= 0.8.4
PORTVERSION= 0.8.5
CATEGORIES= misc kde
MASTER_SITES= http://www.periapsis.org/bookcase/download/
@ -24,7 +24,6 @@ post-patch:
.if ${OSVERSION} < 500000
CFLAGS+= -D__LIBSTDCPP_PARTIAL_SUPPORT__
BROKEN= "Does not compile on 4.x"
.endif
.include "${PORTSDIR}/x11/kde3/Makefile.kde"

View file

@ -1,2 +1,2 @@
MD5 (bookcase-0.8.4.tar.gz) = 301d1c7c046dd02300bbd98bd6b724b0
SIZE (bookcase-0.8.4.tar.gz) = 1409869
MD5 (bookcase-0.8.5.tar.gz) = 82e0c1909c23d7736547f5f00b7e5f30
SIZE (bookcase-0.8.5.tar.gz) = 1410447

View file

@ -1,10 +0,0 @@
--- src/filehandler.h.orig Tue Feb 24 01:11:58 2004
+++ src/filehandler.h Tue Feb 24 01:08:37 2004
@@ -39,6 +39,7 @@
friend class MainWindow;
friend const Data::Image& addImage(const KURL& url);
+class FileRef;
friend class FileRef;
public:

View file

@ -0,0 +1,14 @@
--- src/image.cpp.orig Mon Mar 15 22:39:08 2004
+++ src/image.cpp Mon Mar 15 22:40:08 2004
@@ -21,11 +21,6 @@
using Bookcase::Data::Image;
-inline
-bool operator== (const Image& img1, const Image& img2) {
- return img1.id() == img2.id();
-}
-
// I'm using the MD5 hash as the id. I consider it rather unlikely that two images in one
// collection could ever have the same has, and this lets me do a fast comparison of two images
// simply by comparing their ids.

View file

@ -0,0 +1,12 @@
--- src/image.h.orig Mon Mar 15 22:39:01 2004
+++ src/image.h Mon Mar 15 22:39:59 2004
@@ -55,6 +55,8 @@
} // end namespace
} // end namespace
-bool operator== (const Bookcase::Data::Image& img1, const Bookcase::Data::Image& img2);
+inline bool operator== (const Bookcase::Data::Image& img1, const Bookcase::Data::Image& img2) {
+ return img1.id() == img2.id();
+};
#endif

View file

@ -6,7 +6,7 @@
#
PORTNAME= bookcase
PORTVERSION= 0.8.4
PORTVERSION= 0.8.5
CATEGORIES= misc kde
MASTER_SITES= http://www.periapsis.org/bookcase/download/
@ -24,7 +24,6 @@ post-patch:
.if ${OSVERSION} < 500000
CFLAGS+= -D__LIBSTDCPP_PARTIAL_SUPPORT__
BROKEN= "Does not compile on 4.x"
.endif
.include "${PORTSDIR}/x11/kde3/Makefile.kde"

View file

@ -1,2 +1,2 @@
MD5 (bookcase-0.8.4.tar.gz) = 301d1c7c046dd02300bbd98bd6b724b0
SIZE (bookcase-0.8.4.tar.gz) = 1409869
MD5 (bookcase-0.8.5.tar.gz) = 82e0c1909c23d7736547f5f00b7e5f30
SIZE (bookcase-0.8.5.tar.gz) = 1410447

View file

@ -1,10 +0,0 @@
--- src/filehandler.h.orig Tue Feb 24 01:11:58 2004
+++ src/filehandler.h Tue Feb 24 01:08:37 2004
@@ -39,6 +39,7 @@
friend class MainWindow;
friend const Data::Image& addImage(const KURL& url);
+class FileRef;
friend class FileRef;
public:

View file

@ -0,0 +1,14 @@
--- src/image.cpp.orig Mon Mar 15 22:39:08 2004
+++ src/image.cpp Mon Mar 15 22:40:08 2004
@@ -21,11 +21,6 @@
using Bookcase::Data::Image;
-inline
-bool operator== (const Image& img1, const Image& img2) {
- return img1.id() == img2.id();
-}
-
// I'm using the MD5 hash as the id. I consider it rather unlikely that two images in one
// collection could ever have the same has, and this lets me do a fast comparison of two images
// simply by comparing their ids.

View file

@ -0,0 +1,12 @@
--- src/image.h.orig Mon Mar 15 22:39:01 2004
+++ src/image.h Mon Mar 15 22:39:59 2004
@@ -55,6 +55,8 @@
} // end namespace
} // end namespace
-bool operator== (const Bookcase::Data::Image& img1, const Bookcase::Data::Image& img2);
+inline bool operator== (const Bookcase::Data::Image& img1, const Bookcase::Data::Image& img2) {
+ return img1.id() == img2.id();
+};
#endif