Add fusefs-gnome-vfs
Interface between FUSE and the Gnome VFS 2.0. It allows the user to mount everything you can access via the Nautilus file manager. But of course you can use a convenient CLI instead of the Desktop. WWW: http://www.evolware.org/chri/
This commit is contained in:
parent
e8a13fd635
commit
7dd1953a51
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=180638
5 changed files with 106 additions and 0 deletions
|
@ -207,6 +207,7 @@
|
|||
SUBDIR += ftrace
|
||||
SUBDIR += fusefs-curlftpfs
|
||||
SUBDIR += fusefs-funionfs
|
||||
SUBDIR += fusefs-gnome-vfs
|
||||
SUBDIR += fusefs-httpfs
|
||||
SUBDIR += fusefs-kmod
|
||||
SUBDIR += fusefs-libs
|
||||
|
|
34
sysutils/fusefs-gnome-vfs/Makefile
Normal file
34
sysutils/fusefs-gnome-vfs/Makefile
Normal file
|
@ -0,0 +1,34 @@
|
|||
# New ports collection makefile for: fusefs-gnome-vfs
|
||||
# Date created: 2006-12-23
|
||||
# Whom: Michael Johnson <ahze@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= fusefs-gnome-vfs
|
||||
PORTVERSION= 0.1
|
||||
CATEGORIES= sysutils gnome
|
||||
MASTER_SITES= http://www.evolware.org/chri/
|
||||
DISTNAME= ${RPORTNAME}-${PORTVERSION}
|
||||
|
||||
MAINTAINER= ahze@FreeBSD.org
|
||||
COMMENT= Interface between FUSE and the Gnome VFS 2.0
|
||||
|
||||
RUN_DEPENDS= ${LOCALBASE}/modules/fuse.ko:${PORTSDIR}/sysutils/fusefs-kmod
|
||||
BUILD_DEPENDS= ${LOCALBASE}/include/fuse.h:${PORTSDIR}/sysutils/fusefs-libs
|
||||
|
||||
RPORTNAME= gnome-vfs-fuse
|
||||
WRKSRC= ${WRKDIR}/${RPORTNAME}
|
||||
USE_GNOME= gnomevfs2
|
||||
USE_GMAKE= yes
|
||||
PLIST_FILES= bin/gnomevfs-mount
|
||||
PORTDOCS= README
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/gnomevfs-mount ${PREFIX}/bin
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
3
sysutils/fusefs-gnome-vfs/distinfo
Normal file
3
sysutils/fusefs-gnome-vfs/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (gnome-vfs-fuse-0.1.tar.gz) = 975285e286570573fc7fdd3e89c902fe
|
||||
SHA256 (gnome-vfs-fuse-0.1.tar.gz) = 8b1cf09b6ee06d4b54a4477990bd4b99aa9745f081b2e7f2c696853fe8e3c330
|
||||
SIZE (gnome-vfs-fuse-0.1.tar.gz) = 14061
|
63
sysutils/fusefs-gnome-vfs/files/patch-gnomevfs-mount.c
Normal file
63
sysutils/fusefs-gnome-vfs/files/patch-gnomevfs-mount.c
Normal file
|
@ -0,0 +1,63 @@
|
|||
--- gnomevfs-mount.c.orig Sat Dec 23 21:52:20 2006
|
||||
+++ gnomevfs-mount.c Sat Dec 23 21:55:02 2006
|
||||
@@ -31,7 +31,8 @@
|
||||
#define _GNU_SOURCE 1
|
||||
#endif
|
||||
|
||||
-#define FUSE_USE_VERSION 22
|
||||
+
|
||||
+#define FUSE_USE_VERSION 25
|
||||
|
||||
#include <fuse.h>
|
||||
#include <stdio.h>
|
||||
@@ -40,7 +41,14 @@
|
||||
#include <fcntl.h>
|
||||
#include <dirent.h>
|
||||
#include <errno.h>
|
||||
+
|
||||
+#ifdef __FreeBSD__
|
||||
+#define ENODATA ENOATTR
|
||||
+#define EGREGIOUS EDOOFUS
|
||||
+#else
|
||||
#include <sys/statfs.h>
|
||||
+#endif
|
||||
+
|
||||
#include <sys/types.h>
|
||||
#include <sys/stat.h>
|
||||
|
||||
@@ -705,7 +713,7 @@
|
||||
char *full_path;
|
||||
GnomeVFSOpenMode flags = GNOME_VFS_OPEN_RANDOM;
|
||||
GnomeVFSResult result;
|
||||
- GnomeVFSHandle *handle = (GnomeVFSHandle *) fi->fh;
|
||||
+ GnomeVFSHandle *handle = (GnomeVFSHandle *) (int) fi->fh;
|
||||
|
||||
full_path = g_strdup_printf("%s/%s", mount_name, path);
|
||||
|
||||
@@ -735,7 +743,7 @@
|
||||
{
|
||||
int res;
|
||||
GnomeVFSResult result;
|
||||
- GnomeVFSHandle *handle = (GnomeVFSHandle *) fi->fh;
|
||||
+ GnomeVFSHandle *handle = (GnomeVFSHandle *) (int) fi->fh;
|
||||
GnomeVFSFileSize nread;
|
||||
(void) path;
|
||||
|
||||
@@ -760,7 +768,7 @@
|
||||
{
|
||||
int res;
|
||||
GnomeVFSResult result;
|
||||
- GnomeVFSHandle *handle = (GnomeVFSHandle *) fi->fh;
|
||||
+ GnomeVFSHandle *handle = (GnomeVFSHandle *) (int) fi->fh;
|
||||
GnomeVFSFileSize nwrite;
|
||||
(void) path;
|
||||
|
||||
@@ -790,7 +798,7 @@
|
||||
|
||||
static int xmp_release(const char *path, struct fuse_file_info *fi)
|
||||
{
|
||||
- GnomeVFSHandle *handle = (GnomeVFSHandle *) fi->fh;
|
||||
+ GnomeVFSHandle *handle = (GnomeVFSHandle *) (int) fi->fh;
|
||||
(void) path;
|
||||
|
||||
//g_debug("%s %s", __FUNCTION__, path);
|
5
sysutils/fusefs-gnome-vfs/pkg-descr
Normal file
5
sysutils/fusefs-gnome-vfs/pkg-descr
Normal file
|
@ -0,0 +1,5 @@
|
|||
Interface between FUSE and the Gnome VFS 2.0. It allows the user to mount
|
||||
everything you can access via the Nautilus file manager. But of course you
|
||||
can use a convenient CLI instead of the Desktop.
|
||||
|
||||
WWW: http://www.evolware.org/chri/
|
Loading…
Reference in a new issue