Update to 3.0.5.
This commit is contained in:
parent
d6f1cd48a5
commit
7dec06d74d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=232153
6 changed files with 65 additions and 1794 deletions
|
@ -6,8 +6,7 @@
|
||||||
#
|
#
|
||||||
|
|
||||||
PORTNAME= octave
|
PORTNAME= octave
|
||||||
PORTVERSION= 3.0.3
|
PORTVERSION= 3.0.5
|
||||||
PORTREVISION= 4
|
|
||||||
CATEGORIES= math
|
CATEGORIES= math
|
||||||
MASTER_SITES= ftp://ftp.octave.org/pub/octave/ \
|
MASTER_SITES= ftp://ftp.octave.org/pub/octave/ \
|
||||||
ftp://ftp.u-aizu.ac.jp/pub/SciEng/numanal/Octave/bleeding-edge/
|
ftp://ftp.u-aizu.ac.jp/pub/SciEng/numanal/Octave/bleeding-edge/
|
||||||
|
@ -70,13 +69,11 @@ PLIST_SUB= OCTAVE_VERSION=${OCTAVE_VERSION} GNU_HOST=${GNU_HOST}
|
||||||
INCLUDES= -I${LOCALBASE}/include -I${LOCALBASE}/include/metis
|
INCLUDES= -I${LOCALBASE}/include -I${LOCALBASE}/include/metis
|
||||||
MAKE_ENV+= CPPFLAGS="${CPPFLAGS} ${INCLUDES}" \
|
MAKE_ENV+= CPPFLAGS="${CPPFLAGS} ${INCLUDES}" \
|
||||||
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}"
|
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}"
|
||||||
|
CFLAGS+= ${INCLUDES}
|
||||||
|
CXXFLAGS+= ${INCLUDES}
|
||||||
|
CPPFLAGS+= ${INCLUDES}
|
||||||
CONFIGURE_ENV+= GPERF="${LOCALBASE}/bin/gperf" \
|
CONFIGURE_ENV+= GPERF="${LOCALBASE}/bin/gperf" \
|
||||||
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
|
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
|
||||||
CFLAGS="${CFLAGS} ${INCLUDES}" \
|
|
||||||
CXXFLAGS="${CXXFLAGS} ${INCLUDES}" \
|
|
||||||
CPPFLAGS="${CPPFLAGS} ${INCLUDES}" \
|
|
||||||
F77="${FC}" \
|
|
||||||
FFLAGS="${FFLAGS}" \
|
|
||||||
CC="${CC}" \
|
CC="${CC}" \
|
||||||
CXX="${CXX}" \
|
CXX="${CXX}" \
|
||||||
TERMIOS_H="termios.h"
|
TERMIOS_H="termios.h"
|
||||||
|
@ -106,5 +103,13 @@ post-install:
|
||||||
${INSTALL_DATA} ${WRKSRC}/doc/${file} ${DOCSDIR}
|
${INSTALL_DATA} ${WRKSRC}/doc/${file} ${DOCSDIR}
|
||||||
.endfor
|
.endfor
|
||||||
.endif
|
.endif
|
||||||
|
${RM} -f ${WRKDIR}/PLIST
|
||||||
|
.for d in ${PREFIX}/include/octave-${OCTAVE_VERSION} ${PREFIX}/share/octave ${PREFIX}/libexec/octave ${PREFIX}/lib/octave-${OCTAVE_VERSION}
|
||||||
|
@${FIND} -s $d -not -type d | \
|
||||||
|
${SED} -e 's#^${PREFIX}/##' >> ${WRKDIR}/PLIST
|
||||||
|
@${FIND} $d -type d | ${SORT} -r | \
|
||||||
|
${SED} 's,^${PREFIX}/,@dirrm ,' >> ${WRKDIR}/PLIST
|
||||||
|
.endfor
|
||||||
|
cd ${WRKDIR} ; ${SED} -i -e "/PLIST/ r PLIST" ${TMPPLIST}
|
||||||
|
|
||||||
.include <bsd.port.post.mk>
|
.include <bsd.port.post.mk>
|
||||||
|
|
|
@ -1,3 +1,3 @@
|
||||||
MD5 (octave-3.0.3.tar.bz2) = 38d258d60242cf4844e3c4350691ccff
|
MD5 (octave-3.0.5.tar.bz2) = bfba44eeda8fa6e29c2bbcd2604c34eb
|
||||||
SHA256 (octave-3.0.3.tar.bz2) = f90108bf6a2f9930907aa740d1c4d39551985cf3b5c5eb5dfdb436e0d3b5d79d
|
SHA256 (octave-3.0.5.tar.bz2) = 40b84071d07e17eafe338638b4f1bfce991bdac07d277f1098cb7e6b0b8f4ad7
|
||||||
SIZE (octave-3.0.3.tar.bz2) = 10159024
|
SIZE (octave-3.0.5.tar.bz2) = 10158578
|
||||||
|
|
17
math/octave/files/patch-examples+Makefile.in
Normal file
17
math/octave/files/patch-examples+Makefile.in
Normal file
|
@ -0,0 +1,17 @@
|
||||||
|
--- examples/Makefile.in~ 2008-07-22 00:59:03.000000000 +0900
|
||||||
|
+++ examples/Makefile.in 2008-08-23 05:46:34.000000000 +0900
|
||||||
|
@@ -95,10 +95,10 @@
|
||||||
|
rm -f $(DESTDIR)$(imagedir)/$$f; \
|
||||||
|
$(INSTALL_DATA) $(srcdir)/$$f $(DESTDIR)$(imagedir)/$$f; \
|
||||||
|
done
|
||||||
|
- -if test -n "$(DESKTOP_FILE_INSTALL)"; then \
|
||||||
|
- $(DESKTOP_FILE_INSTALL) --dir=$(DESTDIR)$(datadir)/applications \
|
||||||
|
- --vendor www.octave.org octave.desktop; \
|
||||||
|
- fi
|
||||||
|
+# -if test -n "$(DESKTOP_FILE_INSTALL)"; then \
|
||||||
|
+# $(DESKTOP_FILE_INSTALL) --dir=$(DESTDIR)$(datadir)/applications \
|
||||||
|
+# --vendor www.octave.org octave.desktop; \
|
||||||
|
+# fi
|
||||||
|
.PHONY: install install-strip
|
||||||
|
|
||||||
|
uninstall:
|
|
@ -1,11 +1,11 @@
|
||||||
--- scripts/pkg/pkg.m~ 2007-12-20 16:55:26.000000000 +0000
|
--- scripts/pkg/pkg.m~ 2009-04-09 17:26:54.000000000 +0900
|
||||||
+++ scripts/pkg/pkg.m 2008-02-25 16:32:59.000000000 +0000
|
+++ scripts/pkg/pkg.m 2009-04-09 17:27:14.000000000 +0900
|
||||||
@@ -1052,7 +1052,7 @@
|
@@ -1242,7 +1242,7 @@
|
||||||
## make
|
## make
|
||||||
if (exist (fullfile (src, "Makefile"), "file"))
|
if (exist (fullfile (src, "Makefile"), "file"))
|
||||||
[status, output] = shell (strcat ("export INSTALLDIR=\"", desc.dir,
|
[status, output] = shell (strcat ("export INSTALLDIR=\"", desc.dir,
|
||||||
- "\"; make -C ", src));
|
- "\"; make -C '", src, "'"));
|
||||||
+ "\"; gmake -C ", src));
|
+ "\"; gmake -C '", src, "'"));
|
||||||
if (status != 0)
|
if (status != 0)
|
||||||
rm_rf (desc.dir);
|
rm_rf (desc.dir);
|
||||||
error ("'make' returned the following error: %s", output);
|
error ("'make' returned the following error: %s", output);
|
||||||
|
|
|
@ -1,53 +0,0 @@
|
||||||
# HG changeset patch
|
|
||||||
# User Jaroslav Hajek <highegg@gmail.com>
|
|
||||||
# Date 1223800240 -7200
|
|
||||||
# Node ID 712d9e045b1e4936708405de8be086bce580b588
|
|
||||||
# Parent 4c023cbfab27fe07ad5c65162c815bbccc601bbb
|
|
||||||
fix for SuiteSparse 3.2
|
|
||||||
|
|
||||||
--- liboctave/ChangeLog Fri Oct 10 11:35:10 2008 +0200
|
|
||||||
+++ liboctave/ChangeLog Sun Oct 12 10:30:40 2008 +0200
|
|
||||||
@@ -1,3 +1,9 @@ 2008-10-08 John W. Eaton <jwe@octave.o
|
|
||||||
+2008-10-10 Jaroslav Hajek <highegg@gmail.com>
|
|
||||||
+
|
|
||||||
+ * sparse-util.h (SparseCholPrint): Change char * argument to const
|
|
||||||
+ char *.
|
|
||||||
+ * sparse-util.cc (SparseCholPrint): Likewise.
|
|
||||||
+
|
|
||||||
2008-10-08 John W. Eaton <jwe@octave.org>
|
|
||||||
|
|
||||||
* Sparse-op-defs.h (SPARSE_SMSM_BOOL_OPS): Duplicate code for scalar
|
|
||||||
--- liboctave/sparse-util.cc Fri Oct 10 11:35:10 2008 +0200
|
|
||||||
+++ liboctave/sparse-util.cc Sun Oct 12 10:30:40 2008 +0200
|
|
||||||
@@ -30,8 +30,15 @@ along with Octave; see the file COPYING.
|
|
||||||
#include "lo-error.h"
|
|
||||||
#include "sparse-util.h"
|
|
||||||
|
|
||||||
+// FIXME this overload is here due to API change in SuiteSparse (3.1 -> 3.2)
|
|
||||||
void
|
|
||||||
SparseCholError (int status, char *file, int line, char *message)
|
|
||||||
+{
|
|
||||||
+ SparseCholError (status, file, line, message);
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
+void
|
|
||||||
+SparseCholError (int status, const char *file, int line, const char *message)
|
|
||||||
{
|
|
||||||
(*current_liboctave_warning_handler)("warning %i, at line %i in file %s",
|
|
||||||
status, line, file);
|
|
||||||
--- liboctave/sparse-util.h Fri Oct 10 11:35:10 2008 +0200
|
|
||||||
+++ liboctave/sparse-util.h Sun Oct 12 10:30:40 2008 +0200
|
|
||||||
@@ -24,7 +24,11 @@ along with Octave; see the file COPYING.
|
|
||||||
#if !defined (octave_sparse_util_h)
|
|
||||||
#define octave_sparse_util_h 1
|
|
||||||
|
|
||||||
-extern OCTAVE_API void SparseCholError (int status, char *file, int line, char *message);
|
|
||||||
+// FIXME this overload is here due to API change in SuiteSparse (3.1 -> 3.2)
|
|
||||||
+extern OCTAVE_API void SparseCholError (int status, char *file,
|
|
||||||
+ int line, char *message);
|
|
||||||
+extern OCTAVE_API void SparseCholError (int status, const char *file,
|
|
||||||
+ int line, const char *message);
|
|
||||||
extern OCTAVE_API int SparseCholPrint (const char *fmt, ...);
|
|
||||||
|
|
||||||
#endif
|
|
||||||
|
|
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue