Update to 2.0.26 (latest stable version).
This commit is contained in:
parent
4a65fd9e5d
commit
7dec95e419
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=101624
16 changed files with 474 additions and 147 deletions
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= cvsnt
|
||||
PORTVERSION= 2.0.14
|
||||
PORTVERSION= 2.0.26
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://www.cvsnt.org/archive/ \
|
||||
http://homepages.nildram.co.uk/~tmhoyle/
|
||||
|
@ -18,7 +18,11 @@ LIB_DEPENDS= ltdl.4:${PORTSDIR}/devel/libltdl
|
|||
|
||||
USE_LIBTOOL= yes
|
||||
CONFIGURE_ARGS= --enable-fork
|
||||
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
||||
USE_GETOPT_LONG=yes
|
||||
CPPFLAGS+= -I${LOCALBASE}/include
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
|
||||
|
||||
.if exists(/usr/include/gssapi.h)
|
||||
PLIST_SUB= GSERVER=""
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
MD5 (cvsnt-2.0.14.tar.gz) = 1ed977577ae688ddca498edccf51923a
|
||||
SIZE (cvsnt-2.0.14.tar.gz) = 3590566
|
||||
MD5 (cvsnt-2.0.26.tar.gz) = ba4b98eef1860cc381c98b9ac49545e7
|
||||
SIZE (cvsnt-2.0.26.tar.gz) = 3490404
|
||||
|
|
|
@ -1,28 +1,12 @@
|
|||
--- configure.orig Wed Dec 10 23:43:42 2003
|
||||
+++ configure Wed Feb 4 02:44:05 2004
|
||||
@@ -19209,6 +19209,7 @@
|
||||
--- configure.orig Mon Feb 9 21:48:11 2004
|
||||
+++ configure Sun Feb 22 03:02:53 2004
|
||||
@@ -19221,7 +19221,8 @@
|
||||
|
||||
|
||||
# This can be used to rebuild libtool when needed
|
||||
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
|
||||
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
|
||||
-LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
|
||||
+LIBTOOL_DEPS="--disable-ltlibs /usr/local/share/libtool13/ltmain.sh"
|
||||
+/usr/local/share/libtool13/ltconfig13 $LIBTOOL_DEPS
|
||||
|
||||
# Always use our own libtool.
|
||||
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
|
||||
@@ -25221,7 +25222,7 @@
|
||||
rm -f conftest.err conftest.$ac_objext \
|
||||
conftest$ac_exeext conftest.$ac_ext
|
||||
if test "$ac_cv_search_SSL_CTX_new" = no; then
|
||||
- for ac_lib in ssl ssleay32; do
|
||||
+ for ac_lib in "ssl -lcrypto" ssleay32; do
|
||||
LIBS="-l$ac_lib $ac_func_search_save_LIBS"
|
||||
cat >conftest.$ac_ext <<_ACEOF
|
||||
/* confdefs.h. */
|
||||
@@ -27699,7 +27700,7 @@
|
||||
#define LOCKSERVER_SUPPORT
|
||||
_ACEOF
|
||||
|
||||
- enable_server="yes"
|
||||
+ enable_lockserver="yes"
|
||||
fi
|
||||
fi;
|
||||
echo "$as_me:$LINENO: result: $enable_lockserver" >&5
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- configure.in.orig Sun Jan 25 20:32:56 2004
|
||||
+++ configure.in Sun Jan 25 20:32:22 2004
|
||||
@@ -305,7 +305,7 @@
|
||||
fi],
|
||||
[if test "$ac_cv_search_connect" != no; then
|
||||
AC_DEFINE(LOCKSERVER_SUPPORT,[],[Support CVS lock server])
|
||||
- enable_server="yes"
|
||||
+ enable_lockserver="yes"
|
||||
fi])
|
||||
AC_MSG_RESULT($enable_lockserver)
|
||||
AM_CONDITIONAL(WITH_LOCKSERVER, test "$enable_lockserver" = "yes")
|
18
devel/cvsnt/files/patch-cvsdelta-cvsdelta.cpp
Normal file
18
devel/cvsnt/files/patch-cvsdelta-cvsdelta.cpp
Normal file
|
@ -0,0 +1,18 @@
|
|||
--- cvsdelta/cvsdelta.cpp.orig Sun Feb 22 03:05:15 2004
|
||||
+++ cvsdelta/cvsdelta.cpp Sun Feb 22 03:04:56 2004
|
||||
@@ -10,7 +10,6 @@
|
||||
* the rest thrown together from a mixture of inspiration and google.
|
||||
*/
|
||||
|
||||
-#include <malloc.h>
|
||||
#include <stdio.h>
|
||||
#include <assert.h>
|
||||
#include <string.h>
|
||||
@@ -20,6 +19,7 @@
|
||||
#if defined(_WIN32)
|
||||
#include <winsock2.h>
|
||||
#else
|
||||
+ #include <sys/types.h>
|
||||
#include <netinet/in.h>
|
||||
#endif
|
||||
|
20
devel/cvsnt/files/patch-diff-diff.c
Normal file
20
devel/cvsnt/files/patch-diff-diff.c
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- diff/diff.c.orig Sun Feb 22 04:47:45 2004
|
||||
+++ diff/diff.c Sun Feb 22 04:56:06 2004
|
||||
@@ -19,6 +19,7 @@
|
||||
Richard Stallman, Len Tower, and Paul Eggert. */
|
||||
|
||||
#define GDIFF_MAIN
|
||||
+#include "config.h"
|
||||
#include "diff.h"
|
||||
#include <signal.h>
|
||||
#include "getopt1.h"
|
||||
@@ -29,9 +30,6 @@
|
||||
#endif
|
||||
|
||||
#ifdef HAVE_UNISTD_H
|
||||
-#ifndef _XOPEN_SOURCE
|
||||
-#define _XOPEN_SOURCE /* Required for snprinf on GNU */
|
||||
-#endif
|
||||
#define __EXTENSIONS__ /* Solaris fix */
|
||||
#include <unistd.h>
|
||||
#endif
|
12
devel/cvsnt/files/patch-diff-diff3.c
Normal file
12
devel/cvsnt/files/patch-diff-diff3.c
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- diff/diff3.c.orig Sun Feb 22 04:57:07 2004
|
||||
+++ diff/diff3.c Sun Feb 22 04:57:14 2004
|
||||
@@ -26,9 +26,6 @@
|
||||
#include "diffrun.h"
|
||||
|
||||
#ifdef HAVE_UNISTD_H
|
||||
-#ifndef _XOPEN_SOURCE
|
||||
-#define _XOPEN_SOURCE /* Required for snprinf on GNU */
|
||||
-#endif
|
||||
#define __EXTENSIONS__ /* Solaris fix */
|
||||
#include <unistd.h>
|
||||
#endif
|
|
@ -1,11 +0,0 @@
|
|||
--- lib/getopt.h.orig Sun Jan 25 20:07:35 2004
|
||||
+++ lib/getopt.h Sun Jan 25 20:08:37 2004
|
||||
@@ -97,7 +97,7 @@
|
||||
exactly why), and there is no particular need to prototype it.
|
||||
We really shouldn't be trampling on the system's namespace at all by
|
||||
declaring getopt() but that is a bigger issue. */
|
||||
-extern int getopt ();
|
||||
+extern int getopt (int argc, char *const argv[], const char *shortopts);
|
||||
|
||||
extern int getopt_long (int argc, char *const *argv, const char *shortopts,
|
||||
const struct option *longopts, int *longind);
|
|
@ -1,13 +0,0 @@
|
|||
--- lib/regex.h.orig Sun Jan 25 20:56:51 2004
|
||||
+++ lib/regex.h Sun Jan 25 20:59:22 2004
|
||||
@@ -485,8 +485,8 @@
|
||||
#ifdef _REGEX_RE_COMP
|
||||
/* 4.2 bsd compatibility. */
|
||||
/* CVS: don't use prototypes: they may conflict with system headers. */
|
||||
-extern char *re_comp _RE_ARGS (());
|
||||
-extern int re_exec _RE_ARGS (());
|
||||
+extern char *re_comp _RE_ARGS ((const char *));
|
||||
+extern int re_exec _RE_ARGS ((const char *));
|
||||
#endif
|
||||
|
||||
/* POSIX compatibility. */
|
|
@ -1,10 +0,0 @@
|
|||
--- lockservice/LockParse.cpp.orig Sun Jan 25 20:42:06 2004
|
||||
+++ lockservice/LockParse.cpp Sun Jan 25 20:42:39 2004
|
||||
@@ -5,6 +5,7 @@
|
||||
#include <winsock2.h>
|
||||
#include <ws2tcpip.h>
|
||||
#else
|
||||
+#include <sys/types.h>
|
||||
#include <sys/socket.h>
|
||||
#include <netdb.h>
|
||||
#include <errno.h>
|
|
@ -1,22 +0,0 @@
|
|||
--- lockservice/server.cpp.orig Thu Mar 13 04:28:10 2003
|
||||
+++ lockservice/server.cpp Tue Feb 3 11:35:11 2004
|
||||
@@ -8,7 +8,10 @@
|
||||
#include <ws2tcpip.h>
|
||||
#define SOCKET_ERRNO WSAGetLastError()
|
||||
#else
|
||||
+#include <sys/types.h>
|
||||
+#include <sys/time.h>
|
||||
#include <sys/socket.h>
|
||||
+#include <netinet/in.h>
|
||||
#include <netdb.h>
|
||||
#include <errno.h>
|
||||
#include <unistd.h>
|
||||
@@ -162,7 +165,7 @@
|
||||
#ifdef _WIN32
|
||||
int addrlen;
|
||||
#else
|
||||
- size_t addrlen;
|
||||
+ socklen_t addrlen;
|
||||
#endif
|
||||
int maxdesc = -1;
|
||||
|
|
@ -1,8 +0,0 @@
|
|||
--- rcs/common.cpp.orig Sun Jan 25 21:05:34 2004
|
||||
+++ rcs/common.cpp Sun Jan 25 21:05:42 2004
|
||||
@@ -1,5 +1,4 @@
|
||||
#include <stdio.h>
|
||||
-#include <malloc.h>
|
||||
#include <string>
|
||||
#ifdef _WIN32
|
||||
#define WIN32_LEAN_AND_MEAN
|
|
@ -1,21 +1,12 @@
|
|||
--- src/cvs.h.orig Fri Jan 23 18:47:11 2004
|
||||
+++ src/cvs.h Fri Jan 23 18:48:21 2004
|
||||
@@ -931,6 +931,9 @@
|
||||
/* stdio redirection, the easy way... */
|
||||
#include <stdio.h>
|
||||
#define printf cvs_printf
|
||||
+#if defined(putchar)
|
||||
+#undef putchar
|
||||
+#endif
|
||||
#define putchar cvs_putchar
|
||||
#define puts cvs_puts
|
||||
#define fputs cvs_fputs
|
||||
@@ -982,7 +985,7 @@
|
||||
--- src/cvs.h.orig Sun Feb 22 04:59:14 2004
|
||||
+++ src/cvs.h Sun Feb 22 04:59:22 2004
|
||||
@@ -34,9 +34,6 @@
|
||||
#include <stdlib.h>
|
||||
|
||||
#ifndef __USER_HANDLE_T_DEFINED
|
||||
/* User handle pointer */
|
||||
-typedef struct { void *__unused; } *user_handle_t;
|
||||
+typedef struct { void *_unused; } *user_handle_t;
|
||||
#define __USER_HANDLE_T_DEFINED
|
||||
#ifdef HAVE_UNISTD_H
|
||||
-#ifndef _XOPEN_SOURCE
|
||||
-#define _XOPEN_SOURCE /* Required for snprinf on GNU */
|
||||
-#endif
|
||||
#define __EXTENSIONS__ /* Solaris fix */
|
||||
#include <unistd.h>
|
||||
#endif
|
||||
|
||||
|
|
400
devel/cvsnt/files/patch-src-rcs.c
Normal file
400
devel/cvsnt/files/patch-src-rcs.c
Normal file
|
@ -0,0 +1,400 @@
|
|||
--- src/rcs.c.orig Thu Jan 29 06:12:24 2004
|
||||
+++ src/rcs.c Sun Feb 22 03:30:20 2004
|
||||
@@ -6600,7 +6600,7 @@
|
||||
{
|
||||
struct binbuffer *bb;
|
||||
} binary;
|
||||
- };
|
||||
+ } u;
|
||||
};
|
||||
|
||||
static void linevector_init (struct linevector *vec);
|
||||
@@ -6637,30 +6637,30 @@
|
||||
int n = 0, ln;
|
||||
char *p;
|
||||
|
||||
- for (ln = 0; ln < lines->text.nlines; ++ln)
|
||||
+ for (ln = 0; ln < lines->u.text.nlines; ++ln)
|
||||
/* 1 for \n */
|
||||
- n += lines->text.vector[ln]->len + 1;
|
||||
+ n += lines->u.text.vector[ln]->len + 1;
|
||||
|
||||
lv.is_binary = 1;
|
||||
- lv.binary.bb=(struct binbuffer*)xmalloc(sizeof(struct binbuffer));
|
||||
- memset(lv.binary.bb,0,sizeof(struct binbuffer));
|
||||
- p = lv.binary.bb->buffer = xmalloc (n);
|
||||
- lv.binary.bb->refcount=1;
|
||||
+ lv.u.binary.bb=(struct binbuffer*)xmalloc(sizeof(struct binbuffer));
|
||||
+ memset(lv.u.binary.bb,0,sizeof(struct binbuffer));
|
||||
+ p = lv.u.binary.bb->buffer = xmalloc (n);
|
||||
+ lv.u.binary.bb->refcount=1;
|
||||
|
||||
- for (ln = 0; ln < lines->text.nlines; ++ln)
|
||||
+ for (ln = 0; ln < lines->u.text.nlines; ++ln)
|
||||
{
|
||||
- memcpy (p, lines->text.vector[ln]->text,
|
||||
- lines->text.vector[ln]->len);
|
||||
- p += lines->text.vector[ln]->len;
|
||||
- if (lines->text.vector[ln]->has_newline)
|
||||
+ memcpy (p, lines->u.text.vector[ln]->text,
|
||||
+ lines->u.text.vector[ln]->len);
|
||||
+ p += lines->u.text.vector[ln]->len;
|
||||
+ if (lines->u.text.vector[ln]->has_newline)
|
||||
*p++ = '\n';
|
||||
}
|
||||
- assert ((p-((char*)lv.binary.bb->buffer))==n);
|
||||
+ assert ((p-((char*)lv.u.binary.bb->buffer))==n);
|
||||
linevector_free(lines);
|
||||
memcpy(lines,&lv,sizeof(struct linevector));
|
||||
}
|
||||
|
||||
- if(cvsdelta_patch(lines->binary.bb->buffer,lines->binary.bb->length,diffbuf,difflen,&tmpbuf->binary.bb->buffer,&tmpbuf->binary.bb->length,&tmpbuf->binary.bb->reserved))
|
||||
+ if(cvsdelta_patch(lines->u.binary.bb->buffer,lines->u.binary.bb->length,diffbuf,difflen,&tmpbuf->u.binary.bb->buffer,&tmpbuf->u.binary.bb->length,&tmpbuf->u.binary.bb->reserved))
|
||||
error(1,0,"Binary patch failed");
|
||||
|
||||
t = *lines;
|
||||
@@ -6704,18 +6704,18 @@
|
||||
if(is_binary)
|
||||
{
|
||||
assert(!pos);
|
||||
- if(vec->text.vector || vec->text.lines_alloced)
|
||||
+ if(vec->u.text.vector || vec->u.text.lines_alloced)
|
||||
{
|
||||
error(1,0,"Attempting binary operation on text linevector");
|
||||
}
|
||||
|
||||
vec->is_binary=1;
|
||||
- vec->binary.bb=(struct binbuffer *)xmalloc(sizeof(struct binbuffer));
|
||||
- vec->binary.bb->buffer = xmalloc(len);
|
||||
- vec->binary.bb->length = len;
|
||||
- vec->binary.bb->reserved = len;
|
||||
- vec->binary.bb->refcount=1;
|
||||
- memcpy(vec->binary.bb->buffer,text,len);
|
||||
+ vec->u.binary.bb=(struct binbuffer *)xmalloc(sizeof(struct binbuffer));
|
||||
+ vec->u.binary.bb->buffer = xmalloc(len);
|
||||
+ vec->u.binary.bb->length = len;
|
||||
+ vec->u.binary.bb->reserved = len;
|
||||
+ vec->u.binary.bb->refcount=1;
|
||||
+ memcpy(vec->u.binary.bb->buffer,text,len);
|
||||
return 1;
|
||||
}
|
||||
|
||||
@@ -6733,29 +6733,29 @@
|
||||
++nnew;
|
||||
|
||||
/* Expand VEC->VECTOR if needed. */
|
||||
- if (vec->text.nlines + nnew >= vec->text.lines_alloced)
|
||||
+ if (vec->u.text.nlines + nnew >= vec->u.text.lines_alloced)
|
||||
{
|
||||
- if (vec->text.lines_alloced == 0)
|
||||
- vec->text.lines_alloced = 10;
|
||||
- while (vec->text.nlines + nnew >= vec->text.lines_alloced)
|
||||
- vec->text.lines_alloced *= 3;
|
||||
- vec->text.vector = xrealloc (vec->text.vector,
|
||||
- vec->text.lines_alloced * sizeof (*vec->text.vector));
|
||||
+ if (vec->u.text.lines_alloced == 0)
|
||||
+ vec->u.text.lines_alloced = 10;
|
||||
+ while (vec->u.text.nlines + nnew >= vec->u.text.lines_alloced)
|
||||
+ vec->u.text.lines_alloced *= 3;
|
||||
+ vec->u.text.vector = xrealloc (vec->u.text.vector,
|
||||
+ vec->u.text.lines_alloced * sizeof (*vec->u.text.vector));
|
||||
}
|
||||
|
||||
- /* Make room for the new lines in vec->text.VECTOR. */
|
||||
- if(vec->text.nlines && pos < vec->text.nlines)
|
||||
- memmove(vec->text.vector + pos + nnew, vec->text.vector + pos, sizeof(vec->text.vector[0]) * (vec->text.nlines - pos));
|
||||
-/* for (i = vec->text.nlines + nnew - 1; i >= pos + nnew; --i)
|
||||
- vec->text.vector[i] = vec->text.vector[i - nnew];
|
||||
+ /* Make room for the new lines in vec->u.text.VECTOR. */
|
||||
+ if(vec->u.text.nlines && pos < vec->u.text.nlines)
|
||||
+ memmove(vec->u.text.vector + pos + nnew, vec->u.text.vector + pos, sizeof(vec->u.text.vector[0]) * (vec->u.text.nlines - pos));
|
||||
+/* for (i = vec->u.text.nlines + nnew - 1; i >= pos + nnew; --i)
|
||||
+ vec->u.text.vector[i] = vec->text.vector[i - nnew];
|
||||
*/
|
||||
- if (pos > vec->text.nlines)
|
||||
+ if (pos > vec->u.text.nlines)
|
||||
{
|
||||
- error(0,0,"Dropping data: pos>vec->text.nlines");
|
||||
+ error(0,0,"Dropping data: pos>vec->u.text.nlines");
|
||||
return 0;
|
||||
}
|
||||
|
||||
- /* Actually add the lines, to vec->text.VECTOR. */
|
||||
+ /* Actually add the lines, to vec->u.text.VECTOR. */
|
||||
i = pos;
|
||||
nextline_text = text;
|
||||
nextline_newline = 0;
|
||||
@@ -6776,7 +6776,7 @@
|
||||
q->has_newline = nextline_newline;
|
||||
q->refcount = 1;
|
||||
memcpy (q->text, nextline_text, nextline_len);
|
||||
- vec->text.vector[i++] = q;
|
||||
+ vec->u.text.vector[i++] = q;
|
||||
|
||||
nextline_text = (char *)p + 1;
|
||||
nextline_newline = 0;
|
||||
@@ -6790,9 +6790,9 @@
|
||||
q->has_newline = nextline_newline;
|
||||
q->refcount = 1;
|
||||
memcpy (q->text, nextline_text, nextline_len);
|
||||
- vec->text.vector[i] = q;
|
||||
+ vec->u.text.vector[i] = q;
|
||||
|
||||
- vec->text.nlines += nnew;
|
||||
+ vec->u.text.nlines += nnew;
|
||||
|
||||
return 1;
|
||||
}
|
||||
@@ -6807,15 +6807,15 @@
|
||||
register unsigned int i;
|
||||
unsigned int last;
|
||||
|
||||
- last = vec->text.nlines - nlines;
|
||||
+ last = vec->u.text.nlines - nlines;
|
||||
for (i = pos; i < pos + nlines; ++i)
|
||||
{
|
||||
- if (--vec->text.vector[i]->refcount == 0)
|
||||
- xfree (vec->text.vector[i]);
|
||||
+ if (--vec->u.text.vector[i]->refcount == 0)
|
||||
+ xfree (vec->u.text.vector[i]);
|
||||
}
|
||||
- if(nlines && (i < vec->text.nlines))
|
||||
- memmove(vec->text.vector + pos, vec->text.vector + pos + nlines, sizeof(vec->text.vector[0]) * (vec->text.nlines - i));
|
||||
- vec->text.nlines -= nlines;
|
||||
+ if(nlines && (i < vec->u.text.nlines))
|
||||
+ memmove(vec->u.text.vector + pos, vec->u.text.vector + pos + nlines, sizeof(vec->u.text.vector[0]) * (vec->u.text.nlines - i));
|
||||
+ vec->u.text.nlines -= nlines;
|
||||
}
|
||||
|
||||
|
||||
@@ -6828,32 +6828,32 @@
|
||||
linevector_free(to);
|
||||
if(from->is_binary)
|
||||
{
|
||||
- from->binary.bb->refcount++;
|
||||
+ from->u.binary.bb->refcount++;
|
||||
linevector_free(to);
|
||||
to->is_binary=1;
|
||||
- to->binary.bb=from->binary.bb;
|
||||
+ to->u.binary.bb=from->u.binary.bb;
|
||||
}
|
||||
else
|
||||
{
|
||||
- for (ln = 0; ln < to->text.nlines; ++ln)
|
||||
+ for (ln = 0; ln < to->u.text.nlines; ++ln)
|
||||
{
|
||||
- if (--to->text.vector[ln]->refcount == 0)
|
||||
- xfree (to->text.vector[ln]);
|
||||
+ if (--to->u.text.vector[ln]->refcount == 0)
|
||||
+ xfree (to->u.text.vector[ln]);
|
||||
}
|
||||
- if (from->text.nlines > to->text.lines_alloced)
|
||||
+ if (from->u.text.nlines > to->u.text.lines_alloced)
|
||||
{
|
||||
- if (to->text.lines_alloced == 0)
|
||||
- to->text.lines_alloced = 10;
|
||||
- while (from->text.nlines > to->text.lines_alloced)
|
||||
- to->text.lines_alloced *= 2;
|
||||
- to->text.vector = (struct line **)
|
||||
- xrealloc (to->text.vector, to->text.lines_alloced * sizeof (*to->text.vector));
|
||||
+ if (to->u.text.lines_alloced == 0)
|
||||
+ to->u.text.lines_alloced = 10;
|
||||
+ while (from->u.text.nlines > to->u.text.lines_alloced)
|
||||
+ to->u.text.lines_alloced *= 2;
|
||||
+ to->u.text.vector = (struct line **)
|
||||
+ xrealloc (to->u.text.vector, to->u.text.lines_alloced * sizeof (*to->u.text.vector));
|
||||
}
|
||||
- memcpy (to->text.vector, from->text.vector,
|
||||
- from->text.nlines * sizeof (*to->text.vector));
|
||||
- to->text.nlines = from->text.nlines;
|
||||
- for (ln = 0; ln < to->text.nlines; ++ln)
|
||||
- ++to->text.vector[ln]->refcount;
|
||||
+ memcpy (to->u.text.vector, from->u.text.vector,
|
||||
+ from->u.text.nlines * sizeof (*to->u.text.vector));
|
||||
+ to->u.text.nlines = from->u.text.nlines;
|
||||
+ for (ln = 0; ln < to->u.text.nlines; ++ln)
|
||||
+ ++to->u.text.vector[ln]->refcount;
|
||||
}
|
||||
}
|
||||
|
||||
@@ -6864,23 +6864,23 @@
|
||||
|
||||
if(vec->is_binary)
|
||||
{
|
||||
- if(vec->binary.bb && !vec->binary.bb->refcount--)
|
||||
+ if(vec->u.binary.bb && !vec->u.binary.bb->refcount--)
|
||||
{
|
||||
- xfree(vec->binary.bb->buffer);
|
||||
- xfree(vec->binary.bb);
|
||||
+ xfree(vec->u.binary.bb->buffer);
|
||||
+ xfree(vec->u.binary.bb);
|
||||
}
|
||||
else
|
||||
- vec->binary.bb=NULL;
|
||||
+ vec->u.binary.bb=NULL;
|
||||
}
|
||||
else
|
||||
{
|
||||
- if (vec->text.vector != NULL)
|
||||
+ if (vec->u.text.vector != NULL)
|
||||
{
|
||||
- for (ln = 0; ln < vec->text.nlines; ++ln)
|
||||
- if (--vec->text.vector[ln]->refcount == 0)
|
||||
- xfree (vec->text.vector[ln]);
|
||||
+ for (ln = 0; ln < vec->u.text.nlines; ++ln)
|
||||
+ if (--vec->u.text.vector[ln]->refcount == 0)
|
||||
+ xfree (vec->u.text.vector[ln]);
|
||||
|
||||
- xfree (vec->text.vector);
|
||||
+ xfree (vec->u.text.vector);
|
||||
}
|
||||
}
|
||||
}
|
||||
@@ -6944,7 +6944,7 @@
|
||||
if(lines->is_binary)
|
||||
{
|
||||
struct linevector lv = {0};
|
||||
- linevector_add(&lv,lines->binary.bb->buffer,lines->binary.bb->length,delvers,0,0);
|
||||
+ linevector_add(&lv,lines->u.binary.bb->buffer,lines->u.binary.bb->length,delvers,0,0);
|
||||
linevector_free(lines);
|
||||
lv=*lines;
|
||||
}
|
||||
@@ -7025,12 +7025,12 @@
|
||||
return 0;
|
||||
break;
|
||||
case FRAG_DELETE:
|
||||
- if (df->pos > lines->text.nlines
|
||||
- || df->pos + df->nlines > lines->text.nlines)
|
||||
+ if (df->pos > lines->u.text.nlines
|
||||
+ || df->pos + df->nlines > lines->u.text.nlines)
|
||||
return 0;
|
||||
if (delvers != NULL)
|
||||
for (ln = df->pos; ln < df->pos + df->nlines; ++ln)
|
||||
- lines->text.vector[ln]->vers = delvers;
|
||||
+ lines->u.text.vector[ln]->vers = delvers;
|
||||
linevector_delete (lines, df->pos, df->nlines);
|
||||
break;
|
||||
}
|
||||
@@ -7084,18 +7084,18 @@
|
||||
unsigned int ln;
|
||||
|
||||
n = 0;
|
||||
- for (ln = 0; ln < lines.text.nlines; ++ln)
|
||||
+ for (ln = 0; ln < lines.u.text.nlines; ++ln)
|
||||
/* 1 for \n */
|
||||
- n += lines.text.vector[ln]->len + 1;
|
||||
+ n += lines.u.text.vector[ln]->len + 1;
|
||||
|
||||
p = xmalloc (n);
|
||||
*retbuf = p;
|
||||
|
||||
- for (ln = 0; ln < lines.text.nlines; ++ln)
|
||||
+ for (ln = 0; ln < lines.u.text.nlines; ++ln)
|
||||
{
|
||||
- memcpy (p, lines.text.vector[ln]->text, lines.text.vector[ln]->len);
|
||||
- p += lines.text.vector[ln]->len;
|
||||
- if (lines.text.vector[ln]->has_newline)
|
||||
+ memcpy (p, lines.u.text.vector[ln]->text, lines.u.text.vector[ln]->len);
|
||||
+ p += lines.u.text.vector[ln]->len;
|
||||
+ if (lines.u.text.vector[ln]->has_newline)
|
||||
*p++ = '\n';
|
||||
}
|
||||
|
||||
@@ -7303,13 +7303,13 @@
|
||||
else if(STREQ(deltatype,"binary") || STREQ(deltatype,"compressed_binary"))
|
||||
{
|
||||
/* If we've been copied, disconnect the copy */
|
||||
- if(!binbuf.binary.bb || binbuf.binary.bb->refcount>1)
|
||||
+ if(!binbuf.u.binary.bb || binbuf.u.binary.bb->refcount>1)
|
||||
{
|
||||
- if(binbuf.binary.bb)
|
||||
- binbuf.binary.bb->refcount--;
|
||||
- binbuf.binary.bb=(struct binbuffer*)xmalloc(sizeof(struct binbuffer));
|
||||
- memset(binbuf.binary.bb,0,sizeof(struct binbuffer));
|
||||
- binbuf.binary.bb->refcount=1;
|
||||
+ if(binbuf.u.binary.bb)
|
||||
+ binbuf.u.binary.bb->refcount--;
|
||||
+ binbuf.u.binary.bb=(struct binbuffer*)xmalloc(sizeof(struct binbuffer));
|
||||
+ memset(binbuf.u.binary.bb,0,sizeof(struct binbuffer));
|
||||
+ binbuf.u.binary.bb->refcount=1;
|
||||
}
|
||||
if (! apply_binary_changes(&curlines, &binbuf, value, vallen))
|
||||
error(1,0,"invalid binary delta text in %s", fn_root(rcs->path));
|
||||
@@ -7364,8 +7364,8 @@
|
||||
/* Reset the version information we have
|
||||
accumulated so far. It only applies to the
|
||||
changes from the head to this version. */
|
||||
- for (ln = 0; ln < curlines.text.nlines; ++ln)
|
||||
- curlines.text.vector[ln]->vers = NULL;
|
||||
+ for (ln = 0; ln < curlines.u.text.nlines; ++ln)
|
||||
+ curlines.u.text.vector[ln]->vers = NULL;
|
||||
}
|
||||
}
|
||||
|
||||
@@ -7423,7 +7423,7 @@
|
||||
if(headlines.is_binary)
|
||||
error(1,0,"Cannot annotate a binary delta");
|
||||
|
||||
- for (ln = 0; ln < headlines.text.nlines; ++ln)
|
||||
+ for (ln = 0; ln < headlines.u.text.nlines; ++ln)
|
||||
{
|
||||
char buf[80];
|
||||
/* Period which separates year from month in date. */
|
||||
@@ -7432,7 +7432,7 @@
|
||||
char *md;
|
||||
RCSVers *prvers;
|
||||
|
||||
- prvers = headlines.text.vector[ln]->vers;
|
||||
+ prvers = headlines.u.text.vector[ln]->vers;
|
||||
if (prvers == NULL)
|
||||
prvers = vers;
|
||||
|
||||
@@ -7474,9 +7474,9 @@
|
||||
cvs_output (ym - 2, 2);
|
||||
}
|
||||
cvs_output ("): ", 0);
|
||||
- if (headlines.text.vector[ln]->len != 0)
|
||||
- cvs_output (headlines.text.vector[ln]->text,
|
||||
- headlines.text.vector[ln]->len);
|
||||
+ if (headlines.u.text.vector[ln]->len != 0)
|
||||
+ cvs_output (headlines.u.text.vector[ln]->text,
|
||||
+ headlines.u.text.vector[ln]->len);
|
||||
cvs_output ("\n", 1);
|
||||
}
|
||||
}
|
||||
@@ -7492,25 +7492,25 @@
|
||||
|
||||
if(headlines.is_binary)
|
||||
{
|
||||
- p = xmalloc(headlines.binary.bb->length);
|
||||
+ p = xmalloc(headlines.u.binary.bb->length);
|
||||
*text = p;
|
||||
- *len = headlines.binary.bb->length;
|
||||
- memcpy(p, headlines.binary.bb->buffer,headlines.binary.bb->length);
|
||||
+ *len = headlines.u.binary.bb->length;
|
||||
+ memcpy(p, headlines.u.binary.bb->buffer,headlines.u.binary.bb->length);
|
||||
}
|
||||
else
|
||||
{
|
||||
n = 0;
|
||||
- for (ln = 0; ln < headlines.text.nlines; ++ln)
|
||||
+ for (ln = 0; ln < headlines.u.text.nlines; ++ln)
|
||||
/* 1 for \n */
|
||||
- n += headlines.text.vector[ln]->len + 1;
|
||||
+ n += headlines.u.text.vector[ln]->len + 1;
|
||||
p = xmalloc (n);
|
||||
*text = p;
|
||||
- for (ln = 0; ln < headlines.text.nlines; ++ln)
|
||||
+ for (ln = 0; ln < headlines.u.text.nlines; ++ln)
|
||||
{
|
||||
- memcpy (p, headlines.text.vector[ln]->text,
|
||||
- headlines.text.vector[ln]->len);
|
||||
- p += headlines.text.vector[ln]->len;
|
||||
- if (headlines.text.vector[ln]->has_newline)
|
||||
+ memcpy (p, headlines.u.text.vector[ln]->text,
|
||||
+ headlines.u.text.vector[ln]->len);
|
||||
+ p += headlines.u.text.vector[ln]->len;
|
||||
+ if (headlines.u.text.vector[ln]->has_newline)
|
||||
*p++ = '\n';
|
||||
}
|
||||
*len = p - *text;
|
|
@ -1,17 +0,0 @@
|
|||
--- src/server.h.orig Fri Jan 23 18:51:00 2004
|
||||
+++ src/server.h Fri Jan 23 18:54:13 2004
|
||||
@@ -91,7 +91,13 @@
|
||||
struct buffer;
|
||||
#endif
|
||||
|
||||
-extern void server_updated();
|
||||
+extern void server_updated(
|
||||
+ struct file_info *finfo,
|
||||
+ Vers_TS *vers,
|
||||
+ enum server_updated_arg4 updated,
|
||||
+ mode_t mode,
|
||||
+ unsigned char *checksum,
|
||||
+ struct buffer *filebuf);
|
||||
|
||||
/* Whether we should send RCS format patches. */
|
||||
extern int server_use_rcs_diff();
|
|
@ -1,10 +0,0 @@
|
|||
--- src/subr.c.orig Fri Jan 23 18:54:50 2004
|
||||
+++ src/subr.c Fri Jan 23 18:55:17 2004
|
||||
@@ -20,6 +20,7 @@
|
||||
#include <winsock2.h>
|
||||
#include <ws2tcpip.h>
|
||||
#else
|
||||
+#include <sys/socket.h>
|
||||
#include <netdb.h>
|
||||
#endif
|
||||
#include <errno.h>
|
Loading…
Reference in a new issue