- update to 20070115

PR:		108307
Approved by:	(maintainer timeout)
This commit is contained in:
Dirk Meyer 2007-02-12 03:34:10 +00:00
parent 90a1a14e9f
commit 7e15904e7c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=184938
4 changed files with 6 additions and 66 deletions

View file

@ -6,19 +6,15 @@
#
PORTNAME= aiccu
PORTVERSION= 20060725
PORTVERSION= 20070115
CATEGORIES= net ipv6
MASTER_SITES= http://www.sixxs.net/archive/sixxs/aiccu/unix/
MASTER_SITES= http://noc.sixxs.net/archive/sixxs/aiccu/unix/
PKGNAMEPREFIX= sixxs-
DISTNAME= aiccu_2006.07.25
DISTNAME= aiccu_20070115
MAINTAINER= meno.abels@adviser.com
COMMENT= SixXS IPv6 TIC+ tunnel broker heartbeat client
BROKEN= Unfetchable
DEPRECATED= ${BROKEN}
EXPIRATION_DATE=2007-04-10
USE_RC_SUBR= sixxs-aiccu
USE_GMAKE= yes

View file

@ -1,3 +1,3 @@
MD5 (aiccu_2006.07.25.tar.gz) = 0df76e92eb34f4ce8aa3cfcf6896f271
SHA256 (aiccu_2006.07.25.tar.gz) = ce735aced6d18594a726c9b027ddc80ca1ff658f6e436c530b60779f2dc5d4df
SIZE (aiccu_2006.07.25.tar.gz) = 64161
MD5 (aiccu_20070115.tar.gz) = c9bcc83644ed788e22a7c3f3d4021350
SHA256 (aiccu_20070115.tar.gz) = 2260f426c13471169ccff8cb4a3908dc5f79fda18ddb6a55363e7824e6c4c760
SIZE (aiccu_20070115.tar.gz) = 70056

View file

@ -1,21 +0,0 @@
--- common/tun.c.orig Tue Jul 25 02:20:46 2006
+++ common/tun.c Thu Nov 30 02:02:05 2006
@@ -703,9 +703,7 @@
char buf[128];
unsigned int i;
-#ifndef _FREEBSD
int mode = IFF_MULTICAST | IFF_POINTOPOINT;
-#endif
/* Try the configured interface */
tun_log(LOG_DEBUG, "start", "Trying Configured TUN/TAP interface %s...\n", g_aiccu->ipv6_interface);
@@ -752,7 +750,7 @@
#endif
#endif
-#ifdef _DFBSD
+#ifdef NEED_IFHEAD
tun_log(LOG_DEBUG, "start", "Setting TUNSIFHEAD for %s\n", g_aiccu->ipv6_interface);
mode = 1;
if (ioctl(tun_fd, TUNSIFHEAD, &mode, sizeof(mode)) == -1)

View file

@ -1,35 +0,0 @@
--- unix-console/Makefile.orig Tue Jul 25 11:20:48 2006
+++ unix-console/Makefile Sat Dec 30 20:19:04 2006
@@ -21,7 +21,7 @@
#INCS += ../common/tsp.h ../common/teepee.h
# Our very *bliep* set of options to make sure that these things can't cause any issues
-CWARNS += -W -Wall -Wshadow -Wpointer-arith -Wcast-align -Wwrite-strings -Waggregate-return -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wredundant-decls -Wnested-externs -Winline -Wbad-function-cast -fshort-enums -fstrict-aliasing -fno-common -Wpadded -pedantic -pthread -D_REENTRANT
+#CWARNS += -W -Wall -Wshadow -Wpointer-arith -Wcast-align -Wwrite-strings -Waggregate-return -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wredundant-decls -Wnested-externs -Winline -Wbad-function-cast -fshort-enums -fstrict-aliasing -fno-common -Wpadded -pedantic -pthread -D_REENTRANT
# CWARNS += -Wpacked
#CFLAGS += $(CWARNS) -D_GNU_SOURCE -D_DEBUG -g3 -O0
@@ -62,19 +62,19 @@
CFLAGS += -D AICCU_TYPE="\"freebsd4\""
SRCS += ../common/aiccu_freebsd4.c
OBJS += ../common/aiccu_freebsd4.o
-CFLAGS += -pthread
+#CFLAGS += -pthread
else
# FreeBSD 5.x/6.x/7.x
-CFLAGS += -D AICCU_TYPE="\"kame\""
+CFLAGS += -D NEED_IFHEAD -D AICCU_TYPE="\"kame\""
SRCS += ../common/aiccu_kame.c
OBJS += ../common/aiccu_kame.o
-CFLAGS += -pthread
+#CFLAGS += -pthread
endif
endif
# DragonFlyBSD
ifeq ($(shell uname | grep -c "DragonFly"),1)
-CFLAGS += -D _DFBSD -D AICCU_TYPE="\"dragonfly\""
+CFLAGS += -D _DFBSD -D NEED_IFHEAD -D AICCU_TYPE="\"dragonfly\""
SRCS += ../common/aiccu_freebsd4.c
OBJS += ../common/aiccu_freebsd4.o
CFLAGS += -pthread