- Update to 0.2.1
PR: 118764 Submitted by: Dmitry Marakasov <amdmi3@amdmi3.ru> (maintainer)
This commit is contained in:
parent
13049c1e8f
commit
7e564b8b2f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=204025
4 changed files with 31 additions and 38 deletions
|
@ -6,8 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= kobodeluxe
|
||||
DISTVERSION= 0.4pre10
|
||||
PORTREVISION= 1
|
||||
DISTVERSION= 0.4.1
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= http://olofson.net/kobodl/download/ \
|
||||
http://www.amdmi3.ru/distfiles/
|
||||
|
@ -16,15 +15,19 @@ DISTNAME= KoboDeluxe-${DISTVERSION}
|
|||
MAINTAINER= amdmi3@amdmi3.ru
|
||||
COMMENT= An SDL port of the scrolling game XKobo
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_SDL= image sdl
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
||||
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL} \
|
||||
--sharedstatedir=${SCOREDIR}
|
||||
|
||||
MAN6= kobodl.6
|
||||
|
||||
SCOREDIR= /var/games/${PORTNAME}
|
||||
PLIST_SUB= SCOREDIR="${SCOREDIR}"
|
||||
|
||||
DATADIR= ${PREFIX}/share/kobo-deluxe
|
||||
|
||||
OPTIONS= OPENGL "OpenGL rendering layer (experimental)" off
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (KoboDeluxe-0.4pre10.tar.gz) = 6c075837ae680bf5490c1fc4279dcc8b
|
||||
SHA256 (KoboDeluxe-0.4pre10.tar.gz) = b68d5977e9ef447285002a1d4eac0b3319c9f7f6f261028d6a7dfd0bcebe513a
|
||||
SIZE (KoboDeluxe-0.4pre10.tar.gz) = 800650
|
||||
MD5 (KoboDeluxe-0.4.1.tar.bz2) = 49a36c1cef7ec1acee4ab67a2468fd85
|
||||
SHA256 (KoboDeluxe-0.4.1.tar.bz2) = ccb25febf6ab3ffbf93fb0bb3ff3f778735a97328d75420fb4c06cac544aaa57
|
||||
SIZE (KoboDeluxe-0.4.1.tar.bz2) = 802115
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- gamestate.h.orig Sun Apr 28 05:48:59 2002
|
||||
+++ gamestate.h Sat Sep 30 23:58:17 2006
|
||||
@@ -24,6 +24,8 @@
|
||||
|
||||
#include "window.h"
|
||||
|
||||
+class gamestatemanager_t;
|
||||
+
|
||||
class gamestate_t
|
||||
{
|
||||
friend class gamestatemanager_t;
|
|
@ -1,55 +1,55 @@
|
|||
bin/kobodl
|
||||
%%DATADIR%%/gfx/bigship.pcx
|
||||
%%DATADIR%%/gfx/bigship.png
|
||||
%%DATADIR%%/gfx/bolt.png
|
||||
%%DATADIR%%/gfx/brushes.png
|
||||
%%DATADIR%%/gfx/bullets.pcx
|
||||
%%DATADIR%%/gfx/bullets.png
|
||||
%%DATADIR%%/gfx/counter.png
|
||||
%%DATADIR%%/gfx/deluxe.png
|
||||
%%DATADIR%%/gfx/explo1b.png
|
||||
%%DATADIR%%/gfx/explo2b.png
|
||||
%%DATADIR%%/gfx/focusfx.png
|
||||
%%DATADIR%%/gfx/font2b.png
|
||||
%%DATADIR%%/gfx/font3b.png
|
||||
%%DATADIR%%/gfx/font4b.png
|
||||
%%DATADIR%%/gfx/hitnoise.png
|
||||
%%DATADIR%%/gfx/loading.png
|
||||
%%DATADIR%%/gfx/logo3.png
|
||||
%%DATADIR%%/gfx/noise.pcx
|
||||
%%DATADIR%%/gfx/logo.png
|
||||
%%DATADIR%%/gfx/logomask.png
|
||||
%%DATADIR%%/gfx/microfont.png
|
||||
%%DATADIR%%/gfx/noise.png
|
||||
%%DATADIR%%/gfx/screen.png
|
||||
%%DATADIR%%/gfx/sprites.pcx
|
||||
%%DATADIR%%/gfx/tiles.pcx
|
||||
%%DATADIR%%/gfx/tube1.png
|
||||
%%DATADIR%%/gfx/tube2.png
|
||||
%%DATADIR%%/gfx/sprites.png
|
||||
%%DATADIR%%/gfx/tiles.png
|
||||
%%DATADIR%%/sfx/aguitar1.agw
|
||||
%%DATADIR%%/sfx/ballad1.agw
|
||||
%%DATADIR%%/sfx/ballad1.mid
|
||||
%%DATADIR%%/sfx/bassdrum3.agw
|
||||
%%DATADIR%%/sfx/bassdrum5.agw
|
||||
%%DATADIR%%/sfx/beam.raw
|
||||
%%DATADIR%%/sfx/bomb.raw
|
||||
%%DATADIR%%/sfx/bongo1.agw
|
||||
%%DATADIR%%/sfx/brass2.agw
|
||||
%%DATADIR%%/sfx/breakdown1.agw
|
||||
%%DATADIR%%/sfx/bubble.raw
|
||||
%%DATADIR%%/sfx/bzzzt1.agw
|
||||
%%DATADIR%%/sfx/claps1.agw
|
||||
%%DATADIR%%/sfx/edge2.agw
|
||||
%%DATADIR%%/sfx/elecbass2.agw
|
||||
%%DATADIR%%/sfx/enemym.raw
|
||||
%%DATADIR%%/sfx/expl.raw
|
||||
%%DATADIR%%/sfx/expl2.raw
|
||||
%%DATADIR%%/sfx/expl3.raw
|
||||
%%DATADIR%%/sfx/fine.raw
|
||||
%%DATADIR%%/sfx/gameover1.agw
|
||||
%%DATADIR%%/sfx/hardsync1.agw
|
||||
%%DATADIR%%/sfx/kobosfx.h
|
||||
%%DATADIR%%/sfx/launch.agw
|
||||
%%DATADIR%%/sfx/launch2.agw
|
||||
%%DATADIR%%/sfx/marimba2.agw
|
||||
%%DATADIR%%/sfx/metallic.raw
|
||||
%%DATADIR%%/sfx/missile1.agw
|
||||
%%DATADIR%%/sfx/music.agw
|
||||
%%DATADIR%%/sfx/noiseburst1.agw
|
||||
%%DATADIR%%/sfx/music_c.agw
|
||||
%%DATADIR%%/sfx/noiseburst2.agw
|
||||
%%DATADIR%%/sfx/oneup.raw
|
||||
%%DATADIR%%/sfx/phattpad1.agw
|
||||
%%DATADIR%%/sfx/phattpad2.agw
|
||||
%%DATADIR%%/sfx/ready1.agw
|
||||
%%DATADIR%%/sfx/ring.raw
|
||||
%%DATADIR%%/sfx/save_waves.agw
|
||||
%%DATADIR%%/sfx/sfx.agw
|
||||
%%DATADIR%%/sfx/shot.raw
|
||||
%%DATADIR%%/sfx/sfx_c.agw
|
||||
%%DATADIR%%/sfx/sine.agw
|
||||
%%DATADIR%%/sfx/snare1.agw
|
||||
%%DATADIR%%/sfx/synbass1.agw
|
||||
|
@ -58,8 +58,9 @@ bin/kobodl
|
|||
%%DATADIR%%/sfx/thunder1.agw
|
||||
%%DATADIR%%/sfx/trance1.agw
|
||||
%%DATADIR%%/sfx/trance1.mid
|
||||
@exec install -d -o root -g games -m 775 %%SCOREDIR%%
|
||||
@unexec rmdir %%SCOREDIR%% 2>/dev/null || true
|
||||
%%DATADIR%%/sfx/trance1_c.agw
|
||||
@dirrm %%DATADIR%%/sfx
|
||||
@dirrm %%DATADIR%%/gfx
|
||||
@dirrm %%DATADIR%%
|
||||
@exec install -d -o root -g games -m 775 %%SCOREDIR%%
|
||||
@dirrmtry %%SCOREDIR%%
|
||||
|
|
Loading…
Reference in a new issue