Update port: sysutils/gtoaster

- Fix handling PORTVERSION
	- Reaarange USE_GNOME
	- machine/soundcard.h -> sys/soundcard.h

PR:		ports/56530
Submitted by:	KATO Tsuguru <tkato@prontomail.com>
This commit is contained in:
Edwin Groothuis 2003-09-08 05:49:41 +00:00
parent 0f15a9d90f
commit 7e5f15f927
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=88733
3 changed files with 60 additions and 13 deletions

View file

@ -6,11 +6,11 @@
#
PORTNAME= gtoaster
PORTVERSION= 1.0.Beta6
PORTEPOCH= 1
PORTVERSION= 1.0.b6
PORTEPOCH= 2
CATEGORIES= sysutils gnome
MASTER_SITES= http://gnometoaster.rulez.org/archive/
DISTNAME= ${PORTNAME}1.0Beta6
DISTNAME= ${PORTNAME}${PORTVERSION:S/.b/Beta/}
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
@ -19,17 +19,42 @@ COMMENT= Graphical cd cooking interface
RUN_DEPENDS= cdrecord:${PORTSDIR}/sysutils/cdrtools \
mkisofs:${PORTSDIR}/sysutils/mkisofs
WRKSRC= ${WRKDIR}/gtoaster
WRKSRC= ${WRKDIR}/${PORTNAME}
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${X11BASE}
CONFIGURE_ENV= GTK_CONFIG=${X11BASE}/bin/gtk12-config
USE_GNOME= gtk12
USE_GMAKE= yes
USE_X_PREFIX= yes
WANT_GNOME= yes
USE_GNOME= gnomehack gnometarget gtk12
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
pre-configure:
@${RM} ${WRKSRC}/config.guess
.include <bsd.port.pre.mk>
.include <bsd.port.mk>
.if ${HAVE_GNOME:Mgnomelibs}!=""
PKGNAMESUFFIX= -gnome
USE_GNOME+= gnomelibs
.else
CONFIGURE_ARGS+= --without-gnome
.endif
.if ${HAVE_GNOME:Morbit}!=""
USE_GNOME+= orbit
.else
CONFIGURE_ARGS+= --without-orbit
.endif
.if ${HAVE_GNOME:Mesound}!=""
USE_GNOME+= esound
.else
CONFIGURE_ARGS+= --without-esd
.endif
post-extract:
@${RM} -f ${WRKSRC}/config.guess
@${TOUCH} ${WRKSRC}/config.guess
post-patch:
${REINPLACE_CMD} -e 's, -pthread, ${PTHREAD_LIBS},g' \
${WRKSRC}/configure
.include <bsd.port.post.mk>

View file

@ -0,0 +1,11 @@
--- audio_oss.c.orig Sun Sep 7 22:30:57 2003
+++ audio_oss.c Sun Sep 7 22:31:10 2003
@@ -15,7 +15,7 @@
#ifndef __FreeBSD__
#include <linux/soundcard.h>
#else
-#include <machine/soundcard.h>
+#include <sys/soundcard.h>
#define SNDCTL_DSP_CHANNELS SNDCTL_DSP_STEREO
#endif

View file

@ -0,0 +1,11 @@
--- configure.orig Sun Sep 7 22:33:01 2003
+++ configure Sun Sep 7 22:35:58 2003
@@ -4696,7 +4696,7 @@
USEOSS=no
-if test -e /usr/include/linux/soundcard.h;
+if test -e /usr/include/sys/soundcard.h;
then
USEOSS=yes
echo "*** open sound system header file detected ***"