Adding paintlib version 0.2.1.
A small but powerful C++ graphics library. PR: 15952 Submitted by: Will Andrews <andrews@technologist.com>
This commit is contained in:
parent
b195601658
commit
7e6310cab7
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=25210
7 changed files with 68 additions and 0 deletions
|
@ -103,6 +103,7 @@
|
|||
SUBDIR += p5-GD
|
||||
SUBDIR += p5-Image-Size
|
||||
SUBDIR += p5-chart
|
||||
SUBDIR += paintlib
|
||||
SUBDIR += pgperl
|
||||
SUBDIR += pgplot
|
||||
SUBDIR += photopc
|
||||
|
|
34
graphics/twinlib/Makefile
Normal file
34
graphics/twinlib/Makefile
Normal file
|
@ -0,0 +1,34 @@
|
|||
# New ports collection makefile for: paintlib
|
||||
# Version required: 0.2.1
|
||||
# Date created: 04 Jan 2000
|
||||
# Whom: Will Andrews <andrews@technologist.com>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
DISTNAME= paintlib.0.2.1
|
||||
PKGNAME= paintlib-0.2.1
|
||||
CATEGORIES= graphics devel
|
||||
MASTER_SITES= http://rio.xdev.org/paintlib/
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= andrews@technologist.com
|
||||
|
||||
USE_QT2= yes
|
||||
USE_X_PREFIX= yes
|
||||
WRKSRC= ${WRKDIR}/paintlib
|
||||
MAKE_ENV+= PREFIX=${PREFIX} CXX=${CXX}
|
||||
VERSION= 0
|
||||
PLIST_SUB+= VERSION=${VERSION}
|
||||
|
||||
post-patch:
|
||||
@${PERL} -pi -e "s:%%VERSION%%:${VERSION}:g" ${WRKSRC}/Makefile
|
||||
@${PERL} -pi -e "s:g\+\+:${CXX}:g" ${WRKSRC}/Makefile
|
||||
|
||||
do-install:
|
||||
@${INSTALL_DATA} ${WRKSRC}/PaintLib.h ${PREFIX}/include
|
||||
@${INSTALL_DATA} ${WRKSRC}/libPaintLib.so.${VERSION} ${PREFIX}/lib
|
||||
@${LN} -sf libPaintLib.so.${VERSION} ${PREFIX}/lib/libPaintLib.so
|
||||
${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
|
||||
|
||||
.include <bsd.port.mk>
|
1
graphics/twinlib/distinfo
Normal file
1
graphics/twinlib/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (paintlib.0.2.1.tgz) = fcdac1684bb2aad93e83e06d4e9ca18f
|
17
graphics/twinlib/files/patch-aa
Normal file
17
graphics/twinlib/files/patch-aa
Normal file
|
@ -0,0 +1,17 @@
|
|||
--- Makefile Mon Jan 3 21:53:07 2000
|
||||
+++ Makefile.new Tue Jan 4 13:27:24 2000
|
||||
@@ -1,6 +1,11 @@
|
||||
-QT = /usr/local/qt/include
|
||||
-LIBS = -L/usr/X11R6/lib -lqt -lqimgio -lpng -ljpeg
|
||||
-LIBPATH = /usr/X11R6/lib
|
||||
+CXX ?= g++
|
||||
+QT = $(PREFIX)/include/qt2 -I$(PREFIX)/include
|
||||
+LIBS = -L$(PREFIX)/lib -lqt2 -lpng -ljpeg
|
||||
+LIBPATH = $(PREFIX)/lib
|
||||
+LIBRARY = libPaintLib.so.%%VERSION%%
|
||||
+
|
||||
+all: Image.o
|
||||
+ $(CXX) -shared -Wl,-soname,libPaintLib.so -o $(LIBRARY)
|
||||
|
||||
install: Image.o PaintLib.h
|
||||
clear
|
1
graphics/twinlib/pkg-comment
Normal file
1
graphics/twinlib/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
Small but powerful C++ graphics library
|
9
graphics/twinlib/pkg-descr
Normal file
9
graphics/twinlib/pkg-descr
Normal file
|
@ -0,0 +1,9 @@
|
|||
Paintlib is a small but powerful C++ graphics
|
||||
library that makes its base on the Qt Image I/O
|
||||
extensions offered by Qt 2. It is somewhat useful
|
||||
for simple graphics programs.
|
||||
|
||||
WWW: http://rio.xdev.org/
|
||||
Author: Nicolas Roard <nroard@e-motive.com>
|
||||
|
||||
--Will <andrews@technologist.com>
|
5
graphics/twinlib/pkg-plist
Normal file
5
graphics/twinlib/pkg-plist
Normal file
|
@ -0,0 +1,5 @@
|
|||
include/PaintLib.h
|
||||
lib/libPaintLib.so
|
||||
lib/libPaintLib.so.%%VERSION%%
|
||||
@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
|
||||
@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
|
Loading…
Reference in a new issue