fix security/py-m2crypto:
- use PYTHON_VERSION Pointed out by: kuriyama
This commit is contained in:
parent
248db8434a
commit
7e6e9ca46e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=86369
2 changed files with 10 additions and 5 deletions
|
@ -23,9 +23,13 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/SWIG
|
|||
USE_PYTHON= yes
|
||||
USE_ZIP= yes
|
||||
USE_OPENSSL= yes
|
||||
USE_REINPLACE= yes
|
||||
|
||||
PINSTALL_PLIST= ${WRKDIR}/pinstall-plist
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} "s/PYTHON_VERSION/${PYTHON_VERSION}/" ${WRKSRC}/Makefile
|
||||
|
||||
post-build:
|
||||
${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}/../M2Crypto
|
||||
|
||||
|
|
|
@ -1,11 +1,12 @@
|
|||
--- Makefile.orig Wed Aug 6 16:47:51 2003
|
||||
+++ Makefile Wed Aug 6 16:49:15 2003
|
||||
@@ -3,7 +3,7 @@
|
||||
--- Makefile.orig Wed Aug 6 17:33:10 2003
|
||||
+++ Makefile Wed Aug 6 17:34:04 2003
|
||||
@@ -3,8 +3,7 @@
|
||||
CFLAGS = -DTHREADING -g
|
||||
INCLUDE = -I/usr/local/include -I.
|
||||
LIBS = -L/usr/local/lib -lssl -lcrypto
|
||||
-PYVER = 2.2
|
||||
+PYVER = 2.3
|
||||
PYINCLUDE = -DHAVE_CONFIG_H -I/usr/local/include/python$(PYVER) \
|
||||
-PYINCLUDE = -DHAVE_CONFIG_H -I/usr/local/include/python$(PYVER) \
|
||||
+PYINCLUDE = -DHAVE_CONFIG_H -I/usr/local/include/PYTHON_VERSION \
|
||||
-I/usr/local/lib/python$(PYVER)/config
|
||||
PYLIB = /usr/local/lib/python$(PYVER)/config
|
||||
|
||||
|
|
Loading…
Reference in a new issue