Update to 2.8.9.
This commit is contained in:
parent
c29d50eed7
commit
7e775e74d6
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=499846
8 changed files with 53 additions and 31 deletions
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= gcin
|
||||
PORTVERSION= 2.8.8
|
||||
PORTVERSION= 2.8.9
|
||||
CATEGORIES= chinese textproc gnome
|
||||
MASTER_SITES= http://hyperrate.com/gcin-source/
|
||||
EXTRACT_ONLY= gcin-${PORTVERSION}.tar.xz
|
||||
|
@ -16,10 +16,10 @@ BROKEN_powerpc64= fails to build: gmake[3]: *** [Makefile:30: en-american] Error
|
|||
|
||||
LIB_DEPENDS= libcurl.so:ftp/curl
|
||||
|
||||
USES= gmake pkgconfig tar:xz
|
||||
USES= gmake gnome pkgconfig tar:xz
|
||||
HAS_CONFIGURE= YES
|
||||
CONFIGURE_ARGS+= --use_gtk3=N --use_qt3=N --use_qt4=N --use_qt5=N
|
||||
USE_GNOME= gtk20
|
||||
CONFIGURE_ARGS+= --use_gtk3=N --use_qt5=N
|
||||
USE_GNOME= gtk30
|
||||
USE_XORG= x11 xtst xext
|
||||
INSTALLS_ICONS= YES
|
||||
USE_LDCONFIG= ${PREFIX}/lib/gcin
|
||||
|
@ -43,7 +43,7 @@ post-patch:
|
|||
s,%%PREFIX%%,${PREFIX},;' \
|
||||
${WRKSRC}/Makefile
|
||||
@${REINPLACE_CMD} -e 's,/usr/local,/usr,g' \
|
||||
${WRKSRC}/gtk-im/Makefile ${WRKSRC}/menu/Makefile
|
||||
${WRKSRC}/menu/Makefile
|
||||
@${REINPLACE_CMD} -e 's,modify-XIM ,,; 8,10 d' \
|
||||
${WRKSRC}/scripts/Makefile
|
||||
@${REINPLACE_CMD} -e 's,bash,sh,; s/&//; s,/opt/gnome,${LOCALBASE},;' \
|
||||
|
@ -54,8 +54,6 @@ post-patch:
|
|||
@${REINPLACE_CMD} -e 's,bash,sh,; s/&//; 12,13 s/=/ /; \
|
||||
s/export/setenv/; s/$$UTF8ED/xdg-open/' \
|
||||
${WRKSRC}/scripts/html-browser
|
||||
@${REINPLACE_CMD} -e 's,gcin-im-client.h,im-client/gcin-im-client.h,;' \
|
||||
${WRKSRC}/gtk-im/gtkimcontextgcin.c
|
||||
@${REINPLACE_CMD} -e 's,/usr/X11R6,${LOCALBASE},' \
|
||||
${WRKSRC}/IMdkit/lib/Makefile ${WRKSRC}/Makefile \
|
||||
${WRKSRC}/qt-im/Makefile ${WRKSRC}/scripts/modify-XIM \
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1545093618
|
||||
SHA256 (gcin-2.8.8.tar.xz) = 22b64d519a28ac82e662f6107dbb8c829a80b07a216a8b00e64103feacb031f3
|
||||
SIZE (gcin-2.8.8.tar.xz) = 4035876
|
||||
TIMESTAMP = 1552571155
|
||||
SHA256 (gcin-2.8.9.tar.xz) = e08426cc85c5932392ebf73ac7d140cd778862517c3ea0cf8953aaab6c14d078
|
||||
SIZE (gcin-2.8.9.tar.xz) = 4033152
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
--- Makefile.orig 2017-11-18 04:48:43 UTC
|
||||
--- Makefile.orig 2019-03-07 09:07:52 UTC
|
||||
+++ Makefile
|
||||
@@ -4,8 +4,11 @@ include config.mak
|
||||
include suffixes-rule
|
||||
|
@ -26,27 +26,28 @@
|
|||
OBJS_TSLEARN=tslearn.o util.o gcin-conf.o pho-util.o tsin-util.o gcin-send.o pho-sym.o \
|
||||
table-update.o locale.o gcin-settings.o gcin-common.o gcin-icon.o pho-dbg.o \
|
||||
pho2pinyin.o pinyin.o lang.o gtab-list.o gtab-init.o fullchar.o \
|
||||
@@ -103,7 +110,7 @@ PROGS_CV=kbmcv pin-juyin
|
||||
@@ -102,8 +109,7 @@ PROGS_CV=kbmcv pin-juyin
|
||||
|
||||
all: $(PROGS) trad2sim $(GCIN_SO) $(DATA) $(PROGS_CV) gcin.spec gcin-fedora.spec
|
||||
$(MAKE) -C data
|
||||
$(MAKE) -C gtk-im
|
||||
- $(MAKE) -C gtk-im
|
||||
- if [ $(BUILD_MODULE) = 'Y' ]; then $(MAKE) -C modules; fi
|
||||
+ $(MAKE) -C modules
|
||||
if [ $(USE_I18N) = 'Y' ]; then $(MAKE) -C po; fi
|
||||
if [ $(GTK3_IM) = 'Y' ]; then $(MAKE) -C gtk3-im; fi
|
||||
if [ $(QT_IM) = 'Y' ]; then $(MAKE) -C qt-im; fi
|
||||
@@ -113,18 +120,18 @@ all: $(PROGS) trad2sim $(GCIN_SO) $(DATA) $(PROGS_CV)
|
||||
@@ -113,18 +119,18 @@ all: $(PROGS) trad2sim $(GCIN_SO) $(DATA) $(PROGS_CV)
|
||||
#gcc_ld_run_path=-Wl,-rpath,$(gcin_ld_run_path)
|
||||
|
||||
gcin: $(OBJS) $(IMdkitLIB) $(OBJ_IMSRV)
|
||||
- $(CCLD) $(EXTRA_LDFLAGS) $(gcc_ld_run_path) -o $@ $(OBJS) $(IMdkitLIB) $(OBJ_IMSRV) -lXtst $(GCIN_LDFLAGS) -L/usr/X11R6/$(LIB)
|
||||
+ $(CCLD) $(EXTRA_LDFLAGS) $(gcc_ld_run_path) -o $@ $(OBJS) $(IMdkitLIB) $(OBJ_IMSRV) -lXtst $(GCIN_LDFLAGS) -L/usr/local/$(LIB)
|
||||
+ $(CCLD) $(EXTRA_LDFLAGS) $(gcc_ld_run_path) -o $@ $(OBJS) $(IMdkitLIB) $(OBJ_IMSRV) -lXtst $(GCIN_LDFLAGS) -L%%PREFIX%%/$(LIB)
|
||||
rm -f core.* vgcore.*
|
||||
ln -sf $@ $@.test
|
||||
|
||||
gcin-nocur: $(OBJS) $(IMdkitLIB) $(OBJ_IMSRV)
|
||||
- $(CCLD) -Wl,-rpath,$(gcinlibdir) $(EXTRA_LDFLAGS) -o $@ $(OBJS) $(IMdkitLIB) $(OBJ_IMSRV) -lXtst $(LDFLAGS) -L/usr/X11R6/$(LIB)
|
||||
+ $(CCLD) -Wl,-rpath,$(gcinlibdir) $(EXTRA_LDFLAGS) -o $@ $(OBJS) $(IMdkitLIB) $(OBJ_IMSRV) -lXtst $(LDFLAGS) -L/usr/local/$(LIB)
|
||||
+ $(CCLD) -Wl,-rpath,$(gcinlibdir) $(EXTRA_LDFLAGS) -o $@ $(OBJS) $(IMdkitLIB) $(OBJ_IMSRV) -lXtst $(LDFLAGS) -L%%PREFIX%%/$(LIB)
|
||||
rm -f core.*
|
||||
|
||||
-tslearn: $(OBJS_TSLEARN)
|
||||
|
@ -58,7 +59,7 @@
|
|||
$(CCLD) $(gcc_ld_run_path) -o $@ $(OBJS_TS_EDIT) -L./im-client -lgcin-im-client -lcurl $(LDFLAGS)
|
||||
|
||||
ts-contribute: ts-edit
|
||||
@@ -171,16 +178,16 @@ gtab-merge: $(OBJS_gtab_merge)
|
||||
@@ -171,16 +177,16 @@ gtab-merge: $(OBJS_gtab_merge)
|
||||
kbmcv: $(OBJS_kbmcv)
|
||||
$(CCLD) -o $@ $(OBJS_kbmcv) $(LDFLAGS)
|
||||
|
||||
|
@ -79,10 +80,11 @@
|
|||
$(CCLD) $(gcc_ld_run_path) -o $@ $(OBJS_gcin_message) -L./im-client -lgcin-im-client $(LDFLAGS)
|
||||
|
||||
pin-juyin: $(OBJS_pin_juyin)
|
||||
@@ -229,23 +236,19 @@ install:
|
||||
@@ -228,24 +234,19 @@ install:
|
||||
install -d $(bindir)
|
||||
$(MAKE) -C data install
|
||||
$(MAKE) -C im-client install
|
||||
$(MAKE) -C gtk-im install
|
||||
- $(MAKE) -C gtk-im install
|
||||
- if [ $(BUILD_MODULE) = 'Y' ]; then $(MAKE) -C modules install; fi
|
||||
+ $(MAKE) -C modules install
|
||||
if [ $(GTK3_IM) = 'Y' ]; then $(MAKE) -C gtk3-im install; fi
|
||||
|
@ -106,7 +108,7 @@
|
|||
install -s $(PROGS) $(bindir); \
|
||||
rm -f $(bindir)/trad2sim; ln -sf sim2trad $(bindir)/trad2sim; \
|
||||
rm -f $(bindir)/ts-contribute; ln -sf ts-edit $(bindir)/ts-contribute; \
|
||||
@@ -253,6 +256,7 @@ install:
|
||||
@@ -253,6 +254,7 @@ install:
|
||||
rm -f $(bindir)/ts-edit-en; ln -sf ts-edit $(bindir)/ts-edit-en; \
|
||||
fi
|
||||
$(MAKE) -C scripts install
|
||||
|
@ -114,7 +116,15 @@
|
|||
$(MAKE) -C menu install
|
||||
if [ $(USE_I18N) = 'Y' ]; then $(MAKE) -C po install; fi
|
||||
|
||||
@@ -286,5 +290,3 @@ gcin.spec: gcin.spec.in
|
||||
@@ -261,7 +263,6 @@ clean:
|
||||
$(MAKE) -C data clean
|
||||
$(MAKE) -C scripts clean
|
||||
$(MAKE) -C im-client clean
|
||||
- $(MAKE) -C gtk-im clean
|
||||
$(MAKE) -C modules clean
|
||||
if [ $(GTK3_IM) = 'Y' ]; then $(MAKE) -C gtk3-im clean; fi
|
||||
$(MAKE) -C qt-im clean
|
||||
@@ -286,5 +287,3 @@ gcin.spec: gcin.spec.in
|
||||
gcin-fedora.spec: gcin-fedora.spec.in VERSION.gcin
|
||||
rm -f $@
|
||||
sed -e "s/__gcin_version__/$(GCIN_VERSION)/" < $< > $@
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
--- configure.orig 2018-05-12 11:15:17 UTC
|
||||
--- configure.orig 2019-02-01 23:11:02 UTC
|
||||
+++ configure
|
||||
@@ -1,4 +1,4 @@
|
||||
-##!/bin/bash
|
||||
|
@ -47,10 +47,10 @@
|
|||
grep -v qt3/plugins/inputmethods gcin.spec.tmp > gcin.spec
|
||||
else
|
||||
- for i in /usr/share/qt/bin/moc /usr/lib/qt/bin/moc /usr/lib64/qt/bin/moc /usr/lib/qt3/bin/moc /usr/share/qt3/bin/moc /usr/lib64/qt3/bin/moc
|
||||
+ for i in $prefix/share/qt/bin/moc /usr/lib/qt/bin/moc /usr/lib64/qt/bin/moc /usr/lib/qt3/bin/moc /usr/share/qt3/bin/moc /usr/lib64/qt3/bin/moc
|
||||
+ for i in $prefix/share/qt/bin/moc /usr/lib/qt/bin/moc /usr/lib64/qt/bin/moc /usr/lib/qt3/bin/moc $prefix/share/qt3/bin/moc /usr/lib64/qt3/bin/moc
|
||||
do
|
||||
- [ ! -x $i ] && continue
|
||||
+ [ ! -x $i ] & continue
|
||||
+ [ ! -x $i ] continue
|
||||
QT_MOC=$i
|
||||
echo "QT_MOC=$QT_MOC"
|
||||
break;
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
--- gcb.cpp.orig 2015-11-22 23:15:12 UTC
|
||||
--- gcb.cpp.orig 2019-03-06 00:33:25 UTC
|
||||
+++ gcb.cpp
|
||||
@@ -1,3 +1,4 @@
|
||||
+#if USE_GCB
|
||||
|
@ -13,9 +13,12 @@
|
|||
static GtkWidget *mainwin;
|
||||
static GtkClipboard *pclipboard_clipboard, *pclipboard_primary;
|
||||
static GtkWidget **buttonArr;
|
||||
@@ -529,4 +531,4 @@ void free_gcb() {
|
||||
g_free(buttonStr); buttonStr = NULL;
|
||||
@@ -256,7 +258,7 @@ static void get_mouse_button( GtkWidget *widget,GdkEve
|
||||
|
||||
}
|
||||
}
|
||||
-
|
||||
+#endif
|
||||
static void hist_get_mouse_button( GtkWidget *widget,GdkEventButton *event, gpointer data)
|
||||
{
|
||||
int i;
|
||||
|
|
14
chinese/gcin/files/patch-im-client_Makefile
Normal file
14
chinese/gcin/files/patch-im-client_Makefile
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- im-client/Makefile.orig 2011-12-17 06:16:17 UTC
|
||||
+++ im-client/Makefile
|
||||
@@ -20,10 +20,9 @@ OBJS = gcin-im-client.o im-addr.o gcin-conf.o util.o g
|
||||
$(CC) -x c -c $(CFLAGS) $<
|
||||
|
||||
$(SOFILEVER): $(OBJS)
|
||||
- $(CC) $(SO_FLAGS) -Wl,-soname,libgcin-im-client.so.1 $(OBJS) -lX11 -o $@ -L/usr/X11R6/lib
|
||||
+ $(CC) $(SO_FLAGS) -Wl,-soname,libgcin-im-client.so.1 $(OBJS) -lX11 -o $@ -L/usr/local/lib
|
||||
ln -sf $(SOFILEVER) $(SOFILE)
|
||||
ln -sf $(SOFILEVER) $(SOFILE).1
|
||||
- $(MAKE) -C ../gtk-im
|
||||
|
||||
LOCALLIB=/usr/local/$(LIB)
|
||||
|
|
@ -2,7 +2,7 @@
|
|||
Remember to set these environment varibles (such as your ~/.xinitrc):
|
||||
|
||||
export XMODIFIERS='@im=gcin'
|
||||
export GTK_IM_MODULE=xim
|
||||
export GTK_IM_MODULE=gcin
|
||||
|
||||
# Finally, to start the GCIN input method daemon, use command:
|
||||
exec gcin &
|
||||
|
|
|
@ -28,7 +28,6 @@ lib/gcin/intcode-module.so
|
|||
lib/gcin/libgcin-im-client.so
|
||||
lib/gcin/libgcin-im-client.so.1
|
||||
lib/gcin/libgcin-im-client.so.1.2.5
|
||||
lib/gtk-2.0/immodules/im-gcin.so
|
||||
man/man1/gcin-exit.1.gz
|
||||
man/man1/gcin-gb-toggle.1.gz
|
||||
man/man1/gcin-kbm-toggle.1.gz
|
||||
|
@ -167,5 +166,3 @@ share/icons/gcin/vocabulary.png
|
|||
share/icons/gcin/wm2.png
|
||||
share/icons/gcin/wubi.png
|
||||
share/icons/hicolor/64x64/apps/gcin.png
|
||||
@postexec %%LOCALBASE%%/bin/gtk-query-immodules-2.0 --update-cache
|
||||
@postunexec %%LOCALBASE%%/bin/gtk-query-immodules-2.0 --update-cache
|
||||
|
|
Loading…
Reference in a new issue