Unbroke - new gcc now doesn't accept unterminated milti-line strings.
This commit is contained in:
parent
8d03d4678e
commit
7e9c9e9a3b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=91451
3 changed files with 26 additions and 8 deletions
|
@ -21,10 +21,6 @@ MAN8= l2tpd.8
|
|||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} >= 501000
|
||||
BROKEN= "Does not compile"
|
||||
.endif
|
||||
|
||||
do-configure:
|
||||
${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/doc/l2tpd.8 \
|
||||
${WRKSRC}/doc/l2tpd.conf.sample ${WRKSRC}/doc/l2tp-secrets.5 \
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- call.c 2002/10/22 09:41:27 1.1
|
||||
+++ call.c 2002/10/22 09:43:13
|
||||
@@ -13,9 +13,6 @@
|
||||
--- call.c.orig Sat Aug 10 03:47:25 2002
|
||||
+++ call.c Thu Oct 16 23:13:51 2003
|
||||
@@ -14,9 +14,6 @@
|
||||
|
||||
#include <stdio.h>
|
||||
#include <fcntl.h>
|
||||
|
@ -13,3 +13,14 @@ $FreeBSD$
|
|||
#include <sys/wait.h>
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
@@ -193,8 +190,8 @@
|
||||
}
|
||||
}
|
||||
/* I should never get here */
|
||||
- log (LOG_WARN, "%s: You should not see this message. If you do, please
|
||||
- enter a bug report at http://sourceforge.net/projects/l2tpd", __FUNCTION__);
|
||||
+ log (LOG_WARN, "%s: You should not see this message. If you do, please "
|
||||
+ "enter a bug report at http://sourceforge.net/projects/l2tpd", __FUNCTION__);
|
||||
return -EINVAL;
|
||||
}
|
||||
|
||||
|
|
|
@ -2,7 +2,7 @@
|
|||
$FreeBSD$
|
||||
|
||||
--- network.c.orig Wed Apr 10 23:09:33 2002
|
||||
+++ network.c Wed Apr 16 16:07:19 2003
|
||||
+++ network.c Thu Oct 16 23:14:23 2003
|
||||
@@ -14,9 +14,6 @@
|
||||
#include <stdio.h>
|
||||
#include <errno.h>
|
||||
|
@ -30,3 +30,14 @@ $FreeBSD$
|
|||
server.sin_port = htons (gconfig.port);
|
||||
if ((server_socket = socket (PF_INET, SOCK_DGRAM, 0)) < 0)
|
||||
{
|
||||
@@ -364,8 +360,8 @@
|
||||
extract (buf->start, &tunnel, &call);
|
||||
if (debug_network)
|
||||
{
|
||||
- log (LOG_DEBUG, "%s: recv packet from %s, size = %d,
|
||||
-tunnel = %d, call = %d\n", __FUNCTION__, inet_ntoa (from.sin_addr), recvsize, tunnel, call);
|
||||
+ log (LOG_DEBUG, "%s: recv packet from %s, size = %d, "
|
||||
+"tunnel = %d, call = %d\n", __FUNCTION__, inet_ntoa (from.sin_addr), recvsize, tunnel, call);
|
||||
}
|
||||
if (packet_dump)
|
||||
{
|
||||
|
|
Loading…
Reference in a new issue