MindGuard protects your mind by jamming and/or scrambling psychotronic
mind-control signals and removing harmful engrammic pollutants from your brain. It also has the ability to scan for and decipher into English specific signals so you can see exactly Who wants to control you and what They are trying to make you think. With MindGuard, you can rest assured that your most valuable possession - your mind - is safe from the nefarious tinkering of evil-doers. This port is cleverly hidden in the games category rather than sysutils where it belongs, so the forces of evil are less likely to find it.
This commit is contained in:
parent
c043b3cdf7
commit
7e9ef3a2de
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=31075
8 changed files with 154 additions and 0 deletions
|
@ -104,6 +104,7 @@
|
|||
SUBDIR += mangband
|
||||
SUBDIR += merlin
|
||||
SUBDIR += mindfocus
|
||||
SUBDIR += mindguard
|
||||
SUBDIR += mirrormagic
|
||||
SUBDIR += miscom
|
||||
SUBDIR += nethack
|
||||
|
|
48
games/mindguard/Makefile
Normal file
48
games/mindguard/Makefile
Normal file
|
@ -0,0 +1,48 @@
|
|||
# New ports collection makefile for: mindguard
|
||||
# Date created: 27 July 2000
|
||||
# Whom: kris
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= mindguard
|
||||
PORTVERSION= 0.0.0.2
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= http://zapatopi.net/mindguard/
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= kris@FreeBSD.org
|
||||
|
||||
LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
|
||||
ALL_TARGET= # empty
|
||||
|
||||
CARRIERS= antarctic.carrier belgian.carrier beta.carrier \
|
||||
brother.carrier kpsi.carrier liberati.carrier \
|
||||
reticulian.carrier russel.carrier tz8.carrier \
|
||||
unmetric.carrier
|
||||
|
||||
DOCS= index.html mg01.html mg02.html mg03.html mg04.html \
|
||||
mg05.html mg06.html mg07.html mg08.html mg09.html \
|
||||
mg10.html mg11.html mg12.html mg13.html mg14.html \
|
||||
mg15.html mg16.html mg17.html mg18.html mg19.html \
|
||||
mg20.html mg21.html mg22.html mg23.html mg30.html \
|
||||
mg31.html mg32.html mg33.html mg40.html mg41.html \
|
||||
mg42.html mg43.html mg44.html mg45.html mg46.html \
|
||||
mg47.html mg48.html mg60.html mgjamtab.png \
|
||||
mglogtab.png mgmisctab.png mgpsid.png mgwin.png \
|
||||
style.css
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/mindguard ${X11BASE}/bin/mindguard
|
||||
${MKDIR} ${X11BASE}/share/mindguard
|
||||
.for i in ${CARRIERS}
|
||||
${INSTALL_DATA} ${WRKSRC}/carriers/$i ${X11BASE}/share/mindguard
|
||||
.endfor
|
||||
${MKDIR} ${X11BASE}/share/doc/mindguard
|
||||
.for i in ${DOCS}
|
||||
${INSTALL_DATA} ${WRKSRC}/docs/$i ${X11BASE}/share/doc/mindguard
|
||||
.endfor
|
||||
.include <bsd.port.mk>
|
1
games/mindguard/distinfo
Normal file
1
games/mindguard/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (mindguard-0.0.0.2.tgz) = 0f73eec197bfa8143fdd68d2da6847be
|
15
games/mindguard/files/patch-aa
Normal file
15
games/mindguard/files/patch-aa
Normal file
|
@ -0,0 +1,15 @@
|
|||
--- Makefile.orig Sun May 21 23:03:01 2000
|
||||
+++ Makefile Thu Jul 27 23:41:05 2000
|
||||
@@ -1,9 +1,10 @@
|
||||
BINDIR = /usr/local/bin
|
||||
MGDIR = /usr/local/share/MindGuard
|
||||
-CC = gcc
|
||||
+CC ?= gcc
|
||||
+CFLAGS ?= -O -pipe
|
||||
|
||||
mindguard: mindguard.c
|
||||
- $(CC) `gtk-config --cflags` mindguard.c -o mindguard `gtk-config --libs`
|
||||
+ $(CC) -DX11BASE=\"${X11BASE}\" `${X11BASE}/bin/gtk12-config --cflags` ${CFLAGS} mindguard.c -o mindguard `${X11BASE}/bin/gtk12-config --libs`
|
||||
|
||||
clean:
|
||||
rm -f mindguard
|
20
games/mindguard/files/patch-ab
Normal file
20
games/mindguard/files/patch-ab
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- mindguard.c.orig Sun May 21 23:03:01 2000
|
||||
+++ mindguard.c Fri Jul 28 00:01:43 2000
|
||||
@@ -356,7 +356,7 @@
|
||||
sprintf(car_path, "%s/MindGuard/carriers/", getenv("HOME"));
|
||||
break;
|
||||
case 2:
|
||||
- strcpy(car_path, "/usr/local/share/MindGuard/carriers/");
|
||||
+ strcpy(car_path, X11BASE "/share/mindguard/");
|
||||
break;
|
||||
default:
|
||||
break;
|
||||
@@ -424,7 +424,7 @@
|
||||
{
|
||||
int result = FALSE, len;
|
||||
static int i;
|
||||
- char word[4];
|
||||
+ char word[5];
|
||||
FILE *file;
|
||||
|
||||
if ((file = fopen (path, "r")) != NULL)
|
1
games/mindguard/pkg-comment
Normal file
1
games/mindguard/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
Helpful utility for detecting and jamming harmful mind-control rays
|
11
games/mindguard/pkg-descr
Normal file
11
games/mindguard/pkg-descr
Normal file
|
@ -0,0 +1,11 @@
|
|||
MindGuard protects your mind by jamming and/or scrambling psychotronic
|
||||
mind-control signals and removing harmful engrammic pollutants from
|
||||
your brain. It also has the ability to scan for and decipher into
|
||||
English specific signals so you can see exactly Who wants to control
|
||||
you and what They are trying to make you think.
|
||||
|
||||
With MindGuard, you can rest assured that your most valuable
|
||||
possession - your mind - is safe from the nefarious tinkering of
|
||||
evil-doers.
|
||||
|
||||
WWW: http://zapatopi.net/mindguard.html
|
57
games/mindguard/pkg-plist
Normal file
57
games/mindguard/pkg-plist
Normal file
|
@ -0,0 +1,57 @@
|
|||
bin/mindguard
|
||||
share/mindguard/belgian.carrier
|
||||
share/mindguard/beta.carrier
|
||||
share/mindguard/brother.carrier
|
||||
share/mindguard/kpsi.carrier
|
||||
share/mindguard/liberati.carrier
|
||||
share/mindguard/reticulian.carrier
|
||||
share/mindguard/russel.carrier
|
||||
share/mindguard/tz8.carrier
|
||||
share/mindguard/unmetric.carrier
|
||||
share/mindguard/antarctic.carrier
|
||||
share/doc/mindguard/index.html
|
||||
share/doc/mindguard/mg01.html
|
||||
share/doc/mindguard/mg02.html
|
||||
share/doc/mindguard/mg03.html
|
||||
share/doc/mindguard/mg04.html
|
||||
share/doc/mindguard/mg05.html
|
||||
share/doc/mindguard/mg06.html
|
||||
share/doc/mindguard/mg07.html
|
||||
share/doc/mindguard/mg08.html
|
||||
share/doc/mindguard/mg09.html
|
||||
share/doc/mindguard/mg10.html
|
||||
share/doc/mindguard/mg11.html
|
||||
share/doc/mindguard/mg12.html
|
||||
share/doc/mindguard/mg13.html
|
||||
share/doc/mindguard/mg14.html
|
||||
share/doc/mindguard/mg15.html
|
||||
share/doc/mindguard/mg16.html
|
||||
share/doc/mindguard/mg17.html
|
||||
share/doc/mindguard/mg18.html
|
||||
share/doc/mindguard/mg19.html
|
||||
share/doc/mindguard/mg20.html
|
||||
share/doc/mindguard/mg21.html
|
||||
share/doc/mindguard/mg22.html
|
||||
share/doc/mindguard/mg23.html
|
||||
share/doc/mindguard/mg30.html
|
||||
share/doc/mindguard/mg31.html
|
||||
share/doc/mindguard/mg32.html
|
||||
share/doc/mindguard/mg33.html
|
||||
share/doc/mindguard/mg40.html
|
||||
share/doc/mindguard/mg41.html
|
||||
share/doc/mindguard/mg42.html
|
||||
share/doc/mindguard/mg43.html
|
||||
share/doc/mindguard/mg44.html
|
||||
share/doc/mindguard/mg45.html
|
||||
share/doc/mindguard/mg46.html
|
||||
share/doc/mindguard/mg47.html
|
||||
share/doc/mindguard/mg48.html
|
||||
share/doc/mindguard/mg60.html
|
||||
share/doc/mindguard/mgjamtab.png
|
||||
share/doc/mindguard/mglogtab.png
|
||||
share/doc/mindguard/mgmisctab.png
|
||||
share/doc/mindguard/mgpsid.png
|
||||
share/doc/mindguard/mgwin.png
|
||||
share/doc/mindguard/style.css
|
||||
@dirrm share/doc/mindguard
|
||||
@dirrm share/mindguard
|
Loading…
Reference in a new issue