Fix pkg-plist, set NOT_FOR_ARCHS to amd64.
PR: ports/95479 Submitted by: Jimmy F.Klarke <iss.jfk@gmail.dot.com>
This commit is contained in:
parent
426445a69c
commit
7ebe8d6d9c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=164270
3 changed files with 6 additions and 8 deletions
|
@ -13,15 +13,15 @@ DISTNAME= 3.0-RELEASE
|
|||
MAINTAINER= edwardchuang@gmail.com
|
||||
COMMENT= A Common BBS Server with its own customized INN News Server
|
||||
|
||||
BROKEN= Incomplete pkg-plist
|
||||
|
||||
WRKSRC= ${WRKDIR}/bbs/bbssrc
|
||||
GNU_CONFIGURE= yes
|
||||
USE_BZIP2= yes
|
||||
IS_INTERACTIVE= yes
|
||||
NOT_FOR_ARCHS= amd64
|
||||
|
||||
pre-install:
|
||||
${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
|
||||
${FIND} ${WRKSRC} -name "*.orig" -delete
|
||||
|
||||
post-install:
|
||||
@if [ ! -f ${PREFIX}/etc/rc.d/bbs.sh.example ]; then \
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- src/screen.c.orig Sat Jan 15 09:45:29 2000
|
||||
+++ src/screen.c Tue Mar 8 03:06:59 2005
|
||||
+++ src/screen.c Sat Jun 3 17:58:30 2006
|
||||
@@ -27,7 +27,7 @@
|
||||
#include "screen.h"
|
||||
#include "edit.h"
|
||||
|
@ -9,7 +9,7 @@
|
|||
|
||||
extern char clearbuf[];
|
||||
extern char cleolbuf[];
|
||||
@@ -538,14 +538,13 @@
|
||||
@@ -538,15 +538,12 @@
|
||||
int dec[] = {1000000000, 100000000, 10000000, 1000000, 100000, 10000, 1000, 100, 10, 1};
|
||||
|
||||
void
|
||||
|
@ -19,11 +19,11 @@
|
|||
{
|
||||
va_list ap;
|
||||
- register char *fmt;
|
||||
+ register char;
|
||||
char *bp;
|
||||
register int i, count, hd, indx;
|
||||
- va_start(ap);
|
||||
- fmt = va_arg(ap, char *);
|
||||
+ va_start(ap, fmt);
|
||||
fmt = va_arg(ap, char *);
|
||||
while (*fmt != '\0') {
|
||||
if (*fmt == '%') {
|
||||
int sgn = 1;
|
||||
|
|
|
@ -111,7 +111,6 @@ bbs/bbssrc/src/userinfo.c
|
|||
bbs/bbssrc/src/ver.sh
|
||||
bbs/bbssrc/src/vote.c
|
||||
bbs/bbssrc/src/xyz.c
|
||||
bbs/bbssrc/src/Install.sh.in.orig
|
||||
bbs/bbssrc/src/Install.sh
|
||||
bbs/bbssrc/src/bbsd
|
||||
bbs/bbssrc/src/chatd
|
||||
|
@ -369,7 +368,6 @@ bbs/bbssrc/config.sub
|
|||
bbs/bbssrc/configure
|
||||
bbs/bbssrc/configure.in
|
||||
bbs/bbssrc/install.sh
|
||||
bbs/bbssrc/configure.orig
|
||||
bbs/bbssrc/configure.inf
|
||||
bbs/bbssrc/Makefile
|
||||
bbs/bbssrc/.reldate
|
||||
|
|
Loading…
Reference in a new issue