Add port graphics/libvisual04:
Libvisual is an abstraction library that sits between apps and visual plugin. This is a new (0.4.0) version of graphics/libvisual. They can coexist safely on one system.
This commit is contained in:
parent
f64eca9ca0
commit
7eda4e5d57
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=180703
6 changed files with 74 additions and 75 deletions
|
@ -376,6 +376,7 @@
|
|||
SUBDIR += libv3d
|
||||
SUBDIR += libvisual
|
||||
SUBDIR += libvisual-plugins
|
||||
SUBDIR += libvisual04
|
||||
SUBDIR += libwmf
|
||||
SUBDIR += libwpcg
|
||||
SUBDIR += libx3dtk
|
||||
|
|
|
@ -5,36 +5,29 @@
|
|||
# $FreeBSD$
|
||||
#
|
||||
|
||||
# WARNING: when updating this port check if the ports that use libvisual
|
||||
# can work with it. Backwards compatiblity is known to be broken in the past.
|
||||
|
||||
PORTNAME= libvisual
|
||||
PORTVERSION= 0.2.0
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 0.4.0
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
MASTER_SITES= SF
|
||||
PKGNAMESUFFIX= 04
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
MAINTAINER= infofarmer@FreeBSD.org
|
||||
COMMENT= Abstraction library that sits between apps and visual plugin
|
||||
|
||||
USE_XLIBS= yes
|
||||
USE_GNOME= gnomehack pkgconfig
|
||||
USE_AUTOTOOLS= libtool:15
|
||||
CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}" \
|
||||
LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}"
|
||||
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
||||
USE_GETTEXT= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
|
||||
LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
|
||||
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} < 500001
|
||||
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-libvisual_lv_cpu.c
|
||||
.endif
|
||||
PLIST_SUB= VER=-0.4
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|-Wno-unused-variable||g' \
|
||||
-e 's|-O3|${CFLAGS}|g' \
|
||||
@${REINPLACE_CMD} -e 's|-Wno-unused-variable||g;s|-O3|${CFLAGS}|g' \
|
||||
${WRKSRC}/libvisual/Makefile.in
|
||||
@${REINPLACE_CMD} -e 's|sys/sched.h||g' -e '/test.*==/s|==|=|g' ${WRKSRC}/configure
|
||||
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e 's|$$<|$${.ALLSRC}|g'
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (libvisual-0.2.0.tar.gz) = 668236dcbd252c70f1beff551f36b8b3
|
||||
SHA256 (libvisual-0.2.0.tar.gz) = a440254208bd4bd13e0e77789ff5fc07cd64f4c9022ff43c6c64ec29a2aa03aa
|
||||
SIZE (libvisual-0.2.0.tar.gz) = 431141
|
||||
MD5 (libvisual-0.4.0.tar.gz) = f4e78547c79ea8a8ad111cf8b85011bb
|
||||
SHA256 (libvisual-0.4.0.tar.gz) = 0b4dfdb87125e129567752089e3c8b54cefed601eef169d2533d8659da8dc1d7
|
||||
SIZE (libvisual-0.4.0.tar.gz) = 583386
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
--- libvisual/lv_cpu.c.orig Sun Mar 20 20:17:51 2005
|
||||
+++ libvisual/lv_cpu.c Sun Mar 20 20:18:19 2005
|
||||
@@ -65,6 +65,9 @@
|
||||
#include "lv_log.h"
|
||||
#include "lv_cpu.h"
|
||||
|
||||
+/* stolen from 5.3-stable's unistd.h */
|
||||
+#define _SC_NPROCESSORS_ONLN 58
|
||||
+
|
||||
static VisCPU _lv_cpu_caps;
|
||||
static int _lv_cpu_initialized = FALSE;
|
||||
|
|
@ -13,4 +13,4 @@ wants.
|
|||
The framework also allows you to morph to different plugins and mix two at
|
||||
once; all kinds of neat tricks are possible using this method.
|
||||
|
||||
WWW: http://libvisual.sourceforge.net
|
||||
WWW: http://libvisual.sourceforge.net/
|
||||
|
|
|
@ -1,38 +1,55 @@
|
|||
include/libvisual/libvisual.h
|
||||
include/libvisual/lv_actor.h
|
||||
include/libvisual/lv_audio.h
|
||||
include/libvisual/lv_bin.h
|
||||
include/libvisual/lv_bmp.h
|
||||
include/libvisual/lv_color.h
|
||||
include/libvisual/lv_common.h
|
||||
include/libvisual/lv_cpu.h
|
||||
include/libvisual/lv_endianess.h
|
||||
include/libvisual/lv_error.h
|
||||
include/libvisual/lv_event.h
|
||||
include/libvisual/lv_fft.h
|
||||
include/libvisual/lv_input.h
|
||||
include/libvisual/lv_keysym.h
|
||||
include/libvisual/lv_libvisual.h
|
||||
include/libvisual/lv_list.h
|
||||
include/libvisual/lv_log.h
|
||||
include/libvisual/lv_mem.h
|
||||
include/libvisual/lv_morph.h
|
||||
include/libvisual/lv_object.h
|
||||
include/libvisual/lv_palette.h
|
||||
include/libvisual/lv_param.h
|
||||
include/libvisual/lv_plugin.h
|
||||
include/libvisual/lv_random.h
|
||||
include/libvisual/lv_songinfo.h
|
||||
include/libvisual/lv_thread.h
|
||||
include/libvisual/lv_time.h
|
||||
include/libvisual/lv_transform.h
|
||||
include/libvisual/lv_types.h
|
||||
include/libvisual/lv_ui.h
|
||||
include/libvisual/lv_video.h
|
||||
include/libvisual/lvconfig.h
|
||||
lib/libvisual.a
|
||||
lib/libvisual.la
|
||||
lib/libvisual.so
|
||||
lib/libvisual.so.0
|
||||
libdata/pkgconfig/libvisual.pc
|
||||
@dirrm include/libvisual
|
||||
include/libvisual%%VER%%/libvisual/libvisual.h
|
||||
include/libvisual%%VER%%/libvisual/lv_actor.h
|
||||
include/libvisual%%VER%%/libvisual/lv_audio.h
|
||||
include/libvisual%%VER%%/libvisual/lv_bin.h
|
||||
include/libvisual%%VER%%/libvisual/lv_bits.h
|
||||
include/libvisual%%VER%%/libvisual/lv_bmp.h
|
||||
include/libvisual%%VER%%/libvisual/lv_buffer.h
|
||||
include/libvisual%%VER%%/libvisual/lv_cache.h
|
||||
include/libvisual%%VER%%/libvisual/lv_collection.h
|
||||
include/libvisual%%VER%%/libvisual/lv_color.h
|
||||
include/libvisual%%VER%%/libvisual/lv_common.h
|
||||
include/libvisual%%VER%%/libvisual/lv_config.h
|
||||
include/libvisual%%VER%%/libvisual/lv_cpu.h
|
||||
include/libvisual%%VER%%/libvisual/lv_defines.h
|
||||
include/libvisual%%VER%%/libvisual/lv_error.h
|
||||
include/libvisual%%VER%%/libvisual/lv_event.h
|
||||
include/libvisual%%VER%%/libvisual/lv_fourier.h
|
||||
include/libvisual%%VER%%/libvisual/lv_gl.h
|
||||
include/libvisual%%VER%%/libvisual/lv_hashlist.h
|
||||
include/libvisual%%VER%%/libvisual/lv_hashmap.h
|
||||
include/libvisual%%VER%%/libvisual/lv_input.h
|
||||
include/libvisual%%VER%%/libvisual/lv_keysym.h
|
||||
include/libvisual%%VER%%/libvisual/lv_libvisual.h
|
||||
include/libvisual%%VER%%/libvisual/lv_list.h
|
||||
include/libvisual%%VER%%/libvisual/lv_log.h
|
||||
include/libvisual%%VER%%/libvisual/lv_math.h
|
||||
include/libvisual%%VER%%/libvisual/lv_mem.h
|
||||
include/libvisual%%VER%%/libvisual/lv_morph.h
|
||||
include/libvisual%%VER%%/libvisual/lv_object.h
|
||||
include/libvisual%%VER%%/libvisual/lv_os.h
|
||||
include/libvisual%%VER%%/libvisual/lv_palette.h
|
||||
include/libvisual%%VER%%/libvisual/lv_param.h
|
||||
include/libvisual%%VER%%/libvisual/lv_plugin.h
|
||||
include/libvisual%%VER%%/libvisual/lv_random.h
|
||||
include/libvisual%%VER%%/libvisual/lv_rectangle.h
|
||||
include/libvisual%%VER%%/libvisual/lv_ringbuffer.h
|
||||
include/libvisual%%VER%%/libvisual/lv_songinfo.h
|
||||
include/libvisual%%VER%%/libvisual/lv_thread.h
|
||||
include/libvisual%%VER%%/libvisual/lv_time.h
|
||||
include/libvisual%%VER%%/libvisual/lv_transform.h
|
||||
include/libvisual%%VER%%/libvisual/lv_types.h
|
||||
include/libvisual%%VER%%/libvisual/lv_ui.h
|
||||
include/libvisual%%VER%%/libvisual/lv_utils.h
|
||||
include/libvisual%%VER%%/libvisual/lv_video.h
|
||||
include/libvisual%%VER%%/libvisual/lvconfig.h
|
||||
lib/libvisual%%VER%%.la
|
||||
lib/libvisual%%VER%%.so
|
||||
lib/libvisual%%VER%%.so.0
|
||||
libdata/pkgconfig/libvisual%%VER%%.pc
|
||||
share/locale/es_AR/LC_MESSAGES/libvisual%%VER%%.mo
|
||||
share/locale/es_ES/LC_MESSAGES/libvisual%%VER%%.mo
|
||||
@dirrmtry share/locale/es_AR/LC_MESSAGES
|
||||
@dirrmtry share/locale/es_AR
|
||||
@dirrm include/libvisual%%VER%%/libvisual
|
||||
@dirrm include/libvisual%%VER%%
|
||||
|
|
Loading…
Reference in a new issue