Update system-config-printer to 1.4.7.
Restrict to python 2. Add PORTSCOUT to ignore the 1.5 series for now, which are for python 3.
This commit is contained in:
parent
b2e21bc198
commit
7ee16b703b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=378775
4 changed files with 22 additions and 19 deletions
|
@ -1,10 +1,8 @@
|
|||
# Created by: Michael Johnson <ahze@FreeBSD.org>
|
||||
# $FreeBSD$
|
||||
# $MCom: ports/print/system-config-printer/Makefile,v 1.6 2009/12/29 16:03:58 ahze Exp $
|
||||
|
||||
PORTNAME= system-config-printer
|
||||
PORTVERSION= 1.4.2
|
||||
PORTREVISION= 3
|
||||
PORTVERSION= 1.4.7
|
||||
CATEGORIES= print gnome
|
||||
MASTER_SITES= http://cyberelk.net/tim/data/${PORTNAME}/${PORTVERSION:R}/
|
||||
|
||||
|
@ -18,8 +16,11 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/cups.so:${PORTSDIR}/print/py-cups \
|
|||
${PYTHON_SITELIBDIR}/pycurl.so:${PORTSDIR}/ftp/py-curl \
|
||||
${LOCALBASE}/libexec/cups-pk-helper-mechanism:${PORTSDIR}/print/cups-pk-helper
|
||||
|
||||
# 1.5 series is python3 ignore them for now.
|
||||
PORTSCOUT= limitw:1,even
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USES= desktop-file-utils gettext gmake pathfix pkgconfig python \
|
||||
USES= desktop-file-utils gettext gmake pathfix pkgconfig python:2 \
|
||||
shebangfix tar:xz
|
||||
CPPFLAGS+= -I${LOCALBASE}/include
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (system-config-printer-1.4.2.tar.xz) = f0e464435532f73cf8c328ceb1220f02ab2acfc1dcdec729cf5a0acf4193dbea
|
||||
SIZE (system-config-printer-1.4.2.tar.xz) = 888848
|
||||
SHA256 (system-config-printer-1.4.7.tar.xz) = 6a20074c809109ce0208aa431590cac318edd13ebd96feac08ad2942105c8926
|
||||
SIZE (system-config-printer-1.4.7.tar.xz) = 901920
|
||||
|
|
|
@ -1,15 +1,15 @@
|
|||
--- newprinter.py.orig 2013-08-29 15:46:51.000000000 +0200
|
||||
+++ newprinter.py 2013-08-29 15:48:44.000000000 +0200
|
||||
@@ -1038,7 +1038,7 @@
|
||||
# Does the backend need to be installed?
|
||||
if ((self._host == 'localhost' or
|
||||
self._host[0] == '/') and
|
||||
- not os.access ("/usr/lib/cups/backend/smb", os.F_OK)):
|
||||
+ not os.access ("%%PREFIX%%/libexec/cups/backend/smb", os.F_OK)):
|
||||
p = subprocess.Popen (["gpk-install-package-name",
|
||||
"samba-client"],
|
||||
close_fds=True,
|
||||
@@ -1844,7 +1844,7 @@
|
||||
--- newprinter.py.orig 2015-01-13 11:56:34.450684352 +0100
|
||||
+++ newprinter.py 2015-01-13 11:57:28.467679877 +0100
|
||||
@@ -1067,7 +1067,7 @@
|
||||
|
||||
(self._host == 'localhost' or
|
||||
self._host[0] == '/') and
|
||||
- not os.access ("/usr/lib/cups/backend/smb", os.F_OK)):
|
||||
+ not os.access ("%%PREFIX%%/libexec/cups/backend/smb", os.F_OK)):
|
||||
debugprint ("No smb backend so attempting install")
|
||||
try:
|
||||
pk = installpackage.PackageKit ()
|
||||
@@ -1909,7 +1909,7 @@
|
||||
host = device.uri[s:s+e]
|
||||
# Try to get make and model via SNMP
|
||||
if host:
|
||||
|
@ -18,7 +18,7 @@
|
|||
debugprint (host + ": " + repr(args))
|
||||
stdout = None
|
||||
try:
|
||||
@@ -3799,7 +3799,7 @@
|
||||
@@ -3842,7 +3842,7 @@
|
||||
try:
|
||||
# We want this to be in the current natural language,
|
||||
# so we intentionally don't set LC_ALL=C here.
|
||||
|
|
|
@ -30,6 +30,7 @@ etc/xdg/autostart/print-applet.desktop
|
|||
%%PYTHON_SITELIBDIR%%/cupshelpers/xmldriverprefs.pyo
|
||||
man/man1/system-config-printer-applet.1.gz
|
||||
man/man1/system-config-printer.1.gz
|
||||
share/appdata/system-config-printer.appdata.xml
|
||||
share/applications/system-config-printer.desktop
|
||||
share/dbus-1/interfaces/org.fedoraproject.Config.Printing.xml
|
||||
share/dbus-1/services/org.fedoraproject.Config.Printing.service
|
||||
|
@ -99,6 +100,7 @@ share/locale/vi/LC_MESSAGES/system-config-printer.mo
|
|||
share/locale/zh_CN/LC_MESSAGES/system-config-printer.mo
|
||||
share/locale/zh_TW/LC_MESSAGES/system-config-printer.mo
|
||||
share/system-config-printer/HIG.py
|
||||
share/system-config-printer/OpenPrintingRequest.py
|
||||
share/system-config-printer/PhysicalDevice.py
|
||||
share/system-config-printer/SearchCriterion.py
|
||||
share/system-config-printer/ToolbarSearchEntry.py
|
||||
|
|
Loading…
Reference in a new issue