* Update to 0.5.9 [1]

* Fix build when WITHOUT_NLS is defined [2]

PR:             144719
Submitted by:   Sunpoet Po-Chuan Hsieh <sunpoet@sunpoet.net> [1], maintainer [2]
Approved by:    maintainer
This commit is contained in:
Vsevolod Stakhov 2010-04-22 15:12:55 +00:00
parent c71081c3b3
commit 7ee2621d88
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=253059
3 changed files with 68 additions and 6 deletions

View file

@ -6,7 +6,7 @@
#
PORTNAME= mp3splt
PORTVERSION= 2.2.7a
PORTVERSION= 2.2.8
CATEGORIES= audio
MASTER_SITES= SF
@ -26,7 +26,8 @@ OPTIONS= NLS "Native language support" on
MAN1= oggsplt.1 mp3splt.1
PLIST_FILES= bin/mp3splt bin/oggsplt
post-install:
.include <bsd.port.pre.mk>
.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+= --disable-nls
.else
@ -37,4 +38,4 @@ PLIST_FILES+= share/locale/${language}/LC_MESSAGES/mp3splt.mo
.endfor
.endif
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View file

@ -1,3 +1,3 @@
MD5 (mp3splt-2.2.7a.tar.gz) = 7e782063ccb16f05a714be7d6f342cac
SHA256 (mp3splt-2.2.7a.tar.gz) = a18705093d1766f9d2680fd71aac01b659af01472fbbc78dcb188f8328148725
SIZE (mp3splt-2.2.7a.tar.gz) = 216521
MD5 (mp3splt-2.2.8.tar.gz) = 2e6f53d6385912c7e8395813048cd28c
SHA256 (mp3splt-2.2.8.tar.gz) = e5581d953fad596cb6fb22f220414e8aa69cb5324aa123a6b7b9b7a2142225d8
SIZE (mp3splt-2.2.8.tar.gz) = 218621

View file

@ -0,0 +1,61 @@
--- src/mp3splt.c.orig 2010-04-22 14:06:08.000000000 +0400
+++ src/mp3splt.c 2010-04-22 14:16:50.000000000 +0400
@@ -30,7 +30,6 @@
#include <ctype.h>
#include <getopt.h>
#include <locale.h>
-#include <libintl.h>
#ifdef __WIN32__
#include <windows.h>
@@ -46,6 +45,10 @@
#define PACKAGE_NAME "mp3splt"
#endif
+#ifdef ENABLE_NLS
+#include <libintl.h>
+#endif
+
#define MP3SPLT_DATE "17/02/10"
#define MP3SPLT_AUTHOR1 "Matteo Trotta"
#define MP3SPLT_AUTHOR2 "Alexandru Munteanu"
@@ -54,7 +57,11 @@
#define MP3SPLT_CDDBFILE "query.cddb"
#define MP3SPLT_GETTEXT_DOMAIN "mp3splt"
+#ifdef ENABLE_NLS
#define _(STR) gettext(STR)
+#else
+#define _(STR) STR
+#endif
//in case of STDIN/STDOUT usage, we change the console file handle
//-yeah indeed, global variables might suck
@@ -1801,9 +1808,11 @@ split:
//main program starts here
int main(int argc, char **orig_argv)
{
+#ifdef ENABLE_NLS
//gettext
setlocale(LC_ALL, "");
textdomain(MP3SPLT_GETTEXT_DOMAIN);
+#endif
console_out = stdout;
console_err = stderr;
@@ -1814,6 +1823,7 @@ int main(int argc, char **orig_argv)
main_data *data = create_main_struct(argc, orig_argv);
+#ifdef ENABLE_NLS
#ifdef __WIN32__
char mp3splt_uninstall_file[2048] = { '\0' };
DWORD dwType, dwSize = sizeof(mp3splt_uninstall_file) - 1;
@@ -1873,6 +1883,7 @@ int main(int argc, char **orig_argv)
#endif
bind_textdomain_codeset(MP3SPLT_GETTEXT_DOMAIN, "UTF-8");
+#endif
data->state = mp3splt_new_state(&err);
process_confirmation_error(err, data);