Add prboom 2.2.0,
a multiplayer-capable and modified version of ID's classic doom game. PR: 28022 Submitted by: Jordan DeLong <fracture@allusion.net>
This commit is contained in:
parent
2c0c8003ec
commit
7f4f3c0a1d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=44987
11 changed files with 148 additions and 0 deletions
|
@ -181,6 +181,7 @@
|
|||
SUBDIR += pmars
|
||||
SUBDIR += powerpak
|
||||
SUBDIR += pp
|
||||
SUBDIR += prboom
|
||||
SUBDIR += ptkei
|
||||
SUBDIR += pyching
|
||||
SUBDIR += pysol
|
||||
|
|
41
games/prboom/Makefile
Normal file
41
games/prboom/Makefile
Normal file
|
@ -0,0 +1,41 @@
|
|||
# New ports collection makefile for: prboom
|
||||
# Date created: 10 June 2001
|
||||
# Whom: Jordan DeLong <fracture@allusion.net>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= prboom
|
||||
PORTVERSION= 2.2.0
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
||||
MAINTAINER= fracture@allusion.net
|
||||
|
||||
LIB_DEPENDS= SDL-1.1.3:${PORTSDIR}/devel/sdl12 \
|
||||
smpeg.1:${PORTSDIR}/graphics/smpeg \
|
||||
SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer \
|
||||
SDL_net.0:${PORTSDIR}/net/sdl_net
|
||||
|
||||
SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
|
||||
|
||||
USE_GMAKE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
|
||||
CFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
|
||||
MAN5= boom.cfg.5
|
||||
MAN6= prboom.6 prboom-game-server.6
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${PREFIX}/share/doc/prboom
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/prboom
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/README.compat ${PREFIX}/share/doc/prboom
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/README.demos ${PREFIX}/share/doc/prboom
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/boom.txt ${PREFIX}/share/doc/prboom
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
1
games/prboom/distinfo
Normal file
1
games/prboom/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (prboom-2.2.0.tar.gz) = 249b083cf644291f928674626d569e6f
|
26
games/prboom/files/patch-Makefile.in
Normal file
26
games/prboom/files/patch-Makefile.in
Normal file
|
@ -0,0 +1,26 @@
|
|||
--- Makefile.in.orig Fri Jun 29 03:30:25 2001
|
||||
+++ Makefile.in Fri Jun 29 03:31:24 2001
|
||||
@@ -167,23 +167,8 @@
|
||||
cd $(top_builddir) && CONFIG_FILES=$@ CONFIG_HEADERS= $(SHELL) ./config.status
|
||||
|
||||
install-docDATA: $(doc_DATA)
|
||||
- @$(NORMAL_INSTALL)
|
||||
- $(mkinstalldirs) $(DESTDIR)$(docdir)
|
||||
- @list='$(doc_DATA)'; for p in $$list; do \
|
||||
- if test -f $(srcdir)/$$p; then \
|
||||
- echo " $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(docdir)/$$p"; \
|
||||
- $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(docdir)/$$p; \
|
||||
- else if test -f $$p; then \
|
||||
- echo " $(INSTALL_DATA) $$p $(DESTDIR)$(docdir)/$$p"; \
|
||||
- $(INSTALL_DATA) $$p $(DESTDIR)$(docdir)/$$p; \
|
||||
- fi; fi; \
|
||||
- done
|
||||
|
||||
uninstall-docDATA:
|
||||
- @$(NORMAL_UNINSTALL)
|
||||
- list='$(doc_DATA)'; for p in $$list; do \
|
||||
- rm -f $(DESTDIR)$(docdir)/$$p; \
|
||||
- done
|
||||
|
||||
# This directory's subdirectories are mostly independent; you can cd
|
||||
# into them and run `make' without going through this Makefile.
|
14
games/prboom/files/patch-configure
Normal file
14
games/prboom/files/patch-configure
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- configure.orig Sat Mar 31 12:50:28 2001
|
||||
+++ configure Sun Jun 10 16:41:12 2001
|
||||
@@ -920,9 +920,9 @@
|
||||
|
||||
|
||||
if test "x$prefix" != xNONE; then
|
||||
- DOOMWADDIR="$prefix/share/games/doom"
|
||||
+ DOOMWADDIR="$prefix/share/doom"
|
||||
else
|
||||
- DOOMWADDIR="$ac_default_prefix/share/games/doom"
|
||||
+ DOOMWADDIR="$ac_default_prefix/share/doom"
|
||||
fi
|
||||
cat >> confdefs.h <<EOF
|
||||
#define DOOMWADDIR "$DOOMWADDIR"
|
11
games/prboom/files/patch-data-Makefile.in
Normal file
11
games/prboom/files/patch-data-Makefile.in
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- data/Makefile.in.orig Sun Apr 1 02:14:06 2001
|
||||
+++ data/Makefile.in Sun Jun 10 16:49:16 2001
|
||||
@@ -91,7 +91,7 @@
|
||||
VERSION = @VERSION@
|
||||
ac_aux_dir = @ac_aux_dir@
|
||||
|
||||
-waddir = $(datadir)/games/doom
|
||||
+waddir = $(datadir)/doom
|
||||
wad_DATA = prboom.wad
|
||||
EXTRA_DIST = prboom.wad
|
||||
mkinstalldirs = $(SHELL) $(top_srcdir)/autotools/mkinstalldirs
|
27
games/prboom/files/patch-doc-Makefile.in
Normal file
27
games/prboom/files/patch-doc-Makefile.in
Normal file
|
@ -0,0 +1,27 @@
|
|||
--- doc/Makefile.in.orig Sun Apr 1 02:14:05 2001
|
||||
+++ doc/Makefile.in Fri Jun 29 03:39:06 2001
|
||||
@@ -196,23 +196,9 @@
|
||||
$(MAKE) $(AM_MAKEFLAGS) uninstall-man5 uninstall-man6
|
||||
|
||||
install-docDATA: $(doc_DATA)
|
||||
- @$(NORMAL_INSTALL)
|
||||
- $(mkinstalldirs) $(DESTDIR)$(docdir)
|
||||
- @list='$(doc_DATA)'; for p in $$list; do \
|
||||
- if test -f $(srcdir)/$$p; then \
|
||||
- echo " $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(docdir)/$$p"; \
|
||||
- $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(docdir)/$$p; \
|
||||
- else if test -f $$p; then \
|
||||
- echo " $(INSTALL_DATA) $$p $(DESTDIR)$(docdir)/$$p"; \
|
||||
- $(INSTALL_DATA) $$p $(DESTDIR)$(docdir)/$$p; \
|
||||
- fi; fi; \
|
||||
- done
|
||||
|
||||
uninstall-docDATA:
|
||||
- @$(NORMAL_UNINSTALL)
|
||||
- list='$(doc_DATA)'; for p in $$list; do \
|
||||
- rm -f $(DESTDIR)$(docdir)/$$p; \
|
||||
- done
|
||||
+
|
||||
tags: TAGS
|
||||
TAGS:
|
||||
|
11
games/prboom/files/patch-src-Makefile.in
Normal file
11
games/prboom/files/patch-src-Makefile.in
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- src/Makefile.in.orig Sun Apr 1 02:14:08 2001
|
||||
+++ src/Makefile.in Sun Jun 10 16:44:19 2001
|
||||
@@ -97,7 +97,7 @@
|
||||
|
||||
SUBDIRS = SDL POSIX
|
||||
|
||||
-gamesdir = $(prefix)/games
|
||||
+gamesdir = $(prefix)/bin
|
||||
EXTRA_PROGRAMS = prboom-game-server
|
||||
games_PROGRAMS = prboom @BUILD_SERVER@
|
||||
|
1
games/prboom/pkg-comment
Normal file
1
games/prboom/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
A multiplayer-capable and modified version of ID's classic doom game
|
6
games/prboom/pkg-descr
Normal file
6
games/prboom/pkg-descr
Normal file
|
@ -0,0 +1,6 @@
|
|||
Prboom is a modified version of the ID Software's classic game Doom.
|
||||
It runs on several platforms (include Win32 and Unixes) and features
|
||||
many additions to the original game. It also supports multiplayer
|
||||
games.
|
||||
|
||||
WWW: http://prboom.sourceforge.net
|
9
games/prboom/pkg-plist
Normal file
9
games/prboom/pkg-plist
Normal file
|
@ -0,0 +1,9 @@
|
|||
bin/prboom
|
||||
bin/prboom-game-server
|
||||
share/doom/prboom.wad
|
||||
@dirrm share/doom
|
||||
%%PORTDOCS%%share/doc/prboom/README
|
||||
%%PORTDOCS%%share/doc/prboom/README.compat
|
||||
%%PORTDOCS%%share/doc/prboom/README.demos
|
||||
%%PORTDOCS%%share/doc/prboom/boom.txt
|
||||
%%PORTDOCS%%@dirrm share/doc/prboom
|
Loading…
Reference in a new issue