- Update to 0.9.8.1.
This commit is contained in:
parent
a506ddafe6
commit
7f67b960f4
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=187569
5 changed files with 88 additions and 22 deletions
|
@ -7,24 +7,31 @@
|
|||
#
|
||||
|
||||
PORTNAME= omake
|
||||
PORTVERSION= 0.9.6.9.1
|
||||
PORTVERSION= 0.9.8.1
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://omake.metaprl.org/downloads/ \
|
||||
http://sunner.elcomnet.ru/~stas/
|
||||
DISTNAME= omake-0.9.6.9-1
|
||||
DISTNAME= omake-0.9.8.1-1
|
||||
|
||||
MAINTAINER= stas@FreeBSD.org
|
||||
COMMENT= A flexible build system
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/\.[0-9]*$//}
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||
USE_OCAML= yes
|
||||
NO_OCAML_RUNDEPENDS=yes
|
||||
|
||||
FETCH_CMD?= /usr/bin/fetch -Rr
|
||||
|
||||
MAN1= omake-base.1 omake-doc.1 omake-language.1 omake-options.1 \
|
||||
omake-pervasives.1 omake-quickstart.1 omake-root.1 omake-rules.1 \
|
||||
omake-shell.1 omake-system.1 omake.1 osh.1
|
||||
# XXX: exists untill it will be committed to bsd.port.mk
|
||||
COPYTREE_SHARE= ${SH} -c '(${FIND} -d $$0 $$2 | ${CPIO} -dumpl $$1 >/dev/null \
|
||||
2>&1) && \
|
||||
${CHOWN} -R ${SHAREOWN}:${SHAREGRP} $$1 && \
|
||||
${FIND} $$1/ -type d -exec ${CHMOD} 755 {} \; && \
|
||||
${FIND} $$1/ -type f -exec ${CHMOD} ${SHAREMODE} {} \;' --
|
||||
|
||||
.if !defined(NOPORTDOCS)
|
||||
INFO= omake-doc
|
||||
.endif
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
|
@ -58,4 +65,12 @@ post-patch:
|
|||
${WRKSRC}/mk/make_config ${WRKSRC}/mk/defaults
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}/
|
||||
@(cd ${WRKSRC}/doc/html/ && ${COPYTREE_SHARE} \* "${DOCSDIR}/")
|
||||
@(cd ${WRKSRC}/doc/info/ \
|
||||
&& ${COPYTREE_SHARE} \* "${PREFIX}/${INFO_PATH}/")
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (omake-0.9.6.9-1.tar.gz) = 81a44fcf8192140b3147ffe849818742
|
||||
SHA256 (omake-0.9.6.9-1.tar.gz) = f9a296b06d4a68407ae499f95f601a4a7ba2ca0157b1b03808183ba26e2afc26
|
||||
SIZE (omake-0.9.6.9-1.tar.gz) = 2046152
|
||||
MD5 (omake-0.9.8.1-1.tar.gz) = 1d0fb573fab8f4de38993f81f3d383cd
|
||||
SHA256 (omake-0.9.8.1-1.tar.gz) = 3265293803e75dcea72c62ebb18022b16e1984d59f1ab6cc4397b17b976f7500
|
||||
SIZE (omake-0.9.8.1-1.tar.gz) = 2919405
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
--- Makefile.orig Thu Sep 8 04:43:14 2005
|
||||
+++ Makefile Mon Aug 7 13:01:39 2006
|
||||
@@ -18,8 +18,8 @@
|
||||
@exit 1
|
||||
|
||||
boot: boot/Makefile
|
||||
- @touch boot/Makefile.dep
|
||||
- @cd boot; $(MAKE) Makefile.dep; $(MAKE) omake
|
||||
+ @sed -i "" -e '/include Makefile.dep/d' boot/Makefile
|
||||
+ @cd boot; $(MAKE) Makefile.dep; echo "include Makefile.dep" >> Makefile; $(MAKE) omake
|
||||
@ln -sf boot/omake omake-boot
|
||||
|
||||
boot/Makefile: src/Makefile
|
12
devel/omake/files/patch-doc_info_omake-doc.info
Normal file
12
devel/omake/files/patch-doc_info_omake-doc.info
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- doc/info/omake-doc.info.orig Sat Mar 17 03:14:47 2007
|
||||
+++ doc/info/omake-doc.info Sat Mar 17 03:16:18 2007
|
||||
@@ -1,4 +1,9 @@
|
||||
This file has been translated from LaTeX by HeVeA.
|
||||
+
|
||||
+START-INFO-DIR-ENTRY
|
||||
+* Omake: (omake-doc). The flexible build system.
|
||||
+END-INFO-DIR-ENTRY
|
||||
+
|
||||
|
||||
Indirect:
|
||||
omake-doc.info-1: 51
|
|
@ -1,4 +1,5 @@
|
|||
bin/cvs_realclean
|
||||
bin/ocamldep-omake
|
||||
bin/omake
|
||||
bin/osh
|
||||
lib/omake/OMakefile.default
|
||||
|
@ -9,12 +10,63 @@ lib/omake/build/C.om
|
|||
lib/omake/build/Common.om
|
||||
lib/omake/build/LaTeX.om
|
||||
lib/omake/build/OCaml.om
|
||||
lib/omake/build/svn_realclean.om
|
||||
lib/omake/configure/Configure.om
|
||||
lib/omake/configure/X.om
|
||||
lib/omake/configure/fam.om
|
||||
lib/omake/configure/ncurses.om
|
||||
lib/omake/configure/readline.om
|
||||
lib/omake/configure/snprintf.om
|
||||
lib/omake/parse/C/Lex.om
|
||||
lib/omake/parse/C/Parse.om
|
||||
%%PORTDOCS%%%%DOCSDIR%%/announce.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/changelog.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/contents_motif.gif
|
||||
%%PORTDOCS%%%%DOCSDIR%%/download.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/announce.ps
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/announce.tex
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/grid.ai
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/omake-manual.ai
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/omake-manual.gif
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/omake.ai
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/omake.eps
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/omake.gif
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/omake.psd
|
||||
%%PORTDOCS%%%%DOCSDIR%%/index.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/next_motif.gif
|
||||
%%PORTDOCS%%%%DOCSDIR%%/omake-all-index.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/omake-autoconf.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/omake-base.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/omake-build-examples.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/omake-build.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/omake-contents.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/omake-detail.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/omake-doc.css
|
||||
%%PORTDOCS%%%%DOCSDIR%%/omake-doc.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/omake-fun-index.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/omake-grammar.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/omake-language-examples.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/omake-language.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/omake-obj-index.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/omake-option-index.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/omake-options.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/omake-pervasives.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/omake-quickstart.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/omake-references.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/omake-rules.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/omake-shell.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/omake-system.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/omake-target-index.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/omake-toc.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/omake-var-index.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/omake.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/omake_lists.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/omake_papers.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/omake_users.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/osh.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/previous_motif.gif
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%/images
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
@dirrm lib/omake/parse/C
|
||||
@dirrm lib/omake/parse
|
||||
@dirrm lib/omake/configure
|
||||
|
|
Loading…
Reference in a new issue