- Fix parallel builds: call make(1) correctly, register dependencies
- Drop LICENSE_FILE for a standard license (GPLv2) - Respect CC and CFLAGS without patching of makefile (use MAKE_ARGS) - Convert NOPORTDOCS -> PORT_OPTIONS:MDOCS, add OPTIONS_DEFINE - Move "make test" under the wing of our standard regression-test target - Generally cleanup Makefile and port description while I am here
This commit is contained in:
parent
58c11ef9cb
commit
7f6c37b99b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=327855
3 changed files with 37 additions and 36 deletions
|
@ -1,4 +1,4 @@
|
|||
# Created by: Stephane Legrand
|
||||
# Created by: Stephane Legrand <stephane@lituus.fr>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= bugs
|
||||
|
@ -9,42 +9,56 @@ MASTER_SITES= SUNSITE/apps/crypto
|
|||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Great cryptography library and sample programs
|
||||
COMMENT= Great cryptographic library and sample programs
|
||||
|
||||
LICENSE= GPLv2
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
NO_STAGE= yes
|
||||
USES= gmake
|
||||
|
||||
MAKE_JOBS_UNSAFE= yes
|
||||
MAKE_ARGS= CC="${CC}" BFLAG="${CFLAGS}" \
|
||||
INSTALL_PATH="${PREFIX}/${DISTNAME}"
|
||||
|
||||
PLIST_SUB= PORTVERSION="${PORTVERSION}"
|
||||
|
||||
DOCSDIR= ${PREFIX}/${DISTNAME}/doc
|
||||
|
||||
NO_STAGE= yes
|
||||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
post-patch:
|
||||
# Sanitize permissions so "make clean" can work
|
||||
@${CHMOD} +x ${WRKSRC}/lib/unix ${WRKSRC}/lib/windows
|
||||
# Allow parallel builds (-jX): fix make(1) syntax, register dependencies
|
||||
@${REINPLACE_CMD} -E 's+cd (.*); make+$$(MAKE) -C \1+' \
|
||||
${WRKSRC}/Makefile.bsd
|
||||
@${ECHO_CMD} 'apps: lib' >> ${WRKSRC}/Makefile.bsd
|
||||
@${REINPLACE_CMD} -E '/^(bcrypt|bchat|bpass|blogin|bkey|bpassdel|bmore|block|bunlock|shell):/s+ *$$+ extra.o+' \
|
||||
${WRKSRC}/apps/Makefile.bsd
|
||||
|
||||
post-configure:
|
||||
(cd ${WRKSRC}; ${MAKE} bsd);
|
||||
${REINPLACE_CMD} -e 's:^INSTALL_PATH = "/usr/local/bugs-.*":INSTALL_PATH = "${PREFIX}/${DISTNAME}":' ${WRKSRC}/Makefile;
|
||||
${REINPLACE_CMD} -e 's/^install: instchoice all/install: instchoice/' ${WRKSRC}/Makefile;
|
||||
# Comment the docs installation
|
||||
${REINPLACE_CMD} -e 's+\(@echo "Copying docs.*\)+# \1+' ${WRKSRC}/Makefile;
|
||||
${REINPLACE_CMD} -e 's+\(@cp -rf ./doc/.*\)+# \1+' ${WRKSRC}/Makefile;
|
||||
${MAKE_CMD} -C ${WRKSRC} bsd
|
||||
@${REINPLACE_CMD} -e 's/^install: instchoice all/install: instchoice/' ${WRKSRC}/Makefile;
|
||||
@${REINPLACE_CMD} -e 's+\(@echo "Copying docs.*\)+# \1+' ${WRKSRC}/Makefile;
|
||||
@${REINPLACE_CMD} -e 's+\(@cp -rf ./doc/.*\)+# \1+' ${WRKSRC}/Makefile
|
||||
@${REINPLACE_CMD} -e 's+\(@cp -rf ./doc/.*\)+# \1+' ${WRKSRC}/Makefile
|
||||
|
||||
post-build:
|
||||
@${LN} -sf ${WRKSRC}/lib/unix/*.a ${WRKSRC}/lib/
|
||||
|
||||
pre-install:
|
||||
(cd ${WRKSRC}; ${MAKE} test)
|
||||
|
||||
post-install:
|
||||
@${MKDIR} ${PREFIX}/${DISTNAME}/include
|
||||
${INSTALL_DATA} ${WRKSRC}/include/*.h ${PREFIX}/${DISTNAME}/include
|
||||
.for file in bchat bcrypt bhide bkey block blogin bmore bpass bpassdel bunlock
|
||||
@${STRIP_CMD} ${PREFIX}/${DISTNAME}/${file}
|
||||
.endfor
|
||||
.if !defined(NOPORTDOCS)
|
||||
.if ${PORT_OPTIONS:MDOCS}
|
||||
@(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${DOCSDIR})
|
||||
.endif
|
||||
|
||||
test: build
|
||||
${MAKE_CMD} -C ${WRKSRC} test
|
||||
|
||||
regression-test: test
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- lib/unix/Makefile.bsd.orig Thu Jun 6 17:17:21 2002
|
||||
+++ lib/unix/Makefile.bsd Thu Jun 6 17:32:09 2002
|
||||
@@ -1,6 +1,6 @@
|
||||
#YOU MUST CHOOSE YOUR COMPILER
|
||||
-#CC=gcc
|
||||
-#BFLAG=-Wall -O3
|
||||
+CC?=cc
|
||||
+BFLAG= ${CFLAGS}
|
||||
|
||||
all: message bugscrypt.a
|
||||
|
|
@ -1,13 +1,11 @@
|
|||
This package include a C library and some samples program that
|
||||
demonstrate that this library is powerful.
|
||||
This package include a C library and some sample programs that demonstrate
|
||||
the library's power.
|
||||
|
||||
It is a cryptography library, you can crypt any type of data.
|
||||
Your key length to crypt is unlimited.
|
||||
You can generate password, manage users, hide text in file, etc.
|
||||
|
||||
|
||||
ATTENTION !!! IN SOME COUNTRIES THIS SOFTWARE MAY BE ILLEGAL SO DON'T USE
|
||||
IT IF YOU ARE NOT ALLOWED...
|
||||
It is a cryptographic library: you can crypt any type of data. Key length
|
||||
is unlimited. You can generate password, manage users, hide text in file,
|
||||
etc.
|
||||
|
||||
ATTENTION!!! IN SOME COUNTRIES THIS SOFTWARE MAY BE ILLEGAL, SO DON'T USE
|
||||
IT IF YOU ARE NOT ALLOWED.
|
||||
|
||||
WWW: http://www.encryptsolutions.com/
|
||||
|
|
Loading…
Reference in a new issue