Initial import of MirrorMagic version 1.3.
An arcade style game for X Windows with stereo sound. PR: 9164 Submitted by: Andrey Zakhvatov <andy@icc.surw.chel.su>
This commit is contained in:
parent
8564e7f4c1
commit
7fa384c54d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=16528
8 changed files with 152 additions and 0 deletions
42
games/mirrormagic/Makefile
Normal file
42
games/mirrormagic/Makefile
Normal file
|
@ -0,0 +1,42 @@
|
|||
# New ports collection makefile for: mirrormagic
|
||||
# Version required: 1.3
|
||||
# Date created: 1 April 1998
|
||||
# Whom: Andrey Zakhvatov
|
||||
#
|
||||
# $Id$
|
||||
#
|
||||
|
||||
DISTNAME= mirrormagic-1.3
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= ${MASTER_SITE_XCONTRIB}
|
||||
MASTER_SITE_SUBDIR= games
|
||||
|
||||
MAINTAINER= andy@icc.surw.chel.su
|
||||
|
||||
LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
|
||||
pre-build:
|
||||
.for file in DoubleRayDoor DoubleRayFont DoubleRayFont2 DoubleRayScreen
|
||||
@ ${GUNZIP_CMD} ${WRKSRC}/graphics/${file}.xpm
|
||||
.endfor
|
||||
@ (cd ${WRKDIR}; ${CP} ${FILESDIR}/RAY.* .; uudecode *.uu; ${RM} *.uu)
|
||||
|
||||
do-install:
|
||||
@ ${INSTALL_PROGRAM} ${WRKSRC}/mirrormagic ${PREFIX}/bin
|
||||
@ ${MKDIR} ${PREFIX}/share/mirrormagic/graphics
|
||||
@ ${INSTALL_DATA} ${WRKSRC}/graphics/* ${PREFIX}/share/mirrormagic/graphics
|
||||
@ ${MKDIR} ${PREFIX}/share/mirrormagic/sounds
|
||||
@ ${INSTALL_DATA} ${WRKSRC}/sounds/*.8svx ${PREFIX}/share/mirrormagic/sounds
|
||||
@ ${MKDIR} ${PREFIX}/share/mirrormagic/data
|
||||
@ ${INSTALL_DATA} ${WRKSRC}/RAY.level ${PREFIX}/share/mirrormagic/data
|
||||
@ ${INSTALL_DATA} ${WRKDIR}/RAY.* ${PREFIX}/share/mirrormagic/data
|
||||
@ ${MKDIR} ${PREFIX}/share/doc/mirrormagic
|
||||
.for file in CHANGES COPYRIGHT DISCLAIMER README
|
||||
@ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/mirrormagic
|
||||
.endfor
|
||||
# @ chmod a=rwx ${PREFIX}/share/mirrormagic/data
|
||||
@ chmod a=rw ${PREFIX}/share/mirrormagic/data/RAY.*
|
||||
|
||||
.include <bsd.port.mk>
|
1
games/mirrormagic/distinfo
Normal file
1
games/mirrormagic/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (mirrormagic-1.3.tar.gz) = 4b130375b8a923788470f616b28dddfe
|
5
games/mirrormagic/files/RAY.names.uu
Normal file
5
games/mirrormagic/files/RAY.names.uu
Normal file
|
@ -0,0 +1,5 @@
|
|||
begin 644 RAY.names
|
||||
M34E24D]234%'24-?3D%-15-?1DE,15]615)324].7S$N,V%N9'D`````````
|
||||
.86YD>0`````````!``--
|
||||
`
|
||||
end
|
1
games/mirrormagic/files/RAY.score
Normal file
1
games/mirrormagic/files/RAY.score
Normal file
File diff suppressed because one or more lines are too long
48
games/mirrormagic/files/patch-aa
Normal file
48
games/mirrormagic/files/patch-aa
Normal file
|
@ -0,0 +1,48 @@
|
|||
--- Makefile Wed Sep 6 11:56:17 1995
|
||||
+++ /home/andy/tmp/wrk/Makefile Tue Mar 31 23:07:25 1998
|
||||
@@ -8,11 +8,17 @@
|
||||
CC = gcc
|
||||
# CC = cc # for HP-UX and others
|
||||
|
||||
-GFX_PATH = -DGFX_PATH=\"./graphics\" # path where the graphics are
|
||||
-SND_PATH = -DSND_PATH=\"./sounds\" # path where the sounds are
|
||||
-LEVEL_PATH = -DLEVEL_PATH=\".\" # path where the level file is
|
||||
-SCORE_PATH = -DSCORE_PATH=\".\" # path where the score file is
|
||||
-NAMES_PATH = -DNAMES_PATH=\".\" # path where the names file is
|
||||
+.ifndef PREFIX
|
||||
+ROOT= .
|
||||
+.else
|
||||
+ROOT=${PREFIX}/share/mirrormagic
|
||||
+.endif
|
||||
+
|
||||
+GFX_PATH = -DGFX_PATH=\"${ROOT}/graphics\" # path where the graphics are
|
||||
+SND_PATH = -DSND_PATH=\"${ROOT}/sounds\" # path where the sounds are
|
||||
+LEVEL_PATH = -DLEVEL_PATH=\"${ROOT}/data\" # path where the level file is
|
||||
+SCORE_PATH = -DSCORE_PATH=\"${ROOT}/data\" # path where the score file is
|
||||
+NAMES_PATH = -DNAMES_PATH=\"${ROOT}/data\" # path where the names file is
|
||||
# SOUNDS = -DNO_SOUNDS # don't play any sounds
|
||||
# SCORE_ENTRIES = -DONE_PER_NAME # only one score entry per name
|
||||
SCORE_ENTRIES = -DMANY_PER_NAME # many score entries per name
|
||||
@@ -26,7 +32,7 @@
|
||||
|
||||
# DEBUG = -DDEBUG -g -ansi -pedantic -Wall
|
||||
# DEBUG = -DDEBUG -g -Wall
|
||||
-DEBUG = -O6
|
||||
+# DEBUG = -O6
|
||||
|
||||
# SYSTEM = -Aa -D_HPUX_SOURCE -Dhpux # for HP-UX (obsolete)
|
||||
# SYSTEM = -DSYSV -Ae # for HP-UX
|
||||
@@ -34,10 +40,11 @@
|
||||
# INCL = -I/usr/include/X11R5 # for HP-UX and others
|
||||
# LIBS = -lXpm -lX11 -lm
|
||||
# LIBS = -L/usr/lib/X11R5 -lXpm -lX11 -lm # for HP-UX and others
|
||||
-LIBS = -lXpm -lXpm -lXpm -lX11 -lm # triple "-lXpm" because of Xpm error
|
||||
+INCL = -I/usr/X11R6/include
|
||||
+LIBS = -L/usr/X11R6/lib -lXpm -lX11 -lm # triple "-lXpm" because of Xpm error
|
||||
|
||||
# CFLAGS = -O2 $(CONFIG) $(SYSTEM)
|
||||
-CFLAGS = $(DEBUG) $(CONFIG) $(SYSTEM) $(INCL)
|
||||
+CFLAGS+= $(DEBUG) $(CONFIG) $(SYSTEM) $(INCL)
|
||||
|
||||
OBJS = main.o \
|
||||
init.o \
|
1
games/mirrormagic/pkg-comment
Normal file
1
games/mirrormagic/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
An arcade style game for X Windows with stereo sound.
|
6
games/mirrormagic/pkg-descr
Normal file
6
games/mirrormagic/pkg-descr
Normal file
|
@ -0,0 +1,6 @@
|
|||
This is a nice little game with color graphics and sound for your
|
||||
Unix system with color X11. You need an 8-Bit color display or better.
|
||||
It is not recommended on black&white systems, and maybe not on gray
|
||||
scale systems.
|
||||
It was first released as "Mirror Magic" in the year 1989 on the
|
||||
Amiga (with ports on other computer systems).
|
48
games/mirrormagic/pkg-plist
Normal file
48
games/mirrormagic/pkg-plist
Normal file
|
@ -0,0 +1,48 @@
|
|||
bin/mirrormagic
|
||||
share/doc/mirrormagic/CHANGES
|
||||
share/doc/mirrormagic/COPYRIGHT
|
||||
share/doc/mirrormagic/DISCLAIMER
|
||||
share/doc/mirrormagic/README
|
||||
@mode 666
|
||||
share/mirrormagic/data/RAY.level
|
||||
share/mirrormagic/data/RAY.names
|
||||
share/mirrormagic/data/RAY.score
|
||||
@mode
|
||||
share/mirrormagic/graphics/DoubleRayDoor.xpm
|
||||
share/mirrormagic/graphics/DoubleRayDoorMaske.xbm
|
||||
share/mirrormagic/graphics/DoubleRayFont.xpm
|
||||
share/mirrormagic/graphics/DoubleRayFont2.xpm
|
||||
share/mirrormagic/graphics/DoubleRayFont2Maske.xbm
|
||||
share/mirrormagic/graphics/DoubleRayFontMaske.xbm
|
||||
share/mirrormagic/graphics/DoubleRayMaskeF.xbm
|
||||
share/mirrormagic/graphics/DoubleRayScreen.xpm
|
||||
share/mirrormagic/graphics/DoubleRayScreenMaske.xbm
|
||||
share/mirrormagic/graphics/mirrormagic_icon.xbm
|
||||
share/mirrormagic/graphics/mirrormagic_iconmask.xbm
|
||||
share/mirrormagic/sounds/amoebe.8svx
|
||||
share/mirrormagic/sounds/antigrav.8svx
|
||||
share/mirrormagic/sounds/autsch.8svx
|
||||
share/mirrormagic/sounds/bong.8svx
|
||||
share/mirrormagic/sounds/fuel.8svx
|
||||
share/mirrormagic/sounds/halloffame.8svx
|
||||
share/mirrormagic/sounds/holz.8svx
|
||||
share/mirrormagic/sounds/hui.8svx
|
||||
share/mirrormagic/sounds/kabumm.8svx
|
||||
share/mirrormagic/sounds/kink.8svx
|
||||
share/mirrormagic/sounds/kling.8svx
|
||||
share/mirrormagic/sounds/laser.8svx
|
||||
share/mirrormagic/sounds/oeffnen.8svx
|
||||
share/mirrormagic/sounds/quiek.8svx
|
||||
share/mirrormagic/sounds/rhythmloop.8svx
|
||||
share/mirrormagic/sounds/roaaar.8svx
|
||||
share/mirrormagic/sounds/sirr.8svx
|
||||
share/mirrormagic/sounds/slurp.8svx
|
||||
share/mirrormagic/sounds/tyger.8svx
|
||||
share/mirrormagic/sounds/voyager.8svx
|
||||
share/mirrormagic/sounds/warnton.8svx
|
||||
share/mirrormagic/sounds/whoosh.8svx
|
||||
@dirrm share/doc/mirrormagic
|
||||
@dirrm share/mirrormagic/data
|
||||
@dirrm share/mirrormagic/graphics
|
||||
@dirrm share/mirrormagic/sounds
|
||||
@dirrm share/mirrormagic
|
Loading…
Reference in a new issue