- Fix PLIST

- Add a temporary workaround to enable build swig modules on Python 2.4.
- Bump PORTREVISION
This commit is contained in:
Hye-Shik Chang 2004-12-05 03:17:37 +00:00
parent 40a6833797
commit 7fa7bdf2b6
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=123165
3 changed files with 15 additions and 0 deletions

View file

@ -7,6 +7,7 @@
PORTNAME= pyrex
PORTVERSION= 0.9.3
PORTREVISION= 1
CATEGORIES= devel lang python
MASTER_SITES= http://www.cosc.canterbury.ac.nz/~greg/python/Pyrex/
PKGNAMEPREFIX= ${PYTHONPKGNAMEPREFIX}

View file

@ -0,0 +1,11 @@
--- Pyrex/Distutils/build_ext.py.orig Sun Dec 5 12:11:14 2004
+++ Pyrex/Distutils/build_ext.py Sun Dec 5 12:11:41 2004
@@ -32,7 +32,7 @@
if self.compiler == 'mingw32':
self.swig_cpp = 1
- def swig_sources (self, sources):
+ def swig_sources (self, sources, extension=None): # workaround for 2.4 compat
if not self.extensions:
return

View file

@ -9,6 +9,7 @@ bin/pyrexc
%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/DebugFlags.pyc
%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/DebugFlags.pyo
%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/Errors.py
%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/Errors.pyc
%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/Errors.pyo
%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/ExprNodes.py
%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/ExprNodes.pyc
@ -104,6 +105,7 @@ bin/pyrexc
%%PYTHON_SITELIBDIR%%/Pyrex/Plex/Regexps.py
%%PYTHON_SITELIBDIR%%/Pyrex/Plex/Regexps.pyc
%%PYTHON_SITELIBDIR%%/Pyrex/Plex/Regexps.pyo
%%PYTHON_SITELIBDIR%%/Pyrex/Plex/Scanners.py
%%PYTHON_SITELIBDIR%%/Pyrex/Plex/Scanners.pyc
%%PYTHON_SITELIBDIR%%/Pyrex/Plex/Scanners.pyo
%%PYTHON_SITELIBDIR%%/Pyrex/Plex/Timing.py
@ -151,6 +153,7 @@ bin/pyrexc
%%PORTDOCS%%%%EXAMPLESDIR%%/callback/cheesefinder.c
%%PORTDOCS%%%%EXAMPLESDIR%%/callback/cheesefinder.h
%%PORTDOCS%%%%EXAMPLESDIR%%/callback/run_cheese.py
%%PORTDOCS%%%%EXAMPLESDIR%%/embed/Makefile
%%PORTDOCS%%%%EXAMPLESDIR%%/embed/Makefile.msc
%%PORTDOCS%%%%EXAMPLESDIR%%/embed/Makefile.msc.static
%%PORTDOCS%%%%EXAMPLESDIR%%/embed/Makefile.unix