Add libIDL 0.7.3, a library for creating trees of CORBA Interface Definition
Language files.
This commit is contained in:
parent
a918fa6f04
commit
7ff087dd4d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=54611
7 changed files with 84 additions and 0 deletions
|
@ -222,6 +222,7 @@
|
|||
SUBDIR += lclint
|
||||
SUBDIR += lemon
|
||||
SUBDIR += leoarg
|
||||
SUBDIR += libIDL
|
||||
SUBDIR += libPropList
|
||||
SUBDIR += libU77
|
||||
SUBDIR += libafterbase
|
||||
|
|
35
devel/libIDL/Makefile
Normal file
35
devel/libIDL/Makefile
Normal file
|
@ -0,0 +1,35 @@
|
|||
# New ports collection makefile for: libIDL
|
||||
# Date Created: 12 February 2002
|
||||
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= libIDL
|
||||
PORTVERSION= 0.7.3
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_GNOME}
|
||||
MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-alpha2
|
||||
DIST_SUBDIR= gnome2
|
||||
|
||||
MAINTAINER= gnome@FreeBSD.org
|
||||
|
||||
BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
|
||||
LIB_DEPENDS= glib-1.3.13:${PORTSDIR}/devel/glib13
|
||||
RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_GMAKE= yes
|
||||
USE_BISON= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
|
||||
|
||||
pre-patch:
|
||||
@find ${WRKSRC} -name Makefile.in | xargs ${PERL} -pi -e \
|
||||
's|\$\(libdir\)/pkgconfig|\$\(prefix\)/libdata/pkgconfig|g'
|
||||
|
||||
.include <bsd.port.mk>
|
1
devel/libIDL/distinfo
Normal file
1
devel/libIDL/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (gnome2/libIDL-0.7.3.tar.bz2) = f52fc93a78aeb97644e882f4085bac97
|
28
devel/libIDL/files/patch-ltmain.sh
Normal file
28
devel/libIDL/files/patch-ltmain.sh
Normal file
|
@ -0,0 +1,28 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- ltmain.sh 2001/08/27 09:51:26 1.1
|
||||
+++ ltmain.sh 2001/08/27 09:51:42
|
||||
@@ -2408,6 +2408,9 @@
|
||||
*-*-netbsd*)
|
||||
# Don't link with libc until the a.out ld.so is fixed.
|
||||
;;
|
||||
+ *-*-freebsd*)
|
||||
+ # FreeBSD doesn't need this...
|
||||
+ ;;
|
||||
*)
|
||||
# Add libc to deplibs on all other systems if necessary.
|
||||
if test "$build_libtool_need_lc" = "yes"; then
|
||||
@@ -4175,10 +4178,12 @@
|
||||
fi
|
||||
|
||||
# Install the pseudo-library for information purposes.
|
||||
+ if /usr/bin/false; then
|
||||
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
|
||||
instname="$dir/$name"i
|
||||
$show "$install_prog $instname $destdir/$name"
|
||||
$run eval "$install_prog $instname $destdir/$name" || exit $?
|
||||
+ fi
|
||||
|
||||
# Maybe install the static library, too.
|
||||
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
|
1
devel/libIDL/pkg-comment
Normal file
1
devel/libIDL/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
A library for creating trees of CORBA Interface Definition Language files
|
7
devel/libIDL/pkg-descr
Normal file
7
devel/libIDL/pkg-descr
Normal file
|
@ -0,0 +1,7 @@
|
|||
libIDL is a library for creating trees of CORBA Interface Definition Language
|
||||
(IDL) files, which is a specification for defining portable interfaces.
|
||||
libIDL was initially written for ORBit (the ORB from the GNOME project, and
|
||||
the primary means of libIDL distribution). However, the functionality was
|
||||
designed to be as reusable and portable as possible.
|
||||
|
||||
WWW: http://www.gnome.org/
|
11
devel/libIDL/pkg-plist
Normal file
11
devel/libIDL/pkg-plist
Normal file
|
@ -0,0 +1,11 @@
|
|||
bin/libIDL-config-2
|
||||
include/libIDL-2.0/libIDL/IDL.h
|
||||
@unexec install-info --delete %D/info/libIDL2.info %D/info/dir
|
||||
info/libIDL2.info
|
||||
@exec install-info %D/info/libIDL2.info %D/info/dir
|
||||
lib/libIDL-2.a
|
||||
lib/libIDL-2.so
|
||||
lib/libIDL-2.so.0
|
||||
libdata/pkgconfig/libIDL-2.0.pc
|
||||
@dirrm include/libIDL-2.0/libIDL
|
||||
@dirrm include/libIDL-2.0
|
Loading…
Reference in a new issue