Add ftrace 0.9, a file modification/creation watcher.

(Note: This port can be used to easily create PLIST's!)

PR:		24105
Submitted by:	George Reid <greid@ukug.uk.freebsd.org>
This commit is contained in:
Alexander Langer 2001-01-06 14:28:05 +00:00
parent 0e8b58d01f
commit 8073f81d69
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=36856
8 changed files with 54 additions and 0 deletions

View file

@ -37,6 +37,7 @@
SUBDIR += fontedit
SUBDIR += fortunelock
SUBDIR += fsck_ext2fs
SUBDIR += ftrace
SUBDIR += gcombust
SUBDIR += gkrellm
SUBDIR += glload

18
sysutils/ftrace/Makefile Normal file
View file

@ -0,0 +1,18 @@
# New ports collection makefile for: ftrace
# Date created: 06 January 2001
# Whom: George Reid <greid@ukug.uk.freebsd.org>
#
# $FreeBSD$
#
PORTNAME= ftrace
PORTVERSION= 0.9
CATEGORIES= sysutils
MASTER_SITES= http://software.senko.net/pub/
DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= greid@ukug.uk.freebsd.org
WRKSRC= ${WRKDIR}/${DISTNAME:S/_/-/}
.include <bsd.port.mk>

1
sysutils/ftrace/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (ftrace_0.9.tar.gz) = b2a479f2eec86ec24fd02a6723afe303

View file

@ -0,0 +1,16 @@
--- Makefile.orig Fri Jan 5 18:40:20 2001
+++ Makefile Sat Jan 6 14:11:10 2001
@@ -1,11 +1,10 @@
-PREFIX = /usr/local
BINDIR = $(PREFIX)/bin
LIBDIR = $(PREFIX)/lib
CC = gcc
LD = ld
-CFLAGS = -Wall -O3 -DPIC -fPIC -D_REENTRANT
-LDFLAGS = -shared -ldl
+CFLAGS += -Wall -O3 -DPIC -fPIC -D_REENTRANT
+LDFLAGS = -shared
OBJS = ftrace.o
.PHONY: all clean install

View file

@ -0,0 +1,8 @@
--- ftrace.orig Sat Jan 6 14:11:37 2001
+++ ftrace Sat Jan 6 14:11:24 2001
@@ -1,4 +1,4 @@
-#!/bin/bash
+#!/bin/sh
if [ "$1" = "-i" ]; then
export FTRACEIGNOREME=1

View file

@ -0,0 +1 @@
A file modification/creation watcher

View file

@ -0,0 +1,7 @@
Ftrace logs files created and/or modified by some process (typically
`make install') and its children. It consists of a shell wrapper and
library that is preloaded to the target program. Ftrace is basically
an 'installwatch' clone, but has some additional features.
- George Reid
greid@ukug.uk.freebsd.org

View file

@ -0,0 +1,2 @@
bin/ftrace
lib/libftrace.so