- Update to 1.6.1
PR: ports/87743 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
This commit is contained in:
parent
f6dc97d64e
commit
80a461697b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=145978
14 changed files with 9 additions and 186 deletions
|
@ -6,8 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= xlogmaster
|
||||
PORTVERSION= 1.6.0
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 1.6.1
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= ${MASTER_SITE_GNU}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
@ -15,8 +14,10 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
|
|||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Quick & easy monitoring of logfiles and devices
|
||||
|
||||
USE_GNOME= gtk12
|
||||
USE_GCC= 3.4+
|
||||
USE_GNOME= gtk12 gnometarget
|
||||
USE_GETOPT_LONG= yes
|
||||
USE_REINPLACE= yes
|
||||
USE_GMAKE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
|
||||
|
@ -27,11 +28,11 @@ INFO= xlogmaster
|
|||
CPPFLAGS= -I${LOCALBASE}/include -DHAVE_DECL_GETOPT
|
||||
LDFLAGS= -L${LOCALBASE}/lib
|
||||
|
||||
post-extract:
|
||||
-${RM} ${WRKSRC}/import/getopt*
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e \
|
||||
's|getopt_long_only|getopt_long|g' ${WRKSRC}/src/xlogmaster.cc
|
||||
|
||||
post-install:
|
||||
@install-info ${PREFIX}/info/xlogmaster.info ${PREFIX}/info/dir
|
||||
${INSTALL_DATA} ${FILESDIR}/xlogmasterrc ${PREFIX}/etc/xlogmaster
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
MD5 (xlogmaster-1.6.0.tar.gz) = b1900ebae821656fb6b7f028fab8bf10
|
||||
SIZE (xlogmaster-1.6.0.tar.gz) = 358648
|
||||
MD5 (xlogmaster-1.6.1.tar.gz) = f4c6a225fb6bc6beaf9f9ea7681699c3
|
||||
SIZE (xlogmaster-1.6.1.tar.gz) = 692821
|
||||
|
|
|
@ -1,16 +0,0 @@
|
|||
--- ../../original/doc/Makefile.in Wed Mar 31 17:01:03 1999
|
||||
+++ doc/Makefile.in Fri Apr 2 06:56:30 1999
|
||||
@@ -173,13 +173,6 @@
|
||||
done; \
|
||||
done
|
||||
@$(POST_INSTALL)
|
||||
- @if $(SHELL) -c 'install-info --version | sed 1q | fgrep -s -v -i debian' >/dev/null 2>&1; then \
|
||||
- list='$(INFO_DEPS)'; \
|
||||
- for file in $$list; do \
|
||||
- echo " install-info --info-dir=$(DESTDIR)$(infodir) $(DESTDIR)$(infodir)/$$file";\
|
||||
- install-info --info-dir=$(DESTDIR)$(infodir) $(DESTDIR)$(infodir)/$$file || :;\
|
||||
- done; \
|
||||
- else : ; fi
|
||||
|
||||
uninstall-info:
|
||||
$(PRE_UNINSTALL)
|
|
@ -1,20 +0,0 @@
|
|||
--- configure.orig Thu Apr 1 01:00:59 1999
|
||||
+++ configure Thu Feb 5 22:01:46 2004
|
||||
@@ -860,7 +860,7 @@
|
||||
|
||||
|
||||
|
||||
-CFLAGS=""
|
||||
+#CFLAGS=""
|
||||
if test x${CXXFLAGS+set} = xset ; then
|
||||
:
|
||||
else
|
||||
@@ -1874,7 +1874,7 @@
|
||||
import_sources="$force_libimport"
|
||||
rx_sources="$force_libimport"
|
||||
|
||||
-for ac_func in getopt_long_only
|
||||
+for ac_func in getopt_long
|
||||
do
|
||||
echo $ac_n "checking for $ac_func""... $ac_c" 1>&6
|
||||
echo "configure:1881: checking for $ac_func" >&5
|
|
@ -1,13 +0,0 @@
|
|||
--- src/Makefile.in.orig Thu Apr 1 01:01:02 1999
|
||||
+++ src/Makefile.in Thu Feb 5 22:17:35 2004
|
||||
@@ -80,8 +80,8 @@
|
||||
@DEVELMODE_TRUE@DEVELFLAGS = -g -Wall
|
||||
|
||||
CLEANFILES = *~ .deps/*
|
||||
-CXXFLAGS = $(GTK_CFLAGS) -DXLM_HOME=\"$(XLM_HOME)\" -DXLM_DB=\"$(XLM_DB)\" -DXLM_USER_DB=\"$(XLM_USER_DB)\" -DXLM_LIB=\"$(XLM_LIB)\" -I../import $(DEVELFLAGS)
|
||||
-LDFLAGS = $(GTK_LIBS)
|
||||
+CXXFLAGS = @CXXFLAGS@ $(GTK_CFLAGS) -DXLM_HOME=\"$(XLM_HOME)\" -DXLM_DB=\"$(XLM_DB)\" -DXLM_USER_DB=\"$(XLM_USER_DB)\" -DXLM_LIB=\"$(XLM_LIB)\" -I../import $(DEVELFLAGS)
|
||||
+LDFLAGS = @LDFLAGS@ $(GTK_LIBS)
|
||||
|
||||
bin_PROGRAMS = xlogmaster
|
||||
xlogmaster_SOURCES = xlogmaster.cc alert.cc audio.cc database.cc dialog.cc execute.cc file.cc logclass.cc menu.cc customize.cc watchdog.cc output.cc
|
|
@ -1,11 +0,0 @@
|
|||
--- src/database.cc.orig Thu Apr 1 01:00:29 1999
|
||||
+++ src/database.cc Thu Feb 5 21:39:55 2004
|
||||
@@ -38,6 +38,8 @@
|
||||
#include "logclass.H"
|
||||
#include "database.H"
|
||||
#include "extern.H"
|
||||
+#include <iostream>
|
||||
+using namespace std;
|
||||
|
||||
/*}}}*/
|
||||
|
|
@ -1,11 +0,0 @@
|
|||
--- src/execute.cc.orig Thu Apr 1 01:00:29 1999
|
||||
+++ src/execute.cc Thu Feb 5 21:39:55 2004
|
||||
@@ -38,6 +38,8 @@
|
||||
#include "logclass.H"
|
||||
#include "execute.H"
|
||||
#include "extern.H"
|
||||
+#include <iostream>
|
||||
+using namespace std;
|
||||
|
||||
/*}}}*/
|
||||
|
|
@ -1,11 +0,0 @@
|
|||
--- src/file.cc.orig Thu Apr 1 01:00:29 1999
|
||||
+++ src/file.cc Thu Feb 5 22:11:38 2004
|
||||
@@ -38,6 +38,8 @@
|
||||
#include "logclass.H"
|
||||
#include "file.H"
|
||||
#include "extern.H"
|
||||
+#include <iostream>
|
||||
+using namespace std;
|
||||
|
||||
/*}}}*/
|
||||
|
|
@ -1,20 +0,0 @@
|
|||
--- src/logclass.H.orig Thu Apr 1 01:00:29 1999
|
||||
+++ src/logclass.H Thu Feb 5 21:39:55 2004
|
||||
@@ -28,7 +28,7 @@
|
||||
|
||||
class Log {
|
||||
/*{{{ Functions */
|
||||
- friend Filter;
|
||||
+ friend class Filter;
|
||||
public:
|
||||
Log();
|
||||
~Log();
|
||||
@@ -200,7 +200,7 @@
|
||||
class Filter
|
||||
{
|
||||
/*{{{ Functions */
|
||||
- friend Log;
|
||||
+ friend class Log;
|
||||
public:
|
||||
Filter();
|
||||
~Filter();
|
|
@ -1,11 +0,0 @@
|
|||
--- src/logclass.cc.orig Thu Apr 1 01:00:29 1999
|
||||
+++ src/logclass.cc Thu Feb 5 21:39:55 2004
|
||||
@@ -37,6 +37,8 @@
|
||||
#include "../import/import.h"
|
||||
#include "logclass.H"
|
||||
#include "extern.H"
|
||||
+#include <iostream>
|
||||
+using namespace std;
|
||||
|
||||
/*}}}*/
|
||||
|
|
@ -1,11 +0,0 @@
|
|||
--- src/output.cc.orig Thu Apr 1 01:00:29 1999
|
||||
+++ src/output.cc Thu Feb 5 21:39:55 2004
|
||||
@@ -38,6 +38,8 @@
|
||||
#include "logclass.H"
|
||||
#include "output.H"
|
||||
#include "extern.H"
|
||||
+#include <iostream>
|
||||
+using namespace std;
|
||||
|
||||
/*}}}*/
|
||||
|
|
@ -1,14 +0,0 @@
|
|||
--- src/sysinc.H.orig Thu Apr 1 01:00:29 1999
|
||||
+++ src/sysinc.H Thu Feb 5 22:12:43 2004
|
||||
@@ -20,8 +20,9 @@
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#include <fcntl.h>
|
||||
-#include <fstream.h>
|
||||
-#include <strstream.h>
|
||||
+#include <fstream>
|
||||
+#include <strstream>
|
||||
+using namespace std;
|
||||
#include <unistd.h>
|
||||
#include <string.h>
|
||||
#include <time.h>
|
|
@ -1,11 +0,0 @@
|
|||
--- src/watchdog.cc.orig Thu Apr 1 01:00:29 1999
|
||||
+++ src/watchdog.cc Thu Feb 5 21:39:55 2004
|
||||
@@ -38,6 +38,8 @@
|
||||
#include "logclass.H"
|
||||
#include "watchdog.H"
|
||||
#include "extern.H"
|
||||
+#include <iostream>
|
||||
+using namespace std;
|
||||
|
||||
/*}}}*/
|
||||
|
|
@ -1,29 +0,0 @@
|
|||
--- src/xlogmaster.cc.orig Thu Apr 1 01:00:29 1999
|
||||
+++ src/xlogmaster.cc Thu Feb 5 22:09:28 2004
|
||||
@@ -41,6 +41,8 @@
|
||||
|
||||
#include "../graphics/logo.xpm"
|
||||
#include "../graphics/logo_small.xpm"
|
||||
+#include <iostream>
|
||||
+using namespace std;
|
||||
|
||||
/*}}}*/
|
||||
|
||||
@@ -996,7 +998,7 @@
|
||||
int gtkrc = FALSE;
|
||||
terse = FALSE;
|
||||
|
||||
- x = getopt_long_only(argc, argv, "", options, &opt_index);
|
||||
+ x = getopt_long(argc, argv, "", options, &opt_index);
|
||||
while ( x != -1 && x != '?' ){
|
||||
const gchar* opt = options[opt_index].name;
|
||||
|
||||
@@ -1183,7 +1185,7 @@
|
||||
}
|
||||
}
|
||||
|
||||
- x = getopt_long_only(argc, argv, "", options, &opt_index);
|
||||
+ x = getopt_long(argc, argv, "", options, &opt_index);
|
||||
};
|
||||
|
||||
if ( optind < argc || x == '?' )
|
Loading…
Reference in a new issue