Add beacon 0.9.06,
The NLANR/DAST Multicast Beacon is a program written in Perl which uses the RTP protocol to provide useful statistics and diagnostic information about a given multicast group. It is used in Internet2 AccessGrid project and EU FP5 6NET project. PR: ports/63440 Submitted by: Janos.Mohacsi@bsd.hu
This commit is contained in:
parent
605eb95c62
commit
80f46400db
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=102457
6 changed files with 87 additions and 0 deletions
|
@ -33,6 +33,7 @@
|
|||
SUBDIR += b2bua
|
||||
SUBDIR += balance
|
||||
SUBDIR += bbsnet
|
||||
SUBDIR += beacon
|
||||
SUBDIR += beacon-server
|
||||
SUBDIR += bfilter
|
||||
SUBDIR += bing
|
||||
|
|
54
net/beacon/Makefile
Normal file
54
net/beacon/Makefile
Normal file
|
@ -0,0 +1,54 @@
|
|||
# New ports collection makefile for: beacon
|
||||
# Date created: 26 February 2004
|
||||
# Whom: Janos.Mohacsi@bsd.hu
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= beacon
|
||||
PORTVERSION= 0.9.06
|
||||
CATEGORIES= net perl5 mbone ipv6
|
||||
MASTER_SITES= http://dast.nlanr.net/Projects/Beacon/Releases/
|
||||
|
||||
MAINTAINER= janos.mohacsi@bsd.hu
|
||||
COMMENT= Beacon active measurement tool to monitor multicast
|
||||
|
||||
BUILD_DEPENDS= ${SITE_PERL}/Net/Domain.pm:${PORTSDIR}/net/p5-Net
|
||||
RUN_DEPENDS= ${BUILD_DEPENDS}
|
||||
|
||||
WWW_DIR?= ${PREFIX}/www/
|
||||
PLIST_SUB+= VERSION=${PORTVERSION}
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${PERL_LEVEL} < 500601
|
||||
IGNORE= Port requires perl 5.6.1 or later. Install lang/perl5 then try again
|
||||
.endif
|
||||
|
||||
do-build:
|
||||
#Build unreleased NET::RTP perl module
|
||||
cd ${WRKSRC}/Net-RTP-0.4/ ; \
|
||||
./configure --enable-ipv6 ; \
|
||||
${PERL} Makefile.PL ; \
|
||||
make
|
||||
|
||||
do-install:
|
||||
#Install unreleased NET::RTP perl module
|
||||
cd ${WRKSRC}/Net-RTP-0.4/ ; \
|
||||
make install
|
||||
#Install the Beacon itself
|
||||
${MKDIR} ${WWW_DIR}/${PORTNAME}-${PORTVERSION}
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/beacon.pl ${WWW_DIR}/${PORTNAME}-${PORTVERSION}
|
||||
${INSTALL_DATA} ${WRKSRC}/beacon.conf ${PREFIX}/etc/beacon.conf.sample
|
||||
@${ECHO} ""
|
||||
@${ECHO} "Sample config installed at \
|
||||
${PREFIX}/etc/beacon.conf.sample"
|
||||
@${ECHO} "Copy the customised version to ${PREFIX}/etc/beacon.conf"
|
||||
|
||||
.ifndef(NOPORTDOCS)
|
||||
post-install:
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
2
net/beacon/distinfo
Normal file
2
net/beacon/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
MD5 (beacon-0.9.06.tar.gz) = a0a845fb352eb4caa00ed8b4b9cc65ca
|
||||
SIZE (beacon-0.9.06.tar.gz) = 436777
|
11
net/beacon/files/patch-beacon.pl
Normal file
11
net/beacon/files/patch-beacon.pl
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- beacon.pl.orig Thu Feb 26 13:58:02 2004
|
||||
+++ beacon.pl Thu Feb 26 13:58:35 2004
|
||||
@@ -1849,7 +1849,7 @@
|
||||
die("Partial options specified -- You must give group, port, and ttl values - Triggered");
|
||||
} else { # Didn't specify any options at all -- Use default config file
|
||||
if (! defined $CONFIGFILE) { # They DIDN'T specify a config file on the command line
|
||||
- $CONFIGFILE = "beacon.conf"; # Default config file for Beacon -- Otherwise, use what they gave us
|
||||
+ $CONFIGFILE = "${PREFIX}/etc/beacon.conf"; # Default config file for Beacon -- Otherwise, use what they gave us
|
||||
}
|
||||
}
|
||||
}
|
7
net/beacon/pkg-descr
Normal file
7
net/beacon/pkg-descr
Normal file
|
@ -0,0 +1,7 @@
|
|||
The NLANR/DAST Multicast Beacon is a program written in Perl which uses the
|
||||
RTP protocol to provide useful statistics and diagnostic information about
|
||||
a given multicast group.
|
||||
The Multicast Beacon can be used as a general-purpose active multicast
|
||||
measurement tool.
|
||||
|
||||
WWW: http://dast.nlanr.net/Projects/Beacon/
|
12
net/beacon/pkg-plist
Normal file
12
net/beacon/pkg-plist
Normal file
|
@ -0,0 +1,12 @@
|
|||
%%SITE_PERL%%/%%PERL_ARCH%%/Net/RTP.pm
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/Net/time.pl
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/Net/rtpdemo.pl
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/RTP/.packlist
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/RTP/RTP.bs
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/RTP/RTP.so
|
||||
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/RTP
|
||||
@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Net 2>/dev/null || true
|
||||
www/beacon-%%VERSION%%/beacon.pl
|
||||
etc/beacon.conf.sample
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
Loading…
Reference in a new issue