Fix for -current.

PR:		57130
This commit is contained in:
Cy Schubert 2003-12-31 19:20:15 +00:00
parent 8ad5abe097
commit 8137d350d2
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=97008
2 changed files with 51 additions and 9 deletions

View file

@ -16,10 +16,6 @@ COMMENT= An X based alarm clock
.include <bsd.port.pre.mk>
.if ${OSVERSION} > 501102
BROKEN= "Does not compile"
.endif
USE_IMAKE= yes
IS_INTERACTIVE= yes

View file

@ -1,8 +1,54 @@
--- Imakefile.orig Sat Jul 22 00:32:07 1995
+++ Imakefile Tue Dec 25 17:40:22 2001
@@ -23,7 +23,7 @@
/**/# this may not work if xalarm is invoked from a pseudo terminal).
/**/# o Define USECUSERID to use cuserid(3) to get the user name.
--- Imakefile.orig Fri Jul 21 07:32:07 1995
+++ Imakefile Wed Nov 12 22:24:04 2003
@@ -1,29 +1,29 @@
-/**/# Based on an Imakefile from:
-/**/# Andreas Stolcke
-/**/# International Computer Science Institute, Berkeley.
-/**/# With help from:
-/**/# George Lindholm, Jonathan I. Kamens, Braham Levy.
-
-
-/**/# o Define FORKRETURNSSHORT/FORKRETURNSLONG/FORKRETURNSPID_T if your
-/**/# fork(2) returns short/long/pid_t not int.
-/**/# o Define USEFLOCK or USELOCKF to use flock(2) or lockf(3) to lock files,
-/**/# rather than fcntl(2).
-/**/# o Define USELSEEK to use lseek(2) to move to the end of the file, rather
-/**/# than fseek(3).
-/**/# o Define USERENAME to use rename(2) to rename file names (otherwise
-/**/# un/link(2)).
-/**/# o Define USEGETHOSTNAME or USEUNAME (or neither if you don't have
-/**/# gethostname(2) or uname(2)) to get the name of your system.
-/**/# o Define USEGETPWUID to use getpwuid(3) and getuid(2) to get the user
-/**/# name and home directory on your system. Note that if you want to use
-/**/# this method to get the user's home directory, but another method to get
-/**/# the user name, this symbol must still be defined.
-/**/# o Define USEGETLOGIN to use getlogin(3) to get the user name (note that
-/**/# this may not work if xalarm is invoked from a pseudo terminal).
-/**/# o Define USECUSERID to use cuserid(3) to get the user name.
+# Based on an Imakefile from:
+# Andreas Stolcke
+# International Computer Science Institute, Berkeley.
+# With help from:
+# George Lindholm, Jonathan I. Kamens, Braham Levy.
+
+
+# o Define FORKRETURNSSHORT/FORKRETURNSLONG/FORKRETURNSPID_T if your
+# fork(2) returns short/long/pid_t not int.
+# o Define USEFLOCK or USELOCKF to use flock(2) or lockf(3) to lock files,
+# rather than fcntl(2).
+# o Define USELSEEK to use lseek(2) to move to the end of the file, rather
+# than fseek(3).
+# o Define USERENAME to use rename(2) to rename file names (otherwise
+# un/link(2)).
+# o Define USEGETHOSTNAME or USEUNAME (or neither if you don't have
+# gethostname(2) or uname(2)) to get the name of your system.
+# o Define USEGETPWUID to use getpwuid(3) and getuid(2) to get the user
+# name and home directory on your system. Note that if you want to use
+# this method to get the user's home directory, but another method to get
+# the user name, this symbol must still be defined.
+# o Define USEGETLOGIN to use getlogin(3) to get the user name (note that
+# this may not work if xalarm is invoked from a pseudo terminal).
+# o Define USECUSERID to use cuserid(3) to get the user name.
-DEFINES = $(SIGNAL_DEFINES) -DUSERENAME -DUSEGETHOSTNAME -DUSEGETPWUID
+DEFINES = $(SIGNAL_DEFINES) -DFORKRETURNSPID_T -DUSERENAME -DUSEGETHOSTNAME -DUSEGETPWUID