o update to 1.13.19.
o deinstall info properly. o add WANT_STATIC flavor. PR: 24502 Submitted by: Cyrille Lefevre <clefevre@citeweb.net>, maintainer
This commit is contained in:
parent
e46598248a
commit
8155707f26
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=37882
16 changed files with 80 additions and 42 deletions
|
@ -6,8 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= tar
|
||||
PORTVERSION= 1.13.18
|
||||
PORTREVISION= 3
|
||||
PORTVERSION= 1.13.19
|
||||
PKGNAMEPREFIX= g
|
||||
CATEGORIES= sysutils archivers
|
||||
MASTER_SITES= ftp://alpha.gnu.org/gnu/tar/ \
|
||||
|
@ -21,10 +20,12 @@ LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
|
|||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --program-prefix=g
|
||||
CONFIGURE_ENV= CPPFLAGS='-I${LOCALBASE}/include' \
|
||||
LDFLAGS='-L${LOCALBASE}/lib' \
|
||||
DEFAULT_ARCHIVE='/dev/rsa0'
|
||||
DEFAULT_ARCHIVE='/dev/sa0'
|
||||
|
||||
post-extract:
|
||||
@rm -f ${WRKSRC}/doc/tar.info*
|
||||
.if defined(WANT_STATIC)
|
||||
CONFIGURE_ENV+= LDFLAGS='-L${LOCALBASE}/lib -static'
|
||||
.else
|
||||
CONFIGURE_ENV+= LDFLAGS='-L${LOCALBASE}/lib'
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (tar-1.13.18.tar.gz) = fd76b10a8e57cb944f0b2c9cb8bf742b
|
||||
MD5 (tar-1.13.19.tar.gz) = ff10ade59f5b312869ffb2f229177e14
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- doc/Makefile.in.orig Wed Sep 27 19:15:21 2000
|
||||
+++ doc/Makefile.in Wed Sep 27 19:15:33 2000
|
||||
@@ -80,7 +80,7 @@
|
||||
INTLLIBS = @INTLLIBS@
|
||||
INTLOBJS = @INTLOBJS@
|
||||
LIBOBJS = @LIBOBJS@
|
||||
-MAKEINFO = @MAKEINFO@
|
||||
+MAKEINFO = @MAKEINFO@ --no-split
|
||||
MKINSTALLDIRS = @MKINSTALLDIRS@
|
||||
MSGFMT = @MSGFMT@
|
||||
PACKAGE = @PACKAGE@
|
16
archivers/gtar/files/patch-lib_dirname_c
Normal file
16
archivers/gtar/files/patch-lib_dirname_c
Normal file
|
@ -0,0 +1,16 @@
|
|||
$FreeBSD$
|
||||
--- lib/dirname.c.orig Wed Jan 31 02:08:57 2001
|
||||
+++ lib/dirname.c Wed Jan 31 02:10:31 2001
|
||||
@@ -19,6 +19,12 @@
|
||||
# include <config.h>
|
||||
#endif
|
||||
|
||||
+#if HAVE_STRING_H
|
||||
+# include <string.h>
|
||||
+#else
|
||||
+# include <strings.h>
|
||||
+#endif
|
||||
+
|
||||
#if HAVE_STDLIB_H
|
||||
# include <stdlib.h>
|
||||
#endif
|
|
@ -1,3 +1,4 @@
|
|||
$FreeBSD$
|
||||
--- lib/prepargs.c.orig Thu Nov 16 01:32:16 2000
|
||||
+++ lib/prepargs.c Thu Nov 16 01:32:58 2000
|
||||
@@ -23,6 +23,11 @@
|
|
@ -1 +1 @@
|
|||
The GNU tape archiver
|
||||
GNU version of the traditional tar archiver
|
||||
|
|
|
@ -1 +1,12 @@
|
|||
gtar is the GNU Project's Tape Archiver (tar).
|
||||
The Free Software Foundation's "tar" tape archiver.
|
||||
|
||||
GNU tar saves many files together into a single tape or disk archive,
|
||||
and can restore individual files from the archive. It includes
|
||||
multivolume support, the ability to archive sparse files, automatic
|
||||
archive compression/decompression, remote archives and special
|
||||
features that allow tar to be used for incremental and full backups.
|
||||
This distribution also includes rmt, the remote tape server.
|
||||
|
||||
Note that this port will install these utilities with a 'g' prefix,
|
||||
e.g. gtar, but the texinfo documentation will refer to them without
|
||||
the 'g' prefix.
|
||||
|
|
|
@ -1,7 +1,8 @@
|
|||
@comment $FreeBSD$
|
||||
bin/gtar
|
||||
@unexec install-info --delete %D/info/tar.info %D/info/dir
|
||||
info/tar.info
|
||||
@exec install-info %D/info/tar.info %D/info/dir
|
||||
@unexec install-info --delete %D/info/tar.info %D/info/dir
|
||||
libexec/grmt
|
||||
share/locale/cs/LC_MESSAGES/tar.mo
|
||||
share/locale/da/LC_MESSAGES/tar.mo
|
||||
|
|
|
@ -6,8 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= tar
|
||||
PORTVERSION= 1.13.18
|
||||
PORTREVISION= 3
|
||||
PORTVERSION= 1.13.19
|
||||
PKGNAMEPREFIX= g
|
||||
CATEGORIES= sysutils archivers
|
||||
MASTER_SITES= ftp://alpha.gnu.org/gnu/tar/ \
|
||||
|
@ -21,10 +20,12 @@ LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
|
|||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --program-prefix=g
|
||||
CONFIGURE_ENV= CPPFLAGS='-I${LOCALBASE}/include' \
|
||||
LDFLAGS='-L${LOCALBASE}/lib' \
|
||||
DEFAULT_ARCHIVE='/dev/rsa0'
|
||||
DEFAULT_ARCHIVE='/dev/sa0'
|
||||
|
||||
post-extract:
|
||||
@rm -f ${WRKSRC}/doc/tar.info*
|
||||
.if defined(WANT_STATIC)
|
||||
CONFIGURE_ENV+= LDFLAGS='-L${LOCALBASE}/lib -static'
|
||||
.else
|
||||
CONFIGURE_ENV+= LDFLAGS='-L${LOCALBASE}/lib'
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (tar-1.13.18.tar.gz) = fd76b10a8e57cb944f0b2c9cb8bf742b
|
||||
MD5 (tar-1.13.19.tar.gz) = ff10ade59f5b312869ffb2f229177e14
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- doc/Makefile.in.orig Wed Sep 27 19:15:21 2000
|
||||
+++ doc/Makefile.in Wed Sep 27 19:15:33 2000
|
||||
@@ -80,7 +80,7 @@
|
||||
INTLLIBS = @INTLLIBS@
|
||||
INTLOBJS = @INTLOBJS@
|
||||
LIBOBJS = @LIBOBJS@
|
||||
-MAKEINFO = @MAKEINFO@
|
||||
+MAKEINFO = @MAKEINFO@ --no-split
|
||||
MKINSTALLDIRS = @MKINSTALLDIRS@
|
||||
MSGFMT = @MSGFMT@
|
||||
PACKAGE = @PACKAGE@
|
16
sysutils/gtar/files/patch-lib_dirname_c
Normal file
16
sysutils/gtar/files/patch-lib_dirname_c
Normal file
|
@ -0,0 +1,16 @@
|
|||
$FreeBSD$
|
||||
--- lib/dirname.c.orig Wed Jan 31 02:08:57 2001
|
||||
+++ lib/dirname.c Wed Jan 31 02:10:31 2001
|
||||
@@ -19,6 +19,12 @@
|
||||
# include <config.h>
|
||||
#endif
|
||||
|
||||
+#if HAVE_STRING_H
|
||||
+# include <string.h>
|
||||
+#else
|
||||
+# include <strings.h>
|
||||
+#endif
|
||||
+
|
||||
#if HAVE_STDLIB_H
|
||||
# include <stdlib.h>
|
||||
#endif
|
|
@ -1,3 +1,4 @@
|
|||
$FreeBSD$
|
||||
--- lib/prepargs.c.orig Thu Nov 16 01:32:16 2000
|
||||
+++ lib/prepargs.c Thu Nov 16 01:32:58 2000
|
||||
@@ -23,6 +23,11 @@
|
|
@ -1 +1 @@
|
|||
The GNU tape archiver
|
||||
GNU version of the traditional tar archiver
|
||||
|
|
|
@ -1 +1,12 @@
|
|||
gtar is the GNU Project's Tape Archiver (tar).
|
||||
The Free Software Foundation's "tar" tape archiver.
|
||||
|
||||
GNU tar saves many files together into a single tape or disk archive,
|
||||
and can restore individual files from the archive. It includes
|
||||
multivolume support, the ability to archive sparse files, automatic
|
||||
archive compression/decompression, remote archives and special
|
||||
features that allow tar to be used for incremental and full backups.
|
||||
This distribution also includes rmt, the remote tape server.
|
||||
|
||||
Note that this port will install these utilities with a 'g' prefix,
|
||||
e.g. gtar, but the texinfo documentation will refer to them without
|
||||
the 'g' prefix.
|
||||
|
|
|
@ -1,7 +1,8 @@
|
|||
@comment $FreeBSD$
|
||||
bin/gtar
|
||||
@unexec install-info --delete %D/info/tar.info %D/info/dir
|
||||
info/tar.info
|
||||
@exec install-info %D/info/tar.info %D/info/dir
|
||||
@unexec install-info --delete %D/info/tar.info %D/info/dir
|
||||
libexec/grmt
|
||||
share/locale/cs/LC_MESSAGES/tar.mo
|
||||
share/locale/da/LC_MESSAGES/tar.mo
|
||||
|
|
Loading…
Reference in a new issue