- Update to 0.3.9

- Enable the jpeg factory
- Respect ${PTHREAD_CFLAGS}, ${PTHREAD_LIBS} and ${X11BASE}
- Polish the Makefile
This commit is contained in:
Jean-Yves Lefort 2005-11-20 22:15:49 +00:00
parent 05b3433652
commit 81807f2d72
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=148883
6 changed files with 92 additions and 22 deletions

View file

@ -6,7 +6,7 @@
#
PORTNAME= SimGear
PORTVERSION= 0.3.8
PORTVERSION= 0.3.9
CATEGORIES= devel games
MASTER_SITES= ftp://ftp.simgear.org/pub/simgear/Source/ \
ftp://ftp.de.flightgear.org/pub/simgear/Source/
@ -14,21 +14,21 @@ MASTER_SITES= ftp://ftp.simgear.org/pub/simgear/Source/ \
MAINTAINER= jylefort@FreeBSD.org
COMMENT= A toolkit for 3D games and simulations
# These should be LIB_DEPENDS, but it seems bsd.port.mk can't handle
# versionless or static libraries.
BUILD_DEPENDS= ${LOCALBASE}/lib/libmk4.so:${PORTSDIR}/databases/metakit \
${X11BASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib
RUN_DEPENDS= ${LOCALBASE}/lib/libmk4.so:${PORTSDIR}/databases/metakit \
${X11BASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib
LIB_DEPENDS= openal.0:${PORTSDIR}/audio/openal
BUILD_DEPENDS= ${X11BASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib
RUN_DEPENDS= ${X11BASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib
LIB_DEPENDS= openal.0:${PORTSDIR}/audio/openal \
jpeg.9:${PORTSDIR}/graphics/jpeg
USE_X_PREFIX= yes
USE_REINPLACE= yes
USE_GL= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CC="${CC}" CFLAGS="${CFLAGS}" \
CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" \
CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}"
CONFIGURE_ARGS= --with-jpeg-factory
post-patch:
@${REINPLACE_CMD} -e 's|-D_REENTRANT|${PTHREAD_CFLAGS}|' \
${WRKSRC}/configure
.include <bsd.port.mk>

View file

@ -1,2 +1,3 @@
MD5 (SimGear-0.3.8.tar.gz) = d535880954b8d9393f55cc51ee045c60
SIZE (SimGear-0.3.8.tar.gz) = 992609
MD5 (SimGear-0.3.9.tar.gz) = c9586d2ddc6a8200ccaae437eaa2be14
SHA256 (SimGear-0.3.9.tar.gz) = f29b2b418f81994c9aae9c6e71c49116e906e9b9a86ba820f44bf103c1a0d3a6
SIZE (SimGear-0.3.9.tar.gz) = 907159

View file

@ -0,0 +1,11 @@
--- simgear/misc/stdint.hxx.orig Sun Nov 20 05:16:55 2005
+++ simgear/misc/stdint.hxx Sun Nov 20 05:17:02 2005
@@ -51,7 +51,7 @@
#elif defined(sgi) || defined(__sun)
# include <sys/types.h>
#else
-# include <stdint.h>
+# include <unistd.h>
#endif

View file

@ -0,0 +1,20 @@
--- simgear/nasal/data.h.orig Sun Nov 20 22:30:00 2005
+++ simgear/nasal/data.h Sun Nov 20 22:30:14 2005
@@ -47,7 +47,7 @@
struct VecRec {
int size;
int alloced;
- naRef array[];
+ naRef array[0];
};
struct naVec {
@@ -66,7 +66,7 @@
int dels;
int lgalloced;
struct HashNode* nodes;
- struct HashNode* table[];
+ struct HashNode* table[0];
};
struct naHash {

View file

@ -0,0 +1,35 @@
--- simgear/scene/model/shadowvolume.hxx.orig Sun Nov 20 05:25:21 2005
+++ simgear/scene/model/shadowvolume.hxx Sun Nov 20 05:29:56 2005
@@ -60,6 +60,14 @@
void endOfFrame(void);
static int ACpostTravCB( ssgEntity *entity, int traversal_mask );
+ bool shadowsDebug_enabled;
+ bool shadowsAC_transp_enabled;
+ bool use_alpha;
+
+ sgVec3 sunPos;
+ int frameNumber;
+ int lastTraverseTreeFrame;
+ sgMat4 CameraViewM;
private:
class ShadowCaster
@@ -126,16 +134,10 @@
void cull ( ssgBranch *b, sgFrustum *f, sgMat4 m, int test_needed );
bool shadows_enabled;
- bool shadowsAC_enabled, shadowsAI_enabled, shadowsTO_enabled, shadowsDebug_enabled;
- bool shadowsAC_transp_enabled;
- bool use_alpha;
+ bool shadowsAC_enabled, shadowsAI_enabled, shadowsTO_enabled;
bool canDoAlpha, canDoStencil;
SGPropertyNode *sim_rendering;
- sgVec3 sunPos;
- int frameNumber;
- int lastTraverseTreeFrame;
- sgMat4 CameraViewM;
double sun_angle;
SceneryObject_map sceneryObjects;
ssgBranch *ssg_root;

View file

@ -4,6 +4,7 @@ include/simgear/constants.h
include/simgear/debug/debug_types.h
include/simgear/debug/logstream.hxx
include/simgear/environment/metar.hxx
include/simgear/environment/visual_enviro.hxx
include/simgear/ephemeris/celestialBody.hxx
include/simgear/ephemeris/ephemeris.hxx
include/simgear/ephemeris/jupiter.hxx
@ -38,6 +39,7 @@ include/simgear/math/vector.hxx
include/simgear/misc/interpolator.hxx
include/simgear/misc/sg_path.hxx
include/simgear/misc/sgstream.hxx
include/simgear/misc/stdint.hxx
include/simgear/misc/stopwatch.hxx
include/simgear/misc/strutils.hxx
include/simgear/misc/tabbed_values.hxx
@ -59,11 +61,14 @@ include/simgear/scene/model/model.hxx
include/simgear/scene/model/modellib.hxx
include/simgear/scene/model/personality.hxx
include/simgear/scene/model/placement.hxx
include/simgear/scene/model/placementtrans.hxx
include/simgear/scene/model/shadowvolume.hxx
include/simgear/scene/sky/bbcache.hxx
include/simgear/scene/sky/cloud.hxx
include/simgear/scene/sky/clouds3d/SkySceneLoader.hpp
include/simgear/scene/sky/clouds3d/SkyUtil.hpp
include/simgear/scene/sky/cloudfield.hxx
include/simgear/scene/sky/dome.hxx
include/simgear/scene/sky/moon.hxx
include/simgear/scene/sky/newcloud.hxx
include/simgear/scene/sky/oursun.hxx
include/simgear/scene/sky/sky.hxx
include/simgear/scene/sky/sphere.hxx
@ -74,9 +79,12 @@ include/simgear/scene/tgdb/obj.hxx
include/simgear/scene/tgdb/pt_lights.hxx
include/simgear/scene/tgdb/userdata.hxx
include/simgear/scene/tgdb/vasi.hxx
include/simgear/screen/RenderTexture.h
include/simgear/screen/colors.hxx
include/simgear/screen/extensions.hxx
include/simgear/screen/jpgfactory.hxx
include/simgear/screen/screen-dump.hxx
include/simgear/screen/shader.h
include/simgear/screen/texture.hxx
include/simgear/screen/tr.h
include/simgear/serial/serial.hxx
@ -99,10 +107,8 @@ include/simgear/timing/sg_time.hxx
include/simgear/timing/timestamp.hxx
include/simgear/timing/timezone.h
include/simgear/version.h
include/simgear/xgl/xgl.h
include/simgear/xml/easyxml.hxx
lib/libsgbucket.a
lib/libsgclouds3d.a
lib/libsgdebug.a
lib/libsgenvironment.a
lib/libsgephem.a
@ -123,10 +129,8 @@ lib/libsgstructure.a
lib/libsgtgdb.a
lib/libsgthreads.a
lib/libsgtiming.a
lib/libsgxgl.a
lib/libsgxml.a
@dirrm include/simgear/xml
@dirrm include/simgear/xgl
@dirrm include/simgear/timing
@dirrm include/simgear/threads
@dirrm include/simgear/structure
@ -134,7 +138,6 @@ lib/libsgxml.a
@dirrm include/simgear/serial
@dirrm include/simgear/screen
@dirrm include/simgear/scene/tgdb
@dirrm include/simgear/scene/sky/clouds3d
@dirrm include/simgear/scene/sky
@dirrm include/simgear/scene/model
@dirrm include/simgear/scene/material