Respect CFLAGS instead of always incorporating debugging info into libgbrun

shared library, which boosts package size by 10x.
This commit is contained in:
Maxim Sobolev 2002-06-21 13:25:09 +00:00
parent 7e25c75019
commit 8184c132e2
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=61678
2 changed files with 19 additions and 4 deletions

View file

@ -17,16 +17,17 @@ MAINTAINER= gnome@FreeBSD.org
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_GNOME= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
@find ${WRKSRC} -name "Makefile.in*" | xargs ${REINPLACE_CMD} -e \
's|[(]datadir[)]/gnome/|(datadir)/|g ; \
s|[(]datadir[)]/locale|(prefix)/share/locale|g'
.include <bsd.port.mk>

View file

@ -0,0 +1,14 @@
$FreeBSD$
--- gbrun/Makefile.in 2002/06/21 13:21:30 1.1
+++ gbrun/Makefile.in 2002/06/21 13:22:29
@@ -152,7 +152,7 @@
libgbrun_la_LIBADD = $(EXTRA_GNOME_LIBS) -lm @GLIB_LIBS@ $(top_builddir)/gbrun/objects/libgbobj.la $(top_builddir)/gbrun/objects/gba/libgba.la $(top_builddir)/gb/libgb.la
-CFLAGS = -g -Wall $(EXTRA_GNOME_CFLAGS)
+CFLAGS = @CFLAGS@ -Wall $(EXTRA_GNOME_CFLAGS)
libgbrunincludedir = $(includedir)/gbrun