- Fix build on -stable

- Utilize USE_GETOPT_LONG

PR:		51869
Submitted by:	Ports Fury
This commit is contained in:
Ying-Chieh Liao 2003-05-12 07:53:38 +00:00
parent f3350272f6
commit 81bbce0e11
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=80789
5 changed files with 63 additions and 26 deletions

View file

@ -18,22 +18,27 @@ DISTNAME= GOPchop-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= MPEG2 GOP-accurate editor
LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
mpeg2.0:${PORTSDIR}/multimedia/libmpeg2 \
SDL-1.1.5:${PORTSDIR}/devel/sdl12 \
intl.4:${PORTSDIR}/devel/gettext \
iconv.3:${PORTSDIR}/converters/libiconv
LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12 \
mpeg2.0:${PORTSDIR}/multimedia/libmpeg2
SDLCONFIG?= ${LOCALBASE}/bin/sdl11-config
USE_GNOME= gtk12
USE_GETOPT_LONG= yes
USE_REINPLACE= yes
SDLCONFIG?= ${LOCALBASE}/bin/sdl11-config
GNU_CONFIGURE= yes
CONFIGURE_ENV= \
CPPFLAGS="${CXXFLAGS} -DHAVE_DECL_GETOPT -I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt" \
SDLCONFIG="${SDLCONFIG}"
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
SDLCONFIG="${SDLCONFIG}"
CONFIGURE_ARGS= --disable-mlib
CPPFLAGS= -I${LOCALBASE}/include -DHAVE_DECL_GETOPT
LDFLAGS= -L${LOCALBASE}/lib
post-patch:
@${REINPLACE_CMD} -e 's|-lglib||g' ${WRKSRC}/src/Makefile.in
@${REINPLACE_CMD} -e 's| -mcpu=.*"|"|g' ${WRKSRC}/configure
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|pixmaps/\$$(PACKAGE)|\$$(PACKAGE)/pixmaps|g ; \
s|-lglib||g'
.include <bsd.port.mk>

View file

@ -1,15 +0,0 @@
--- Makefile.in.orig Tue Apr 15 19:04:54 2003
+++ Makefile.in Tue Apr 15 19:09:09 2003
@@ -438,10 +438,10 @@
install-data-local:
@$(NORMAL_INSTALL)
if test -d $(srcdir)/pixmaps; then \
- $(mkinstalldirs) $(DESTDIR)$(datadir)/pixmaps/$(PACKAGE); \
+ $(mkinstalldirs) $(DESTDIR)$(datadir)/$(PACKAGE)/pixmaps; \
for pixmap in $(srcdir)/pixmaps/*; do \
if test -f $$pixmap; then \
- $(INSTALL_DATA) $$pixmap $(DESTDIR)$(datadir)/pixmaps/$(PACKAGE); \
+ $(INSTALL_DATA) $$pixmap $(DESTDIR)$(datadir)/$(PACKAGE)/pixmaps; \
fi \
done \
fi

View file

@ -0,0 +1,13 @@
--- src/ElementStream.h.orig Thu Jan 17 06:32:23 2002
+++ src/ElementStream.h Tue May 6 21:35:30 2003
@@ -29,7 +29,10 @@
#include "config.h"
#include "Vector.h"
+
+#ifdef HAVE_STDINT_H
#include <stdint.h>
+#endif
class ElementStream: public Vector
{

View file

@ -0,0 +1,12 @@
--- src/Parser.h.orig Mon Apr 7 07:24:42 2003
+++ src/Parser.h Tue May 6 21:36:18 2003
@@ -42,7 +42,9 @@
// strlen
#include <string.h>
+#ifdef HAVE_STDINT_H
#include <stdint.h>
+#endif
#include "List.h"

View file

@ -0,0 +1,22 @@
--- src/mpegcat.c.orig Mon Apr 14 12:21:04 2003
+++ src/mpegcat.c Tue May 6 21:46:58 2003
@@ -390,11 +390,19 @@
break;
case 'n':
+#ifdef __FreeBSD__
+ num_bytes = strtoll(optarg, NULL, 10);
+#else
num_bytes = atoll(optarg);
+#endif
break;
case 'b':
+#ifdef __FreeBSD__
+ begin_at = strtoll(optarg, NULL, 10);
+#else
begin_at = atoll(optarg);
+#endif
break;
case 'w':